TWRP and Root for OnePlus 6 on Oxygen OS 10 Stable/Beta

This this method work for you?

  • Yes

    Votes: 154 77.0%
  • No

    Votes: 46 23.0%

  • Total voters
    200
Search This thread

kerngehirn

Senior Member
Feb 24, 2013
356
126
What if I accidentally installed the system update?
What will happen if I reboot? Will u lose data? What can u do to prevent it?
Unpated from OB5 to OB6 by accident. Haven't restarted yet.
 

5xonlineage

Member
Jul 6, 2017
34
6
Denver, CO
Rebooting back to recovery, not system

A. If you are on OOS 10

I. If you are on OOS 10.3.0, OB4, or higher

Prerequisites:


  1. Reboot to fastboot mode. Boot to TWRP using the following command:
    Code:
    fastboot boot twrp-3.3.1-18-enchilada-Q-mauronofrio.img
  2. Flash TWRP installer zip. Reboot to recovery.
  3. Flash lastest Magisk. Reboot.

I was on 10.3.2, and I followed the steps above by booting into the twrp img, flashing twrp-3.3.1-x_blu_spark_v9.109_op6.zip, rebooting to recovery, then flashing Magisk-v20.4.zip. However, when I rebooted at the end, it took me back to recovery. What happened? Do I need to flash a boot img?


After clean flashing OOS10 using the stock fastboot image I managed to get the system to boot with Magisk and TWRP working but a lot of apps keep force closing (Gmail, Amazon and a few more). Reinstalling the apps doesn't help. I'm also unable to view symbols like emojis and non-English characters throughout the system, they just show up as rectangular boxes with crosses.

I also fastbooted stock 10.3.2 ROM, and I'm also having issues with missing emojis and non-English characters. Has anyone found a fix for this? Thanks for any suggestions.
 
Last edited:

DJsushi123

Member
May 16, 2017
45
26
Zvolen
I have a problem with OB6. The phone is stuck on the "bootloader unlocked" screen after flashing TWRP. This doesn't happen when I only temporarily flash it. It only happens after the .zip flash inside temporary TWRP. Any help?
 

kerngehirn

Senior Member
Feb 24, 2013
356
126
HI,

i followd the B section after installing full update file.
Now i cant access internal storage with most apps. Both "files" apps show nothing. Gallery is empty and google photos crashes on launch.

Any ideas? :(
 

brausebirne

Senior Member
Nov 3, 2011
145
62
Has anyone successfully installed TWRP on stable version 10.3.3 ? After installing TWRP,my OP6 didn't boot up.It stuck on first screen.Please help me
Yes. But the first boot wasn't sucessful, phone and cell provider were force closed again and again. After switchting off and re-boot everything was fine.
 
  • Like
Reactions: kakkooran

mohdfahad47

Senior Member
Apr 7, 2015
500
76
Muharraq
After clean flashing OOS10 using the stock fastboot image I managed to get the system to boot with Magisk and TWRP working but a lot of apps keep force closing (Gmail, Amazon and a few more). Reinstalling the apps doesn't help. I'm also unable to view symbols like emojis and non-English characters throughout the system, they just show up as rectangular boxes with crosses.

hey, i just rooted my device, everything seems to work fine. but i have this same issue of non english characters shown as boxes with cross, also the emojis are missing. did you find any solution for this issue?? if yes then can you help me out. thanks
 

mohdfahad47

Senior Member
Apr 7, 2015
500
76
Muharraq
hey, i rooted my device yesterday on 10.3.3, all was good until i got into a bootloop after installing busybox from the magisk repo. i keep going back to the fastboot mode, i still have access to twrp but sadly i didnt make a nandroid backup. i really dont know what to do now and i know this is not the relevant thread to ask this question. im sorry, but if anyone knows a method to solve this please let me know. thanks
 

kozmo21

Inactive Recognized Contributor
Jun 4, 2010
1,375
1,917
hey, i rooted my device yesterday on 10.3.3, all was good until i got into a bootloop after installing busybox from the magisk repo. i keep going back to the fastboot mode, i still have access to twrp but sadly i didnt make a nandroid backup. i really dont know what to do now and i know this is not the relevant thread to ask this question. im sorry, but if anyone knows a method to solve this please let me know. thanks

If you can still get into TWRP... just use the file manager in TWRP and go to /data/adb/modules, then select busybox and delete it, then reboot to system.
 

mohdfahad47

Senior Member
Apr 7, 2015
500
76
Muharraq
If you can still get into TWRP... just use the file manager in TWRP and go to /data/adb/modules, then select busybox and delete it, then reboot to system.

Thanks for the reply. Already did that, didn't work. im not doing anything in a hurry, since im new to this a/b partiton thing and dont wanna mess things further.
 
Last edited:

anuajayan

Senior Member
Oct 8, 2012
135
12
Guess It
Could you please provide the steps? How you rooted your device?

---------- Post added at 02:57 PM ---------- Previous post was at 02:55 PM ----------

Thanks for the reply. Already did that, didn't work. im not doing anything in a hurry, since im new to this a/b partiton thing and dont wanna mess things further.

Could you please provide the steps? How you rooted your device?
 

mohdfahad47

Senior Member
Apr 7, 2015
500
76
Muharraq
Could you please provide the steps? How you rooted your device?

---------- Post added at 02:57 PM ---------- Previous post was at 02:55 PM ----------



Could you please provide the steps? How you rooted your device?

Pretty much exactly as the thread says, unlocked the bootloader - flashed mauro's twrp- flash twrp zip and then magisk . It got rooted properly but I had an issue with non English characters shown as boxes and cross, but I fixed that by flashing the reserve_v1.img through magisk . However,I got into this mess by installing the busybox module from magisk repo, I wanted to install viper 4android and for it to get installed it said that I'd need busybox first. Next thing after I flash the busybox module I get into this bootloop, I have access to twrp and I went in file manager data/adb/modules and deleted both busy box and viper 4 android but I'm still in this boot loop. Will a normal factory reset from twrp solve this?? Or maybe flashing the latest oos zip from twrp? Thanks for your help...
 
Last edited:

brausebirne

Senior Member
Nov 3, 2011
145
62
Can you tell me the step by step guide.I tried a lot,but no success.Thanks in advance
First step: I unchecked all the Magisk modules and de-installed the Subtratum themes I use. After that I put the downloaded full OTA zip in the root directory of my phone and installed it via the system update function. After finnishing the update progress I didn't reboot. I installed in Magisk the TWRP Retention Script and directily after that I installed Magisk (last option - OTA). Last step: I rebooted to recovery to install a custom kernel and restarted the phone.
As I mentioned it before: the first re-boot wasnt' sucessfull but after turning off and on the device everything was fine.
 

Ryaki

Member
Jun 17, 2016
14
2
Hello,
after I installed OS version 10.3.3 i flashed twrp-3.3.1-18-enchilada-Q-mauronofrio.img and nothing else but now the phone doesn't boot anymore.
Does anyone have anything to suggest?
 

anuajayan

Senior Member
Oct 8, 2012
135
12
Guess It
First step: I unchecked all the Magisk modules and de-installed the Subtratum themes I use. After that I put the downloaded full OTA zip in the root directory of my phone and installed it via the system update function. After finnishing the update progress I didn't reboot. I installed in Magisk the TWRP Retention Script and directily after that I installed Magisk (last option - OTA). Last step: I rebooted to recovery to install a custom kernel and restarted the phone.
As I mentioned it before: the first re-boot wasnt' sucessfull but after turning off and on the device everything was fine.
Thank you soo much bro.. It works perfectly..
Earlier while updating to 10.3.2 i had faced issue with non English language and smiles.. But this time it's perfect.. No problem all went well.. ??
 
  • Like
Reactions: brausebirne

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Hey everyone, I made a custom magisk update channel that is set to say Magisk 19.4 is the latest version. Using it allows you to use "Install to Inactive Slot" and avoid accidentally updating to Magisk 20.0.

    To use it, go to Magisk Manager>Settings>Update Settings>Update Channel>Custom
    then enter the following url:
    [Link Removed]

    Once the Magisk 20 incompatibility is fixed, you should switch back to the stable/beta repo.

    EDIT: Link removed, as Magisk 20.1 has been released, fixing the TWRP incompatibility. Please switch back to the Stable channel if you are using this custom channel.
    6
    I just installed the latest Canary Magisk V.20.xxxxx . It is working fine and I have no issues going into TWRP.. Seems like topjohnwu commited the fix to the canary branch for the TWRP issues... so no need to stay on 19.4 as far as I'm concerned.

    Release notes here:

    https://github.com/topjohnwu/magisk_files/blob/canary/notes.md

    If you want to install this make sure you download the Canary Magisk Manager and change the update channel to Canary ...

    https://forum.xda-developers.com/apps/magisk/dev-magisk-canary-channel-bleeding-edge-t3839337

    :D
    5
    A10 final on OP6 worked fine without data loss coming from rooted 9.0.9

    1. installed latest TWRP (from first Post)
    2. Reboot to TWRP
    3. Magisk uninstall
    4. Install A10 full -> reinstall TWRP
    5. reboot to TWRP and install Magisk 20.1

    rooted and A10 OP6 with all my Data
    5
    I had magisk v20 installed, I did not uninstall magisk or remove all traces. I flashed TWRP via fastboot, booted to twrp installed twrp zip, rebooted back to twrp and installed magisk 19.4. No issues. So it may not be necessary to uninstall magisk first. So if you forget to do so you may be ok.
    3
    Simply flash the mauronofrio TWRP zip using Magisk (as if you were installing a Magisk module), then direct install Magisk again.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone