TWRP boot loop after Magisk 22 upgrade

kamiller42

Senior Member
Jun 16, 2010
344
20
38
Magisk updater installed Magisk & said it needed to make a change to continue the update. I clicked the Reboot button. The phone boots into TWRP. I reboot & it goes into TWRP. Repeat.

How can I recover, preferably w/o losing apps & most preferably w/o losing data like pics?

I'm using Android 9 rooted.
 

jjgvv

Senior Member
Dec 22, 2018
1,002
231
63
Magisk updater installed Magisk & said it needed to make a change to continue the update. I clicked the Reboot button. The phone boots into TWRP. I reboot & it goes into TWRP. Repeat.

How can I recover, preferably w/o losing apps & most preferably w/o losing data like pics?

I'm using Android 9 rooted.
Backup>select data and internal storage>use a computer to move the backup file out
restore then
You can also try magisk uninstaller which comes with magisk on github(seach github magisk the uninstaller is in assets)
 
  • Like
Reactions: kamiller42

kamiller42

Senior Member
Jun 16, 2010
344
20
38
Backup>select data and internal storage>use a computer to move the backup file out
restore then
You can also try magisk uninstaller which comes with magisk on github(seach github magisk the uninstaller is in assets)
Good suggestions. Came back to phone & found battery ran out. Charged up & now it boot loops to fast mode only. Argh!
 

jjgvv

Senior Member
Dec 22, 2018
1,002
231
63
fastboot flash recovery twrp.img where the recovery image should be renamed 'twrp.img' and placed in the fastboot platform tools folder.
then
fastboot reboot recovery
 
  • Like
Reactions: kamiller42

kamiller42

Senior Member
Jun 16, 2010
344
20
38
fastboot flash recovery twrp.img where the recovery image should be renamed 'twrp.img' and placed in the fastboot platform tools folder.
then
fastboot reboot recovery
Tried 3 different cables including OnePlus. Same result.

fastboot boot twrp-3.3.1-x_blu_spark_v9.101_op6t.img
downloading 'boot.img'...
OKAY [ 0.867s]
booting...
FAILED (remote: Failed to load/authenticate boot image: Load Error)
finished. total time: 0.876s
 

kamiller42

Senior Member
Jun 16, 2010
344
20
38
Tried 3 different cables including OnePlus. Same result.

fastboot boot twrp-3.3.1-x_blu_spark_v9.101_op6t.img
downloading 'boot.img'...
OKAY [ 0.867s]
booting...
FAILED (remote: Failed to load/authenticate boot image: Load Error)
finished. total time: 0.876s
Sorry. I see your rename note. Same result.
fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 0.840s]
booting...
FAILED (remote: Failed to load/authenticate boot image: Load Error)
finished. total time: 0.848s
 

kamiller42

Senior Member
Jun 16, 2010
344
20
38
I see the platform-tools note. I'm on Linux & the adb & fastboot tools are in /usr/bin, not a platform-tools folder.

Found one.
/usr/lib/android-sdk/platform-tools$ fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 0.881s]
booting...
FAILED (remote: Failed to load/authenticate boot image: Load Error)
finished. total time: 0.889s
 

kamiller42

Senior Member
Jun 16, 2010
344
20
38
I was able to get back to TWRP by switching slots. Backup fails because Data is encrypted & TWRP is not prompting for PIN. I'll try using the Magisk uninstaller tomorrow (past bedtime). Long shot.

Open to other approaches. Thanks for your help.