TWRP cannot mount /data; nothing 'sticking' using fastboot

Search This thread

ak.pp

Member
Jun 8, 2012
34
2
Hi all,

hoping on the off-chance someone's still monitoring the Nexus 5 forums here :)

So decided to dust off the old Nexus 5 (now with extra COVID-19 time on my hands!) to use as a backup device, but having serious issues getting it up and running. I had it rooted years ago, and had no issues installing custom roms.

Now I'm having the following situation:

I cannot flash the factory image using fastboot, nor anything is 'sticking' to the phone when I try to re-flash individual component for the factory image. I've also tried to flash TWRP, but again, it doesn't stick and the only way i can boot into TWRP is by using
Code:
fastboot boot recovery.img
.

However in recovery, the data partition is not mounting and all the tutorials/guides I read about fixing it aren't working (e.g. repairing the partition-- get a 'unable to repair data' error; changing from EX4 to EX2 and back-- get 'failed to mount '/data' error).

Ran the following command in the terminal window in TWRP
Code:
cat /etc/fstab
and got the following output:

Code:
/dev/block/mmcblk0p25 /system ext4 rw 0 0
/dev/block/dm-0 /data ext4 rw 0 0
/dev/block/mmcblk0p27 /cache ext4 rw 0 0
/dev/block/mmcblk016 /persist ext 4 rw 0 0
/dev/block/mmcblk0p1 /firmware vfat rw 0 0
 /usb-otg vfat rw 0 0

tried using the make_ext4fs command, but again- nothing happens.

Using TWRP 3.3.1-0 by the way

Any ideas? is the phone completely bricked? it's stuck in a bootloop where the google colours come up but freeze within half a second, repeat and continue.

Any advice would be very much appreciated!
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone