TWRP Error (FAILED (Write to device failed (Invalid argument))

Search This thread

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Ive been trying to install TWRP on my Poco F1 but i am receiving an error message saying " failed write to device failed"

Please Help

im on lastest Official Rom for Poco f1
 

muham47

Senior Member
Mar 14, 2008
116
3
HyD

Attachments

  • Capture.PNG
    Capture.PNG
    23.3 KB · Views: 16,679
  • Like
Reactions: mickrussom

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Have you tried different PC?
Same error(FAILED (Write to device failed (Invalid argument)) when I try on AMD.. Try on Intel processor PC

Okay will give it a try, previously i did install twrp on my amd fx series processor, recently got an upgrade to ryzen, guess thats the issue.
 

ekin_strops

Senior Member
Apr 29, 2016
1,275
532
Munich
OnePlus 9 Pro
Okay will give it a try, previously i did install twrp on my amd fx series processor, recently got an upgrade to ryzen, guess thats the issue.

No, Ryzen has nothing to do with it. I'm using Ryzen long time ago.

---------- Post added at 21:36 ---------- Previous post was at 21:34 ----------

below is the attached screenshot of the error

Try downloading Minimal ADB, instal it to C, and run it with Admin rights. Also, try different USB port, try USB 2.0 port as 3.0 sometimes doesn't recognize the phone when it's in fastboot mode.
 

muham47

Senior Member
Mar 14, 2008
116
3
HyD
No, Ryzen has nothing to do with it. I'm using Ryzen long time ago.

---------- Post added at 21:36 ---------- Previous post was at 21:34 ----------



Try downloading Minimal ADB, instal it to C, and run it with Admin rights. Also, try different USB port, try USB 2.0 port as 3.0 sometimes doesn't recognize the phone when it's in fastboot mode.

okay so i downloaded minimal ADB and tried via that and i encountered different error this time, i have attached the screenshot
 

Attachments

  • Capture.PNG
    Capture.PNG
    40.8 KB · Views: 5,039

muham47

Senior Member
Mar 14, 2008
116
3
HyD
i tried using the command 'fastboot boot twrp-3.2.3-2-beryllium.img' and its just paused
 
Last edited:

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Make.sure your twrp recovery is stored and located in your adb folder where you'll be running the adbpowershelle menu..
1. Fastboot flash recovery name_of_recovery.img
2. Fastboot boot recovery name_of_recovery.img

Have you tried this??

yes, as soon as i try the "1. Fastboot flash recovery name_of_recovery.img" i get the message 'Error (Failed....)' and when i directly try the 2nd thing you mentioned, it just stays there nothings happening
 

santiagoruel13

Senior Member
May 9, 2012
658
254
34
Santa Maria, Ilocos Sur
Huawei P40 Pro
Are you sure your poco has an unlocked boot loader?? Cant say if its because of amd. Coz my pc. Also has amd a7.. with windows 10 pro. And its working fine with me..
Ah. I forgot.. do you have any antivirus? My SMADAV prevented me from accessing any vbsscript or any windoes script. And cant get to work with powershell or adb.. until i find out SMADAV IS THE CULPRIT..
 
  • Like
Reactions: elaizamae16

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Are you sure your poco has an unlocked boot loader?? Cant say if its because of amd. Coz my pc. Also has amd a7.. with windows 10 pro. And its working fine with me..
Ah. I forgot.. do you have any antivirus? My SMADAV prevented me from accessing any vbsscript or any windoes script. And cant get to work with powershell or adb.. until i find out SMADAV IS THE CULPRIT..

yes, bootloader unlocked, debugging enabled, no anti-virus, only windows security enabled. Do you think is it related to latest MIUI update which is preventing TWRP to install ?
 

Top Liked Posts