TWRP Error (FAILED (Write to device failed (Invalid argument))

Search This thread

santiagoruel13

Senior Member
May 9, 2012
658
254
34
Santa Maria, Ilocos Sur
Huawei P40 Pro
Bro. Try changing your ports.
Searched google for your problem. And someone also have encountered that problem.. and says it was solved by changing ports

---------- Post added at 08:10 PM ---------- Previous post was at 08:02 PM ----------

Or try changing cables...

---------- Post added at 08:18 PM ---------- Previous post was at 08:10 PM ----------

Or try this bro..
Option 2
TWRP Installer

Download TWRP Installer and transfer in C: of your computer.
Fastboot your Poco F1 and plug it
Open TWRP Installer folder and click (run as administrator) twrp-installer.bat

https://forum.xda-developers.com/poco-f1/how-to/xiaomi-poco-f1-unlock-bootloader-custom-t3839405
 
  • Like
Reactions: elaizamae16

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Bro. Try changing your ports.
Searched google for your problem. And someone also have encountered that problem.. and says it was solved by changing ports

---------- Post added at 08:10 PM ---------- Previous post was at 08:02 PM ----------

Or try changing cables...

---------- Post added at 08:18 PM ---------- Previous post was at 08:10 PM ----------

Or try this bro..


https://forum.xda-developers.com/poco-f1/how-to/xiaomi-poco-f1-unlock-bootloader-custom-t3839405

I've done 2 things which you mentioned except for different cable, will try it out and let you know.
 

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Bro. Try changing your ports.
Searched google for your problem. And someone also have encountered that problem.. and says it was solved by changing ports

---------- Post added at 08:10 PM ---------- Previous post was at 08:02 PM ----------

Or try changing cables...

---------- Post added at 08:18 PM ---------- Previous post was at 08:10 PM ----------

Or try this bro..


https://forum.xda-developers.com/poco-f1/how-to/xiaomi-poco-f1-unlock-bootloader-custom-t3839405

change of cable didnt work either, plus i noticed one weird thing, the Mi PC Suite won't recognize my device. :confused:
 

santiagoruel13

Senior Member
May 9, 2012
658
254
34
Santa Maria, Ilocos Sur
Huawei P40 Pro
Then you must first re install mi drivers..

---------- Post added at 10:18 PM ---------- Previous post was at 10:12 PM ----------

Why dont you try to un install all.
Reboot your pc.
Reinstall adb and fast boot drivers
Re install mi flash tool (for drivers)
Then dis able your all anti virus..
 

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Then you must first re install mi drivers..

---------- Post added at 10:18 PM ---------- Previous post was at 10:12 PM ----------

Why dont you try to un install all.
Reboot your pc.
Reinstall adb and fast boot drivers
Re install mi flash tool (for drivers)
Then dis able your all anti virus..

done, still same issue..in my device manager when i connect my device in fastboot, it says "LeMobile Bootloader Devicer" and when i drop down, i get "Android Bootloader Interface" when i try to update it says already latest driver.
 
Lol you doing it wrong , flash twrp recovery first .
Use the commands as follow
1. Fastboot devices
2.fastbbot flash recovery (twrp file name .IMG)
3.fastboot boot (twrp file name.img):fingers-crossed:

---------- Post added at 05:04 PM ---------- Previous post was at 05:03 PM ----------

Private message me if you still getting errors
 

muham47

Senior Member
Mar 14, 2008
116
3
HyD
Lol you doing it wrong , flash twrp recovery first .
Use the commands as follow
1. Fastboot devices
2.fastbbot flash recovery (twrp file name .IMG)
3.fastboot boot (twrp file name.img):fingers-crossed:

---------- Post added at 05:04 PM ---------- Previous post was at 05:03 PM ----------

Private message me if you still getting errors

Lol bruh, i already did what you mentioned like a hundred times already.
 

rkmadotra

Senior Member
Jan 17, 2014
190
274
31
jind
same issue

i m facing same issue as you do. i unlocked my poco like 6 months ago and flashed twrp without any error. but as of now 11.06.2019 its not working any more. i think xiaomi has disabled this command in lastest updates. sad thing. :(
 
  • Like
Reactions: mickrussom

pvscz

Member
Jan 10, 2016
15
7
I was in the same situation today, after OTA update to MIUI 10.3.6. Standard ADB and FASTBOOT commands (like devices, reboot, etc.) worked, except of flashing to phone.
Of course bootloader unlocked and all previous rom versions rooted/TWRP flashed without any issues...

Final solution for me was just reboot notebook, nothing else.
 

hasn1212

New member
Oct 20, 2019
1
0
have the same issue on mi mix 3

are there any news ? does anyone know how to solve this case `?
 

Jamith

Senior Member
Oct 12, 2011
108
57
Porto Alegre
I had some issues too, I solved it by disconnecting the phone, exexuting the bootloader flash command and after getting "waiting for device" plug the phone back in the computer. This was back in January with my ryzen 1st gen.

OMG thanks, after many attempts to flash the boot image with fastboot this worked flawlessly, many thanks. Ryzen 7 1700 here.
 
D

Deleted member 1228373

Guest
Hi guys. Using a Mix 3 and keep getting the same error.
Tried other USB-port (mine has USB 2.1 and 3), cable in and out (waiting) etc.
What to do? need an other version of TWRP. Can't flash roms anymore with old one (aaaggh)
 

sinar.bonar

New member
Dec 29, 2017
4
0
I got same issues. My solution is :
1. User Google Android ADB Interface Driver
2. Unplug USB Cable
3. Reboot Poco F1 In Fastboot (Repeat Until success)
 

Top Liked Posts