[TWRP][owens] TWRP for Moto E4 Plus (Qualcomm)

Search This thread

bcrichster

Senior Member
Jun 6, 2013
1,218
833
can you give me the correct steps to flash another rom so i don't mess up again...??
- Flash TWRP and format encryption, totally remove encryption for best results if that's already done, proceed to next step..
- ROM
- Magisk
- Gapps
- Wipe caches
- Reboot

Sent from my owens using Tapatalk
 
  • Like
Reactions: IJoxer

DJBhardwaj

Recognized Contributor
Apr 23, 2011
5,050
2,690
27
Delhi
that's twrp for nicklaus.

err on the side of kindness

Oh, yeah, the MediaTek variant.

I have a spare E4 Plus at hand, just took it out of the drawer. I was thinking of upgrading it to Pie via a custom ROM.

So, if I am not wrong, the following is I will need to do to flash a ROM:
1) Flash TWRP on my SD variant
2) Boot into TWRP. Go to Wipe > Format Data and then enter "yes" to wipe the /data partition
3) Flash Zackptg5's Universal DM-Verity, ForceEncrypt disabler
4) Flash the ROM + GApps + Magisk v20.0 for root
5) Reboot.

Is that correct?
 

tripinva

Member
Aug 2, 2018
6
0
Does anyone have a copy of the stock recovery? I'm trying to root an E4 Plus (owens) and TWRP gets stuck at the loading screen. I saw someone say that TWRP will load if flashed, but I generally prefer to just boot TWRP and install Magisk, so I want to revert to the stock recovery after flashing TWRP to root the device.

- Trip
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    TWRP for the Moto E4 Plus (Qualcomm)

    Based heavily on squid2's TWRP device tree for the Moto E4 (Qualcomm) - See here for more information.

    Seems to work fine, but use at your own risk, std_disclaimer.h, etc.

    Use fastboot to test or boot this recovery.

    To test:
    Code:
    fastboot boot recovery.img

    To flash:
    Code:
    fastboot flash recovery recovery.img

    XDA:DevDB Information
    TWRP for Moto E4 Plus Qualcomm (owens), Tool/Utility for the Moto E4 Plus

    Contributors
    ReimuHakurei, squid2
    Source Code: https://github.com/ReimuHakurei/twrp_device_motorola_owens


    Version Information
    Status: Stable
    Current Stable Version: 3.1.1
    Stable Release Date: 2017-10-30

    Created 2017-10-30
    Last Updated 2017-10-30
    5
    WARNING: Don't do factory reset or update from system

    This version of TWRP is not reading and clearing the bootloader control block (BCB). So, if you do a factory reset via Settings->Backup & Reset->Factory Data Reset, you'll be stuck in a TWRP bootloop.

    The quick workaround is to reboot to bootloader, then proceed from there to Start. However, you'll need to do this *every* time until the BCB is cleared.

    To clear the BCB manually, issue this command in TWRP terminal:

    Code:
    dd if=/dev/zero of=/dev/block/bootdevice/by-name/misc bs=1M

    Or alternatively, just issue the following command from the bootloader:

    Code:
    fastboot erase misc

    @ReimuHakurei: I tried to fix a similar problem with a non-standard BCB offset on Rockchip devices. The BOARD_RECOVERY_BLDRMSG_OFFSET makefile variable is used to set BCB offset for command-line arguments in the /misc partition. However, the code to convert it to the precompiler directive was removed. I submitted a change to restore it in an appropriate context, but I don't believe it was ever checked in.
    4
    Got Root on Qualcomm E4 plus! ( BOOST MOBILE )

    Just tried this on my Boost Mobile E4 plus and it worked. I also used the the no-verify zip and Magisk 14.0 to root.

    Can use this guide and just swap out the twrp.img with the recovery.img from this thread:

    https://forum.xda-developers.com/moto-e4/how-to/moto-e-guide-to-rooting-t3652982
    4
    How did you get substratum to run?


    With permission I want to post like a compete guide for root, BusyBox etc so it's all in one place. I'm doing a bit of cleaning but I can either pm or make a subject and the compendium! I don't want credit just want it to be easier for us e4+ peeps
    3
    Has any one tried this? Does that mean it can be rooted as well? I thought the bootloader had to be unlocked which is not available with qualcomm e4 plus?

    I have a model from Sprint, and it's unlockable, just not on the official list -- I successfully unlocked mine.

    Rooting is also possible -- use phh's; SuperSU doesn't seem to work: https://superuser.phh.me/superuser-r259.zip
    https://play.google.com/store/apps/details?id=me.phh.superuser&hl=en
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone