TWRP recovery error 7

Search This thread

tanmeshn

Senior Member
Mar 14, 2016
280
67
Xiaomi Poco X3 NFC
I flashed this official lineage os for zuk z1 , which is the first build but I am getting error 7 in TWRP while flashing and the installation is aborted. I am attaching screenshots taken of the error I encountered, please kindly check and give me any solution to this problem:confused::rolleyes:
I am using TWRP 3.0.2
Last ROM :-Official CM13 18-12-2016 nightly
 

Attachments

  • Screenshot_2017-03-07-16-01-40.png
    Screenshot_2017-03-07-16-01-40.png
    178.4 KB · Views: 736
  • Like
Reactions: janny_buh

tanmeshn

Senior Member
Mar 14, 2016
280
67
Xiaomi Poco X3 NFC
turnoff signature verification in twrp setting

Tried turning off zip signature verification, it didn't help... Then I googled the problem, I found out that we should modify code in update_script... Decompress the file, that is
1) unzip the nightly zip
2) go into META-INF>com>Google>Android
There you'll find two files , select updater-script and rename it to updater-script.txt
It will convert into txt file so you can edit it.
3) delete the assert commands till last semicolon or delete all from assert till you see ”mount(ext......” (don't delete​ Mount....)
4) save the changes. Then again rename it that is from updater-script.txt to updater-script..
5) compress the file again into zip format.
There you go, you can flash this without any errors.... I tried this , it works fine...
Anyone have any other solution? No one's facing this issue?
I read that old bootloader is also one of the problem to get this issue? How to update bootloader?
 

VJ Guttula

Member
Feb 12, 2017
12
1
I flashed this official lineage os for zuk z1 , which is the first build but I am getting error 7 in TWRP while flashing and the installation is aborted. I am attaching screenshots taken of the error I encountered, please kindly check and give me any solution to this problem:confused::rolleyes:
I am using TWRP 3.0.2
Last ROM :-Official CM13 18-12-2016 nightly

http://forum.xda-developers.com/zuk-...overy-t3572069

Try this Version of TWRP, What i figured is like some versions of twrp do cause some problems,..

STEPS :-
1.) Download that Image file
2.) YOU DON'T HAVE TO WIPE ANYTHING IF YOU INSTALLED ANY ROM, BECAUSE YOU ARE JUST CHANGING YOUR TWRP VERSION.
3.) IT'S JUST THE WAY YOU FLASH A ZIP FILE BUT HERE WHEN YOU GO TO THE INSTALL OPTION BOTTOM RIGHT CHANGE INTO INSTALL IMAGE.
4.) SEARCH FOR THE IMAGE AND FLASH IT. AND THEN REBOOT THEN REBOOT INTO RECOVERY AND HAVE FUN FLASHING OFFICIAL LINEAGE.

----SENT FROM LINEAGE ZUK.
 
Feb 4, 2017
25
2
Indore
Tried turning off zip signature verification, it didn't help... Then I googled the problem, I found out that we should modify code in update_script... Decompress the file, that is
1) unzip the nightly zip
2) go into META-INF>com>Google>Android
There you'll find two files , select updater-script and rename it to updater-script.txt
It will convert into txt file so you can edit it.
3) delete the assert commands till last semicolon or delete all from assert till you see ”mount(ext......” (don't delete​ Mount....)
4) save the changes. Then again rename it that is from updater-script.txt to updater-script..
5) compress the file again into zip format.
There you go, you can flash this without any errors.... I tried this , it works fine...
Anyone have any other solution? No one's facing this issue?
I read that old bootloader is also one of the problem to get this issue? How to update bootloader?

Well,turning off signature verification worked for me after i clean flashed over unofficial los 14.1 and using twrp 3.1.0.0...
 

ameyau

Member
Dec 25, 2015
8
0
This worked for me,give a try
1.Wipe-> apvance wipe system dalvik data cache
2.flash unofficial recursion remix rom
3.Wipe-> apvance wipe system dalvik data cache
4.flash offical cm /los
5.flash gapps
 

ameyau

Member
Dec 25, 2015
8
0
Is this the only way?? There's no other way to do it without wiping data?
I shall recommend u to create a back up in twrp..
After that follow above steps
And after 1st boot..restore only data part...
If that dont work u have complete backup u can restore any time
 

tanmeshn

Senior Member
Mar 14, 2016
280
67
Xiaomi Poco X3 NFC
From stock cos12.1 I came to cm13 ... Then I flashed many roms like RR, nuclear ROM, mokee, unofficial LOS even ZUI.
Before flashing official LOS I had official cm13 nightly.. but before flashing Los I wanted to try ZUI nougat so I took backup of Cm13 ROM through TWRP then clean flashed ZUI 2.5.306 based on nougat. I didn't find this ROM interesting so I restored my previous ROM that is CM13...
Then after few days I did clean install of this official Lineage OS nightly and started getting this error 7 while installing...
 

ameyau

Member
Dec 25, 2015
8
0
From stock cos12.1 I came to cm13 ... Then I flashed many roms like RR, nuclear ROM, mokee, unofficial LOS even ZUI.
Before flashing official LOS I had official cm13 nightly.. but before flashing Los I wanted to try ZUI nougat so I took backup of Cm13 ROM through TWRP then clean flashed ZUI 2.5.306 based on nougat. I didn't find this ROM interesting so I restored my previous ROM that is CM13...
Then after few days I did clean install of this official Lineage OS nightly and started getting this error 7 while installing...
Internal data will be safe
Titanium backup can help to backup and restore... But unfortunately u have to clean install.. Unofficial rr rom (nougat)1st and then official Los.
 
Last edited:

ameyau

Member
Dec 25, 2015
8
0
Last edited:

tanmeshn

Senior Member
Mar 14, 2016
280
67
Xiaomi Poco X3 NFC
https://www.androidfilehost.com/?fid=385035244224405398 try this one..
I am not a developer so i cant suggest u on this link u posted...
I can suggest u another method.. It will work..
Backup cm13 with data in twrp..
Clean install unofficial(rr/los) rom nougat one..
Restore the back up
Now u can flash official los..
Hope this will help u

I'll try this once.. I hope it works out.. thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I flashed this official lineage os for zuk z1 , which is the first build but I am getting error 7 in TWRP while flashing and the installation is aborted. I am attaching screenshots taken of the error I encountered, please kindly check and give me any solution to this problem:confused::rolleyes:
    I am using TWRP 3.0.2
    Last ROM :-Official CM13 18-12-2016 nightly