TWRP recovery loop

Search This thread

slifer225

New member
Oct 3, 2016
3
0
0
So the case was I reset my device, and later after i flashed a ROM into my device, it does not boot. Instead, it goes into TWRP recovery. And it goes to TWRP every time i boot my device.

I have done this for so many times and I cannot even know what is going wrong this time. I am quite frustrated and I did googled a lot but it did not solve my problem. So, I want to know if anyone else encounter similar problem and solution towards it.

I tried:
1. Wipe the dalvik cache.
2. Remove the battery for half an hour
3. Reflash the twrp

Any efforts and reply is much appreciated.

Thank you.
 

andydgg

Member
Sep 1, 2014
28
0
0
Mine's exactly the same, I factory reset so I could pass the phone on; and now it will not install custom roms, I've tried about 7 or 8, and it will only boot into twrp 3.0.2-5. Soft brick, but I'm unable to find any solution.

Here's hoping someone will come and help.
I think I'll have to reinstall twrp by connecting the phone to the computer, but I've no idea how to do this.


So the case was I reset my device, and later after i flashed a ROM into my device, it does not boot. Instead, it goes into TWRP recovery. And it goes to TWRP every time i boot my device.

I have done this for so many times and I cannot even know what is going wrong this time. I am quite frustrated and I did googled a lot but it did not solve my problem. So, I want to know if anyone else encounter similar problem and solution towards it.

I tried:
1. Wipe the dalvik cache.
2. Remove the battery for half an hour
3. Reflash the twrp

Any efforts and reply is much appreciated.

Thank you.
 

slifer225

New member
Oct 3, 2016
3
0
0
Mine's exactly the same, I factory reset so I could pass the phone on; and now it will not install custom roms, I've tried about 7 or 8, and it will only boot into twrp 3.0.2-5. Soft brick, but I'm unable to find any solution.

Here's hoping someone will come and help.
I think I'll have to reinstall twrp by connecting the phone to the computer, but I've no idea how to do this.

Well i have took the ultimate solution. Back to stock firmware fix everything. Well, i guess not much to mention on stock firmware=)

I think you should do the same thing too. Good luck.
 
Last edited:

justwondering

Senior Member
Nov 18, 2010
343
44
28
Well i have took the ultimate solution. Back to stock firmware fix everything. Well, i guess not much to mention on stock firmware=)

I think you should do the same thing too. Good luck.

That is good to know, I shall attempt to do the same, did you later install a custom rom and everything was fine afterwards?
 

slifer225

New member
Oct 3, 2016
3
0
0
Yes, i flashed custom recovery and ROM afterward. Even several attempt on wipe and flash the new ROM. So i guess it should be fixed

Thank you.
 

svs36

Member
Mar 19, 2017
18
2
0
Mine's exactly the same, I factory reset so I could pass the phone on; and now it will not install custom roms, I've tried about 7 or 8, and it will only boot into twrp 3.0.2-5. Soft brick, but I'm unable to find any solution.

Here's hoping someone will come and help.
I think I'll have to reinstall twrp by connecting the phone to the computer, but I've no idea how to do this.

As slifer225 mentioned you can downgrade to stock firmware by installing the stock MM rom s433 version using spftools.
Download and Install stock MM rom using spftools.
Here is the link- https://cloud.mail.ru/public/Cco5/JYk3ytrW1
For further info follow this post- https://forum.xda-developers.com/k3-...3#post71749243
Follow this step by step guide to go back to unrooted stock rom. If you want to root after that then try installing custom recovery(twrp) again using spftools and flash supersu.zip using recovery. Do take a backup though before rooting your device.

---------- Post added at 10:11 AM ---------- Previous post was at 10:04 AM ----------

That is good to know, I shall attempt to do the same, did you later install a custom rom and everything was fine afterwards?
Everything is working perfectly as I myself had gone through the same issue and did everything to fix the problem until I downgraded back to stock. Did root on my device again and installed lineage 7.1.1 and it works like a charm. One thing I love about this rom is the efficient ram management, lag free but battery management is not upto the mark but I guess we can work it out.
Whatever you do never forget taking a backup of functional rom.
 

justwondering

Senior Member
Nov 18, 2010
343
44
28
Yes, I can confirm the solution worked for me, I left it with stock rom for my friend, I tried lineage 14.1 and did a factory reset, but ended once again with softbrick , lineage will install and work perfectly, but as soon as you do a factory reset, soft brick
 
Last edited:

andydgg

Member
Sep 1, 2014
28
0
0
Now I've hard bricked it. I loaded up a 'looprecovery' when it rebooted there's nothing, no charge light no vibrations PC doesn't see it, land fill?
 
Nov 26, 2009
10
0
0
27
Bucharest
gadget4u.ro
Wondering...

Exactly the same issue here too, installed lineage 14.1, was working great, I was selling to a friend, did a factory reset, now stuck at twrp, roms install etc, but after a reset, every time straight back to TWRP.

Looks like I might need to flash back to stock somehow.

But I did find this, but not yet tried.

https://www.reddit.com/r/LineageOS/comments/5riech/how_fix_twrp_recovery_boot_loop_after_lineageos/

I think that solution only works on Snapdragons. It didn't for me. Is there a solution for MTK devices?
 

Arjunism

Member
Oct 23, 2017
30
35
28
My phone TWRP-looped many times. The solution is actually easy.

1. Reflash using SPFlashtool ONLY the stock recovery
2. boot into stock recovery
3. choose english > press reboot phone
4. phone will reboot into rom without problemos
5. reflash TWRP
;) cheers

or
1. Copy stock recovery.img into sdcard
2. In twrp, select Install and navigate to where you put stock recovery.img
3. Press install image. Then, Select recovery.img. Slide to install
4. boot into stock recovery
5. choose english > press reboot phone
6. phone will reboot into rom without problemos
7. reflash TWRP
;) DONE
 
Last edited:

Pajorve

Senior Member
Jul 13, 2010
457
44
0
Osasco/SP
Infinity loop recovery

Now I've hard bricked it. I loaded up a 'looprecovery' when it rebooted there's nothing, no charge light no vibrations PC doesn't see it, land fill?

hI MY FRIEND , you have been able to fix your K3 note, I have the same problem, I made twrp flash and went into infinite loop. Can you help? thank you
 

Kartikey311

New member
May 12, 2018
1
0
0
Not working for Lenovo K3 Note.

My K3 note stuck in the twrp recovery after factory reset from the RR. I tried this solution but it didn't work.
Please help.