• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[TWRP][Root] Unofficial TWRP 3.5.0 Android 11 for Galaxy A50

Search This thread

JuanTamqd21

Senior Member
I have an A505FN. My experience so far:

I followed the guide but installed multidisabler 3.1, not 2.6.

It first seemed like I was stuck in boot, but it turned out that apparently that only happens if I do what the bootloader warning screen tells me and press the power button. If I do nothing it boots normally. Still weird.

Everything seemed in order until I tried installing Riru through Magisk.

After rebooting I could no longer unlock my phone. Entering my pattern just led to the screen going black and then returning to the lock screen. This persists after rebooting.

What's more, I cannot boot into Recovery either. That's seemingly because of the unlocked bootloader. The warning actually prevents the phone from being shut off, somehow, because seemingly the phone immediately reboots to show me the warning again. It also blocks the recovery button combo. Timing doesn't seem to matter, it just ignores it.

This is the first time I'm trying to root this phone and it's a mess. Much worse than my A5, which at least has the decency of behaving the same during boot even when modified. It's like Samsung is constantly looking for new ways to mess with rooters.

Any suggestions on how to fix this?
flash pass reset or manually delete locksettings.db in /data/system
 
  • Like
Reactions: otterwise

otterwise

Member
Sep 2, 2021
6
0
Thanks. I found out that in order to boot into recovery on recent firmware, the phone needs to be connected to a PC.

Yare yare.
 

otterwise

Member
Sep 2, 2021
6
0
I tried following the instructions in the OP again, but after flashing TWRP+Magisk and multidisabler, and rebooting, Magisk isn't detected by the Magisk app. It says "N/A".

Edit: Nevermind I forgot a step.

Also looks like a lot of my issues were caused by not realizing that the OS has to be launched every time in a special way to enable Magisk. Like you have to select reboot to recovery in Magisk to launch the system with Magisk enabled.
 
Last edited:

kslakhani

Senior Member
Jul 12, 2006
225
80
infront of ma HD2
I successfully installed on SM-A505F and works perfectly without any extra installs on Android 11

How can you reboot to non root mode? Device not booting in non root mode.
 

shethjay88

New member
Mar 30, 2019
4
0
Cant update magisk to 23 from within the app? I am stuck at the login screen asking passcode multiple times.
 

LucasUruguay

Senior Member
May 8, 2014
504
113
Samsung Galaxy A50
Anybodoy knows why its in bootloop for me? i do all the steps and know, when appear the screen with the warning, its all the time restarting.
Now i was waiting to the battery empty
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    TWRP 3.5.0 One UI 3.1 for Samsung Galaxy A50 Android 11. How to Root Samsung Galaxy A50 Android 11 with TWRP 3.5.0 + Magisk. The TWRP Recovery support Galaxy A50 One UI 3.1 Android 11 firmware. It may be works for SM-A505F, SM-A505FN, SM-A505G, SM-A505GN. The TWRP 3.5.0 comes with Magisk Patched. Use it at your own risk! Follow the instructions carefully and Make sure to backup all your important data!

    LET ME KNOW IF IT WORKS FOR:
    SM-A505FN, SM-A505G, SM-A505GN

    Manual Instructions for Flashing and Rooting
    1. Make sure the bootloader are unlocked, OEM unlock option is grey out
    2. Enter Download Mode
    3. Open ODIN, IMPORTANT!: Uncheck “Auto Reboot” in Options!
    4. Flashing TWRP as AP in ODIN, then click start.
    5. DO NOT SKIP THIS STEP! Don't remove USB Cable, let it connected. Press and hold Volume Down + Power Key, when the screen blank quickly press and hold Volume Up + Power key, when Samsung Logo appears release Power key only, keep pressing Volume Up key until TWRP Recovery Appears.
    6. Format data
    7. Install multidisabler-samsung-2.6.zip
    8. Reboot to Recovery
    9. When SAMSUNG logo appears wait for a few minutes or more then press and hold volume down + power key until the screen blank
    10. Setup the phone
    11. Connect Phone to Internet
    12. Install Magisk-v22.0.apk and Open it. Magisk will ask to do additional setups. Let it do its job and the app will automatically reboot your device.
    13. Done!
    Video Instructions - Details

    Download
    TWRP 3.5.0 A11
    Magisk22 app

    Thanks to:
    @neel0210 for Kernel Source
    @Enzoaquino for OrangeFox
    1
    D
    Deleted member 10623565
    Good work
    1
    1
    The twrp works but the multi disabler didn't work