TWRP stuck on splash screen?

Search This thread

otto888

Senior Member
I just got my 3T, flashed TWRP, flashed the new OOS Beta 2 build, and changed my 3T's splash image. Now out of nowhere, TWRP will get stuck in its logo. I didn't flash anything the last time it worked, it just randomly stopped working after a backup. I've gave it a few minutes, tried older/newer versions, and deleting the .twrps file on the internal storage. Does anyone know what's going on and how to fix it, preferably without wiping data?

Edit: I can boot into OOS just fine and everything but TWRP works.
 
Last edited:
  • Like
Reactions: loved.by.Jesus

mximer

Member
Jan 26, 2014
20
7
Dresden
I had the same problem a few hours ago...
I flashed the latest TWRP and then booted it via fastboot (fastboot boot twrp-3.0.3-1-oneplus3t.img.).
I waited 1-2 minutes, rebooted it into TWRP again (this time not via fastboot but with the buttons of the phone). After a few minutes I finally saw the usual TWRP UI.
I don't know why or how, but it worked.
 

otto888

Senior Member
I had the same problem a few hours ago...
I flashed the latest TWRP and then booted it via fastboot (fastboot boot twrp-3.0.3-1-oneplus3t.img.).
I waited 1-2 minutes, rebooted it into TWRP again (this time not via fastboot but with the buttons of the phone). After a few minutes I finally saw the usual TWRP UI.
I don't know why or how, but it worked.
Thanks. I had to wait about 6 minutes, but it worked.
 

amuzavali

Senior Member
May 2, 2014
230
60
Produlesti
OPPO A72
I have similar problem but for me just get black screen with only notification led on... I have tried everything (reflash, dm verity zip, swap zip, f2fs version etc.) but nothing work. Im using RR rom, EXT4, decrypted. Only way to boot recovery is "fastboot boot twrp.img"
Me to

Trimis de pe al meu ONEPLUS A3003 folosind Tapatalk
 

shadyabhi

Member
Jun 24, 2011
43
3
Bangalore
blog.abhijeetr.com
Same thing happened with me. Followed the usual "flash recovery" and "boot" approach. Got stuck at splash forever.

Removed the USB cable, turned off the phone. Started the phone with "Volume Down+Power" combination and it booted in recovery after a few minutes of the splash screen.
 
Last edited:

bowlandspoon

Senior Member
Last edited:

Mad Medik

Senior Member
Jan 28, 2006
399
83
The Hammer!
This a late addition to the thread but it will hopefully avoid continued confusion or new threads on the same subject. It seems that Nougat defaults to ext4 for the SYSTEM (and boot?) partitions but f2s2 for the DATA partition. TWRP will open within seconds with an EXT based partition but will take several minutes (eg 5-10) to open if your DATA is f2s2. You can live with it for now, or you can reformat your DATA partition to EXT4. Note that this will wipe out all of your data!
 

Osga21

Senior Member
Aug 3, 2013
71
50
I had the same problem recently, I found a solution on a reddit post somewhere;
Basically in terminal/CMD in fastboot mode wipe cache and userdata then reboot to recovery.

Code:
fastboot format cache
fastboot format userdata

Worked for me.
Disclaimer; Data will be lost!

Edit: found OP https://www.reddit.com/r/Nexus6P/comments/4agvpc/help_android_n_twrp_hangs_at_splash_screen/

Just replying to say this worked on my Redmi Note 3 even though this isn't the correct forum. Formatting cache only doesn't work, you must format both cache and userdata, so I hope you have a backup. I wonder what causes this...
 
  • Like
Reactions: speck1234

speck1234

Member
Jan 27, 2017
32
1
You sir are a saint. This command worked for me I was able to boot into TWRP

---------- Post added at 12:19 AM ---------- Previous post was at 12:17 AM ----------

I was able to boot into TWRP after formatting :D :D
Just replying to say this worked on my Redmi Note 3 even though this isn't the correct forum. Formatting cache only doesn't work, you must format both cache and userdata, so I hope you have a backup. I wonder what causes this...
 

BarcellosBR

Member
Dec 29, 2022
13
0
meu samsung j6 plus está travado no logotipo twrp alguém pode me ajudar?
my samsung j6 plus is stuck on the twrp logo can someone help me?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    I had the same problem recently, I found a solution on a reddit post somewhere;
    Basically in terminal/CMD in fastboot mode wipe cache and userdata then reboot to recovery.

    Code:
    fastboot format cache
    fastboot format userdata

    Worked for me.
    Disclaimer; Data will be lost!

    Edit: found OP https://www.reddit.com/r/Nexus6P/comments/4agvpc/help_android_n_twrp_hangs_at_splash_screen/
    3
    I had the same problem a few hours ago...
    I flashed the latest TWRP and then booted it via fastboot (fastboot boot twrp-3.0.3-1-oneplus3t.img.).
    I waited 1-2 minutes, rebooted it into TWRP again (this time not via fastboot but with the buttons of the phone). After a few minutes I finally saw the usual TWRP UI.
    I don't know why or how, but it worked.
    3
    Remember that it takes a while to boot up TWRP if you're using f2fs, the more files on the data partitions the longer it takes.

    true ! kernel source been released hopefully some one makes an advance stock kernel.
    1
    I just got my 3T, flashed TWRP, flashed the new OOS Beta 2 build, and changed my 3T's splash image. Now out of nowhere, TWRP will get stuck in its logo. I didn't flash anything the last time it worked, it just randomly stopped working after a backup. I've gave it a few minutes, tried older/newer versions, and deleting the .twrps file on the internal storage. Does anyone know what's going on and how to fix it, preferably without wiping data?

    Edit: I can boot into OOS just fine and everything but TWRP works.
    1
    I have similar problem but for me just get black screen with only notification led on... I have tried everything (reflash, dm verity zip, swap zip, f2fs version etc.) but nothing work. Im using RR rom, EXT4, decrypted. Only way to boot recovery is "fastboot boot twrp.img"