U696CL Old Thread - Android won't show up as USB device on VirtualBox after putting phone in ADB/EDL mode?

Search This thread

gregeerg

Senior Member
May 12, 2022
108
14
then adb exec-out is probably not working in general. do you have access to MicroSD Card meanwhile?

then create some directory on it and make dumps in there (where 0815-4711 is the UUID of my SD Card, yours is different!)

Code:
phhgsi_a64_ab:/ # cd /storage/????-????
phhgsi_a64_ab:/storage/0815-4711 # mkdir u696cl
phhgsi_a64_ab:/storage/0815-4711 # cd u696cl
phhgsi_a64_ab:/storage/0815-4711/u696cl # for b in $(ls /dev/block/*/*/*/by-name/!(userdata)); do dd if=$b of=${b##*/}; done
phhgsi_a64_ab:/storage/0815-4711/u696cl # sha256sum /dev/block/*/*/*/by-name/* | tee sha2.txt
EDIT: PizzaG has built a working TWRP! IF ANYONE HAPPENS TO GET THIS PHONE, PLEASE MESSAGE ME SO WE CAN PULL SUPER.IMG WITH THE STOCK ROM!

So, we have everything figured out *except* the recovery thing. We think something simply may just be wrong with the TWRP.img file and are trying to figure out what.
@Renate @aIecxs
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    EDIT: See the unofficial thread I made that has to do with the U696CL root and where we are:

    Been trying to figure this out for 5-6hrs now. My Linux VM on my Windows 10 PC detects my phone when plugged into my PC. Great. What I cannot figure out is how to get the phone to still show up when I re-boot it into EDL/ADB mode. It simply doesn't show up in my VM *nor* my PC. But when it's booted normally, it shows just fine on both. PLEASE help. For reference: https://forum.xda-developers.com/t/umx-u693cl-assurant-wireless.4085149/post-86882085
    1
    all it needs is linux and working method to enter EDL mode.

    I recommend to boot Xubuntu 20.04 LTS from pendrive and create a backup straight from pure linux instead (no more issues with vm usb passthrough)

    extract UMX-U693CL-FireHose_Programmer.mbn from UMX_U693CL-A-Team-Root_Recovery_Package.zip and see if it works for your device.

    device must listed as QDLoader 9008 mode in lsusb

    Code:
    edl --loader='/path/to/UMX-U693CL-FireHose_Programmer.mbn' rl dumps

    (run sudo apt update once then follow install instructions as descripted here)
    https://github.com/bkerler/edl
    1
    Factory Loader = Firehose programmer. the Loaders repo is a collection for other devices. "Install EDL Loaders" is for adding own firehose file to collection. you don't need this. just add the --loader flag to each command pointing to your own loader.

    "Device is in Sahara error state, please reboot device" is most likely caused by timeout. some devices only accept initiation during first 30 sec

    Wait, add —loader to what commands?
    EDIT: ok, I went into EDL mode again and very quickly ran the initial command you gave. It says “Firehose mode detected, uploading…” and is sitting there currently. Not sure how long that’s supposed to take but it’s been a good 18mins. I ran adb devices and phone isn’t showing there at the moment
    1
    .bin .mbn .elf file whatever name it has is irrelevant as it will be renamed. dirname doesn't matter you can name it tmp, newstuff, examples just put your file(s) somewhere.

    usage is (where ~/tmp is any directory with your own files and Loaders is existing target dir inside edl)
    Code:
    cd edl
    git submodule update --init --recursive
    fhloaderparse ~/tmp Loaders

    your linux is live distro from pendrive? you don't need this as you have to re-install everything on each boot anyway, its temporary linux like DVD so it's pointless.
    the only command needed is that from post #2 it's fine to test loaders. it seems like the loader is crashing your phone...
    I installed Xubuntu with my Windows so I can boot into either.
    So my commands in Terminal would look like this then if the Programmer you linked that I downloaded is at the newstuff folder?:
    Code:
    cd edl
    git submodule update --init --recursive
    fhloaderparse /home/name/edl/newstuff/ Loaders

    Because running that doesn't have seemed to change anything? Still empty folders.
    1
    you could also request user release source code in compliance to GPL. You can probably pick up in person between 9-5 in Shenzhen office :p