• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Ubuntu 20.04 - Asus Zenfone Max Pro M2 detected by adb but not by fastboot

Search This thread

heavenriver

New member
Oct 10, 2021
3
0
As the title suggests I have a Zenfone Max Pro M2. Currently running LineageOS 16 + TWRP 3.3.1.
I want to upgrade to LineageOS 18.1 so I thought I would update TWRP first, to the latest version (3.5.1). This is because when I installed LineageOS 16 I remember I had to upgrade TWRP for it to work (ROM wouldn't flash with older versions of TWRP).

I got my Android SDK tools from here: https://developer.android.com/studio/releases/platform-tools
I also have adb and fastboot that come from the standard Ubuntu repositories (installed with apt-get).

I'm following this guide to upgrade TWRP: https://twrp.me/asus/asuszenfonemaxprom2.html
And this guide to upgrade LineageOS: https://wiki.lineageos.org/devices/X01BD/install

With both versions of adb (standalone + from repos) it seems that my device is correctly detected:

# adb devices -l
List of devices attached
K9AXB76070808CH recovery usb:1-4 product:X01BD model:Zenfone_Max_Pro_M2 device:X01BD transport_id:2

But once I do adb reboot bootloader, and then fastboot devices, there are no devices showing in fastboot and I can't flash anything. Yes I have tried to run adb/fastboot as root, and obtained the same result.
I've done a lot of looking around on the web and I think this may be a driver issue, but I can't find any drivers for Linux that work with my phone model.

Can someone please help? Let me know if you need more info and I'll provide.
 
D

Deleted member 1890170

Guest
To get Fastboot work

1. enable OEM Unlock in Android's setting - and reboot phone

2. install on computer the official "Android USB Driver" suitable to your phone.
 
Last edited by a moderator: