Ulefone Power (Real Reviews & Discussion) 6050mAh, 5.5", Fingerprint ID, MTK6753

Search This thread

Fardenco

Member
Mar 17, 2015
25
2
Hi everyone,
I've been using this phone for about 1 month now, and I've to say I'm pretty disapointed. I've a lot of issues.
1) The jack plug. Seriously =0
2) Sim card randomly not detected
3) Top of the touchscreen randomly not working
4) Glitchy GPS, very bad precision, lose signal extremely easily
5) Very closed (not customisable) ROM (I used to be happy, with Cyanogen on my previous phone...). I hope it will be better with Android 6
6) Max headphone volume too weak
7) Screen luminosity randomly change (always to the same value, and yes, auto adjust is disabled)
8) Vibrations are just too weak, I miss every calls....
9) no gyro (I need it for better precision in VR)
10) Sometime I can't lock the phone, it's not frozen but the power button have no effect
11) Sometime, I don't receive notifications until I manually open the application ( mail, messenger, etc)
12) WiFi tethering not working well (can open a page on my phone in 1/4 sec but same page takes 20 sec to load on the computer. No problem with USB tethering)
13) Notification diode. Except the known issue, I find it's very weak and little (I liked the big one on my s4)
14) Minimum luminosity, I have to use an app to be able to use my phone in the dark without burning my eyes. Same for the colours, I find them very aggressive, I use "twilight" app to make them softer but on my previous phone, I was able to change this in my settings. I was also able to set luminosity to auto, with an offset (like Auto +2)

Some of these problems are software related, and I hope they'll be fixed soon !! But for the other ones...

Do you guys have the same issues ?

Sorry for my english
Fardenco
 
Last edited:

Fl1nt91

Senior Member
Oct 3, 2010
96
3
Hi everyone,
I've been using this phone for about 1 month now, and I've to say I'm pretty disapointed. I've a lot of issues.
1) The jack plug. Seriously =0
2) Sim card randomly not detected
3) Top of the touchscreen randomly not working
4) Glitchy GPS, very bad precision, lose signal extremely easily
5) Very closed (not customisable) ROM (I used to be happy, with Cyanogen on my previous phone...). I hope it will be better with Android 6
6) Max headphone volume too weak
7) Screen luminosity randomly change (always to the same value, and yes, auto adjust is disabled)
8) Vibrations are just too weak, I miss every calls....
9) no gyro (I need it for better precision in VR)
10) Sometime I can't lock the phone, it's not frozen but the power button have no effect
11) Sometime, I don't receive notifications until I manually open the application ( mail, messenger, etc)
12) WiFi tethering not working well (can open a page on my phone in 1/4 sec but same page takes 20 sec to load on the computer. No problem with USB tethering)
13) Notification diode. Except the known issue, I find it's very weak and little (I liked the big one on my s4)
14) Minimum luminosity, I have to use an app to be able to use my phone in the dark without burning my eyes. Same for the colours, I find them very aggressive, I use "twilight" app to make them softer but on my previous phone, I was able to change this in my settings. I was also able to set luminosity to auto, with an offset (like Auto +2)

Some of these problems are software related, and I hope they'll be fixed soon !! But for the other ones...

Do you guys have the same issues ?

Sorry for my english
Fardenco
Pretty the same, but i did't try few things
 

megthebest

Senior Member
Jul 18, 2014
1,370
653
goo.gl
Hi everyone,
I've been using this phone for about 1 month now, and I've to say I'm pretty disapointed. I've a lot of issues.
1) The jack plug. Seriously =0
2) Sim card randomly not detected
3) Top of the touchscreen randomly not working
4) Glitchy GPS, very bad precision, lose signal extremely easily
5) Very closed (not customisable) ROM (I used to be happy, with Cyanogen on my previous phone...). I hope it will be better with Android 6
6) Max headphone volume too weak
7) Screen luminosity randomly change (always to the same value, and yes, auto adjust is disabled)
8) Vibrations are just too weak, I miss every calls....
9) no gyro (I need it for better precision in VR)
10) Sometime I can't lock the phone, it's not frozen but the power button have no effect
11) Sometime, I don't receive notifications until I manually open the application ( mail, messenger, etc)
12) WiFi tethering not working well (can open a page on my phone in 1/4 sec but same page takes 20 sec to load on the computer. No problem with USB tethering)
13) Notification diode. Except the known issue, I find it's very weak and little (I liked the big one on my s4)
14) Minimum luminosity, I have to use an app to be able to use my phone in the dark without burning my eyes. Same for the colours, I find them very aggressive, I use "twilight" app to make them softer but on my previous phone, I was able to change this in my settings. I was also able to set luminosity to auto, with an offset (like Auto +2)

Some of these problems are software related, and I hope they'll be fixed soon !! But for the other ones...

Do you guys have the same issues ?

Sorry for my english
Fardenco
1) The jack plug. Seriously =0

never used it.. i use BT

2) Sim card randomly not detected
Never happened (only use 1 sim card)

3) Top of the touchscreen randomly not working
Never happened

4) Glitchy GPS, very bad precision, lose signal extremely easily
i used GPS for some trips, about 400km in the center and south of italy (Rome, Naples) and no particular issue...
5) Very closed (not customisable) ROM (I used to be happy, with Cyanogen on my previous phone...). I hope it will be better with Android 6

i solved when arrived, with my TWRP, Xposed + Gravity box and other customizations...

6) Max headphone volume too weak

engineering mode mtk is your friend...
7) Screen luminosity randomly change (always to the same value, and yes, auto adjust is disabled)
i used automatic brightness, no particular issues .. try to calibrate light senson in engineering mode mtk...
8) Vibrations are just too weak, I miss every calls....

sorry, but my vibration is good enough.. no issue also on this..

9) no gyro (I need it for better precision in VR)

this is an hardware missing, and is also absent in the tech specs.. if you need gyro, you have to choose another phone.. and different from 90% os Chinaphone..

10) Sometime I can't lock the phone, it's not frozen but the power button have no effect
never happened
11) Sometime, I don't receive notifications until I manually open the application ( mail, messenger, etc)
this happened also for me on some apps like whatsapp, hangouts etc... i hope Ulefone will fix it.. we asked to Ulefone support many times.. and they promise a fix (or i hope that new android 6 will fix it)
12) WiFi tethering not working well (can open a page on my phone in 1/4 sec but same page takes 20 sec to load on the computer. No problem with USB tethering)
i use tethering with my Power.. no issue using wifi connection and share connection with other phones... never tested with notebook o pc
13) Notification diode. Except the known issue, I find it's very weak and little (I liked the big one on my s4)

the issue is that it's only blue light.. but i like his brightness... also i like the backlight soft on the soft keys

14) Minimum luminosity, I have to use an app to be able to use my phone in the dark without burning my eyes. Same for the colours, I find them very aggressive, I use "twilight" app to make them softer but on my previous phone, I was able to change this in my settings. I was also able to set luminosity to auto, with an offset (like Auto +2)
I think that your sample is buggy..

one question.. are you using last rom of 23rd of february?
 

Krauthaus

Member
Sep 21, 2008
35
11
ulefone problems

Hi everyone,
I've been using this phone for about 1 month now, and I've to say I'm pretty disapointed. I've a lot of issues.
1) The jack plug. Seriously =0

I chopped the plug from the ulefone headphones off and attached it to my akg headphones. Working perfectly.

2) Sim card randomly not detected

Never had this, but i only use one sim card and a micro-sd card.

3) Top of the touchscreen randomly not working
Never had this problem.

4) Glitchy GPS, very bad precision, lose signal extremely easily
My GPS signal is really strong, until now i had no problems with it.

5) Very closed (not customisable) ROM (I used to be happy, with Cyanogen on my previous phone...). I hope it will be better with Android 6
I also use xposed and gravitybox and modded a few things.

6) Max headphone volume too weak

My volume is really ok, but i never listen at max volume, so might i am the wrong person to answer this.

7) Screen luminosity randomly change (always to the same value, and yes, auto adjust is disabled)
Never had this. Might your brightness sensor works not proper?

8) Vibrations are just too weak, I miss every calls....
Yes and no. It is weaker than my old phone was, but its still ok.

9) no gyro (I need it for better precision in VR)
Well, the phone do not have a gyrosensor.

10) Sometime I can't lock the phone, it's not frozen but the power button have no effect
Never happened for me.

11) Sometime, I don't receive notifications until I manually open the application ( mail, messenger, etc)

Yup, same for me.

12) WiFi tethering not working well (can open a page on my phone in 1/4 sec but same page takes 20 sec to load on the computer. No problem with USB tethering)

Just plugged it in and tested it, everything is working fine for me.

13) Notification diode. Except the known issue, I find it's very weak and little (I liked the big one on my s4)
My old phones diode burned out four years ago, so i am really happy with the new one. (Because i am used to have no one xD

14) Minimum luminosity, I have to use an app to be able to use my phone in the dark without burning my eyes. Same for the colours, I find them very aggressive, I use "twilight" app to make them softer but on my previous phone, I was able to change this in my settings. I was also able to set luminosity to auto, with an offset (like Auto +2)
I not noticed problems here.

Some of these problems are software related, and I hope they'll be fixed soon !! But for the other ones...

Do you guys have the same issues ?

Sorry for my english
Fardenco

It sounds like you got a buggy one, i suggest you to ask for a replacement.

Edit: I use the first rom from needrom. (the oldest)
 
Last edited:

LordMobias

New member
Mar 8, 2016
1
0
How would you go around to updating to the 23 FEB rom? The inphone update software tells me I have the latest version. :\
 
Last edited:

rl4engx

Member
Feb 29, 2008
6
0
Internal SD Cards now not recognised?

Hi All, I've had my phone for just over a month, running great with a SanDisk Ultra 32GB card, however I wanted to upgrade to a 128GB, so did the following:

1) Remove microSD card from phone (I think it was switched on)
2) Inserted into PC card reader, copied all files (inc. hidden) to a folder
3) Inserted the 128Gb card into reader, copied all the files back (I think it was already formatted as xFAT?)
4) Inserted 128Gb card into phone (I think it was switched on)

Now, on this and my other 32Gb card, the phone doesn't recognise it. No notification saying it needs to be mounted, in Settings -> Storage it only shows Internal Phone Storage, "Mount SD Card" is greyed out, I've looked in the Engineer Mode but that can't see it. The cards still work in the PC reader and I've tried (quick) formatting them all to NTFS/FAT/xFAT, rebooting phone, rebooting with no card in, power off, switch card with power off, long 8 sec power press, clean the contacts, "jiggle" the card tray in and out. Nothing. :(

It seems to never recognise any card now so most of my apps don't work. Any ideas what could be wrong? I've got the OTA update T875_GQ3026AF_BOM6_Power_20160129 ROM.

Any help appreciated, I've been very happy with this phone so far. :(
 

swamptastic

Member
Jan 6, 2016
7
0
Laaaaag

Super! Anyone else experiencing laggy gps?

I'm getting serious lag and lockups happening, I have no apps open, I have cleared down recent apps, killed tasks and I still get a massive lag opening app drawer etc sometimes. Have had to reboot a few times. Thought it might be the rom, so I have flattened the phone and installed stock rom with TWRP, only basic apps, but still having problems.
 

Fl1nt91

Senior Member
Oct 3, 2010
96
3
Hi All, I've had my phone for just over a month, running great with a SanDisk Ultra 32GB card, however I wanted to upgrade to a 128GB, so did the following:

1) Remove microSD card from phone (I think it was switched on)
2) Inserted into PC card reader, copied all files (inc. hidden) to a folder
3) Inserted the 128Gb card into reader, copied all the files back (I think it was already formatted as xFAT?)
4) Inserted 128Gb card into phone (I think it was switched on)

Now, on this and my other 32Gb card, the phone doesn't recognise it. No notification saying it needs to be mounted, in Settings -> Storage it only shows Internal Phone Storage, "Mount SD Card" is greyed out, I've looked in the Engineer Mode but that can't see it. The cards still work in the PC reader and I've tried (quick) formatting them all to NTFS/FAT/xFAT, rebooting phone, rebooting with no card in, power off, switch card with power off, long 8 sec power press, clean the contacts, "jiggle" the card tray in and out. Nothing. :(

It seems to never recognise any card now so most of my apps don't work. Any ideas what could be wrong? I've got the OTA update T875_GQ3026AF_BOM6_Power_20160129 ROM.

Any help appreciated, I've been very happy with this phone so far. :(
Probably some contacts has broken
Bye micro SD

Same for me...
 

Krauthaus

Member
Sep 21, 2008
35
11
Hi All, I've had my phone for just over a month, running great with a SanDisk Ultra 32GB card, however I wanted to upgrade to a 128GB, so did the following:

1) Remove microSD card from phone (I think it was switched on)
2) Inserted into PC card reader, copied all files (inc. hidden) to a folder
3) Inserted the 128Gb card into reader, copied all the files back (I think it was already formatted as xFAT?)
4) Inserted 128Gb card into phone (I think it was switched on)

Now, on this and my other 32Gb card, the phone doesn't recognise it. No notification saying it needs to be mounted, in Settings -> Storage it only shows Internal Phone Storage, "Mount SD Card" is greyed out, I've looked in the Engineer Mode but that can't see it. The cards still work in the PC reader and I've tried (quick) formatting them all to NTFS/FAT/xFAT, rebooting phone, rebooting with no card in, power off, switch card with power off, long 8 sec power press, clean the contacts, "jiggle" the card tray in and out. Nothing. :(

It seems to never recognise any card now so most of my apps don't work. Any ideas what could be wrong? I've got the OTA update T875_GQ3026AF_BOM6_Power_20160129 ROM.

Any help appreciated, I've been very happy with this phone so far. :(

try following:

open cmd
type diskpart
select your card in the reader (select disk=x)
type clean
type create partition primary
type active
type format fs=fat32 QUICK
type assign

<- This will completly format and repartition your sd card, so backup first! This helped me a few times with similar problems. (You could also try a factory reset on your phone, might this could help.)
 
Last edited:

megthebest

Senior Member
Jul 18, 2014
1,370
653
goo.gl
Hi All, I've had my phone for just over a month, running great with a SanDisk Ultra 32GB card, however I wanted to upgrade to a 128GB, so did the following:

1) Remove microSD card from phone (I think it was switched on)
2) Inserted into PC card reader, copied all files (inc. hidden) to a folder
3) Inserted the 128Gb card into reader, copied all the files back (I think it was already formatted as xFAT?)
4) Inserted 128Gb card into phone (I think it was switched on)

Now, on this and my other 32Gb card, the phone doesn't recognise it. No notification saying it needs to be mounted, in Settings -> Storage it only shows Internal Phone Storage, "Mount SD Card" is greyed out, I've looked in the Engineer Mode but that can't see it. The cards still work in the PC reader and I've tried (quick) formatting them all to NTFS/FAT/xFAT, rebooting phone, rebooting with no card in, power off, switch card with power off, long 8 sec power press, clean the contacts, "jiggle" the card tray in and out. Nothing. :(

It seems to never recognise any card now so most of my apps don't work. Any ideas what could be wrong? I've got the OTA update T875_GQ3026AF_BOM6_Power_20160129 ROM.

Any help appreciated, I've been very happy with this phone so far. :(
the old 32gb card is still read by card reader on a pc? have you tried to format it?
the 128Gb is correctly recognized by the phone?
I'm getting serious lag and lockups happening, I have no apps open, I have cleared down recent apps, killed tasks and I still get a massive lag opening app drawer etc sometimes. Have had to reboot a few times. Thought it might be the rom, so I have flattened the phone and installed stock rom with TWRP, only basic apps, but still having problems.
probably hardware issue... sorry:(
 

rl4engx

Member
Feb 29, 2008
6
0
@Fl1nt91

You have the uleFone Power too? What were your symptoms of how the SD failed? This was literally the 2nd time I'd put an SD card in so I can imagine if this is a hardware issue it will start affecting a lot of phones, where the microSD card is, is also the SIM2 slot so there must be some kind of dual array of contacts there.
@Krauthaus
Many thanks I tried that on my 32Gb card (128Gb wouldn't let me FAT32 quick format, I assume 128Gb can be formatted as FAT32?) but no joy, still not recognised. :(
@megthebest
Both cards are recognised by the PC, neither card is recognised by the phone now.

What are my other options short of a factory reset? Is there a way of clearing out some partition or something? Sorry I'm not that hot on rooting and ROMs etc, but might have to learn fast. :)

Cheers all,
 

Fl1nt91

Senior Member
Oct 3, 2010
96
3
@Fl1nt91

You have the uleFone Power too? What were your symptoms of how the SD failed? This was literally the 2nd time I'd put an SD card in so I can imagine if this is a hardware issue it will start affecting a lot of phones, where the microSD card is, is also the SIM2 slot so there must be some kind of dual array of contacts there.

@Krauthaus
Many thanks I tried that on my 32Gb card (128Gb wouldn't let me FAT32 quick format, I assume 128Gb can be formatted as FAT32?) but no joy, still not recognised. :(

@megthebest
Both cards are recognised by the PC, neither card is recognised by the phone now.

What are my other options short of a factory reset? Is there a way of clearing out some partition or something? Sorry I'm not that hot on rooting and ROMs etc, but might have to learn fast. :)

Cheers all,
On the first time i pull off the slot i saw a little metal piece comes out

At the beginning i tought was some clip or little spring, who cares
Later, when microsd didn't work, i supposed was a contact...
 

rl4engx

Member
Feb 29, 2008
6
0
On the first time i pull off the slot i saw a little metal piece comes out

At the beginning i tought was some clip or little spring, who cares
Later, when microsd didn't work, i supposed was a contact...

That's pretty grim, anyone got a photo of the internals/PCB/sliding tray area? I can imagine if it's a poorly designed it'd be easy for the tray to rip out a contact.. :(
 

megthebest

Senior Member
Jul 18, 2014
1,370
653
goo.gl
@Fl1nt91

You have the uleFone Power too? What were your symptoms of how the SD failed? This was literally the 2nd time I'd put an SD card in so I can imagine if this is a hardware issue it will start affecting a lot of phones, where the microSD card is, is also the SIM2 slot so there must be some kind of dual array of contacts there.

@Krauthaus
Many thanks I tried that on my 32Gb card (128Gb wouldn't let me FAT32 quick format, I assume 128Gb can be formatted as FAT32?) but no joy, still not recognised. :(

@megthebest
Both cards are recognised by the PC, neither card is recognised by the phone now.

What are my other options short of a factory reset? Is there a way of clearing out some partition or something? Sorry I'm not that hot on rooting and ROMs etc, but might have to learn fast. :)

Cheers all,
try to format with PC in fat32 file system, with this windows program:
http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm
 

f1c

Senior Member
Nov 5, 2015
94
20
I don't think this is software related anymore. If the phone couldn't read the card, it would ask if it could format the SD card for you.

I had an SD card fail recently on another phone and it was pretty noticable when it happened because the phone would slow down immensly. Whether it was when you booted or tried to open apps, it was lagging because it tried to read of the SD card which obviously didn't work well. It even caused the power button to sometimes not work or only work delayed. All of this was gone once the SD card was replaced though.
 

Krauthaus

Member
Sep 21, 2008
35
11
internal

2afy1bq.jpg

And here it is removed

Yes there are pictures.
 
  • Like
Reactions: vex0rg and Fl1nt91

rob1992

Member
Feb 5, 2016
49
10
The phone is pretty easy to take apart, but as per usual the battery is glued in. And the rf shielding is soldered on instead of by a clip system.
 

f1c

Senior Member
Nov 5, 2015
94
20
I take it getting to the sim card tray isn't as easy as removing the metal under the part with the sticker (where someone wrote on it with a blue pen) but on the other side of the board?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    yeah...
    TWRP (Three Themes Version READY)
    http://www.needrom.com/download/twrp-2-8-7-3-megthebest-6/

    Choose the one you like much..
    Material DARK


    Material Play


    Classic Style



    a thanks is really Appreciated!
    12
    DISCLAIMER:
    Rooting your phone and using custom Recoveries and ROMS have risks and may result in bricking your device, and has nothing to do with Google or the device manufacturers. In case of any mishap I am not responsible if you brick/ruin your phone in any way.
    Basic computer skills are required and minimal knowledges about phones and phones utilities too.
    Make sure that whatever you do, you are doing it at your own responsibility.

    How to root :

    You need to download four files

    1. TWRP for your ROM version
    2. SP_Flash_Tool
    3. UPDATE-SuperSU-<version>.zip
    4. MTK_Drivers_carliv_repack_win7_x64.zip

    Copy UPDATE-SuperSU-v<latest>.zip to your internal storage card on your phone. You will need this later.

    In Windows (not virtualbox) extract the recovery, SP_Flash_Tool_5.1532.00.000_Windows.zip and MTK_Drivers_carliv_repack_win7_x64.zip

    Go to the MTK_Drivers_carliv_repack_win7_x64 folder and click flash_tool

    Then Click the Download tab at the top.

    In that window click the Scatter Loading button and browse to the TWRP folder and select the scatter file.

    Click Download.


    Turn off your phone
    Plug the USB cable into your phone and into the computer
    Don't turn on your phone
    When the Windows driver installer pops up cancel searching Windows Update and make it install the driver from MTK_Drivers_carliv_repack_win7_x64
    You may have to force this by agreeing to install a non-signed driver, don't worry, it will still work.

    Your phone should stay on a black screen, if not do this again until Windows has the correct driver.

    You need to have the Preloader driver installed, once it is the flash_tool will flash the recovery.

    The phone boots to Preloader then normal boot, if you miss the preloader option you have to restart and try again.

    If your phone does not reboot (mine did not) you need to turn off the phone and then turn it on while holding Volume +

    You will get three options on the screen
    Recovery
    Fastboot
    Normal

    You change the option with volume +
    You choose the option with volume -

    We want recovery

    In Recovery
    The volume buttons move up and down
    Power selects the option you are on

    You need to Install Zip
    choose file from /sdcard
    0/
    UPDATE-SuperSU-<version>.zip

    After installation choose reboot and YES fix root!

    Your phone will restart and you will now have root access.
    10
    Ulefone Power (Real Reviews & Discussion) 6050mAh, 5.5", Fingerprint ID, MTK6753

    Full UNBOXING video

    Camera & 3D Gaming Review

    Full Complete IN-DEPTH Review

    In this video I show you some Ulefone Power camera samples & a video clip (1:23). I also compare some few pictures with the Samsung Galaxy S6 Edge (00:18), so you can get an idea about the quality. The original HQ pictures can be found here: http://mediafire.com/folder/96gyk9onaa0n5/Ulefone_Power_Camera_Samples

    (1:57) Part two in the video is all about gaming on the Ulefone Power. I test 8 different light & heavy 3D games and show you how they perform on the phone. I test Real Racing 3, Need For Speed, Modern Combat 5, Asphalt 8 and others.

    (12:13) Part three, I show you the AnTuTu score with AnTuTu version 6.0 and the very dimmed backlight in the touch buttons (12:20), close-up so you can see it.

    More Ulefone Power videos here:
    https://www.youtube.com/watch?v=ah40iOtEemI (Hands-on by Gizchina)
    https://www.youtube.com/watch?v=dV5hoyhnerg (Review en Español)
    https://www.youtube.com/watch?v=-MTlyqusY_s (by ITXTutor)

    Known problems so far? (24/1 2016)
    Asphalt 8 is only running with software rendering. So far the only 3D game that has a problem with the phone. Other games like Modern Combat 5, Real Racing 3 or Dead Trigger 2 all run fine and fast.

    ROM & Updates?
    There are in fact some updates out, that can't be found via OTA Wireless Update on the phone.
    The updated ROMs can be found on Needrom - just search for "Ulefone Power" on Needrom. I can not link directly to them here.

    And the battery?
    I have run a Geekbench 3 battery test (on screen time) on the device and got 20 hours, before it died, but unfortunately Geekbench 3 didn't allow me to upload the results. So it can not be found online. But expect 3-4 days good battery life with normal usage.

    The Fast Charger can charge the phone from 0-100% in 120 minutes! (I checked it) that is really good.... the charger gives 1.66A output.

    Regarding the battery mAh capacity:
    I have measured the battery capacity mAh, you can have a look here: (to 5958mAh with a normal charger)
    http://peecee.dk/uploads/012016/POWER-S7YLER.jpg

    To that you probably need to subtract a bit still, as some will be lost. But seems to be legit.
    I was not able to measure the correct capacity with the included fast charger, so I measured it while it just charged via a normal 5V 1A charger.

    In real life, I have used it as daily driver, and I could go 3 1/2 day before I had to put it to the charger, so expect 3-4 days battery life. Depending on the usage.

    Will this phone work in my country with my carrier?
    I can't answer you on that, but you can check it on these 2 sites:
    http://www.willmyphonework.net
    http://www.frequencycheck.com

    Highlights
    - 5.5 inch FullHD 1920x1080 pixels screen LTPS
    - 2.5D Curved Corning Gorilla Glass 3
    - Wood designed backcover
    - MTK6753 1.3 GHz octa core
    - 6050mAh Battery Sony Li-polymer Cell
    - IR Blaster
    - Support Pump Express Plus Quick Charging
    - CNC made full metal frame
    - Smart Key for Camera & Voice Recorder
    - Fingerprint Touch ID (360 degree, multifunctional)
    - 3GB of RAM + 16GB Rom
    - 13 MP Sony IMX214main camera + 5MP front camera OV5648
    - Android 5.1 System (Should also support Android 6.0 later)
    - USB On-The-Go / OTG / OTA
    - Dual SIM, Dual Standby, Dual 4G LTE
    - Supports 2G & 3G & 4G LTE Network
    - Network: GSM 850/900/1800/1900MHz, WCDMA 900/2100MHz, FDD-LTE B1/B3/B7/B8/B20

    Ulefone-Power_3-1600x900.jpg

    2-25.jpg
    10
    After receiving some good feedback, seems that my TWRP 3 for Power with latest Offical Rom 6.0 64 Bit 20160514 works:
    http://www.needrom.com/download/twrp-3-0-0-5/
    8
    If you need and like it, is available also my twrp 3.0.0 for Power:
    http://www.needrom.com/download/twrp-3-0-0-megthebest/



    TWRP 3.0.0 for ULEFONE POWER

    MULTILANGUAGE (more than 7 languages, Italian Translation thanks to freedgt/bovirus)

    Known Bugs

    - CPU TEMP remain ever at 0% and Time Zone seems to be wrong

    - Battery percentage not showed

    - Backup Directory not selectable is TWRP\Backup\8PYL*******

    GUIDE:

    Download and Install correctly Mediatek Preloader drivers

    ( Take care on Windows 8.1/10 drivers, you need to disable driver signature before install:)

    https://www.youtube.com/watch?v=50pD0mONm44

    http://laurentiumihet.ro/technology...-for-32-64-bit-drivers-installation-tutorial/

    https://thebroodle.com/microsoft/windows/install-mediatek-mt65xx-usb-vcom-drivers-windows-8-8-1/

    UNPACK RAR in A FOLDER

    1- With flashtool load*MT6753_Android_Scatter-TWRP 3.0

    2- Select download and connect smartphone to pc (smartphone must be powered off)…* in few seconds will start the process and the new TWRP will be flashed.

    To restore original stock recovery, you need load ad point 1 the file* MT6753_Android_Scatter-Stock.txt

    P.P.S to enter in the recovery, power off the smartphone, push VOL + and Power at the same time, you will see three words with VOL + you move selection, with VOL – you must select Recovery

    During first boot of twrp, allow modification of system files, according to this screen (if you leave read only, you loose TWRP at second boot):

    To have root flash with TWRP the archive supersu.zip found here:*https://download.chainfire.eu/696/supersu/

    Credits: TEAMWIN TWRP TEAM, https://twrp.me/site/update/2016/02/05/twrp-3.0.0-0-released.html

    PLEASE Donate if i help you and Support Me with 5 Stars!