Ultimate Guide For [BOOTLOOP RECOVERY] Noob Friendly

Search This thread
Jul 1, 2022

I'm stuck on TWRP, no way to load Android.
TWRP wasn't reading the partition so I tried to repair, pass to EXT2 and back to EXT4.
All got stuck on TWRP, I could only go to fastboot, at boot it goes back to TWRP automatically. The message on TWRP console is :

"Android Rescue Party trigger! Possible solutions?
Either :
1) Wipe caches, and/or
2) Format data, and/or
3) Clean - Flash your ROM

The reported problem is:
Unable to decrypt FBE device."

TWRP version 3.6.2_12-MI10Ultra_v3.7_A12
First ROM present on device: xiaomi.eu_multi_MI10Ultra_22.6.15_v13-12-fastboot.zip
Second time I tried to flash with fastboot and XiaomiFlash the same ROM, successfully installed, but I was still stuck in the loop.
Third time I flashed xiaomi.eu_multi_MI10Ultra_22.6.29_v13-12.zip with TWRP, successfully, but I'm still stuck on the same loop, Android won't load.

Please I need help, I use the phone for work and actually I've been without for a whole day.
How can i fix TWRP possibly without lose all my apps and data?


Senior Member
Mar 27, 2011
In the worst case you can always flash your original (stock)rom from your phone with the SP flash tool.
you will lose TWRP for the original recovery,but you can reflash the TWRP later with the same SP-Flash-Tool(only replace recovery.img for the TWRP.img in your unzipt stock rom and only point this recovery this time!!)(only flash the TWRPrecovery,unmark all the other stuff in the rom)
Last edited:
Jul 1, 2022
In the worst case you can always flash your original (stock)rom from your phone with the SP flash tool.
you will lose TWRP for the original recovery,but you can reflash the TWRP later with the same SP-Flash-Tool(only replace recovery.img for the TWRP.img in your unzipt stock rom and only point this recovery this time!!)(only flash the TWRPrecovery,unmark all the other stuff in the rom)
I already tried and not even this worked.

Can you please link me a correct stock ROM?
May be I chose a wrong one.


Senior Member
Sep 10, 2010
So I installed an app called CSWE App Manager and disabled some apps/services. Well, I must have disabled something I shouldnt have and my phone is bootlooping. It shows the Samsung splash logo and then after a few miniutes reboots and repeats.

Here is what I have done so far to troubleshoot:

I have taken out the sim/sd card.
I have booted into recover and wiped cache and factory data reset, but still no joy.
I downloaded new firmware and flashed via Odin. Got a sucessfull flash, but still bootloops even after that. I downloaded this firmware from SamMobile:

Product CodeXAA
CountryBluegrass Cellular (LRA)Cellular south (XAR)Comcast (CCT)Nextech / C-Spire (ACG)Spint (cdma) (SPR)Tracfone (TFN)USA (TMK)USA (USC)USA (AT&T) (ATT)USA (T-Mobile) (TMB)USA (Verizon) (VZW)Unknown (BST)Unknown (AIO)Unknown (XAA)Unknown (XAS)Virgin Mobile USA (VMU)Xfinity Mobile (CHA)
Unknown (XAA)
  • Unknown (XAA)
Security Patch Level2022-06-01
OS VersionAndroid 10
Build DateThu, 21 Jul 2022 23:19:55 +0000

I have tried everything and I cannot figure out why this is boot looping even after a successful ODIN and SamFirm flash. Anybody that can help me? I'm begging you.

Is there anyway to fix this? Can the storage on the phone be repartitioned and the stock software reinstalled? I don't see how the emmc could just fail like that. Especially after I was using CCSWE App Manger and disabled apps. Seems very coincidental that the emmc would fail right after doing that. I think I messed up the software with that app. I just don't know how to get it fixed.

{Mod edit: Link to paid application removed. Oswald Boelcke}
Last edited by a moderator:
{Mod edit: Link to paid application removed. Oswald Boelcke}
Hello and good morning, @Tenacious--M

I've removed the link to Google Play Store from your above post. Links to paid applications are only allowed under very special conditions as mentioned in rule no. 11 of the XDA Forum Rules.
Please refrain in future from sharing of paid applications on XDA. Thanks for your cooperation.

Oswald Boelcke
Senior Moderator
Apr 30, 2023
Stuck at a Bootloop on my galaxy A7 (2017) i installed a one ui icon pack or what do you call i have encountered a bootloop when i restart, ps i have a broken power button (installed using magisk, linage os 20 as rom)


New member
Aug 30, 2023
Hello, Can someone help me on a bootloop on my Samsung Galaxy J4 SM-J400M, The powered by Android and phone's logo appear but it immediatly restarts. I recently flashed TWRP and worked, I formatted the phone and installed SuperSU and Magisk (Later learned that I had to choose ONE of them.).Please help, I don't want to loose my phone (Luckily I made a backup of my important files.)

Top Liked Posts

  • There are no posts matching your filters.
  • 55

    Most people use the term "bricked" improperly. A bricked phone means one thing: your phone won't turn on in any way, shape or form, and there's Probably nothing you can do to fix it. It is, for all intents and purposes, as useful as a brick. A phone stuck in a boot loop is not bricked, nor is a phone that boots straight into recovery mode. These are things you can usually fix, and they're a lot more common than a truly bricked phone. If your phone is actually bricked, you Probably won't be able to fix it yourself.
    Start by removing the device's battery and wait for a few minute's before putting it back in your phone.
    OR Switch off for non-removable battery phones for five to ten minutes so it can remove any charge that is left in the phone and to initiate a complete power-cycle once you insert the battery.
    Now Boot the device into Recovery Mode by pressing and holding the relevant shortcut keys for your device. For instance, most Samsung devices can boot into Recovery Mode while pressing the key combination Volume Up, Home and Power (for tablets it is Volume Up and Power). If using a HTC phone, boot into HBOOT first by tapping Volume Down and Power button together and then browse to Recovery using Volume Up/ Down buttons. If you cant get it to boot in Recovery you can always use (ADB) and type in the command] > adb reboot recovery <--- Hit Enter now your Device will reboot into recovery mode. If your not familar with adb or even know what adb is there is a link on the bottom of this page for the sdk download and a gude on the adb.

    Now browse and select the option Wipe Data/Factory Reset in Recovery Mode.Check if the device can now boot into the newly installed ROM or firmware. If not, then perform Wipe Cache Partition And Return to the main Recovery menu and reboot the device by choosing Reboot System Now option.After Flashing or Installing a New ROM and If the device is already rooted with ClockworkMod Recovery (CWM) installed, then do the following steps (1) Remove you'r battery and reinsert it after 30 seconds. (2) Boot the device into CWM Recovery by pressing and holding Volume Up, Home and Power buttons together. NOTE: The key combination may vary depending on your device model.So, CONFIRM BEFORE YOU PROCEED. (3) Now Go to Advanced option in Recovery menu and choose Wipe Dalvik Cache. Then perform Wipe/cache under Mounts & Storage. Reboot the device and check if the boot loop issue is resolved. If not repeat the above three steps, but perform both Wipe/data and Wipe/cache under Mounts & Storage before rebooting.

    After Setting an Incorrect File Permission.The Android operating system (OS) works on file permissions and hence incorrectly set file permissions may permanently damage or soft brick your device. Here are some of the commonly used file permissions:- 644 (RW-R-R) - (this is most common system permission, it exists in /system/app, /system/framework, /system/etc, /system/lib and allot of separate files) - 755 (RWX-RX-RX) - (mainly used for /system/bin) - 777 (RWX-RWX-RWX) - (used for scripts inside /system/etc/init.d and busybox files)
    To fix or reset any of these file permissions, do the following:Boot the device into CWM or TWRP recovery Go to Advanced option.Click Fix Permission and confirm the action. After Restoring a Backup.If the bootloop error occurs immediately after restoring a Nandroid Backup, follow the steps on -(#:2)- to fix it. If everything else fails, just try re installing the original ROM or flash the first official firmware.

    Using ADB BY Samantha
    DB can be used to access the phone while booting, be aware that some bootloops make it unable to use ADB since they do not go further then the manufacturer logo. (In new CWM versions it’s possible to use adb)
    The only tricky part about using ADB with bootloops is that you have to do it on the right time, this is different from every device, but normally it’s after the manufacturer logo that the partitions get mounted. The easiest way to enter your phone in this part is using a batch script that monitors the state of your device and connects directly when possible.

    I use this script for example, called ondemand.bat (requires adb.exe and the 2 dlls)

    1 @ECHO off
    2 cd /d %~dp0
    3 echo.
    4 echo Waiting for device…
    5 adb wait-for-device
    6 echo.
    7 adb -d shell stop
    8 adb push mycwmfix.zip /sdcard/mycwmfix.zip
    9 adb reboot recovery

    Linux Version (ondemand.sh):

    1 #!/system/bin/sh
    2 echo " "
    3 echo "Wating for device..."
    4 ./adb wait-for-device
    5 echo " "
    6 ./adb -d shell stop
    7 ./adb push mycwmfix.zip /sdcard/mycwmfix.zip
    8 ./adb reboot recovery

    This script will wait for the device to become ready, when it’s ready it freeze the device, so the script has more time to push the file (instead of keep rebooting). Then it will push the specified cwmfix zip to your sdcard, and after that it will reboot in recovery so you can install the cwm fix you made. You can also make an batch script that pushes the files automatically to your phone, here is an example:

    (1 @ECHO off
    (2)cd /d %~dp0
    (4)echo Waiting for device...adb wait-for-device
    (6)adb -d shell stop
    (7)adb -d shell su -c "mount -o remount rw /system"
    (8)adb push framework-res.apk /system/framework/framework-res.apk
    (9)adb -d shell chmod 644 /system/framework/framework-res.apk
    (10)adb push SystemUI.apk /system/app/SystemUI.apk
    (11)adb -d shell chmod 644 /system/app/SystemUI.apk
    (12)adb reboot

    (13)Linux version:

    2echo " "
    3echo "Waiting for device..."
    4./adb wait-for-device
    5echo " "
    6./adb -d shell stop
    7./adb -d shell su -c "mount -o remount rw /system"
    8./adb push framework-res.apk /system/framework/framework-res.apk
    9./adb -d shell chmod 644 /system/framework/framework-res.apk
    10./adb push SystemUI.apk /system/app/SystemUI.apk
    11./adb -d shell chmod 644 /system/app/SystemUI.apk
    12./adb reboot
    This script will wait for the device to become ready, when it’s ready it freeze the device, so the script has more time to push the file (instead of keep rebooting). Then it will push framework-res.apk and SystemUI.apk to the directory it belongs to, after that it changes the permissions of the files to RW-R-R (644) and then it will reboot.

    Please note that on some devices the command “su -c” cannot be used after using the “stop” command, it gives an error then (Segmentation Fault).
    What you can do to prevent this is adding “adb remount” just under the “adb wait-for-device” line, and remove the “adb -d shell su -c “mount -o remount rw /system” line.
    Save the script and run it again.

    For HTC Phones: HTC phones can flash stock ROMs, known as RUUs, right from the phone's bootloader. You'll need to Google around for your device's specific RUU file, but once you download it, save the ZIP file to your SD card, and rename it (to something like PG05IMG.zip—the download page for the RUU file should specify which filename is required), booting up your phone should automatically flash the stock ROM from HBOOT, HTC's bootloader. Video http://www.youtube.com/watch?feature=player_embedded&v=tE8BiIFUOpk

    For Samsung Phones If you're using a Samsung Galaxy phone, you can use a tool called Odin to reflash an OPS file, which is a stock ROM that will return your phone to factory settings. You'll need a Windows machine and a copy of Odin, which you can find by Googling around the net (as its not an official tool) check out The Unlockr's guide to using Odin to familiarize yourself. You may need to Google around for your specific device's OPS file and instructions.
    Video http://www.youtube.com/watch?feature=player_embedded&v=5s70dwNgdD8

    Verizon Galaxy S3 Bootloop fix using Odin

    The Verizon Galaxy S3 has to be the most problematic variant of the Galaxy S3. If the locked bootloader on it wasn’t enough, many users have seen their Verizon Galaxy S3 get bricked and stop booting after trying to flash a custom ROM.​

    To start off there will be a little bit of downloading:p

    Samsung USB Driver V1.5.14.0 For Android Mobile Devices





    Now lets Start
    Make sure phone is off. Boot into download mode. To do so, hold down the Volume Down, Home and then the Power buttons together until a Warning!! message is displayed on the screen. Here, press Volume Up to enter download mode. A green Android and the text Downloading will be displayed on the screen.
    Now, open Odin by clicking on the Odin3 v3.07.exe file in the Odin307 folder which you obtained after extracting Odin307.zip
    In Odin, click on the PDA button, then select the VRALEC.bootchain.tar.md5 file that you downloaded.
    Important Untick every option under the “Option” section (on the top left of Odin), except F. Reset Time. Check the screenshot below for reference.

    Then, connect the phone to the computer with the USB cable and wait for Windows to finish installing drivers. Odin will say Added!! in the message box on the bottom left if the phone is detected successfully. If not, make sure the drivers are installed and also try using a different USB port – preferably a USB port on the back if using a desktop computer.
    Click on Start to start flashing the VRALEC.bootchain.tar.md5 file on the phone.
    Wait till flashing is complete and you get a PASS message in Odin. When that happens, disconnect the phone from the computer, but DON’T turn it off and let it stay in download mode. Also close Odin.
    Reconnect your phone to the computer (while it is in download mode). Open Odin again.
    This time, click the PDA button and select the BOOTLOADER_I535VRALF2_618049_REV09_user_low_ship.tar.md5 file that you download
    Also, again untick every option except F. Reset Time in Odin. Then, click on the Start button to start flashing the BOOTLOADER_I535VRALF2_618049_REV09_user_low_ship.tar.md5 file on the phone.
    When flashing is complete and you get a PASS message, disconnect the phone and close Odin. But keep the phone in download mode, don’t turn it off.
    Open Odin again and also reconnect the phone to the computer.
    Click the PDA file and select the stock.vzw_root66.tar file that you Downloaded
    [Important] Select the following three options in Odin on the top left: Auto Reboot, F. Reset Time, Nand Erase All. Check the screenshot below for reference.

    Click Start to start the flashing process. Once the flashing is complete and you get a PASS message, the phone will automatically reboot. Disconnect the phone from the computer.
    The phone will still not boot up completely. Now, remove the battery on the phone, then re-insert it. Don’t turn it on.
    Now, boot into recovery. To do so, press and hold the Volume Up + Home + Power buttons together till the screen turns on, then let the buttons go. The phone will boot into recovery in a few seconds. You will see a few error messages in recovery, which is normal.
    In recovery, use the volume buttons to scroll up/down and the home button to select options.
    Select wipe data/factory reset, then select Yes on next screen to confirm. Wait a while till the data wipe is complete (this will NOT delete your personal files on the SD cards).
    Select wipe cache, confirm, then wait for cache wipe to be completed.
    Then, select reboot system now to reboot the phone.
    The phone will now boot up properly into Android and is fixed, and you will be able to use it now.

    Your Verizon Galaxy S3 is now fixed, and saved you from sending it in for repair to Verizon. Do let me know how the procedure works!



    First install java on your pc if you haven’t java go to Java site and install it.
    download one-click Unbrick tool
    window users will need .rar/.zip extractor software , you can download free all in one 7zip extractor form here.


    1. Right-click on the One-Click.jar file, move down to option “7-zip” and then select “Extract to OneClick”.

    2. Now you will get a ‘OneClick’ folder.

    3. Now copy ‘OneClick.jar’ file and paste it into the ‘OneClickheimdalloneclickresourcesHeimdallPackage’ folder.

    4. Right-click on ‘oneclickloader.exe’ file and choose ‘Run as Administrator’.
    5. Proceed with the installation of Heimdall.

    6. After the installation is complete, you will see the the One-Click UnBrick interface.

    Connect the phone to computer via USB and click on “unsoft brick” button to recover your bricked android phone.

    Factory Rom's

    Factory Images for Nexus Devices







    Moto Support

    LG Software & tools Download


    TeamWin - TWRP


    Good job mate! I will be adding this to my help thread soon! :good:

    Thank You :) Just updated
    You sir, are a lifesaver. I downloaded the oldest stock firmware possible in samobile and flashed it and finally worked. It was on the samsung logo again but after a few minutes it finally made it through. I actually didn't think I would be able to fix it since most people gave up doing the same thing as me. Again, many thanks.
    Now update it with the newest stock firmware

    Sent from my SCH-I535 using Tapatalk
    Lost Data Karbonn Titanium S9 Recovery
    Karbonn Titanium S9 is an amazing gift of technology using which you can do lot more than just communicating. This Smartphone is developed on most popular and used operating system i.e. Android and built-in with fantastic features, which keeps you busy enjoying all time. But Karbonn Titanium S9 too has sinister sides as one might lose data from it due to some uncontrollable reasons. Since it’s not just a normal phone, it might contain large amount of your valuable data such as images, audios, videos, games, applications, documents, etc., and losing one of it might create panic. Relax..! Need not to panic, since Karbonn Titanium S9 recovery is possible with trustworthy recovery software.

    It’s pretty common to suffer data loss from Smartphones, since it is an entirely unpredictable scenario. But one should also know about its causes so that he / she might avoid it in possible circumstance. Just go through the below section to know more about these scenarios:

    Use of factory restore / reset option accidentally might invite the data loss
    When SD card or any other memory card mounted on S9 phone gets corrupt or become inaccessible
    Severe infection of spyware, malware and virus may lead to data loss
    Abrupt switching off the Karbonn Titanium S9 numerous times might make few files go missing
    Unintentional formatting, deleting of data by wrong touch
    Unwanted changes after rooting Karbonn Titanium S9 may contribute to data crisis

    What to? What not to?

    Data recovery experts recommend you some tips and advice you certain things to stay away from in order to perform complete recovery of Karbonn Titanium S9 data. First let’s see what to do, when you come across data loss on your Karbonn Titanium S9.

    Keep backup of the data and files that are important to you, so as to avert data disasters
    Immediately discontinue the use of Karbonn Titanium S9 as soon as you come across data loss
    Opt of reliable and safe recovery tool without wasting much of the time

    Here are some things, which you need to avoid after facing loss of data:-

    Do not even attempt tasks like rooting, formatting, etc., until you know the complete process
    Do not add or edit data on your Karbonn Titanium S9 Smartphone
    Do not carry out task like updating the software or version of phone

    Well by following these tips you can avert data overwriting and increase the chances of safe and complete Karbonn Titanium S9 data recovery.

    What’s next?

    Next is Remo Recover..! Yes, it is a smart tool that is designed for Smartphone data recovery using which you can effectively recover Karbonn Titanium S9 data in few simple clicks on mouse button. Software is ahead of its competition as it is integrated with hi-tech data retrieval procedures and assists you to restore Karbonn Titanium S9 data from all severe data crisis. Remo Recover is pre-scanned for faulty and dangerous items and certified as absolutely safe and reliable to use.

    Few striking attributes of Remo Recover..!

    Makes an entire scan of both internal and external memory of phone and help you to retrieve lost data from Karbonn Titanium S9
    Trouble free and easy to understand GUI helps a novice to execute Karbonn Titanium S9 recovery on its own
    Its smart searching algorithms examines complete drive in just one scan
    Tool has the caliber of recognizing Android application files with (.apk) and recovering it along with photo, video and audio file formats
    Authorize you to sort recovered data after completion of lost data recovery from Karbonn Titanium S9
    Prior look of recovered files can be seen using “preview” option.
    You can perform lost data Karbonn Titanium S9 recovery on all types of Android version and from all Windows OS based computers

    Step 1: Connect your Karbonn Titanium S9 to Windows computer using a USB cable and wait until connection gets established.

    Figure A: Detecting Device

    Step 2: Now Main screen gets open from were you can select either “Recover Deleted Files” or “Recover Lost Files” option as per your requirement.

    Figure B: Main Screen

    Step 3: Select Karbonn Titanium S9 drive and click “Next” button for software to begin scanning process.

    Figure C: Select Karbonn Titanium S9 Drive

    Step 4: Once Remo Recover completes the scanning process you can view list of recovered data/files in two types of view which are “File Type View” and “Data View”

    Figure D: List of Recovered Data

    Step 5: You can preview recovered data using Preview option and save it to any location.

    Figure E: Preview Recovered Data

    DOWNLOAD LINK http://www.remorecover.com/download/remorecover-android.exe
    I'll just leave this here:

    5. Create a thread or post a message only once.

    As a large forum, we don't need unnecessary clutter. You're free to edit your message as you like, so if you do not receive an answer, revisit your message and see if you can describe your problem better. Not everyone is online at the same time so it might take a while before you receive an answer. (Also refer to Rule 16)