Umecity (VW): Allwinner T8, 2GB/32GB, 7.1.2, 9" 1024x600, Shallow 2din [2017/11]

Search This thread


Nov 28, 2018
I have questions:
My HU has Android 7.1.2 and supports 3G internet. Will it support 4G LTE after updating to Android 9?
Last edited:


Nov 28, 2018
HU running on Android 9 now, and everything works. @****-jones, thanks a million for sharing your knowledge. Great guides and great help!

Is HU installed in a car or on a table?
If the HU is in the car, it may negatively affect the stock USB port.
Tried both USB ports, still no luck. Cannot get it to work
Should I remove HU from the car and try the installation on the table? What to use to power the HU and not break it?

P.S. I plugged the HU on the table and also the USB ports are not working.

I checked HU with the application USB Host Check and the result is as follows: --->> OK
handheld_core_hardware.xml --->> Not found
tablet_core_hardware.xml --->> USB host not enabled

Could this be the cause of my problem?
Last edited:


New member
Jun 21, 2022
Hello everyone, I have an Eincar device

Processor: UltraOcta-T8
Android version: 9
MCU version: 5.3.19-7-10-656201-170227
System version: V9.4.1_20191213.150600_TW2-i140-Q

Wifi works 10-15 minutes and turns off
What latest firmware can I install to solve the problem


Nov 28, 2018
Hello everyone,

I have a question. Is anyone able to make a HU update file that only uploads two specific system files to the right place? I mean handheld_core_hardware.xml and tablet_core_hardware.xml. They are responsible for connecting other USB devices, and from what I've read, they are missing a few entries. Despite the fact that HU is routed, I am not able to edit them because I get an error while saving. I would like to try to save them when restarting HU as with an update.

Processor: UltraOcta-T8
Android version: 7.1.2
MCU version: 5.3.19-98-41-E56201-170921
System version: V9.2.2_20180424.153155_TW2-FD-mod


Jan 19, 2023
So, the unit seems to report temperature for the CPU, and the battery (makes no sense), which makes it a little easier. In my testing CPU was idling around 50C, and sitting between 65-75C during benchmarking, and stress testing. Now, to be fair, it's fairly cool here at the moment (50F/10C), so on a hot day, that could spike way up.
hello all masters i have a big problem i can't find the firmware and the model number please help me


  • 20230124_191950.jpg
    2.1 MB · Views: 4
  • 20230124_191935.jpg
    2.2 MB · Views: 3
  • CM230122-145604001.jpg
    276.1 KB · Views: 4
  • CM230123-003708001.jpg
    470 KB · Views: 3
  • CM230123-003723004.jpg
    440.7 KB · Views: 6

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    You'd think I'd learn my lesson after the last ten head units I've purchased, but I saw the new Allwinner T8 headunits, and decided I wanted to give it a try. The new radio is currently on it's way from China, and I'll be updating this thread as I find out more information.

    Update: Unit passed testing and has just shipped out. Should have it early next week if it doesn't get hung up in customs.
    Update 2: Head unit arrived yesterday (11/28/2017), and I installed it today. Initial updates below.

    HTB1KECZfLBNTKJjy1zdq6yScpXaw.jpgView attachment 4331016

    [SIZE="+2"]Umecity (Youmecity) Allwinner T8[/SIZE]
    OS: Android 7.1.2 (Nougat)
    CPU: Allwinner T8, 8-core Cortex-A7 @ 1.6GHz, up to 1.8GHz
    Memory: 2GB DDR3 RAM, 32GB EMMC, 2xUSB2, 1 MicroSD
    Graphics: PowerVR SGX544MP1 GPU (OpenGL ES1.1/2.0 OpenCL1.1)
    Display: 9", 1024x600 capacitive
    Radio Tuner: 7786
    Amplifier: TDA7851
    Output Power: 4x50w
    Dimensions: 220mm x 130mm x 27mm
    Weight: 5kg

    MCU Version: 5.3.19-145-13-A46101-171118
    System Vers: V9.2.2_20171117.102842_JP1-FD
    Linux Kernel: 3.10.65
    Security Patch Level: 2017-07-05, 7.1.2 (Nougat)

    MCU Version: T5.3.19-145-10-C06101-170318
    System Vers: V9.2.2_20170915.144527_JP1

    Extra Settings: 123456
    Developer and Reset: 7890

    [SIZE="+2"]Identifying Firmwares[/SIZE]
    [SIZE="+1"]General Information[/SIZE]
    Example: 9.2.2_20171117.102842_JP1-FD
    • 9.2.2 - The hardware version, and android version. For instance, 9 is T8, and 9.2.2 is Nougat.
    • 20171117 - Release date of the firmware in YYYYMMDD format.
    • 102842 - Possibly the build time for the firmware. Uncertain.
    • JP1: The manufacturer ID.
    • FD: ???
    [SIZE="+1"] Version[/SIZE]
    Per @bazanovv, "There are 3 different non-compatible versions of T3 hardware and software, Default one (sleep mode added later and not so good), New one (firmware is a development of R16 branch), and K2001 (usually very compact and cheaper). Allwinner T8 head units continue and develop the same firmware branch - V9.x.x on T8, V8.x.x on T3 New (V8.3.x with Android 7.1) and V7.x.x on R16. Most tips and tricks from T3 (new one) will work on T8."
    • R16 - 7.x.x
    • T3 - 8.x.x
    • T3 - 8.3.x - Android 7.1, Nougat
    • T8 - 9.1.1 - Android 6.0.1, Marshmallow
    • T8 - 9.2.2 - Android 7.1.2, Nougat
    [SIZE="+1"] Manufacturer[/SIZE]
    From information gleaned mostly from various threads over on 4PDA, it is advised to not install firmwares from another manufacturer, unless it has already been patched to be universal. Issues such as red messages at the bottom of the screen, or unsupported hardware can result.
    • JP1 or JP1-FD: Umecity
    • TW2-FD: TopWay
    • KED3-5: Kaier

    [SIZE="+1"]Allwinner T8 Documentation[/SIZE]

    [SIZE="+1"]4PDA Discussion Thread (Russian)[/SIZE]

    [SIZE="+1"]My Initial Feelings:[/SIZE]
    This appears to be basically the same chassis as the Allwinner T3 units, but with a newer CPU and OS. Unfortunately, they cheaped out a little with the bezel on this one, which didn't include a MicroSD card slot like was on the previous model. This model has the same issue of accidentally clicking the capacitive bezel buttons that the T3 had.

    The wiring is a bit of a mess. Some things were obviously just cheaped out on, like boost power for the antenna to the harness should come with connectors already installed. There is a brown/yellow wire pair coming from the CANBUS box that plugs into the back of the unit, rather than connecting via the main harness plug. Just as with the T3 model, the Volkswagen ISO1 harness has an ISO2 harness spliced into it. Having the extra connector leaves the system open to RF interference, and makes the wiring a mess.

    After working with the unit for about an hour, and running the benchmarks, I started to notice some interference from the speakers. It wasn't affected by unit volume, and was present when muted. The noise sounded like either RF interference, or he noise you get when a capacitor is squealing. I did not notice the noise before the benchmarks, and need to see if this recurs on the next boot up. After extensive listening, the noise only seems to occur (for me) after the unit has been powered on for a while, and run hard. Benchmarking, initial setup and app download, etc. Once I reboot, I don't hear the noise anymore.

    For scoring so blandly in the benchmarks, this unit is very responsive. I had no issues or slowdowns running multiple apps at the same time: Maps, Play Music, and Play Store downloading in the background, etc.

    [SIZE="+1"]Some Items Worth Pointing Out[/SIZE]:
    • Bluetooth is for phone use only: I've always been critical of Bluetooth audio quality, especially for music. It's interesting that they point out that Bluetooth only works with one sound channel, so music will not sound good. They suggest music over USB. I'm guessing with android auto, or their EasyConnect mirroring.

    [SIZE="+1"]Tests and Results[/SIZE]
    • Ease of install: Super easy to install, due to the extremely shallow depth of the device. Plenty of room for the wires behind the radio. Only annoyance was the combined ISO 1/2 adapter, which is just a mess.
    • Screen visibility: So far, so good. Less brightness, but better clarity than the Dasaita PX5 unit I have.
    • Deep Sleep: Well, no deep sleep support. Has a few shutdown times, maxing out at 30 minutes IIRC.
    • Boot time: So, the numbers quoted up top are pure fiction. Took ~40s from cold boot to launcher.
    • Backup cam start time: Excellent. Was able to use the backup camera immediately from power on.
    • Antutu Score: ~22500
    • 3DMark Score: Benchmark crashed.
    • Volume scaling: Again, default audio is too freaking loud with my OEM Fender amp. Anything past 4-5 (out of thirty) is way too loud. On the good side, seems the Amp Volume can be adjusted. When set at it's lowest level, the scaling seems to be spot on for my Fender system. Nice!
    • Rootable?: CPU-Z seems to indicate that it is already rooted, however SuperSU states that the su binary is occupied. Need to explore further.
    • Play Store apps: So far, so good. Only missing items in the store were things like Google Dialer, which would have been nice to have.
    • Android Auto: Not available in Play Store. Likely need to fake 720p screen.
    • Google Maps: Works great. No problems in my short test drive.
    • Waze: Works great. No problems that I saw.
    • Voice Search: Not installed by default. Install "Google" from Play Store. Unfortunately, internal Mic couldn't hear my voice in testing.
    • Bluetooth Call w/int mic: No tested yet.
    • Radio Signal: Strong signal, and easily locked to even faint stations.
    • Radio Audio Quality: Meh, it's analog OTA, so it sounds about as good as I would expect it to.
    • CPU Temp: According to Aida64, the CPU temperature idled around 50-60 Celsius, spiking to 74 during the benchmarks.
    • GPS Lock: GPS locked almost immediately.
    • What else should I test?

    • Solid build, with shallow design.
    • Easy to install.
    • Google Maps works great, as does Waze.

    • Very easy to accidentally click the capacitive bezel buttons. Can sometimes even detect a hover as a touch.
    • Internal Microphone only works with Bluetooth calling.
    Thank you ****-jones. Much appreciated. Will try it this weekend.
    @karldink, @lr_man, @majsab, @sparrion

    Link to the modified firmware V9.2.2_20180310.092220_KBT8-FD-mod
    :eek: :eek: :eek:
    Could you upload a new link to the firmware please? The link is dead. I am looking to update the firmware of my ga8150a as well.

    Link to the original firmware
    :D sorry...
    This is my 6.0 software
    First of all, I would like to say that @Rottgrub is ultimately right, and you should not try to flash MCU if not absolutely sure / have a backup image of yours and ready to brick the HU.

    Could you please double check the link and file, because on your screenshot you have Allwinner T8 with Android 6.0 - V9.1.x firmware branch, version V9.1.1_20170830.183839_KED3-5, while filename on your link says it is V8.2.3 (V8.2.3_20170927.200111_KED3-5.rar), which is Android 6.0 too, but for different CPU - it is a Allwinner T3 firmware branch.

    Connection of OBD2 (ELM327) adapters, as well as all other non-phone (headset) devices by Bluetooth on HU is a difficult and complicated process. Firmware and MCU updates both frequently required, and still it is a lottery, it may work, or may not. All non-standard Bluetooth devices will most likely not work. This happens because Bluetooth module is managed by MCU, not Android, is not native to Android, so it will newer work as good as on your phone. This was made, huh, to connect your phone to the HU as a handsfree device. Default Android BT software stack can be a server device on A2DP and HF profile, but can't be a client, like headphones. HU, in it's turn, must be like a headphones. Here be dragons.

    Known problems with OBD2 adapters are that password for adapter and set in BT settings must be the same and set, most frequently, to "1234". You should connect OBD2 in HU Bluetooth or Phone application, not in Android BT settings (may be called by shortcut, but will not work correctly). Bluetooth device name of OBD2 adapter must be exactly "OBDII", others will work OK with your phone, but not with HU. It seems that some fixup procedures in the code are linked to BT device name. And even if all of this is true, it seems that T8 firmware is still under development and do not work with any type of OBD2 adapter.

    Most probably, you will be able to upgrade your Android 6.0 firmware to the new one on Android 7.1, but this process is a bit more complicated and dangerous then regular firmware update. If something goes wrong, HU turns into a brick, software does not work as you want or expect - you have been warned, it's your own responsibility only.
    1) First of all, get a backup of your Android and MCU firmware from the seller, or, if this is not possible, get Root, install this backup tool for R16 and make a backup of all Android partitions, and MCU partition. It is untested on T8 yet, but it's better to have this backup, then nothing. This tool just do dd from known partitions and copy them to file, that's why root required. It may try to restore as well, but this is more risky.

    2) As you may notice, firmware update files are named like GUID's, three files .0 .1 .2 with main Android image, split into 3 parts, and smaller boot partition for Android. Names for Android 7 on T8 are well-known:
    b278023e-7757-11e7-bb3a-07933d230b22.0, .1, .2 - main Android image;
    b1604ca8-7757-11e7-906d-3390eed0c0c2 - boot (Linux core);
    bd07a5ee-fbb0-11e4-ae78-000c29ba27c0 - MCU partition for Android. DON'T FLASH it, if not 100% sure it is from yours or hardware compatible (same Radio, DSP, etc) HU. Delete this file instead, details later.
    203affea-6437-11e6-9d6a-6fc36e3d2c72 - one particular MCU firmware for immediate flashing into the MCU. DON'T FLASH it, if not 1000% sure it is fit your HU, maximal chances to get a brick. Delete this file instead.

    However, names for Android 6 on T8 are unknown. So HU will not "see" and will not start flashing Android 7 files until you rename them to the names that it expects to see. Easiest way to find the correct names - from your firmware you got from seller on step 1, or from any other T8 Android 6 firmware. Btw, if you know any - please share a link. You have to rename files with Android 7 firmware to the names Android 6 firmware expects, and start flashing in usual way. Hopefully, it will work.

    3) As you may see before, firmware version contains letters in the end, "KED3" in your case. This letters name the OEM manufacture name, and must match hardware ID, stored in the MCU firmware. If they will not match, red letters of warning will be written on the top of display: "UI unauthorized, please contact the supplier". It will not affect regular operations, but is very annoying. To delete this, you may zero out this ID in ro.fota.device string in /system/build.prop. Get Root, search for the string "ro.fota.device=" in the build.prop, find OEM letters like TW2-FD or KED1 or JP1 (or others), according to firmware, and then 4 digits of ID. Replace ID with 4 ASCII zeroes, so from ro.fota.device=KED1_0011 you will get ro.fota.device=KED1_0000. Remember about Linux cr/lf, don't edit build.prop with notepad, and restore access rights, or you will brick the HU.

    Alternatively, you may edit this string in the firmware files before flashing, and then sign the modified firmware. Manual here.

    4) Unlike other HU's, this firmware branch (starting from R16 / T3 new one / T8) do have a set of MCU files, different for different car models, stored in the separate Android partition (size 16 Mb). MCU flash size is 128 kb, so lots of them can fit onto this partition. Then you choose car model, HU selects proper MCU file from this partition, flashes it into the MCU, and then reboots. So you must not touch it or switch it off during car model select, or it will become a brick forever, and you should not select the model too frequently to save a MCU flash programming cycles. This mechanism was developed, because CANbus MCU code is different for different cars, and code for all cars does not fit the MCU flash size. Even more, different MCU may and do have different code for Radio module (mostly TDA7786/TDA7703/TEF662x) and audio DSP (mostly TDA7729(TDA7719)/Rohm BD37xxx), if you flash the wrong one, you loose Radio or sound and ability to regulate it).

    This partition gives you a unique chance to backup MCU set before flashing it (see p.1). It may be saved and flashed back with the root and backup tool or just dd (I haven't test it!!! su cd /dev/block/by-name dd if=private of=/usb0/private.img bs=4096). MCU firmware usually encrypted, and can't be read back from the MCU, so for other HUs there are no way to backup existing MCU firmware, unlike this one. However, if you accidently flash firmware with the MCU set file bd07a5ee-fbb0-11e4-ae78-000c29ba27c0, it will overwrite this partition. If this file does not fit your hardware, you will not get a brick - because, unlike 203affea-6437-11e6-9d6a-6fc36e3d2c72 file, only Android partition is flashed, MCU flash remains the same - but you will loose ability to select car model in the factory settings menu, because no suitable MCU is found for your hardware ID in the MCU partition.
    Hardware ID, Car model, Radio, DSP and lot of other features are encoded in the MCU name.
    T5.3.19-hwID-carID-С06101-YYMMDD there С06101 is a Radio, DSP and HU features bitmask. Some may be decoded with the old MCU+1.4+(+4core).exe decode tool from R16. It does not fit exactly, but may give a clue. MCU firmware name should be entered without the T letter in beginning, like 5.3.19-145-10-С06101-170318.
    You see, MCU issue is quite complicated, right? So, if you are not absolutely sure - don't flash the MCU!

    Based on materials.

    P.S. As far as I know, there are no known way to get a root on T8 with Android 7 yet. You have to disassemble (take apart) firmware, insert there files for root, and then assemble and sign it back, or wait, until somebody do it for you. Unfortunately, there are no detailed step-by-step manual available, and I am unable to create it, because my knowledge is not enough.

    ---------- Post added at 04:16 PM ---------- Previous post was at 03:59 PM ----------

    I tried an external microphone, but It didn't work my own dynamic microphone.
    I think that this product uses a condenser microphone.

    It definitely uses the condenser microphone with phantom power. To say even more, it's internal microphone is connected electrically parallel to the external microphone socket, so connecting dynamic microphone will just shortcircuit it and make both unusable. Some people make a microphone jack with the switching contact, so then external mic inserted, internal will be switched off and don't collect car noise.

    Meanwhile you may try any PC computer microphone, they fit ok. Only one problem to consider - HU mic connector is a mono type, so if computer mic do have a stereo connector, it may fit bad and signal pin (right channel) may be connected to the ground. If right and left are connected inside the jack, both will be connected to ground and mic don't work.
    Firmware with the root, red inscription removed. The work has been verified. You can bet on any T8.

    The firmware does not have one file, b1604ca8-7757-11e7-906d-3390eed0c0c2 file missing!

    Please return the file to the archive with the firmware. Thank you.

    Here is a link to the entire firmware from the author's mod V9.2.2_20171026.152904_KED1-mod