• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[UMX U693CL Root/Recovery RELEASE]- DISCONTINUED

Search This thread

Brickstin

Member
Oct 18, 2017
28
0
An AIO ToolKit is about to be released for this device, I wrote it to handle everything from fresh untouched device to fixing a soft-bricked device. The initial release will be removed shortly and this new ToolKit is for Linux...
Wait so... the initial release worked on which Operating system?
I am on Windows... I don't have Linux :/

Thanks for all your hard work though: I have one of these dumb phones.. always installs TopicNews as a System file and cant disable or remove.
 

timjames474

Senior Member
Mar 29, 2016
71
15
22
Terre Haute
Nexus 7 (2013)
Moto E (2020)
Wait so... the initial release worked on which Operating system?
I am on Windows... I don't have Linux :/

Thanks for all your hard work though: I have one of these dumb phones.. always installs TopicNews as a System file and cant disable or remove.
It is linux only because it uses a specific flashing tool optimized for linux. make a LiveUSB or somethin
 

SlickStretch

Member
Dec 8, 2012
37
6
Hillsboro, OR
I think I found a typo in one of your scripts.

In 'Run_Setup.sh' line 5 reads
sudo apt purge ModemManager
I am getting an error that says "ModemManager not found."

Shouldn't it be
sudo apt purge modemmanager?
Now it works fine.
 

SlickStretch

Member
Dec 8, 2012
37
6
Hillsboro, OR
Hey guys, after using the ToolKit to install OrangeFox recovery, root, and the custom Assurance Wireless rom my phone won't boot.

Recovery works fine, but when the phone tries to boot, it shows the start-up animation (spinning balls animation) for about a minute before the screen goes black. (black but not off) Then nothing. I gave it a good 10 minutes.

I tried using the toolkit again, and tried the UnBrick option with the same results.

Can you help me?
 

tuffasagong

Member
Mar 13, 2012
28
12
Hey guys, after using the ToolKit to install OrangeFox recovery, root, and the custom Assurance Wireless rom my phone won't boot.

Recovery works fine, but when the phone tries to boot, it shows the start-up animation (spinning balls animation) for about a minute before the screen goes black. (black but not off) Then nothing. I gave it a good 10 minutes.

I tried using the toolkit again, and tried the UnBrick option with the same results.

Can you help me?
Have you tried installing the custom rom zip file through the recovery that PizzaG inlcuded? I have had no problems with that (except setting up a lockout pin where it says pin not accepted even though it was correct).
 

SlickStretch

Member
Dec 8, 2012
37
6
Hillsboro, OR
Have you tried installing the custom rom zip file through the recovery that PizzaG inlcuded? I have had no problems with that (except setting up a lockout pin where it says pin not accepted even though it was correct).
I figured it out. It was happening because I forgot to wipe the data partition.

On another note, have you guys found any other custom roms? I've tried a couple of the GSI roms that PizzaG linked in the description post. (arm64, A/B roms) but OrangeFox recovery keeps telling me "Invalid zip file format."
 

tuffasagong

Member
Mar 13, 2012
28
12
I figured it out. It was happening because I forgot to wipe the data partition.

On another note, have you guys found any other custom roms? I've tried a couple of the GSI roms that PizzaG linked in the description post. (arm64, A/B roms) but OrangeFox recovery keeps telling me "Invalid zip file format."
That will do it. I tried a couple GSI roms. I think you have to unzip them and install the .img files. I only really got one I tried working and had to switch because I got a TMobile error saying this phone is not compatible with the network.
 

cuzimthatnerd86

New member
Jul 28, 2021
1
1
Hi everyone! I was wondering if I could get some help from someone...anyone lol. Anyone with some tech expertise on this specific device would be a GODSEND. I'm pretty new here but even though it seems like a cool place to askfor help I'm going to go ahead and warn ya, this issue is complicated (at least to me). So I'm trying to figure out the easiest or any possble way to restore the UMX I have back to it's backup or factory status. Here's the deal: (I apologize for the length, I tried slimming up my message a bit)
So I was able to root my UMX U693CL following this guide but OOPS, I unplugged the device before QFIL was done sending it's REBOOT command and it just BRICKED IT....hard. I can still read from the device, and though no screen comes on I can still pull fastboot getvar all (yup, it shows as a fastboot device when the screen actually comes on but it sticks at that first screen and not a single intent-based fastboot command is recognized. So I can't flash/boot/etc. I did do a FULL backup before doing this tutorial so I literally have like 13GB of partitions, I renamed them all by appending the partition name at the start of the filename. My question is, how do I recover or begin to recover this device? Should I attempt making a loader on the sdcard?...I am just guessing but it seems that isn't the answer. I did re-establish the phone in device manager as the Qualcomm HS-USB QBLoader 9008 *proper* driver, but this is my experience...
I launch QFIL. It has found a port but I must select it. Then I select FLAT BUILD. Then I drop the programmer mbn in the correct spot and immediately go up to the top, selecting the second tab I think (I'm picturing it in my head so I'm sorry for the confusion) and then the next from the last option, Partition Manager, but eventually get timed out with an error along the lines of could not load Sahara XML...etc etc. (I will give a clear error message as soon as it turns on; its been sitting in my drawer for months so it's dead dead.) It appears as though when I tried restoring it the intial time, right after bricking it, I somehow managed to duplicate partitions maybe...have a look for yourself (if anyone's still reading this haha) Any advice would be greatly appreciated. I removed the serial number from the getprop.

Also, I use Windows 7 mostly but have Ubuntu/Linux on my laptop. I find working, especially with QPST and stuff, is so much easier on good ol' Windows 7 than any newer version, personally.

*Edit, I attached the QFIL working log*
 

Attachments

  • UMX_U693CL_fastboot-getvar-all_07282021.txt
    5.6 KB · Views: 46
  • load.cmm.txt.txt
    832 bytes · Views: 18
  • QFIL_DownloadedFilesOutputList.jpg
    QFIL_DownloadedFilesOutputList.jpg
    128 KB · Views: 33
  • QFIL_Selecting.jpg
    QFIL_Selecting.jpg
    197.8 KB · Views: 34
  • QFIL_Working.jpg
    QFIL_Working.jpg
    202.2 KB · Views: 31
  • QFIL_working_log-07282021.log
    8.6 KB · Views: 13
  • Like
Reactions: marckoby

earickb

Member
May 28, 2021
16
0
Hi everyone! I was wondering if I could get some help from someone...anyone lol. Anyone with some tech expertise on this specific device would be a GODSEND. I'm pretty new here but even though it seems like a cool place to askfor help I'm going to go ahead and warn ya, this issue is complicated (at least to me). So I'm trying to figure out the easiest or any possble way to restore the UMX I have back to it's backup or factory status. Here's the deal: (I apologize for the length, I tried slimming up my message a bit)
So I was able to root my UMX U693CL following this guide but OOPS, I unplugged the device before QFIL was done sending it's REBOOT command and it just BRICKED IT....hard. I can still read from the device, and though no screen comes on I can still pull fastboot getvar all (yup, it shows as a fastboot device when the screen actually comes on but it sticks at that first screen and not a single intent-based fastboot command is recognized. So I can't flash/boot/etc. I did do a FULL backup before doing this tutorial so I literally have like 13GB of partitions, I renamed them all by appending the partition name at the start of the filename. My question is, how do I recover or begin to recover this device? Should I attempt making a loader on the sdcard?...I am just guessing but it seems that isn't the answer. I did re-establish the phone in device manager as the Qualcomm HS-USB QBLoader 9008 *proper* driver, but this is my experience...
I launch QFIL. It has found a port but I must select it. Then I select FLAT BUILD. Then I drop the programmer mbn in the correct spot and immediately go up to the top, selecting the second tab I think (I'm picturing it in my head so I'm sorry for the confusion) and then the next from the last option, Partition Manager, but eventually get timed out with an error along the lines of could not load Sahara XML...etc etc. (I will give a clear error message as soon as it turns on; its been sitting in my drawer for months so it's dead dead.) It appears as though when I tried restoring it the intial time, right after bricking it, I somehow managed to duplicate partitions maybe...have a look for yourself (if anyone's still reading this haha) Any advice would be greatly appreciated. I removed the serial number from the getprop.

Also, I use Windows 7 mostly but have Ubuntu/Linux on my laptop. I find working, especially with QPST and stuff, is so much easier on good ol' Windows 7 than any newer version, personally.

*Edit, I attached the QFIL working log*
Easiest way to fix is to use Linux to flash Unbrick Files
 

timjames474

Senior Member
Mar 29, 2016
71
15
22
Terre Haute
Nexus 7 (2013)
Moto E (2020)
Have you tried installing the custom rom zip file through the recovery that PizzaG inlcuded? I have had no problems with that (except setting up a lockout pin where it says pin not accepted even though it was correct).
the PIN issue is due to disabled force encryption. If you NEED the ability to lock the screen,i have a debloated vendor of my own that has forceencrypt enabled if youd like it
 

timjames474

Senior Member
Mar 29, 2016
71
15
22
Terre Haute
Nexus 7 (2013)
Moto E (2020)
Just a friendly reminder. Questions asked on XDA, should be answered on XDA. Not everybody uses or needs TG. After all, XDA is why we're all here in the first place.

-Regards: Badger50
JuSt A FrIeNdLy- shut up senior citizen,messageboards are the past. Instant messaging is the future. Just now noticed this high and mighty comment,and woooow. Im siding with Pizza,get telegram or get left out. Might see if releases can be explciity telegram too,just to spite yall. Ill ask him later.....
 

Didgeridoohan

Senior Moderator / Dev Committee / Dev Relations
Staff member
May 31, 2012
11,969
13,434
Gothenburg
Google Nexus 4
Nexus 6
JuSt A FrIeNdLy- shut up senior citizen,messageboards are the past. Instant messaging is the future. Just now noticed this high and mighty comment,and woooow. Im siding with Pizza,get telegram or get left out. Might see if releases can be explciity telegram too,just to spite yall. Ill ask him later.....
There are a couple of things that need to be addressed here...

First of all, that is not the way we expect users to address other members. Rudeness, flaming, etc is not tolerated on XDA. Treat other members with respect (no matter their age, young or old) and courtesy. This is quite clear in the forum rules, under "Member conduct", so if you're not familiar with said rules I suggest you read through them carefully:
https://forum.xda-developers.com/t/xda-developers-forum-rules.4200559/

Secondly, Telegram. Chat apps can be quite useful, especially when there's need for direct and quick communication. But, if someone wants their work available here on XDA there needs to be support for it here as well. We're not simply a gateway to other forums or platforms... We generally allow development projects to have a Telegram support link, but if the thread is used solely to drive traffic away from XDA it will be closed.

XDA is about sharing, and you don't even have to be a member of the forum to be able to benefit from everything that's available here. We want to keep it that way, but if all support and development can be found under Telegram links it won't be so readily available.

TL;DR: Tone down the attitude and while Telegram links are allowed support and development need to be available on XDA if a thread is to stay open.

If anyone has anything to add on this, or have any questions my inbox is always open. Let's not keep posting about this here since we want to keep the thread on topic.

Cheers
Didgeridoohan
Senior Moderator/Developer Committee/Developer Relations
 

guero.lurias

Member
Dec 27, 2018
40
5
40
Mesa
Hi everyone! I was wondering if I could get some help from someone...anyone lol. Anyone with some tech expertise on this specific device would be a GODSEND. I'm pretty new here but even though it seems like a cool place to askfor help I'm going to go ahead and warn ya, this issue is complicated (at least to me). So I'm trying to figure out the easiest or any possble way to restore the UMX I have back to it's backup or factory status. Here's the deal: (I apologize for the length, I tried slimming up my message a bit)
So I was able to root my UMX U693CL following this guide but OOPS, I unplugged the device before QFIL was done sending it's REBOOT command and it just BRICKED IT....hard. I can still read from the device, and though no screen comes on I can still pull fastboot getvar all (yup, it shows as a fastboot device when the screen actually comes on but it sticks at that first screen and not a single intent-based fastboot command is recognized. So I can't flash/boot/etc. I did do a FULL backup before doing this tutorial so I literally have like 13GB of partitions, I renamed them all by appending the partition name at the start of the filename. My question is, how do I recover or begin to recover this device? Should I attempt making a loader on the sdcard?...I am just guessing but it seems that isn't the answer. I did re-establish the phone in device manager as the Qualcomm HS-USB QBLoader 9008 *proper* driver, but this is my experience...
I launch QFIL. It has found a port but I must select it. Then I select FLAT BUILD. Then I drop the programmer mbn in the correct spot and immediately go up to the top, selecting the second tab I think (I'm picturing it in my head so I'm sorry for the confusion) and then the next from the last option, Partition Manager, but eventually get timed out with an error along the lines of could not load Sahara XML...etc etc. (I will give a clear error message as soon as it turns on; its been sitting in my drawer for months so it's dead dead.) It appears as though when I tried restoring it the intial time, right after bricking it, I somehow managed to duplicate partitions maybe...have a look for yourself (if anyone's still reading this haha) Any advice would be greatly appreciated. I removed the serial number from the getprop.

Also, I use Windows 7 mostly but have Ubuntu/Linux on my laptop. I find working, especially with QPST and stuff, is so much easier on good ol' Windows 7 than any newer version, personally.

*Edit, I attached the QFIL working log*
hi, i had a similar issue, good thing u made a backup. this is how i "fixed it". to unbrick: i held down power button and volume up and down , it vibrates 1 time the phones off, vibrates second time phone back on and a second later it turns off again let go, but its not really off, its in edl mode in case you cant get it in edl via toolkit or via adb and then i flashed stock recovery and got it to boot into recovery and factory data reset, booted into edl again and i could flash all the different recoveries and the custom rom without getting bricked again. my biggest mistake was not making a backup and i realized that my imei, baseband and the assurance wireless network had dissapeared, now i figured out how to fix it but i need the stock rom to do so, since you did make a backup you think you can help me out by uploading your stock rom please?
 

timjames474

Senior Member
Mar 29, 2016
71
15
22
Terre Haute
Nexus 7 (2013)
Moto E (2020)
Glad i could help! and to Moderator/Dev Relations,your rules are behind the times,this account is older than half the members here darn near,im aware of the rules,but penalizing someone for not installing your half baked pile of garbage app is absurd at best insulting at worst.

@Didgeridoohan if you expect people to be here,then make a app worth using,like the old app was,it was nice. Could autodetect your device and point you to your forums easily,so dont come at me,for addressing flaws with most forum sites. Until the,telegram supremacy,and i still hope @PizzaG has the sense to switch away from XDA,and take his projects with it. Androidfurms/telegram supremacy. I have half a mind to kill the link for the vendor image just to be petty​

Thank you, that worked.
 

imevil2011

New member
May 2, 2019
3
0
I don't get the hate here but just a fyi the readme in the file is self explained 2 3 4 then as you desire I've bricked my device 3 times with full support and recovery from this tool kudos 🍕 love this keep em coming bro muck love from ky ps my personal number call I'll help
 

Attachments

  • Screenshot_20210809-004933.png
    Screenshot_20210809-004933.png
    45 KB · Views: 23
  • Screenshot_20210809-004946~2.png
    Screenshot_20210809-004946~2.png
    63.3 KB · Views: 22
  • Screenshot_20210809-004906.png
    Screenshot_20210809-004906.png
    84.6 KB · Views: 23

cannotkeepup

Member
Jul 20, 2021
14
6
Can someone take pitty on the stupid in the room???

I have read and read this web page and most of what I read is like some kind of alian to me.

I am hoping someone can in very child like terms set me straight.

I have a UMX u693cl.

I liked the phone because it is light in weight and small enough to fit in my wallet. Thanks to a friend all the extra stuff was removed making it so even the dumb like me could use it.

I could make a call, get a call, look at email, google direction or a phone number. That is all I need.

My service was with Assurance Wireless. Not a great company but I could call AAA if I needed to.

Well as I am sure you know TMoble bought out Sprint and in turn Assurance Wireless..

I got a letter saying I had to upgrade my phone to the new Tmoblie system. I called and asked what I needed to do and was tod I had to get a new phone. Something I cannot do right now so I figured I would wait. Then I get an email telling me all I needed to do was call and get a new SIM card. So I did.

About 4 days later new SIM card in hand I called them and ask now what. They tell me how to open back and install. Then tell me they had to restore something on there end and it would take an hour.

Two hours later my phone went from a 4g to a 3g and will not work at all. If is now a paper weight.

Call again told they sent the wrong SIM card.

A few days later I still have a paper weight.

So I put the old sim card back and it is working again but still on the sprint system.

So I called Safelink to see if I could just switch to them and bring my phone with me. They tell me yes but I have to have Assurance unlock it.

Called Assurance and they tell me they do not have to and will not to bad. I know this is against the law but what am I going to do about it.

So can any one tell me is there a way I can unllock it so I can use it on Safelink and how?

Again thank you for reading this and I am sorry it is so long.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    PSA - Don't cause drama

    Had to do some cleaning. A few posts have been removed, since they were abusive and had no purpose other than creating drama.

    Don't do that...

    The results can now be seen in the 1st post of this thread.

    Stay safe
    Didgeridoohan
    Senior Moderator/Developer Committee/Developer Relations
    2
    Thanks for everything! this is a nifty little tool I really like it.
    Only problem I've really had so far was being locked out after setting a lock screen password.
    If I set up a password I won't be able to unlock when inputting the correct password. I tried searching for that .db file in file manager to delete but couldn't find it. Had to reformat and just use my phone without a lock screen password for now.
    If you look back on page 3 timjames posted a vendor.IMG with force encryption enabled and it does work with setting a pin. It does though encrypt your files so you cannot access or see them through recovery.

    On another note I have been trying a bunch of GSI ROMs and the best luck I have had are the DOT OS ROMs. I had Dot OS 5.1.3 (android 11) running smoothly but I went to 3.1.1 (android 9) because 5.1.3 was all gesture based and didn't use the keys on the bottom of the phone and some apps I use are broken on 11. It is a sweet ROM and runs very well on this umx phone. It is crazy that this phone is not even comparable in terms of performance and look to the stock bloated assurance ROM. If anyone is interested: https://forum.xda-developers.com/t/9-0-unofficial-dot-os-3-1-gsi-arm-arm64-a64-a-ab.3952035/
    2
    I get that, but can you provide a way for me to load into a custom recovery for this phone in the first place? Neither recovery from this toolkit boots into any other than a white flickering screen, and no one so far has shared a TWRP image either.
    These are the files I used to get twrp loaded. The Readme file told how to get the custom recovery loaded. I only used TWRP not familiar with the others. Once you get it loaded then you can install assuranceRom.zip. The only problem I ran into was after doing a factory reset. The UMX U693CL problem of it rebooting into recovery each time after doing a reset. Clearing the misc partition worked like a charm. I used QFIL to do it.
    2
    Edit: Ok well after intalling that ims.apk and messing around with it, i'm able to at receive text messages now. It can still be a little wonky but typically after a long period of not using the phone, i can just restart the phone and all the messages will come in. Once again, I appreciate your support.
    Did you rename it to org.codeaurora.ims and put it in vendor/overlay? Here are the APN settings from the assurance rom.
    Set network to LTE
    Name: T-Mobile US
    APN: fast.metropcs.com
    MMSC: http://mms.msg.eng-t-mobile.com/mms/wapenc
    MCC:310 and MNC:240 (default values)
    APN type: default,supl,mms
    APN protocol: IPv6
    APN roaming protocol: IPv4
    MVN0 type: GID
    MVN0 value: 1A53
    Everything else just leave the same.
    I also used the openGAPPs micro so I could install YouTube vanced
    1
    If you look back on page 3 timjames posted a vendor.IMG with force encryption enabled and it does work with setting a pin. It does though encrypt your files so you cannot access or see them through recovery.

    On another note I have been trying a bunch of GSI ROMs and the best luck I have had are the DOT OS ROMs. I had Dot OS 5.1.3 (android 11) running smoothly but I went to 3.1.1 (android 9) because 5.1.3 was all gesture based and didn't use the keys on the bottom of the phone and some apps I use are broken on 11. It is a sweet ROM and runs very well on this umx phone. It is crazy that this phone is not even comparable in terms of performance and look to the stock bloated assurance ROM. If anyone is interested: https://forum.xda-developers.com/t/9-0-unofficial-dot-os-3-1-gsi-arm-arm64-a64-a-ab.3952035/
    Thanks for your response! I installed that cusotm vendor and I ended up checking out DotOS and I really like it.. lots of customization features. only problem is, I cant receive text messages all of a sudden! I'm assuming you aren't having this issue right?
    My sent messages are going through but I'm not receiving any
  • 8
    JuSt A FrIeNdLy- shut up senior citizen,messageboards are the past. Instant messaging is the future. Just now noticed this high and mighty comment,and woooow. Im siding with Pizza,get telegram or get left out. Might see if releases can be explciity telegram too,just to spite yall. Ill ask him later.....
    There are a couple of things that need to be addressed here...

    First of all, that is not the way we expect users to address other members. Rudeness, flaming, etc is not tolerated on XDA. Treat other members with respect (no matter their age, young or old) and courtesy. This is quite clear in the forum rules, under "Member conduct", so if you're not familiar with said rules I suggest you read through them carefully:
    https://forum.xda-developers.com/t/xda-developers-forum-rules.4200559/

    Secondly, Telegram. Chat apps can be quite useful, especially when there's need for direct and quick communication. But, if someone wants their work available here on XDA there needs to be support for it here as well. We're not simply a gateway to other forums or platforms... We generally allow development projects to have a Telegram support link, but if the thread is used solely to drive traffic away from XDA it will be closed.

    XDA is about sharing, and you don't even have to be a member of the forum to be able to benefit from everything that's available here. We want to keep it that way, but if all support and development can be found under Telegram links it won't be so readily available.

    TL;DR: Tone down the attitude and while Telegram links are allowed support and development need to be available on XDA if a thread is to stay open.

    If anyone has anything to add on this, or have any questions my inbox is always open. Let's not keep posting about this here since we want to keep the thread on topic.

    Cheers
    Didgeridoohan
    Senior Moderator/Developer Committee/Developer Relations
    6
    DISCONTINUED
    If you are upset about this, blame your fellow XDA users

    Link to discontinued files, for archiving purposes;)
    https://androidfilehost.com/?w=devices&uid=8889791610682948689

    Link to Telegram Group for Android Related chat and Other Projects
    https://t.me/Android_General_Chat
    3
    PSA - Don't cause drama

    Had to do some cleaning. A few posts have been removed, since they were abusive and had no purpose other than creating drama.

    Don't do that...

    The results can now be seen in the 1st post of this thread.

    Stay safe
    Didgeridoohan
    Senior Moderator/Developer Committee/Developer Relations
    3
    Have you tried installing the custom rom zip file through the recovery that PizzaG inlcuded? I have had no problems with that (except setting up a lockout pin where it says pin not accepted even though it was correct).
    the PIN issue is due to disabled force encryption. If you NEED the ability to lock the screen,i have a debloated vendor of my own that has forceencrypt enabled if youd like it
    2
    Updates
    6-17-2021: Setup for Official Release
    6-19-2021: Initial Package Release, Bugs Expected, Recovery Tree still needs some work
    6-27-2021: AIO ToolKit Release, removing Initial old release. ToolKit is unfinished and missing some recoveries but is working. I'll add the remaining recoveries and such as time permits
    6-28-2021: ToolKit Update v0.06. Dumping options added to Dev Menu, Custom Stock/unbrick Images further tweaked, bugfixes, menu tweaks, etc...
    7-3-2021: Added option to remove device encryption, custom stock/unbrick option now a menu, DarkStar Recovery added to recovery menu, disabled first boot setup screen, removed a couple more bloat apps
    7-9-2021: AssuranceRom v0.07 recovery flashable zip released, AIO ToolKit v0.09 released, changelog and installation now included in toolkit, removed DarkStar and Batik Recovery(Too Old and Missing Needed Features), Added OrangeFox Recovery, Added PitchBlack Recovery, Android 9 GSI roms tested booting, Android 11 GSI roms tested booting
    7-24-2021: AssuranceRom v0.08 Recovery Flashable zip Released, AIO ToolKit v0.10 Released, Changelog now included in the ToolKit Package
    8-31-2021: Rude people associated with this device and I'm bailing, go find some other sucker willing to give up their free time, for free, only to be bashed.
    9-16-2021: Re-Added Link for The Files, enjoy.