• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Unable to flash the original ROM - SP Flash Tool Error 4032

Search This thread

oukitel654

New member
Aug 4, 2021
1
0
Hello all good souls over here.
Could you please help me out with flashing back the original stock ROM to Mediatek MT6737M phone?
UMAX VisionBook P50 LTE, Mediatek MT6737M, 2GB RAM, 16GB internal memory.

What happened:
Before I was trying Oukitel P5 Pro ROM as well as Lineage OS and flashing with SP Flash Tool was working just perfectly.
But then I tried to flash Oukitel P5 Pro Andorid 7 stock ROM. (Oukitel P5 Pro and UMAX VisionBook P50 LTE are completely the same phones. Just different branding)
(And from now on I am not sure if I remember correctly)
When I loaded in scatter file, SP Flash Tool said something about something .... and recommended to do "Format all + Download" and I have done so.
Clicked on the Download button, flashing started instntly when I connected the phone while holding Volume - button.
Flashing stopped in maybe one second with the error which I do not remember as I closed the error window way too quickly. :-(
Later on I noticed that the preloader file is different in this Android 7 ROM then Android 6 ROM.

What is the current behavior:
When the phone is connected (with the battery inside) to the computer phone keeps connecting and disconnecting (appearing in Device manager as Mediatek USB Port) if I click Download button it starts doing "something" instantly which stops at Download DA 100% and after the while ERROR: S_FT_ENABLE_DRAM_FAIL (4032) pop up windows shows up.
The same error happens if I try to Format it and all other combinations in Download tab (Firmware upgrade, Format All + Download)
If I plug in the phone to the computer while pressing Volume - button phone will show up in the Device manager after about 20 seconds.

(Just to note - When the phone was working OK, I started flashing instantly when I plug the phone into the computer while pressing the Volume - button
So that kind of leads me that if nothing will show up in Device manager when I plug the phone to the computer while pressing Volume - button, then there might be the issue with the phone not switching into META mode? Not sure, just what I have read. But I cannot move any forward at this point.)

What I have tried:
- Correct stock ROM and Oukitel stock ROM (both Android 6 and both I was able to flash correctly and was able to boot them, until I tried Android 7 ROM)
- various SP Flash Tools 5.xxxx (and 3.xxxx too, but version 3 does not accept scatter file at all)
- USBDeview and removing all related USB devices from Windows and re-install them back again.
- Various VCOM drivers I have found on the Internet
- Flashing with SP Flash Tools on Linux (ends up with the exact same result - 4032)
- I tried shorting test point to ground on the phone main board. (The result was the same like when I plug the phone in while holding the Volume - button - Phone would not show up in Device manager for about 20 seconds)
- Tried flashing with the battery inside and outside the phone. (When the battery is outside flashing would not start, but the error about incorrect chip type will show up)
- Read many articles about this error all over the Internet


Do any of you think there is a change to bring the phone back to live? Or do you know what actually might happen to the phone? It does not seems to be completele bricked, but I cannot say in what state the phone is.

Thank you very much for your help and have a nice day.