Unable to get xA2 in fastboot mode

Search This thread

jaw2floor

Senior Member
Jan 8, 2012
211
43
Hi there,

strugggling to get the xa2 into fastboot mode so I can flash a new boot.img and root. I've enabled OEM unlocking and installed the USB drivers. the command 'adb reboot fastboot' doesn't work, just reboots the phone. adb over usb works fine. The official method to get into fastboot 'plug in USB whilst holding vol up/down' also doesnt allow me to get itno fastboot mode, phone just stays blank with a notification LED. I use 'fastboot devices' to see it if it connected. I've tried this on 2 PCs now to no avail

I'm thinking maybe the fastboot drivers are wrong?

Does anyone have any other suggestions or help?

Thanks
 
Last edited:

simply F

Senior Member
Hi there,

strugggling to get the xa2 into fastboot mode so I can flash a new boot.img and root. I've enabled OEM unlocking and installed the USB drivers. the command 'adb reboot fastboot' doesn't work, just reboots the phone. adb over usb works fine. The official method to get into fastboot 'plug in USB whilst holding vol up/down' also doesnt allow me to get itno fastboot mode, phone just stays blank with a notification LED. I use 'fastboot devices' to see it if it connected. I've tried this on 2 PCs now to no avail

I'm thinking maybe the fastboot drivers are wrong?

Does anyone have any other suggestions or help?

Thanks
Hi
Install "5 seconds adb drivers"
Connect the turned off phone to PC via USB just pressing volume down button (no power) and keep pressing it until you see the LED turning green or blue.
Here u have! :highfive:
 
  • Like
Reactions: jaw2floor

jaw2floor

Senior Member
Jan 8, 2012
211
43
Hi
Install "5 seconds adb drivers"
Connect the turned off phone to PC via USB just pressing volume down button (no power) and keep pressing it until you see the LED turning green or blue.
Here u have! :highfive:

Hi thanks for getting back to me,

I assume you meant the '15 second installer', which I just did just install successfully. I am still unable to see the device with 'fastboot devices' command.

Other info: I have factory reset the phone, made sure oem unlock is checked, tried the same process on another computer. I can get adb mode to work fine, but the command 'adb reboot fastboot' just reboots the phone as usual
 

schmatzler

Senior Member
Sep 12, 2009
122
39
The official method to get into fastboot 'plug in USB whilst holding vol up/down' also doesnt allow me to get itno fastboot mode, phone just stays blank with a notification LED.
That is the correct behaviour.

Blue LED = Fastboot mode
Green LED = Flash mode (for reflashing stock firmware with XperiFirm in case EVERYTHING is broken)

Install these drivers:
https://adb.clockworkmod.com/

When in Fastboot mode, go to device manager, there is an Android device in there (may also be called MTP device).
In the device manager, install a new driver for that and use the ADB driver from C:\Program Files (x86)\ClockworkMod\Universal ADB Driver

Windows will tell you that it's the wrong driver. Install it anyway and Fastboot will recognize your XA2 now.
 

simply F

Senior Member
That is the correct behaviour.

Blue LED = Fastboot mode
Green LED = Flash mode (for reflashing stock firmware with XperiFirm in case EVERYTHING is broken)

Install these drivers:
https://adb.clockworkmod.com/

When in Fastboot mode, go to device manager, there is an Android device in there (may also be called MTP device).
In the device manager, install a new driver for that and use the ADB driver from C:\Program Files (x86)\ClockworkMod\Universal ADB Driver

Windows will tell you that it's the wrong driver. Install it anyway and Fastboot will recognize your XA2 now.
If it won't work, after that just go to devices and printers and delete Xperia XA2. It will work.
Else, after installing 15 seconds, inside device manager, update the driver of your phone (or mtp device), select local, then Android device, then fastboot. Disconnect the phone and reconnect as before (volume down)
 

bombenbodo

Member
Jan 31, 2012
8
3
Fastboot is VOL. UP (on this device)! (Not vol. down)
So basically turn off the device, hold Vol. UP and simply connect to USB, hold Vol. UP until LED is steady blue and you are set.

Note: VOLUME UP activates fastboot and VOLUME DOWN enables flashmode and/or recovery mode
 
Last edited:

Corias

Senior Member
May 12, 2009
197
17
33
Moscow
Similar trouble here.
1. VOL UP + plug in USB: Blue led blinks once, then phone shows it's charging (turned off)
2. adb reboot bootloader: Phone just turns off
 

BoernMe

Member
Jul 4, 2019
11
3
Frankfurt
Similar trouble here.
1. VOL UP + plug in USB: Blue led blinks once, then phone shows it's charging (turned off)
2. adb reboot bootloader: Phone just turns off

I had the same issue with my XA2.
The solution (at least for me) was: different USB cable and different USB-port. As it turns out, my cable was somehow worn out (though data transfer and charging was working quite well). Going into fastboot, the blue led lit very short time and then the phone restarted. Furthermore on my PC it somehow only worked on the one USB port and not the other (both USB 3.0).

--> Maybe trying the most obvious might help also some of you :)
 

Corias

Senior Member
May 12, 2009
197
17
33
Moscow
I had the same issue with my XA2.
The solution (at least for me) was: different USB cable and different USB-port. As it turns out, my cable was somehow worn out (though data transfer and charging was working quite well). Going into fastboot, the blue led lit very short time and then the phone restarted. Furthermore on my PC it somehow only worked on the one USB port and not the other (both USB 3.0).

--> Maybe trying the most obvious might help also some of you :)
Did solve this by connecting to different PC. No cable/port/hub change did help. Looks like there was some trouble with drivers (though the same PC fastboots Z3 Tablet Compact perfectly).
 

that_random_guy

New member
Nov 25, 2020
1
0
Same

I'm also having the same issue with my Xperia XA2 Ultra. (boy that's a mouthful)

Phone model is H3223.
Host OS is Windows 10 Pro v. 2004.
Using latest Android SDK tools (i.e. ADB and Fastboot platform tools): platform-tools_r30.0.5-windows. Got it directly from Android site.

I think I had a previous driver for Android already installed or somehow Windows got it. ADB worked, Fastboot didn't. Read online about someone on this forum getting it to work by using XZ2 driver from Sony as they evidently don't have a published driver for this device. The person who posted this solution had reported problems with this driver recently. I tried it anyway.... ADB commands work and my phone shows up when listing devices. Reboot into fastboot mode and the only thing my phone does is show a blue light indicator... no splash screen or logo. To me this means it's starting fastboot but my driver isn't working with it to recognize it as any commands for fastboot return nothing or fail. It doesn't show up under fastboot devices command.

Does anyone have a clue as to what to do?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi there,

    strugggling to get the xa2 into fastboot mode so I can flash a new boot.img and root. I've enabled OEM unlocking and installed the USB drivers. the command 'adb reboot fastboot' doesn't work, just reboots the phone. adb over usb works fine. The official method to get into fastboot 'plug in USB whilst holding vol up/down' also doesnt allow me to get itno fastboot mode, phone just stays blank with a notification LED. I use 'fastboot devices' to see it if it connected. I've tried this on 2 PCs now to no avail

    I'm thinking maybe the fastboot drivers are wrong?

    Does anyone have any other suggestions or help?

    Thanks
    Hi
    Install "5 seconds adb drivers"
    Connect the turned off phone to PC via USB just pressing volume down button (no power) and keep pressing it until you see the LED turning green or blue.
    Here u have! :highfive:
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone