• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

unbrick Lenovo tab M10 plus (x606x)

Search This thread


New member
Nov 14, 2020
Hello everybody,

first of all I'm, sorry for my newbie's awkwardness and for my bad english too...

I'm a linux (Debian) enthusiast and I'd liked to install it on my Lenovo Tab M10 Plus; my choice felt on "Linux Deploy" but it needs a rooted device so, after an internet search for tutorials and tips and a system backup (.adb file saved on PC) I bravely tried with Magisk... and I failed (or I think so). :eek:

The tablet start in a never-end booting loop and on the splash screen appears the message
Orange State
Your device has been unlocked and can't be trusted
You device will boot in 5 seconds

I can access in fastboot mode so I tried to flash a no-rooted (downloaded) boot.img but it didn't works (the flashing process reports OKAY but the device reboot anyway in Orange Status), I tried with the flashall command that reports
error: ANDROID_PRODUCT_OUT not set
I tried to wipe and flash but it didn't works, I granted the access in some recovery mode and tried to install the .adb backup file from the SD card but the system says :
E: signature verification failed
E: error: 21
Installation aborted.

I thought to open the backup .adb file for extract the original files (I don't know if it could be done and if it could be useful) but how? :confused:
I think someday someone more skilled than me will solve the problem but, waiting for that day... any advice ?

Thanks, anyway.

Cheers, Ste.


New member
Oct 24, 2021
Same problem...lenovo tab x606F firmware is not present in Lenovo Rescue Smart Assistant and you can't add it manually!