Unlock Huawei Modems and Routers Free

krysak

New member
Feb 26, 2009
0
0
0
Hi, I've router FD-M60 H1 (HUAWEI E5785 made for Irancell). V2, V3 codes seem to be too short (can't even use Apply button).
IMEI: 862418037744522
Any help appreciated.
 

donci17

Member
Sep 11, 2020
13
0
1
E5577Cs-321 unlock - no COM Port found

Hello,

i have a E5577Cs-321
IMEI: 8646950****


Hardware-Version: CL1E5573SM11
Software-Version: 21.329.63.01.55
Weboberflächen-Version: 17.100.20.02.55

This is still locked. Trying to connect it to my Windows 7 works, but i can't see a COM Port . There was a hint to change the settings with a script and the issue with putty these commands

1.at^sfm=1
2.at^reset
3.AT^NVWREX=8268,0,12,1,0,0,0,2,0,0,0,A,0,0,0
4.at^sfm=0
5.at^reset

I see only a DVD with simple startup commands and a RNIS Driver in my device manager.

From several site i found identical codes V1, V2 and V3/203 but to they work?

Any idea how to unlock this device?
 

arsenal65

Member
Jul 10, 2016
19
0
1
Hello,

i have a E5577Cs-321
IMEI: 8646950****


Hardware-Version: CL1E5573SM11
Software-Version: 21.329.63.01.55
Weboberflächen-Version: 17.100.20.02.55

This is still locked. Trying to connect it to my Windows 7 works, but i can't see a COM Port . There was a hint to change the settings with a script and the issue with putty these commands

1.at^sfm=1
2.at^reset
3.AT^NVWREX=8268,0,12,1,0,0,0,2,0,0,0,A,0,0,0
4.at^sfm=0
5.at^reset

I see only a DVD with simple startup commands and a RNIS Driver in my device manager.
FC_Serial_Driver_Setup and HUAWEI_DataCard_Driver_5.05.01.00_Setup.

From several site i found identical codes V1, V2 and V3/203 but to they work?
Sorry, no.

Any idea how to unlock this device?
Downgrade E5577s-321_Update_21.200.05.00.00_Universal.
Putty-> AT^NVRDEX=50503,0,128

Write the result here or in a private message. I'll help you unlock it.
 
Last edited:

donci17

Member
Sep 11, 2020
13
0
1
Downgrade E5577s-321_Update_21.200.05.00.00_Universal.
Putty-> AT^NVRDEX=50503,0,128

Write the result here or in a private message. I'll help you unlock it.
I installed the both drivers, and when i try to install the firmware it will not find the port. (Error 10 Port not found)

If i use th Open OC UI Interface File found in the net, i get COM4, I can access my device via putty so it seems to work, I closed putty,
I am asked for a password (8 digit flash code) which is accepted and i see something tried to download, my Browser is open but at the end i gat an error 19 (download failed)....

Any idea?
 

arsenal65

Member
Jul 10, 2016
19
0
1
I installed the both drivers, and when i try to install the firmware it will not find the port. (Error 10 Port not found)

If i use th Open OC UI Interface File found in the net, i get COM4, I can access my device via putty so it seems to work, I closed putty,
I am asked for a password (8 digit flash code) which is accepted and i see something tried to download, my Browser is open but at the end i gat an error 19 (download failed)....

Any idea?
PM sent....
Before putty
at^sfm=1
at^reset
 
Last edited:

donci17

Member
Sep 11, 2020
13
0
1


PM sent....
Before putty
at^sfm=1
at^reset
I have 21,329,63,91,55 installed. Seems to be that Huawei disabled these commands..
ati

Manufacturer; huawei
Model: E5577Cs-321
Revision: 21.329.63.01.55
IMEI; 864695039539004
+GCAP: +CGSM,+DS,+ES
OK


at^sfm=1

ERROR


I seem to be forced to open the device and shorten the 2 pins to get into boot mode....
 

donci17

Member
Sep 11, 2020
13
0
1
Hello,

it seems to be that i have to put my modem in boot mode. I opened it and if i connect boot-Pin to ground and then connect it to my pc, i hear a sound and then a browser window
to 192.168.8.1 pops up. Issuing a bat-file turns my e5577 from ip mode to serial mode and i see two com ports (application and gui) but no boot port.
The usbloader detects these 2 COM Ports but i can't flash the boot loader...

Any idea how to downgrade?

I have the required firmware, usbload.bin, usb loader...
 

arsenal65

Member
Jul 10, 2016
19
0
1
Hello,

it seems to be that i have to put my modem in boot mode. I opened it and if i connect boot-Pin to ground and then connect it to my pc, i hear a sound and then a browser window
to 192.168.8.1 pops up. Issuing a bat-file turns my e5577 from ip mode to serial mode and i see two com ports (application and gui) but no boot port.
The usbloader detects these 2 COM Ports but i can't flash the boot loader...

Any idea how to downgrade?

I have the required firmware, usbload.bin, usb loader..
The gui port is the right one.
The display stays dark when connected. (boot-Pin)
Then the Run “Balong USB Downloader” tool.
Load: E5577s_usbloader.bin
https://www.youtube.com/watch?v=vB-V8g3Oy5U&list=PLEg5a8r8YQ10n5F35SN9uaYpzsK8dXBgE&index=2
 
Last edited:

donci17

Member
Sep 11, 2020
13
0
1
The gui port is the right one.
The display stays dark when connected. (boot-Pin)
Then the Run “Balong USB Downloader” tool.
Load: E5577s_usbloader.bin
https://www.youtube.com/watch?v=vB-V8g3Oy5U&list=PLEg5a8r8YQ10n5F35SN9uaYpzsK8dXBgE&index=2
U get a BOOT_3G Port but trying to load the USB loader (Huawei_E5577s_usbloader.bin 5.888.912 Bytes) fails, this is the output,,,

Any idea?

Ïîèñê óñòðîéñòâ:

COM5 - Kommunikationsanschluss
ACPI\VEN_PNP&DEV_0501
ACPI\PNP0501
*PNP0501
COM8 - HUAWEI Mobile Connect - 3G PC UI Interface [BOOT_3G]
USB\VID_12D1&PID_1443&REV_0001
USB\VID_12D1&PID_1443

Ïàðàìåòðû çàãðóçêè:
00000001. 00000D54 00000000 00000054
00000002. 0059CDE8 57900000 00000DA8
Íàéäåíî 2 áëîêà(îâ) äëÿ çàãðóçêè.

Ïûòàåìñÿ îòêðûòü óñòðîéñòâî \\.\COM8 ...
 

donci17

Member
Sep 11, 2020
13
0
1
arsenal65;83577117 Any idea? FC_Serial_Driver_Setup HUAWEI_DataCard_Driver_6.00.08.00_Setup Driver install[/QUOTE said:
I installed the drivers FC_Serial_Setup and the 6.0 Drivers without any change. i still cant download the .bin file...

I have Windows 10.... hmmmm and now?
 

donci17

Member
Sep 11, 2020
13
0
1
I have Windows 10.... hmmmm and now?
does port 2 appear in device manager?[/QUOTE]

If i start the device normal it connects to 192.168.8.1. If i issue the Change Port Script i see

HUAWEI 3G Application Interface
HUAWEI 3G PC UI Interface
and i cant issue the
at^sfm=1 or at^nvwrex commands, this software seem to block them...

I have this Version on my box;

Software-Version: 21.322.01.00.55
Weboberflächen-Version: 17.100.20.02.55
 

Zeyfer87

Member
Jan 13, 2018
30
6
0
help please, i can't get a code that works.
Model: b310s-22
Software version: 21.300.01.00.00

^NVRDEX: 50503,0,128,2B 7B 6E 53 44 2D 7C 63 51 69 14 BC 80 30 F4 01 9A 29 10 E0 84 AE 2F 7C 50 B9 D9 27 A1 68 59 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0 0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 D3 D9 E1 CB F7 1A 21 5F F6 2F CA E2 2A 18 34 A4 56 C2 62 42 B8 E1 9A 33 49 5E 35 DE E6 CC 59 38 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0 0 00

through putty I get that hash but for some reason I get an error, I think there are a couple of numbers missing in the first pattern

2B 7B 6E 53 44 2D 7C 63 51 69 14 BC 80 30 F4 01 9A 29 10 E0 84 AE 2F 7C 50 B9 D9 27 A1 68 59

D3 D9 E1 CB F7 1A 21 5F F6 2F CA E2 2A 18 34 A4 56 C2 62 42 B8 E1 9A 33 49 5E 35 DE E6 CC 59 38 01
 
Last edited:

arsenal65

Member
Jul 10, 2016
19
0
1
help please, i can't get a code that works.
Model: b310s-22
Software version: 21.300.01.00.00
through putty I get that hash but for some reason I get an error, I think there are a couple of numbers missing in the first group

2B 7B 6E 53 44 2D 7C 63 51 69 14 BC 80 30 F4 01 9A 29 10 E0 84 AE 2F 7C 50 B9 D9 27 A1 68 59

D3 D9 E1 CB F7 1A 21 5F F6 2F CA E2 2A 18 34 A4 56 C2 62 42 B8 E1 9A 33 49 5E 35 DE E6 CC 59 38 01
Not Enough characters in your pattern 1
 

donci17

Member
Sep 11, 2020
13
0
1
Downgrade E5577s-321_Update_21.200.05.00.00_Universal.
Putty-> AT^NVRDEX=50503,0,128

Write the result here or in a private message. I'll help you unlock it.
Hello,

so it seems to be a Windows 10 issue, with Windows 7 i can download the boot loader, afterwards 2 COM Ports appear and if i load your firmware i
get an unknown device in my device manager (Huawei Mobile) and it pings to 192.168.1.1..

I can't connect with putty to the device.

Flashing E5577s-321_Update_21.180.99.03.00.exe lets me connect to the device, i set the IMEI and serial number but again i can't flash the WebGui... and the device responds to 192.168.8.1

Any hints?