• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Unlocked N9750 Dual Sim Mobile Network Connection issues with TMobile SIM installed

Search This thread

CTF

Senior Member
Oct 6, 2007
55
4
Hello,

I just purchased an unlocked Note10+ N9750 Dual Sim in Taiwan, and I am currently located in Taiwan. The phone is on the latest SOFTWARE update from September 1st. ...ASI3.
When I put 2 Taiwanese SIM cards in the phone, the mobile internet works flawlessly and is extremely fast (About 200/50 on each network) when selecting SIM1 or SIM2 for mobile internet, with WiFi disabled. I can switch the cards and it works as expected.

The icons usually show 4G+, although it can sometimes slip into 4G for 10-20 seconds or so.
However, when putting my Tmobile SIM card into SIM1 or SIM2 along with a Taiwanese SIM card, and selecting the Taiwanese SIM card for mobile DATA (The goal here is to use the Taiwanese SIM card for data when in Taiwan), the mobile data is extremely slow (Around 2/0.5).
Furthermore, most of the time, when trying to access the internet, it appears that the phone is trying to connect for the first 5-10 seconds before actually bringing back internet data.
This can be with an app, like Whatsapp, or a simple Google search, or a speed test.
The icons will show 4G+ or 4G, not sure there is a pattern here.

I have tried everything I could think of with roaming ON/OFF, moving the SIM cards around, etc.
APN for Tmobile is correct and setup for IPV4/6 for normal, and IPV4 for roaming.

Again, if I simply replace the Tmobile SIM card with another Taiwanese provider (2 Taiwanese SIM cards installed), the internet is super fast and instantaneous on either SIM card.

The Tmobile SIM is working as expected in a Note9 TMobile Single SIM.

Not sure if anybody has some insight on what may be going on here...
Coming from a Note9 and the Tmobile SIM is less than 1 year old if I recall.

Thank you.
 

CTF

Senior Member
Oct 6, 2007
55
4
I forgot to mention that if I go into the SIM DEVICE MANAGER with both a Taiwanese SIM card and the TMOBILE SIM card installed and disable the TMOBILE SIM, the internet works fast as expected on the Taiwanese SIM.

As soon as I re-enable the TMOBILE SIM card, the internet is slow again and takes 5-10 seconds before bringing data back from a Google search, etc...
 

joogle

Senior Member
Dec 26, 2010
259
17
That's because if you are overseas with T-Mobile it caps data speeds I believe at 256kpbs.

I'm guessing the order of the Sim somehow maybe coming into play . Also generally second sim position will give you Lower speeds
 

CTF

Senior Member
Oct 6, 2007
55
4
Hello Joogle,

I should have mentioned that I have the 15GB pass from Tmobile, so 4G speeds while roaming up to 15GB. The speed when on the Tmobile card is very fast, 50/10 or so.
This is not the issue I believe.

Does 2nd position really give slower speeds? I did not know that.
 

CTF

Senior Member
Oct 6, 2007
55
4
Interestingly, I am in China at the moment and put a Hong Kong SIM card in slot #2 with my TMOBILE SIM in slot#1. Selected sim#2 for data, and everything works great and is always fast.
Not sure what to make out of that.

Preferred Network is set to: LET/TD-SCDMA/UMTS.
A bit confused by all the options of 4G SWITCHER.
 

CTF

Senior Member
Oct 6, 2007
55
4
Well, I found out that if I put my TMOBILE SIM in 3G/2G mode only, and leave the Taiwan SIM card at 4G/3G/2G, everything works great and fast with no delay...

This is fine since 3G is good enough for phone calls and text messages.