• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[UNOFFICIAL] LineageOS 16.0 for ZTE Axon 7

Search This thread

blu3wh0

Member
Aug 11, 2018
24
18
Thank you! I'll be trying this later today. Just curious though, does this include the vendor updates made in the latest LOS 15.1 unofficial builds? That is if they are compatible.
 

xXDomXx

Member
Jul 7, 2018
27
13
Up to now I can say system works perfect for me and a little bit smoother than older versions.
First boot took up his time for the changes, but everything works great.

Really good work from @OrdenKrieger!
 

Predatorhaze

Senior Member
Feb 18, 2016
1,191
208
Gelderland
Andriod security patch shows march 2019,vendor security shows july 2018

---------- Post added at 03:39 PM ---------- Previous post was at 02:42 PM ----------

No sound trough earbuds with audiofx on.Turn off audiofx and the sound works
 
  • Like
Reactions: mitchum67

olus

Senior Member
Oct 4, 2008
596
335
Can anyone confirm is the shutdowns and crashes solved ?
5mins ago i had a shutdown at under 50% battery. so i think its not fixed. or my battery is dead. after reboot i have 32% battery. sot is just 2h. when it happens again, i will try the kernel mentioned few post above.

edit: will try to force it by opening camera app. usually the screen flickers and then device shuts down when on camera with less than 50% battery. now im in a train and need my juice, will test it at home in about 30mins.

edit2: after starting cam at 24% battery and taking 2 photos, screen starts flickering, then "shutting down" is shown and battery drops to 0%. after reboot its at 21%.

i have this problem since months now. a few people here confirmed it, so i dont think its a faulty battery.
 
Last edited:

king1990

Senior Member
Oct 13, 2012
413
761
5mins ago i had a shutdown at under 50% battery. so i think its not fixed. or my battery is dead. after reboot i have 32% battery. sot is just 2h. when it happens again, i will try the kernel mentioned few post above.

edit: will try to force it by opening camera app. usually the screen flickers and then device shuts down when on camera with less than 50% battery. now im in a train and need my juice, will test it at home in about 30mins.

edit2: after starting cam at 24% battery and taking 2 photos, screen starts flickering, then "shutting down" is shown and battery drops to 0%. after reboot its at 21%.

i have this problem since months now. a few people here confirmed it, so i dont think its a faulty battery.
only in los16 ? you can try this kernel
Or you can go back to stock ROM and check if you still get the same issue
 
  • Like
Reactions: olus

olus

Senior Member
Oct 4, 2008
596
335
only in los16 ? you can try this kernel
Or you can go back to stock ROM and check if you still get the same issue
dont know, i dont have time to flash other roms.
yes, xXDomXx postet a link to this kernel few post above "kernel from mohammad baddar..".

i will try it, thank you very much!
 
Last edited:

blu3wh0

Member
Aug 11, 2018
24
18
I'm also still getting the crashes to red light and random restarts, so I'm currently trying the other kernel linked to in the above post. I used Schwifty Kernel vR5 previously as well, but that did not help with the crashes at all.

Everything else seems to work though. I had random issues with GPS on the previous build as well, so I'm hoping that was fixed in this one (haven't run into this yet).
 

olus

Senior Member
Oct 4, 2008
596
335
only in los16 ? you can try this kernel
Or you can go back to stock ROM and check if you still get the same issue
i flashed your kernel. will test it few days..

but what makes me really happy is that i finally can adjust the vibration strength with kernel adiutor. finally the ugly metalic/faulty vibrating is gone. thanks!
 

xXDomXx

Member
Jul 7, 2018
27
13
5mins ago i had a shutdown at under 50% battery. so i think its not fixed. or my battery is dead. after reboot i have 32% battery. sot is just 2h. when it happens again, i will try the kernel mentioned few post above.

edit: will try to force it by opening camera app. usually the screen flickers and then device shuts down when on camera with less than 50% battery. now im in a train and need my juice, will test it at home in about 30mins.

edit2: after starting cam at 24% battery and taking 2 photos, screen starts flickering, then "shutting down" is shown and battery drops to 0%. after reboot its at 21%.

i have this problem since months now. a few people here confirmed it, so i dont think its a faulty battery.

Have you tried to delete your batterystats.bin to recalibrate your devices battery?

For me it sounds weird, I have also an old battery but luckily I have not this problems at all.
 

olus

Senior Member
Oct 4, 2008
596
335
Have you tried to delete your batterystats.bin to recalibrate your devices battery?

For me it sounds weird, I have also an old battery but luckily I have not this problems at all.
no, last time i need to do things like this 7 years ago..
a few users confirmed this problem with flickering cam and then shutting down when battery is under 50% a few weeks ago here in this thread with this rom.
so i thought its a bug and not my battery.
will look for this posts and ask this users if they still have this problem.
thanks!
@atakan33 what shutdown and crash problems you had?

edit:here it is, 2 users confirm this "under 50% bug". one has done all battery calibration things:https://forum.xda-developers.com/showthread.php?p=77779078
 
Last edited:

Predatorhaze

Senior Member
Feb 18, 2016
1,191
208
Gelderland
i am using this rom with b12 bootstack.I flashed magisk 18.1 with swifty kernel,but i had to reboot like 5 times for magisk to show up.Then when i open magisk its asking if i want to upgrade to full magisk.Whats up with this? Magisk developer says we need to flash custom kernel after magisk,but others say we flash magik after custom kernel...what are the right steps? I always flash custom after magisk
 

king1990

Senior Member
Oct 13, 2012
413
761
i am using this rom with b12 bootstack.I flashed magisk 18.1 with swifty kernel,but i had to reboot like 5 times for magisk to show up.Then when i open magisk its asking if i want to upgrade to full magisk.Whats up with this? Magisk developer says we need to flash custom kernel after magisk,but others say we flash magik after custom kernel...what are the right steps? I always flash custom after magisk
Flash kernel , boot once , reboot to twrp , flash Magisk.
 
  • Like
Reactions: Predatorhaze

CSRoad

Member
Jun 28, 2014
26
14
I did a dirty flash of OrdenKrieger's latest posted build over LOS 5.1 Official with OpenGapps nano and Magisk with Props, after 25 hours of up time my phone seems to be working without any surprises.
Power usage seems normal, GPS seems accurate enough for a drone strike, it clicks in and out of airplane mode no problem, and no crashes thus far.
My online banking works for me, the phone phones in and out, that's important stuff to me.

Thanks for doing this OrdenKrieger, especially since you are no longer normally running the hardware, a lot of us still are and really appreciate this.
 
  • Like
Reactions: kaidelorenzo

Top Liked Posts

  • There are no posts matching your filters.
  • 80
    http%3A%2F%2Fi.imgur.com%2F2okPze5.png


    About Lineage OS:

    Lin·e·age
    /ˈlinēij/
    noun
    lineal descent from an ancestor; ancestry or pedigree.
    a sequence of species each of which is considered to have evolved from its predecessor.


    Disclaimer:
    LineageOS (Lineage Android Distribution) members or anyone else on this website is not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed. Please do some research if you have any concerns about features included in the products you find here before flashing it! YOU are choosing to make these modifications, and if you point the finger at us for messing up your device, we will laugh at you. Your warranty will be void if you tamper with any part of your device / software.


    Warning:
    This ROM will not work on devices that have not installed the O bootloader and appropriate modem package below. Also does any build from now on require a vendor partition, by doing this you will lose the ability to flash official builds provided by ZTE. Any failure in this process of flashing or repartitioning could lead to an unrecoverable bricked device.

    What's not working:
    SELinux is permissive

    Instructions:
    Attention! The bootloader needs to be unlocked!
    Attention! You'll need a vendor partition!
    1. Install the Universal bootloader and your model specific modem. Download
    2. Flash vendor creation tool. Download (unnecessary, if done already)
    * On first flash the device will reboot, just reboot to recovery and reflash the zip.
    3. Update your version of TWRP. Download
    4. Perform a backup of your current ROM. (optional)
    5. Wipe system,data and cache (optional) [Needed if coming from another rom!; always good to avoid bugs]
    6. Install the ROM. Download
    7. Install GApps. (optional) [Recommended -> Open GApps (arm64) (9.0)]
    8. Reboot.

    What is CAF?
    Code Aurora, a Linux Foundation Collaborative Project, hosts tested open source software code needed to provide upstream enablement for innovative, performance optimized, network connectivity and related ecosystems to support system on a chip (SoC) products. It also serves as a staging area for open source code that is submitted to various upstream projects such as the Linux kernel and Android. CAF also mirrors key upstream projects for use by the community.

    Sources, Changes, & Wiki:
    Source | Changes | Axon 7 Wiki | Lineage OS

    Credits:
    @Unjustified Dev
    @DrakenFX

    XDA:DevDB Information
    [UNOFFICIAL] LineageOS 16.0 for ZTE Axon 7, ROM for the ZTE Axon 7

    Contributors
    OrdenKrieger, Unjustified Dev
    Source Code: https://github.com/OrdenKrieger/android_kernel_zte_msm8996

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.x
    ROM Firmware Required: O bootloader + region modem
    Based On: LineageOS

    Version Information
    Status: Testing

    Created 2018-08-19
    Last Updated 2019-07-28
    52
    -UPDATE-

    Changelog:
    • 2018-09-05 Security Patch (android-9.0.0_r6)
    • Kernel based on newest P CAF tag release (LA.UM.7.6.r1-02000-89xx.0)
    • CNE, DPM, IMS, and RIL blobs updated from Axon M (fujisan) thx to @Unjustified Dev
    • Wlan based on newest P CAF tag release
    • Bluetooth based on newest P CAF tag release
    • RIL based on newest P CAF tag release
    • Fix API1 compatible camera ids, if HAL3 is enabled LineageOS Gerrit
    • Use thermal engine configuration from marlin (Google Pixel XL)
    • Some useful repopicks (e.g. APN updates, icons etc.)
    • LineageOS repo sync
    DOWNLOAD
    lineage-16.0-20180907-UNOFFICIAL-axon7.zip
    51
    Sorry for the inconvenience, didn't notes that LineageOS pushed the new CAF display,media and audio HALs to github. Since our display/media blobs are still based on an Oreo CAF tag, these cause issues with newer P CAF HALs. Next build scheduled for today.
    44
    -UPDATE-

    Changelog:
    • 2018-11-05 Security Patch (9.0.0_r16)
    • Kernel and qcacld-2.0 to LA.UM.7.5.r1-03100-8x96.0
    • Update DRM from Pixel XL (marlin)
    • Update GPS to LA.UM.7.5.r1-03100-8x96.0
    • Update SDM, Vulkan blobs
    • Update CNE, DPM, IMS, and RIL blobs from Axon M (fujisan)
    • Changes from B20 stock build imported
    • Smaller misc fixes
    • Repo sync LineageOS
    DOWNLOAD
    lineage-16.0-20181114-UNOFFICIAL-axon7.zip
    44
    -UPDATE-

    Changelog:
    • SD cards not being detected fixed
    • Snap and Qcom Gallery2 are back
    • ANT+ enabled again and blobs updated for P
    • IPACM enabled again and updated for P
    • Marlins (Pixel XL) brightness curve is used now
    • Smaller misc fixes
    • Repo sync LineageOS
    DOWNLOAD
    lineage-16.0-20180918-UNOFFICIAL-axon7.zip