[UNOFFICIAL][LineageOS 20.0][ Android 13 ] For A310, A510, and A710[ALPHA]

Search This thread

html6405

Recognized Developer
Code:
/*
* Your warranty is now void.
*
* I am not responsible for bricked devices, dead SD cards,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at me for messing up your device, I will laugh at you.
*
*/
Hi,

here you can find my build for the A310, A510, and A710,
most problems are already solved.

Here you can see how far everything is working for now.

  • Boot
  • Audio
  • Bluetooth
  • Graphics
  • Cameras
  • Wifi
  • USB
  • Video playback (HW/SW)
  • Tethering via USB
  • OTA-Updates
  • RIL
  • Mobile data
  • GPS
  • DRM
  • Tethering via WIFI and Bluetooth
  • much more...
  • Sensors
  • Audio server is crashing in a phone call for a5 and a7

Do you like my work?
Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
I'm doing this in my free time and it also costs a lot of money to buy hardware.

donate

Instructions (for S3, simply use the files for your device)
XDA:DevDB Information
[ROM][13.x][a3xelte a5xelte a7xelte][ALPHA] LineageOS 20, ROM for the Samsung Galaxy A3, A5 and A7 ( A310, A510, and A710)

Contributors

html6405
Source Code: https://github.com/html6405

ROM OS Version: 13.x T
ROM Kernel: Linux 3.x
ROM Firmware Required: TWRP 3.5.2
Based On: LineageOS

Thanks
danwood76 for the great work for these devices
The LineageOS team
And all others who have contributed to the Exynos projects past and present

Version Information
Status:
Alpha

Created 2022-11-30
Last Updated 2022-11-30
 
Last edited:

TheRain12

Member
Jul 13, 2022
17
4
I can't wait to try it on the A3 2016 phone, which I put on the shelf after buying a new phone. When will the HTML video come to the YouTube channel
 

kurtn

Senior Member
Jan 28, 2017
4,783
2,139
Small town in Bavaria
Tried to upgrade a3 from 19 to 20. But stuck in twrp updating. Flashed IMG file too recovery partition. Then tried to reboot into recovery.

From that point I only see Samsung logo boot screen. Any long press button combo just vibrates and reboots that screen.

Any idea to debrick?
 

html6405

Recognized Developer
Tried to upgrade a3 from 19 to 20. But stuck in twrp updating. Flashed IMG file too recovery partition. Then tried to reboot into recovery.
yoooo great work!!!!!

i compiled TWRP 3.7.0-11.0 for A310F, anybody wanna test? it's still in a testing stage
Did you try this one?
It should work to get into the download mode, try to press the button combination as long as needed,
it also could help to attach the usb charger to switch it off..
Then unplug it and give it another try to boot into the download mode and reflash a working TWRP.
 
  • Like
Reactions: notnoelchannel
Did you try this one?
i didn't upload the twrp 3.7.0-11.0 anywhere, it's a private build. needs some fixes
Tried to upgrade a3 from 19 to 20. But stuck in twrp updating.
can you attempt a clean install? if not, please try.
Flashed IMG file too recovery partition. Then tried to reboot into recovery.

From that point I only see Samsung logo boot screen. Any long press button combo just vibrates and reboots that screen.
what recovery did you flash after twrp? LOS 20.0 recovery? if did, please reflash twrp 3.6.2 and attempt a clean install
 
Last edited:

kurtn

Senior Member
Jan 28, 2017
4,783
2,139
Small town in Bavaria
i didn't upload the twrp 3.7.0-11.0 anywhere, it's a private build. needs some fixes

can you attempt a clean install? if not, please try.

what recovery did you flash after twrp? LOS 20.0 recovery? if did, please reflash twrp 3.6.2 and attempt a clean install
I cant do anything. I wait now for the battery to drain to shutdown.

I tried to install OP linked
 
I cant do anything. I wait now for the battery to drain to shutdown.

I tried to install OP linked
Use vol down+home+power to force reboot, then try to install twrp 3.5.2
 
  • Like
Reactions: kurtn

kurtn

Senior Member
Jan 28, 2017
4,783
2,139
Small town in Bavaria
So. Dirty upgrade worked. Signature spoofing not yet.
What sensors are to test?


Edit: all Sensors I tested work. Signature spoofing is only for system apps. Minmicrog CLI works.
 
Last edited:

HeladeraDragon

New member
Apr 28, 2022
4
2
How's performance? There's no way Android 13 is actually usable. How bad is performance with gapps?? This ****'s insane, once audio works I'll give this a shot. Keep up the good work!
 

html6405

Recognized Developer
So. Dirty upgrade worked. Signature spoofing not yet.
What sensors are to test?


Edit: all Sensors I tested work. Signature spoofing is only for system apps. Minmicrog CLI works.
Really? That's great, which version did you test?
The one in the main download folder or the one in the test folder?
Could someone test the a7 builds and report?
I've also created two builds, one with maybe not working sensors and another one in the test folder.
 

kurtn

Senior Member
Jan 28, 2017
4,783
2,139
Small town in Bavaria
Ok that's good to know,
could you also test the other build?
It could be that you will face a bootloop but idk.

But if you confirm that the normal build has working sensors, I'm already happy.
So they have identical file names? Only the test build is a few kilobytes larger.

No boot loop. Just stuck in boot animation for 10 minutes now. (Dirty flashed test over normal 20.0)
 
Last edited:
  • Like
Reactions: html6405

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello friends, I see that you are having problems with sound, specifically with sound controls. This is because configuration files are missing. And although html6405, he is doing a great job with his unofficial versions of LineageOS 19.x and 20, Android 10+, changes some things, which cause problems. The first thing is that .conf files no longer work (.conf to .xml compatibility form is removed since Android 10). All files have to be XML. And they must be in, this case in:

    system/vendor/etc

    And with the following attributes/permissions:

    user (uid 0): root
    group: (guid 0) root
    permissions (octal): 644 -> -rw-r--r--

    The missing files, you can download them from the Android 13 Source Code itself:

    https://android.googlesource.com/platform/frameworks/av/+/refs/heads/master/services/audiopolicy/config/

    The main problem is that it was missing, some important file such as default_volume_tables.xml not being found, it is as if the volume was always zero. And in fact if you went up manually, it returned to zero. At least in the case of my SM-A510F.

    By the way, you can copy them all, it is the best. Everything has to do with each set of files, it is a revision or change of Framework (since API 29+ Android 10). Where you have to match the content of this, if not when the problems come. If you look, a 7.0 appears, at the end of some files. This is because it is version 7.0 (HAL/audioserver). The current one is 7.1, but with that it would work for you.

    You can overwrite those who exist, but remember the correct permissions, if not it will not work, and even when restarting you will generate a bootloop.

    Greetings.
    2
    The main problem is that it was missing, some important file such as default_volume_tables.xml not being found, it is as if the volume was always zero. And in fact if you went up manually, it returned to zero. At least in the case of my SM-A510F.
    Hi,

    thanks, default_volume_tables was really accidentally missing on one of the first builds,
    but it should be already back,
    but I fear the audio server crash has another reason.
    Aren't you facing it while a phone call?
    New builds are in the making.
    2
    Screw it. I wanted to like this ROM, but simple things that should work simply don't (3G, calls, decent battery life, low RAM usage). Worst of all, the developer won't share their source (or actively ignores my comments), which makes it extremely difficult to trust that any changes were made in good faith, nor contribute any meaningful patches.

    Yes I know - don't like; don't use. I wanted to like it, but I simply don't trust this developer any more.

    I will go back to the trusty danwood76 lineage-18.1 branch. At least he shares his sources.
    Man, I'm busy and can't answere 100 messages per day, I have a job, life and a family to care for, so I'm sorry that I only find 5 minutes per day for XDA.

    All my sources are on Github.
    You can use the 19.1 branch, there is no 20.0 because there haven't been any changes in this repository,
    but I will create another branch later if there will follow some commits.
    but I simply don't trust this developer any more.
    Thats not a problem for me.
    I will go back to the trusty danwood76 lineage-18.1 branch. At least he shares his sources.
    Good bye 👋
    1
    Tamam, burada bir sorun var umarım birisi yardımcı olur. Oğul şimdi bu rom yüklü a310'a sahip ama o bir pokemon go nutcase(veya sadsac) Annesinin Facebook'u aracılığıyla giriş yapması gerekiyor.. ancak her zaman kimlik doğrulama hatası alıyor, ancak tabletinde sorunsuz oturum açabiliyor... bu ve önceki sürümlerde (18-19.1) oluşur


    Giriş yapmayı başaran var mı, öyleyse nasıl??? Olmazsa işe yarayacak bir rom önerebilir misiniz?

    şimdiden teşekkürler
    RR pie or Crdroid pie
    1
    First of all, forgive my tone -- it genuinely felt like you were deliberately ignoring my requests for the source, since I'd asked twice before.

    Secondly, thanks for dedicating any time at all towards FOSS projects. Toxicity from needy users (such as myself) can really drain any motivation to contribute anything at all, and juggling work and life along with projects like these is definitely not an easy feat and shouldn't be taken for granted.

    Genuinely, apologies for my tone.

    I guess I have one question then - is this LOS 19 or LOS 20? And if the latter, why is it not called LOS 19.1 or something?

    Thanks again
    It's ok, I forgive you, I just wanted to clarify that I'm not ignoring anybody, any message or anything else.
    I really just can answere a few questions per day and I have many threads, because I'm maintaining more than 10 devices and my spare time is really limited.
    Sometimes it's better to contact me via PM, I try to help where I can.
    I will recheck all sources later, if I've forgot anything to push.

    This is LOS 20.0, but there were no changes needed from 19.0 to 20.0 in the a3xelte repo for example.

    But I guess 3G, phone calls etc should work in this builds. Is your IMEI shown? Maybe this causes the battery drain on your phone?
  • 9
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    *
    */
    Hi,

    here you can find my build for the A310, A510, and A710,
    most problems are already solved.

    Here you can see how far everything is working for now.

    • Boot
    • Audio
    • Bluetooth
    • Graphics
    • Cameras
    • Wifi
    • USB
    • Video playback (HW/SW)
    • Tethering via USB
    • OTA-Updates
    • RIL
    • Mobile data
    • GPS
    • DRM
    • Tethering via WIFI and Bluetooth
    • much more...
    • Sensors
    • Audio server is crashing in a phone call for a5 and a7

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.

    donate

    Instructions (for S3, simply use the files for your device)
    XDA:DevDB Information
    [ROM][13.x][a3xelte a5xelte a7xelte][ALPHA] LineageOS 20, ROM for the Samsung Galaxy A3, A5 and A7 ( A310, A510, and A710)

    Contributors

    html6405
    Source Code: https://github.com/html6405

    ROM OS Version: 13.x T
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS

    Thanks
    danwood76 for the great work for these devices
    The LineageOS team
    And all others who have contributed to the Exynos projects past and present

    Version Information
    Status:
    Alpha

    Created 2022-11-30
    Last Updated 2022-11-30
    2
    Hello friends, I see that you are having problems with sound, specifically with sound controls. This is because configuration files are missing. And although html6405, he is doing a great job with his unofficial versions of LineageOS 19.x and 20, Android 10+, changes some things, which cause problems. The first thing is that .conf files no longer work (.conf to .xml compatibility form is removed since Android 10). All files have to be XML. And they must be in, this case in:

    system/vendor/etc

    And with the following attributes/permissions:

    user (uid 0): root
    group: (guid 0) root
    permissions (octal): 644 -> -rw-r--r--

    The missing files, you can download them from the Android 13 Source Code itself:

    https://android.googlesource.com/platform/frameworks/av/+/refs/heads/master/services/audiopolicy/config/

    The main problem is that it was missing, some important file such as default_volume_tables.xml not being found, it is as if the volume was always zero. And in fact if you went up manually, it returned to zero. At least in the case of my SM-A510F.

    By the way, you can copy them all, it is the best. Everything has to do with each set of files, it is a revision or change of Framework (since API 29+ Android 10). Where you have to match the content of this, if not when the problems come. If you look, a 7.0 appears, at the end of some files. This is because it is version 7.0 (HAL/audioserver). The current one is 7.1, but with that it would work for you.

    You can overwrite those who exist, but remember the correct permissions, if not it will not work, and even when restarting you will generate a bootloop.

    Greetings.
    2
    Yes, I have the same audio issues described by @RidaRida08
    So far I haven't found a way to circumvent this sound issue. It also shows the mute sounds icon twice.


    Also in whatsapp when I do a videocall, video is fine but audio is scrumbled.

    Just a sidenote, apart from the sound issue I am really happy with the performance. I did not came across other issues. I installed BiTGApps - arm -13.0.0-v1.8signed

    Let me know if there is something I can do to fix this one, share logs or something similar.
    2
    The main problem is that it was missing, some important file such as default_volume_tables.xml not being found, it is as if the volume was always zero. And in fact if you went up manually, it returned to zero. At least in the case of my SM-A510F.
    Hi,

    thanks, default_volume_tables was really accidentally missing on one of the first builds,
    but it should be already back,
    but I fear the audio server crash has another reason.
    Aren't you facing it while a phone call?
    New builds are in the making.
    2
    Do bank apps work in this ROM? Did anybody test SafetyNet?