[UNOFFICIAL][RECOVERY] OrangeFox Recovery R11.1_A12 (Support Android 12+)

Search This thread

Dkpost3

Senior Member
Dec 17, 2018
61
49
Moscow
OnePlus Nord
@Dkpost3 The thread title has been updated to reflect that this is an unofficial build.

cc: @DarthJabba9

Regards,
shadowstep
Forum Moderator
Can you please state clearly in your thread's title and the OP that this is an UNOFFICIAL release? This is not clear at all, and thus makes it easy for people to assume that this is an official OrangeFox release.

Thanks.

Is there a template for placement by OF (and in general by custom builds)? + I would like to lay out trees, including for OF, so that everyone could easily find them, and there was feedback coming + here is an example of another OF assembly
 

stibuz95

Senior Member
Sep 30, 2012
166
24
This recovery saved my phone from a bad recovery install. Things i've learnt:
-Orange Fox recovery works (boot at least and has a working terminal) with Oxygen OS android 12
- how to?
___fastboot flash "vbmeta partitions" as showed in previous post
___fastboot boot orangefoxrecovery.img

Installations seems not working in android 12 because oxygen os has been hardly changed and it restores its own recovery (recovery from color os way worst than the one from oxygen os android 11).
Anyway, thank you!
For those who read this post: Pixel experience recovery doesn't work on oxygen os android 12, we need to perform the downgrade to android 11 before going to Pixel. I hope to save someone from some softbricks :)
 
  • Like
Reactions: Dkpost3

Doc Sniper

Senior Member
Dec 8, 2010
464
384
  • Like
Reactions: marcol87

marcol87

Senior Member
Mar 17, 2016
91
6
CH-AQ
OnePlus Nord
Simultaneously push and hold the volume up and the power button.

Make sure you hit the UP part of the volume rocker. The down part will initiate a factory reset.

Release both buttons when you see the OnePlus logo come up.

From: https://www.ifixit.com/Guide/How+to+force+restart+the+OnePlus+Nord/135822

yes, this worked but I need to enter in the recovery.

also, I can't flash vbmeta and vbmeta_system because "unknown option -- disable-verity" (I have the last SDK)
 

JERKBALL

Member
Oct 7, 2006
16
4
OnePlus One
Xiaomi Mi 9
I have the same problem... No recovery is starting up... logcat during OrangeFox repeats this lines:

08-23 14:10:15.000 554 564 W HidlServiceManagement: Waited one second for [email protected]::IKeymasterDevice/default 08-23 14:10:15.000 553 553 I hwservicemanager: Since [email protected]::IKeymasterDevice/default is not registered, trying to start it as a lazy HAL. 08-23 14:10:15.000 554 564 I HidlServiceManagement: getService: Trying again for [email protected]::IKeymasterDevice/default... 08-23 14:10:15.001 553 673 W libc : Unable to set property "ctl.interface_start" to "[email protected]::IKeymasterDevice/default": error code: 0x20 08-23 14:10:15.001 553 673 I hwservicemanager: Tried to start [email protected]::IKeymasterDevice/default as a lazy service, but was unable to. Usually this happens when a service is not installed, but if the service is intended to be used as a lazy service, then it may be configured incorrectly. 08-23 14:10:15.004 1 1 E (5)[1:init][20220823_14:10:15.001370]@5 init: Control message: Could not find '[email protected]::IKeymasterDevice/default' for ctl.interface_start from pid: 553 (/system/bin/hwservicemanager)

Maybe someone knows, what this means...
 
  • Like
Reactions: Jonte777

slackarea

New member
Jun 9, 2008
2
0

OrangeFox Recovery Project​

Downloads OrangeFox-R12.1

Code:
fastboot boot OrangeFox-R11.1_A12-vndk30-avicii.img
After booting into the recovery, flash OrangeFox-R11.1_3_A12-vndk30-avicii.zip, it will reboot.

what is inside:
  • Support Android 12
  • Magisk-25.2
  • adb sideload
  • FDE decryption
or brick :)
Good luck.


Give feedback on the work or not work of this tool!

Version Information
Status: Beta
Current Beta Version: R11.1_A12

Release Date: 28-jule-2022



BTC Wallet :
bc1qepm8lmd6228dhdpn9e0rjkplpq7yftdhkxywcp
hi @Dkpost3 , first of all THANK YOU for your work!

I tried last three days to get your recovery working on my phone.

I did "flash boot recovery.img" via Fastboot but screen stuck.

If I wipe data directory recovery works very well. After I finished to setup my phone it didn't work again.

I tried to flash your and mine vbmeta and vbmet_system without success, same problem.

Now, I'm definitely here to help you if you need.

Let me know how can help you in your development. You can write me also in DM.

I'm looking forward to hearing you

P.S.:
Some details:
OneNord - OxygenOS 12.1 - Magisk 25.1
 
I tried this recovery (on OxygenOS 12.1), but unfortunately it remains stuck on the logo and doesn't boot properly. I also flashed the vbmeta partitions with success, but it didn't change anything in the end.

For anyone wandering about the "unknown option -- disable-verity" error when flashing the vbmeta partitions: try using platform tools and the standard windows cmd instead of the powershell, it worked for me.
 

Top Liked Posts