• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[UNOFFICIAL][ROM][10.0][phoenix] LineageOS 17.1

Search This thread

merothh

Senior Member
Sep 6, 2014
625
804
CLKTiI4.png


LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Grab the latest build, gapps, recommended recovery and firmware (if you're on a lower than recommended firmware)
  • Flash recovery via fastboot.
  • Reboot to recovery.
  • Format Data Partition.
  • Flash the latest build, gapps (if you wish)
  • Reboot

Downloads :





Telegram Support Group :

Reporting Bugs :
  • DO NOT Report bugs if you're running a custom kernel , Magisk or any other addons.
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your:
- LineageOS Version
- LineageOS Download url
- GApps version
 
Did you:
- Wipe
- Flash any custom kernel
- Flash any addons (Magisk, or any other mods)
- Restore with Titanium backup
- Reboot after having the issue
 
Are you using:
- A Task killer
- A Non-stock kernel
- Other modifications
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

XDA:DevDB Information
LineageOS 17.1, ROM for the Xiaomi Poco X2

Contributors
merothh, PIPIPIG233666
Source Code: https://github.com/sm6150-dev
ROM OS Version: Android 10
ROM Kernel: Linux 4.x
ROM Firmware Required: https://github.com/sm6150-dev/android_device_xiaomi_phoenix/blob/lineage-17.1/board-info.txt

Version Information
Status: Stable

Created 2020-09-07
Last Updated 2020-09-07
 
Last edited:

ZainBilq

Senior Member
Nov 29, 2014
1,040
425
wow...Reserved

Here are some of the screenshots if u wanna see
 
Last edited:

merothh

Senior Member
Sep 6, 2014
625
804
Can't believe i forgot to link the kernel source code here.

Anyways Android 11 is up and running on the X2. Here's a sneak peek
 
Aug 30, 2019
48
6
is there any recommended macro camera solution for lineageos?

Use ANX Camera v185

---------- Post added at 03:11 AM ---------- Previous post was at 03:10 AM ----------

Sir any thoughts about official lineage support?

Yah soon

---------- Post added at 03:14 AM ---------- Previous post was at 03:11 AM ----------

Is it possible to add refresh rate setting?

Nah lineage not allowed it