• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Unofficial twrp for Elephone u pro v3.2.1.0

Search This thread

kellogs667

Member
Nov 25, 2017
8
1
I flashed the TWRP and wiped Data, Cache and Dalvik but now I'm stuck in an Elephone-Logo Bootloop. Bootloader was unlocked, latest Stock ROM installed. I can get into Bootloader mode and Recovery but System won't boot. What can I do?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    https%3A%2F%2Fpicgur.org%2Fimages%2F2017%2F08%2F19%2F8WqRK.jpg


    WHAT IS TWRP?
    Team Win Recovery Project is a custom recovery for Android devices.
    It allows you to back up and restore your data, flash custom ROMs to your device, repair broken file systems, and root your device.

    Notice1:
    U Pro has A/B partitions. to prevent issues its good to flash it in both slot, because i/we can not know on which partition you are

    Notice 2:
    This version only working on Eragon roms
    Maybe soon I'll manage it to work on stock rom

    Notice 3: Sdcard now working

    DOWNLOAD
    TWRP for 20180227 Base via Qfil Flashtools:
    Go here : https://drive.google.com/file/d/1JZ59mO07Zc1a9kdA6j7LJvrgc9g2kf5d/view?usp=sharing

    TWRP for 20180511 Base and newer:
    Go here: https://drive.google.com/file/d/1RrWuncXsH8GtCTbaEgGpDffRUDK9fMVv/view?usp=sharing

    INSTALLATION

    if you use the old 20180227 Base you have to use Qfil Flashtools , because fastboot commands dont work in that Build.
    we have a good guide of how to use FLashtools already
    look here: https://forum.xda-developers.com/android/development/guide-elephone-pro-user-manual-t3775895


    if you are on 20180511 Base and newer you can use fastboot commands
    required : ADB and fastboot

    enable usb debugging in developer settings.

    do this:

    Code:
    adb shell
    Code:
    reboot bootloader
    now we flash it in slot a
    Code:
    fastboot flash boot_a twrp.img
    after that we flash it also in slot b
    Code:
    fastboot flash boot_b twrp.img
    Special thanks to
    teamwin for this awesome custom recovery
    And @skeleton1911 for his help
    1

    reinstalled, reflashed, flashed and reinstalled and still no show for extSD in TWRP. But am all set for now, placed Eragon v.5 and Magisk Mgr on microSD/USB C OTG dongle and installed the ROM(zip) + Magisk(zip) from there via TWRP. Everything's good 'xept that 0 extSD. I was also able to do TWRP nandroid sys backup which went on that OTG dongle, some 3.8GB, that'll save me some time in the future I'd think :laugh: So, with the Springtime weather outside am gonna leave my computer stuff now and go out to ejnoy some of that Spring! See you later!
    1
    Hi Skeleton my problem is:
    target reported max download size of 536870912 bytes
    sending 'boot_b' (55180 KB)...
    OKAY [ 1.564s]
    writing 'boot_b'...
    FAILED (remote: unknown command)
    finished. total time: 1.567s
    and
    PS C:\adb> fastboot flash boot_b twrp.img
    target reported max download size of 536870912 bytes
    sending 'boot_b' (55180 KB)...
    OKAY [ 1.564s]
    writing 'boot_b'...
    FAILED (remote: unknown command)
    finished. total time: 1.567s


    Can you help me??

    Thanks
    You are on build 20180227 so the flash commands not available you must use Qfil flashing tools to flash twrp
    1
    Thanks but I run now Eragon V6. Each time start the Rom appear yellow !.
    It's because the unlocked bootloader it's normal