General (Update) 12S Ultra doesn't use main sensor at 3rd party apps

Search This thread

jaehisme

New member
Aug 9, 2022
3
0
As you know, 12S Ultra has 3 camera sensors on the back.

The main sensor is IMX989, which is known as 1-inch sensor and it has best quality.
For ultra-wide and telephoto, it uses 1/2" IMX586.

When using default (Xiaomi) camera app, it uses IMX989 for wide, IMX 586 for ultra wide, telephoto, and macro.
This is normal. Nothing to be special.

But the problem starts when you're using 3rd party applications.
If application uses Android standard camera API, they will not utilize the main sensor.

Instead of a huge 1-inch IMX989, they will use IMX586 on the ultra wide.
You will get normal wide focal length (NOT ultra wide), but It will be noisier, less dynamic range, less resolution.

Maybe ultra wide sensor has two mode - full sensor readout for ultra wide, and pixel binning/cropping for macro and normal focal length.

This can be disappointment for some people, and huge minus for some nerdy professionals who using 3rd party apps like Filmic Pro.

You can test this by blocking MIDDLE lens on the back.
As far as I checked, Lightroom, Instagram, MotionCam, was not able to use Main sensor.


UPDATE : after clean installation of MIUI 13.0.7 with factory reset, problems are now fixed.

img.jpeg
 
Last edited:

Gioeli

Member
Nov 7, 2010
28
2
Thit is very weird, so I put it to the test.
The above apps you are saying you tried are working fine with the main sensor on mine phone.
I tried few more camera apps and they all use the main sensor too.
13.0.7 stable
 

Nabicook

Member
Jul 26, 2022
34
9
South Korea
I do confirm using main sensor on Lightroom.
However on lightroom it has only two camera modes, rear and front facing, and when you use the rear mode it first uses main sensor but when you are close to an object or you cover the laser sensor at the top, it automatically switches to ultrawide for macro.
version 13.0.7
 

jaehisme

New member
Aug 9, 2022
3
0
Okay. I made factory reset / clean installation with MIUI 13.0.7 and its fixed now.

Maybe it was an bug on MIUI 13.0.4 or temporal error.

Thanks for checking.
 

Killuminati91

Senior Member
Dec 12, 2012
326
115
Have you tested motioncam / mcpro24fps? Are all sensors available, and what are the possible resolutions / framerates?
Considering a 12s Pro if the compatibility is there.
 

jaehisme

New member
Aug 9, 2022
3
0
I‘ve tested MotionCam 4K at 30fps, 24fps. Only main sensor works.
But system will auto switch to macro (ultra-wide sensor) when you focus to close objects.