[Update 15063.297 & 14393.1884]Enable LED Notification In supported Lumia [09 Dec 17]

Riyad_

Senior Member
Jan 23, 2015
233
100
73
Chittagong
[Update 15063.297 & 14393.1884]Enable LED Notification In supported Lumia [09 Dec 17]

1st thing 1st .
if u have a hwnled Driver option on ur device root.
then this post will work for u.U can check that from Device portal.

Now This trick is for
730,735,830,925(Windows Button) (Tested)
930,950,950XL (Not Tested / Not Working)


Some Devices has hwnLED driver but not working .i don't know why..

N.B. - 830 doesn't have a LED.the windows button will blink as a notification LED. - Confirmed by @titi66200 .

STEPS::

** 1st download the cab From below.

.The cab is for latest production build 10.0.15063.297 . Make sure ur phone has the same build.

N.B. :: This is The Latest Build which is not supported for Older devices like 730,830. U have to change ur registry and get the update .
------------------------------------------------------------------------------------------------------------------
Check This Post for Older builds..
Link - [W10M BUILDS] W10M BUILD ROLLUP (cab-file-links) for all devices (TH2/RS1/RS2)
Thanks To @HD2Owner

Select Ur Build Version then find The Cab named "microsoft.ms_weh_ledalert.mainos.cbs_" .
------------------------------------------------------------------------------------------------------------------
For Build :: 15063.297
Cab Link - microsoft.ms_weh_ledalert.mainos.cbs_88e24d6711435faf43744fafa02760aaad53ad4b.cab

For Build :: 14393.1884
Cab Link - http://download.windowsupdate.com/d..._394677de43991fb2e5c88a8c88cac940692f2456.cab

Then Download I386.zip . from HERE


Instructions:

-Go to iutool path(extracted i386.zip folder) in cmd with admin rights.

Connect Ur phone with USB..
then Type "iutool -l" to see if the device is connected and recognized.

1. put the cab to a new folder like c:\cabs

2. then type: iutool -V -p c:\cabs

3. it should push the cab to the device and start the update.

4. there might be a error 0x8024a110 but it should work.

5. the device will automatically reboot very soon and go to flash mode (gears) to apply the cab.

6. then there will be the usual "data migration".

Voila..check out ur led is already blinking if u had a notification..if not please add those values via Interop tools/Root Tools by device model.

[Recommended] :: (I Prefer this method for better result.)

[HKEY_LOCAL_MACHINE\Software\Microsoft\Shell\Nocontrol\LedAlert]

"HardwareId"="ACPI\QCOM0D50" -for 730,830 and 930 (type=string)
"HardwareId"="ACPI\QCOM24A3" -for 950 (type=string)

Others are same for all device
"InstanceId"=dword:0
"LedHwAvailable"=dword:00000001
"Intensity"=dword:00000064
"Period"=dword:000007d0
"Dutycycle"=dword:0000003c
"Cyclecount"=dword:ffffffff

Then restart ur device..it will work.

[Not Recommended]::

if u cant add those values then download the zip file from below and extract it.. ..u will get a reg file..keep that in ur phone/sd card ..then goto interoptool>import registry file then choose the reg file and ok.. thats it..
View attachment 3944877 for 730,830and 930
View attachment 3945386 for 950

thanks to @djtonka for creating those reg files.
..u can also turn that off for specific app in settings>notification and action..hit thanks please if i helped :p

Check The Link for a short snap of 730 with LED - Check On Youtube !! (Click)
 
Last edited:

dxdy

Senior Member
Apr 17, 2008
5,040
2,106
0
47
www.red-gsm.net
if your phone not restart automatically, try this:

1. turn off phone
2. turn on
3. go to update check in settings, check for update (show no new updates, thats OK)
4. dont close settings, run "iutool -v -p c:\cabs"
5. phone should restart in few seconds

thats worked for me on few devices
 

djtonka

Senior Member
Aug 1, 2010
1,104
506
0
City
I designed it. BTW are we looking for similiar to this?



---------- Post added at 03:00 PM ---------- Previous post was at 02:52 PM ----------

lets plat with egistry also then

<?xml version="1.0" encoding="utf-8"?>
<CustomizationPolicy>
<SettingsGroup Path="LedNotification" xmlns="urn:Microsoft.WindowsPhone/PackageSchema.v8.00">
<Constraints ImageTimeOnly="Yes" />
<Setting Name="HardwareId" Description="HardwareId of LED">
<RegistrySource Type="REG_SZ" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\HardwareId" />
</Setting>
<Setting Name="InstanceId" Description="InstanceId of LED">
<RegistrySource Type="REG_SZ" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\InstanceIdString" />
</Setting>
<Setting Name="Intensity" Description="Denotes the intensity, from 0-100%. This setting is optional. If empty, the default value will be populated at run time.">
<RegistrySource Type="REG_DWORD" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\Intensity" />
<Validate Min="0" Max="100" />
</Setting>
<Setting Name="Period" Description="Specifies the period, in milliseconds. This setting is optional. If empty, the default value will be populated at run time.">
<RegistrySource Type="REG_DWORD" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\Period" />
<Validate Min="0" Max="999" />
</Setting>
<Setting Name="Dutycycle" Description="Specifies the duty cycle, from 0-100%. This setting is optional. If empty, the default value will be populated at run time.">
<RegistrySource Type="REG_DWORD" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\Dutycycle" />
<Validate Min="0" Max="100" />
</Setting>
<Setting Name="Cyclecount" Description="Specifies the number of repetitions per cycle. This setting is optional. If empty, the default value will be populated at run time.">
<RegistrySource Type="REG_DWORD" Path="HKEY_LOCAL_MACHINE\Software\Microsoft\Nocontrol\LedAlert\Cyclecount" />
</Setting>
</SettingsGroup>
 

Riyad_

Senior Member
Jan 23, 2015
233
100
73
Chittagong
I designed it. BTW are we looking for similiar to this?



---------- Post added at 03:00 PM ---------- Previous post was at 02:52 PM ----------

lets plat with egistry also then
i also enabled that via registry..but the led was not working because of policy and drivers.so i pushed the cap and it worked.
 
Nov 22, 2016
6
0
0
Guys, Ah.... I've just done this trick but... there is not LED notifications on my Lumia 730, even in Settings notification and action, there is no option for this, so what now, anyone can help? :D
 
Nov 22, 2016
6
0
0
Okay Thanks :)

---------- Post added at 04:27 PM ---------- Previous post was at 04:21 PM ----------

Can you show me the way to add those registry using Interop Tools beta pre 7?
 

Riyad_

Senior Member
Jan 23, 2015
233
100
73
Chittagong