"Update Failed! Main Version is older!"

Search This thread

petrafan007

Senior Member
Oct 31, 2008
69
1
WTF MATES!

Ok, so I probably should have done more research but I went to google and searched BY DATE for the most CURRENT INFO on rooting the phone. I got this site: http://www.goodandevo.net/2011/11/state-of-the-htc-evo-root-world-november-2011.html

I went by the HTC unlock method because the first link (revolutionary) didn't have my HBOOT version. Now, I'm suffering because of it because my fastboot doesn't come up any more. I get the message "Update Failed! Main Version is older!" So I went to this thread: http://forum.xda-developers.com/showthread.php?t=1239821

...and followed those instructions and...nothing worked. Is there any fix to this? Any help would be appreciated and sorry for being.... yes, a noob. :(
 

1107963

Senior Member
Jun 17, 2009
587
85
N/A
1- This is the wrong section
2- could you provide more info on your phone like what hboot version u have

If u are more specific you may have better luck...

Sent from my PG86100 using Tapatalk
 

amarsidhu

Member
Jul 7, 2005
6
0
@petrafan007:
i am getting the same error
main version is old
what should i do
you wrote "thank you very much, that's what it was. i removed the file and it worked"
which file you removed i have done alot of research and i did everything according to the tutorial but this error msg comes please help me out
i have hboot 1.49.0009 i want to go to 1.49.0007
early reply is appreciated as i want to get it done at the earliest
 

xHausx

Inactive Recognized Developer
Jul 5, 2010
6,782
4,521
Central Florida
@petrafan007:
i am getting the same error
main version is old
what should i do
you wrote "thank you very much, that's what it was. i removed the file and it worked"
which file you removed i have done alot of research and i did everything according to the tutorial but this error msg comes please help me out
i have hboot 1.49.0009 i want to go to 1.49.0007
early reply is appreciated as i want to get it done at the earliest

If you mount your sdcard you should see one named PG86IMG.zip, you'll need to rename or delete it.
 
  • Like
Reactions: amarsidhu

amarsidhu

Member
Jul 7, 2005
6
0
i am not being able to find the solution for this prob. i have done almost everything but still the same error pops up all the time. did it several time. first of all i am not being able to get the mmcblk0p31.img file.
i almost checked all the tutorials but no use i am still not being able to figure out that where i am going wrong.

---------- Post added at 05:36 AM ---------- Previous post was at 05:35 AM ----------

although ma phone is rooted and i have loaded the wifi tether titanium backup also but how to get the s-off done
 

raidraid

Member
May 19, 2009
28
0
hi , i try ti change my hboot 1.49.0018 to 1.49.0007 but in last stap when i try to flash PG86IMG.zip it says , main version is older!
please help
 

intrlude

Senior Member
Feb 1, 2008
149
25
Houston
hi , i try ti change my hboot 1.49.0018 to 1.49.0007 but in last stap when i try to flash PG86IMG.zip it says , main version is older!
please help

If GSM is anything like CDMA, you're S-On and because the file you're trying is older it will not let you flash it. Good luck.

Sent from the 3Dimension.
 

Desso90

Member
Aug 21, 2012
5
1
The reason you're getting stuck is because the bootloader automatically tries to load PG86IMG.zip if it exists on the sd card, the quick and dirty way around this is to remove the SD card, boot the phone up and but the card back when the phone has booted up.

"the main version is older" problem is due to the fact that before updating the timestamps on the hboot in the PG86IMG.zip(1.49.0007) and your current hboot (1.49.0009 or 1.49.0018) are compared, and as it turns out 1.49.0007 is the oldest of the bunch, so it gets rejected.

to get around the above mentioned problem (for the GSM version at least) follow the instructions in this thread http://forum.xda-developers.com/showthread.php?t=1471246 it basically changes the timestamp/versionID of the 1.49.0007 to trick the phone into downgrading.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Do you have a file called [PG86IMG.zip] still in the root of your SD card? It sounds like maybe you have an older update file that the phone wont use because you upgraded to the newest via the HTC Tool.
    1
    @petrafan007:
    i am getting the same error
    main version is old
    what should i do
    you wrote "thank you very much, that's what it was. i removed the file and it worked"
    which file you removed i have done alot of research and i did everything according to the tutorial but this error msg comes please help me out
    i have hboot 1.49.0009 i want to go to 1.49.0007
    early reply is appreciated as i want to get it done at the earliest

    If you mount your sdcard you should see one named PG86IMG.zip, you'll need to rename or delete it.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone