Update firmware with NetOdin

b_inglorious

Member
Jul 6, 2011
5
0
1
0. This process will factory reset your Watch, so make sure you've backed up everything you need!
1. Hold down the Home button for 6-10 seconds until the message " Rebooting ... "
2. Quickly press Home three times until the Reboot Menu appears. (The menu is available for about 10 seconds, after which the clock goes back to "Rebooting ...")
3. The menu selection is made by long holding Home button. To go into Download (wireless mode) press the home button until "Download (Wireless)" is highlighted, then hold down the Home button.
4. Download mode will load in WPS mode. Press Home twice to change the mode to the AP.
5. Connect to the access point that appears (for example, SM-R800-a2a5) (ODIN for some reason does not see the device if several networks are connected.)
6. Run NetOdin3 and then set the firmware files for BL, AP and CSC, then click Start (Copying/flashing of firmware takes about 20 minutes).
7. After the files are downloaded, the Watch will reboot. Again, hold Home and highlight & select Recovery in the Reboot menu.
8. The "Setting Up" screen and "Resetting" screen should appear and after that the Watch will reboot and boot as usual.

N.B. It is advisable to check whether you have disabled the function "find my watch" or make sure you remember the password to your Samsung Account

Files can be found here for R800 and R810 (46mm and 42mm Bluetooth / Non-LTE G.Watches) and NetOdin3 for Tizen:
R800XXU1BSA4
R810XXU1BSA4
NetOdin3 for Tizen
I'm trying to download netodin however the link seems to be expired.. could you please upload it again?
 

ahhydri

New member
Sep 12, 2011
3
0
21
Update firmware with odin mode

Did anyone tried flashing using the odin mode. I have galaxy watch3 in which wireless odin doesn't work. I'm looking to flash with odin. Did anyone here did flashing through odin mode ?
 

0burner0

New member
Dec 9, 2020
1
0
1
Same problem here to find the firmware files for a sm-r800.
Found Net-Odin.

Can someboddy post a link with the latest firmware?
I want to you samsung pay :cool:

Update: Found the files here:



R800XXU1DTG1 Tizen 4.0.0.7
R800XXU1DTC1 Tizen 4.0.0.7
R800XXU1DSL1 Tizen 4.0.0.7
R800XXU1CSI1 Tizen 4.0.0.4
R800XXU1CSG4 Tizen 4.0.0.4
R800XXU1BSU4 Tizen 4.0.0401
COMBASX800


But the next question is what firmware is the best.
I want to have samsung pay on my watch. And the most other cool functions.
 
Last edited:

mffmart

New member
Dec 20, 2020
2
0
11
Hi everyone.

I recently bought a Galaxy Watch running Tizen 4.0.0.7 out of the box, and I wanted to use Samsung Pay with it.

So, I tried changing the region (CSC) using the sdb method mentioned above. Unfortunately, I've then read and verified it doesn't work on 4.0.0.7.

Then I tried using NetOdin to downgrade my firmware, as suggested above, but the connection times out after 20 seconds and I fear the flash will be incomplete and I could brick my watch. I don't believe the firewall would be a problem because NetOdin does recognize the device for 20 seconds before timing out.

I also read something about tapping into the access pins on the back and connecting a cable, but I'd rather not mess around with the watch's internals.

Any ideas on how to fix the timeout, or another method I could use to change the CSC?

Your time and attention are much appreciated. :)

EDIT: It kept timing-out, until it simply started working. The one time it didn't time out, I couldn't believe it. Rebooted just to make sure, and it kept on working. Had to update the system back to Tizen 4.0.0.7 through Odin, though (the Galaxy Wear app wasn't finding the update). Thanks for your attention. :)
 
Last edited:

Allstar007

Member
Aug 24, 2017
30
7
8
Hello I have the Galaxy Watch SM-800 Bluetooth only version, according to Samsung there is an update. But Galaxy Wearble does not show any. I have the version R800XXU1DSL1, I don't know if there are different CSC versions like my Note 10 Plus, my Note 10 Plus has the German DBT version on it. My question is how do I get the correct version or the latest update on my smartwatch?
 

brunomanuelpt

Member
Nov 16, 2014
7
1
23
Hi guys,

I have the SM-R500 and I was trying to update the firmware using NetOdin, I could solve it, first with the AP installation.

Then I was able to turn on the device, all good...but then on the step to connect my smartwatch to the wireless (to change the region), and the smartwatch don't find any wireless network...

Then I was trying to do a new installation using NetOdin and when I'm facing the download (wireless screen) I'm facing the attach file error..."wd_cm_setup_ap: Failed to run soft AP -1"

Can anyone have a clue to solve one of the two situations?

Thank you so much in advance.
 

Attachments

Jeanclaude91

New member
Sep 14, 2020
1
0
1
[QUOTE = "brunomanuelpt, message: 84391973, membre: 6163544"]
Salut les gars,

J'ai le SM-R500 et j'essayais de mettre à jour le firmware en utilisant NetOdin, je pourrais le résoudre, d'abord avec l'installation AP.

Ensuite, j'ai pu allumer l'appareil, tout va bien ... mais ensuite sur l'étape pour connecter ma smartwatch au sans fil (pour changer de région), et la smartwatch ne trouve aucun réseau sans fil ...

Ensuite, j'essayais de faire une nouvelle installation à l'aide de NetOdin et lorsque je suis face au téléchargement (écran sans fil), je suis confronté à l'erreur de fichier joint ... "wd_cm_setup_ap: Impossible d'exécuter le logiciel AP -1"

Quelqu'un peut-il avoir un indice pour résoudre l'une des deux situations?

Merci d'avance.
[/CITATION]
Bonjour
Même problème avec affichage de "l’impossibilité d’exécuter le logiciel AP-1"après avoir essayé un firmware trouvé ici qui a désactivé le wifi.
Tu peux vérifier, car ma watch active 2 ne peux même plus se connecter en wifi car ne trouve plus le réseau.
Retour au SAV
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone