[UPDATED to SP1] WM6 Platinum Edition 5.2.1711.18165.0.5.0 SP1 by NiTroGen

NiTroGenious

Senior Member
Feb 16, 2007
411
18
0
41
Ioannina
www.nitrogen.gr
WM6 English ROM Platinum Edition (Service Pack 1)
OS 5.2.1711.18165.0.5.0


Details:
  • Newest OS version: 5.2.1711.18165.0.5.0 (thanks to GnatGoSplat)
  • Fully application unlocked!
  • 6MB Page Pool (can be changed without reflashing using this tool)
  • .NET CE version 3.5.7283.0
  • Startup/shutdown animation (with optional sound)
  • ATCIUI (Modem Link)
  • Voice Dialing over Bluetooth Headset (YES! I finally did it!!! :D)
  • Animated Startup/Shutdown screens (no sounds included - download here)
  • Bluetooth A2DP support
  • Bluetooth FTP Server and Explorer
  • Bluetooth SAP (Sim Access Profile) support
  • MMS client.
  • HTC Camera 4.00.23355
  • Internet Sharing
  • IE can download rar, exe, doc, pdf, 3gp and many more files thanks to FEADIE.
  • Windows Media Player playback support of 3gp, mpg, mp4, aac
  • Automatic date/time adjustment (needs latest GSM update and support by the network)
  • No connection problems with hidden SSID and WPA
  • NO WM6 VOIP LIBRARIES INCLUDED (since many people cannot use VoIP and it occupies about 1.6MB) - DOWNLOAD VoIP SUPPORT

New settings in Control Panel:
  • Customize hardware keys
  • Adjust scrollbar width
  • Enable/disable SMS send notification
  • Change ActiveSync name
  • Change Temp folder location (warning: new directory should already exist)
  • Change File System cache, Glyph cache (former Font Cache), Font cache (the real one), enable/disable Paging
  • Bluetooth A2DP Settings
  • ...and many more

Included Software
(check also the attached screenshot):
Service Pack 1 fixes/additions/changes:
  • Fix: Windows Media Player could not play midi files (fix included in attached service pack 1)
  • Fix: Windows Media Player could not stay in fullscreen mode (fix included in attached service pack 1)
  • Fix: WM5torage could not function properly (fix included in attached service pack 1)
  • Fix: Long Volume Down keypress could not function properly
  • Fix: FakeCursor was missing
  • Addition: Mortscript (Examples - IDE)
  • Addition: Right Menu
  • Change: Startup/Shutdown sounds removed to keep the available internal storage above 19MB. You can download them here!

Known bugs:
  • Camera application looses brightness when moving joystick left-right. Reset brightness to fix.

Available Memory:
32.29MB (give or take)
Available Internal Storage:
19.05MB (may be less on first boot - reboot and check again - maybe because of temporary first-boot files???)


This ROM is for "educational" purposes only. It is not supported by HTC. I hold no responsibility for any damage, injury, hair loss, sexual incapability or any other unfortunate events that may result from flashing and using this ROM.


Don't forget to SuperCID your phone and "format BINFS" before flashing!

If you like my work on Tornado, please DONATE!!! :rolleyes:

Downloads:
Latest version - WM6 Platinum SP1 (25 Feb 2008):​
Older versions:​
Latest GSM and SPL update:​

Extras:


Important Note
:
Since Feb 12th I'm serving in the army (one-year mandatory service). Although I'm not able to work on the ROM from there, I read the forum almost every day. I'll support my ROM on every change I get. I also plan on releasing a kitchen in the near future (possibly at the end of March), so that you'll be able to cook your own custom ROMs.

Please do not ask for a Vanilla ROM. You'll be able to make one yourself when the kitchen is released!



Many thanks to:
  • vjgrace and EA for implementing a lot of registry tweaks
  • GnatGoSplat for the new XIP
  • DSF, karhoe, Sefy, kartam, kkrull, illi, sonus and many more people for their ideas, hints, suggestions, bug fixes, etc.
  • Shark, Andot, DukeStix, and Phil (jm012a9749) for their original work on WM6 for the Tornado
  • Dr. Gonzo for some nice oem packages taken from his Vox ROM.
  • Everyone of you who have made a donation :)
 

Attachments

Last edited:

Sefy

Senior Member
Jan 2, 2007
671
74
0
Netanya
www.freewebtown.com
Me being the very first to use, saying this new rom rules! lots of new tools in it! and works REALLY fast! i'll report more after 24 hours (i'm reinstalling all of the programs i use :rolleyes:) but for now it's working perfect! :cool:

Remember my Sounds issue? well, although after flashing it was ok, seems like one of the installations is causing it to happen again. Now these are installations i've done on every rom so far, yet it's happening again even after i've done format binfs so can't blame it on that one!
 
Last edited:

superhiperclim

Senior Member
Feb 3, 2008
52
0
0
cascais
I am just starting here, so, if you can please help me...
I have a question for you, does this windows mobile work in any last generation smartphone?
I`m using a Treo 750, but it as wm5 spanish, and i would like to put wm6 eng...
can it be done?
 

Sefy

Senior Member
Jan 2, 2007
671
74
0
Netanya
www.freewebtown.com
I MAY have found the bug causing my "Sounds" to stop working! it's not with an installation! it's one of the tweaks in the registry which the phone is enabling! as soon as i track it down, i'll post which one and i'd recommend it's removal!:cool:

UPDATE! I found the bad Tweak!
Do NOT change the location of the Volatile folder! i strongly suggest REMOVING that option!
 
Last edited:

illi

Senior Member
I MAY have found the bug causing my "Sounds" to stop working! it's not with an installation! it's one of the tweaks in the registry which the phone is enabling! as soon as i track it down, i'll post which one and i'd recommend it's removal!:cool:

UPDATE! I found the bad Tweak!
Do NOT change the location of the Volatile folder! i strongly suggest REMOVING that option!
In my tests on the pre-release ROM I did not face the problem with Sounds that you faced. In fact I point the Volatile folder to SD card but did not delete it from main memory. I have been doing this with other previous ROMs too. It helps when sending emails with large attachments. I noticed this and a number of temp files are in fact in the \Storage Card\Volatile folder.

However during my testing at one stage I lost the sound. It was not as loud as usual. I tinkled with the Bluetooth A2DP and managed to regain the loudness. Seems strange to me.

Still with the pre-release ROM, i am faced with the two soft keys freezing.

Will try the final release in a while.

FYI I also point the UACONTENTS and Messaging
to SD Card without problems. This is for the MMS and SMS files respectively.

Thanks
illi
 

bipinsen

Senior Member
Sep 16, 2007
871
82
0
Windows Media Player

Did no one in beta testing or even now find a problem with WMP not playing *any* video? I can play the files just fine with TCPMP. :confused:
 

Sefy

Senior Member
Jan 2, 2007
671
74
0
Netanya
www.freewebtown.com
@illi, i'm only reporting the experience i had, i kept thinking one of my installation cause the "Sounds" to not work. Only after i restored the Volatile tweak back to it's place, they worked again.

When i put "Sounds" i'm talking about the Ringtones selection settings, when i've pointed the Volatile to my SD card (also, did not remove the original) then none of them would play and i get the error "corrupt or unavailable" even though the files were playable and available using any other player including wmp itself.

I've just given my personal experience, after flashing twice because this error.
 

illi

Senior Member
@illi, i'm only reporting the experience i had, i kept thinking one of my installation cause the "Sounds" to not work. Only after i restored the Volatile tweak back to it's place, they worked again.

When i put "Sounds" i'm talking about the Ringtones selection settings, when i've pointed the Volatile to my SD card (also, did not remove the original) then none of them would play and i get the error "corrupt or unavailable" even though the files were playable and available using any other player including wmp itself.

I've just given my personal experience, after flashing twice because this error.
@Sefy
Quite strange. Our experiences differ. I thought my experience will help you. Hope this new release dont have too much issue.
I am flashing the ROM now.

Shall report accordingly.

Thanks Sefy
 

Sefy

Senior Member
Jan 2, 2007
671
74
0
Netanya
www.freewebtown.com
@illi, what i report is from this release as well, as soon as i've used to tweak to move the Volatile to my Storage Card then none of the ringtones would play. As soon as i restored it to the original place, it started working again :confused:
 

NiTroGenious

Senior Member
Feb 16, 2007
411
18
0
41
Ioannina
www.nitrogen.gr
@illi, what i report is from this release as well, as soon as i've used to tweak to move the Volatile to my Storage Card then none of the ringtones would play. As soon as i restored it to the original place, it started working again :confused:
Did you create the directory on the Storage Card? The temp dir should exist, it is not autocreated!

I hope not many issues will be appeared. Thank you all for testing. And of course, any donation would be appreciated. :rolleyes:

PS. This is my last post before my departure... Goodbye, guys! :(
 

rameshb_v

Senior Member
Oct 29, 2006
89
0
0
Unable to play mid files

The ROM is great and thanks Nitro for the Hard work. However, I am having an issue
setting mid files as ringtone. When I select it, it says as "Corrupt or Not Available". I tried moving the mid files to storage card but still no luck. Is any one able to set mid files as ringtone.
 
Last edited: