• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[UPDATED] Unlock bootloader of Meizu M5c and install TWRP

Search This thread

Linuxovsky

Member
Feb 17, 2021
21
1
Russia
No, disconnect, wait 5 seconds, reconnect it, and try the script again
here are all the attempts ... But there is an inscription about turning off the protection ... Can I try to go further into the utility with this error?
 

Attachments

  • 1617463447327.png
    1617463447327.png
    108.6 KB · Views: 12

Linuxovsky

Member
Feb 17, 2021
21
1
Russia
Вы ошибались, удалите его и используйте тот, который отмечен красным значком
ГОТОВО! Шаг был выполнен правильно, но теперь проблема в инструменте SPFlash, который устройство не видит, или я указываю не то. Скриншот прилагается. Может, в этом случае есть ссылка на рекавери и рекавери?
 

Attachments

  • Screenshot_7.png
    Screenshot_7.png
    345.5 KB · Views: 11

oldman20

Senior Member
Jan 18, 2014
920
67
Hà Nội
Samsung Galaxy Note 9
Try to backup the seccfg (you can use dd with engineering rom using adb root) and after try to do "fastboot erase seccfg"
Important: store seccfg backup to pc
excuse, more clearly sir? about backup seccfg with dd?
and i have problem is M5C can reconigized in normal mode with adb, but when in fastboot, cant detect
what can i do? thank you!
 

Attachments

  • Capture.PNG
    Capture.PNG
    31.1 KB · Views: 6

XRed_CubeX

Senior Member
excuse, more clearly sir? about backup seccfg with dd?
and i have problem is M5C can reconigized in normal mode with adb, but when in fastboot, cant detect
what can i do? thank you!
Check the fastboot drivers carefully and see if the device is recognized.
Regarding seccfg, the backup is not essential, with the engineering bootloader in fact you do not risk the brick but if you deleted seccfg with the stock rom then you ended up in permanent brick if you did not have any backup but as already described, you do not can put back the stock bootloader so one may not even do the backup by now
 

WhiteSoda

New member
Aug 19, 2021
1
0
Hi! I tried flashing recovery and stuck where you need to erase seccfg and install twrp, my device just simply does not show up in the fastboot devices list. What i need to do then? And also, when I wall flash twrp, will I be able to boot back again in the system, if it's just a stock image of flymeos 6.0.2.3G?
 

XRed_CubeX

Senior Member
Hi! I tried flashing recovery and stuck where you need to erase seccfg and install twrp, my device just simply does not show up in the fastboot devices list. What i need to do then? And also, when I wall flash twrp, will I be able to boot back again in the system, if it's just a stock image of flymeos 6.0.2.3G?
Check the fastboot drivers, however this guide makes you unlock the bootloader, do not change the operating system so it is normal that you find yourself in flyme
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hi, after 3 years from its release you can finally unlock the bootloader of this device.
    Unfortunately Meizu with the updates has never been kind and often in order to have some updates, you always have to resort to alternative firmware and now it is finally possible with this guide.
    I begin by saying that obviously I do not take any responsibility for any brick or data loss, so I recommend that you make a backup of your important data and then you can follow the guide.
    First of all I suggest you to read the FAQ below which contains the main information about this procedure and therefore you will have to be careful.

    1) The first step to be able to unlock the bootloader is to download the package containing the engineering bootloader (the one that allows us to boot custom images)
    and you can easily find it in the attachments.
    2) Extract the package with Winrar or any archive manager you prefer.
    3) Download SP Flash Tool (necessarily v5.1636 version) from this link: here
    4) Download the MTK VCOM USB Preloader drivers from this link: here
    5) Turn off your device, open device manager, open the "COM and LPT ports" section, connect your device and install the Preloader drivers.
    6) Make sure you have installed the drivers correctly, unplug the device from the computer.
    7) Open SP Flash Tool, select the scatter inside the archive and press Download with the device turned off and disconnected.
    8) Connect your device and let the package flash, do not unplug the cable otherwise you will have to resort to the unbrick guide that you will find in the FAQ.
    9) The device could boot into the Flyme operating system, all this is normal because in any case we have only changed the bootloader, if it will boot with the writing at the bottom "=> NORMAL BOOT" then you are correctly in the middle of the guide, otherwise if not the message appears, go back and try again.
    10) The unlocking is not finished at this point, now install Adb and fastboot with its related drivers.
    11) Download the TWRP for this device at this link: here
    12) Turn off the device completely, press vol -, press the power button and the device will boot into fastboot mode.
    13) With the CMD give the command: "Fastboot erase seccfg" and then in the cmd write "Fastboot flash recovery" and drag the TWRP image file on the cmd and press enter.
    14) Now you can do "fastboot reboot" and hold down the vol +, at the bottom there will be written "=> RECOVERY BOOT" and after a few seconds the TWRP will be booted.
    15) Congratulations, you now have a fully functional TWRP, be sure to read the FAQ for more information about the situation of the device!


    FAQ:

    A) But will I lose the data with this guide?
    In theory not, because I just wrote an updated version of this guide but it has not been tested because I already have the bootloader unlocked but if you have not lost the data then answer and I will change the question. Always make sure to back up your data in any case!

    B) But this guide is a bit different than usual, where is "fastboot oem unlock"? Or "fastboot flashing unlock"?
    Basic Meizu never implements these commands and in this case not even in this engineering bootloader, in this case you just need to flash the bootloader. In fact it is not a real unlocking of the bootloader but a change of bootloader.

    C) But what is special about this bootloader?
    As said before, this bootloader is engineering, we use this bootloader to be able to boot Custom ROM, Custom RECOVERY, Magisk or other.

    Q) Are there Custom ROMs?
    There is only one custom ROM for this device, the Lineage OS 14 but I advise against using it because it has a bit of a bug but I haven't had more time to work on it yet.

    E) But wasn't the guide different?
    I have made the guide easier and also able to keep the data you have without having to lose them but it is not confirmed that the data will remain, if in doubt ALWAYS make backups!

    F) My device is in Hard Brick! How can I solve?
    There are various types of Hard Brick and it depends from situation to situation, in short I will write a guide for the unbrick.

    G) I flashed Flyme's Update.zip from the official website and now I'm bricked, how do I fix it?
    Read the previous question

    H) I did System Wipe, how do I put the Flyme back?
    Follow the guide in this link: (The guide is in writing)

    I) I have installed Lineage OS 14 but I am not satisfied, I want to go back to Flyme!
    Same as the previous question

    J) Can I do OTA Flyme?
    No, follow question H, if you flash Update.zip from the official Flyme website, you will brick your device.

    K) Can I relock the bootloader? Maybe reflashing the flyme Stock ROM?
    No, the effect will be the same as an OTA Flyme flash, we don't know why when you flash the stock bootloader, you find your device in hard brick but I don't know if we'll ever find out.

    L) TWRP? I am interested in Device Tree, where is the link?
    Here: https://github.com/XRedCubeX/twrp_meizu_m5c

    M) I have a Meizu A5 (Chinese M5c) will it work on it?
    I can't assure you anything but it could work, the only way to be sure is to test on a Meizu A5.
    1
    I can remove the FlameOs from the Meizu M5c and install a custom rom. So far I haven't found any rom for this device?
    Im working on a Lineage OS 14 for this device.
    1
    I tried the procedure and it failed. Apparently it just formatted it but couldn't finish the process, returned an error. Then I tried to reinstall the stock ROM and it generated the error S_BROM_DOWNLOAD_DA_FAIL (0x7D4) & 2004). Now my phone is off and I can't turn it on anymore.

    I tried this method but it didn't work:


    I know it's my responsibility, but I don't know what else to do. Could someone please help me?
    You unplugged the device while it was formatting, consequently it no longer has the bootloader, that error means that the device needs an authorization file that unfortunately only meizu has, shortly if I can try to release a tool to unbrick it in cases similar to these
    1
    I would like to know how to install the latest version of Flyme OS via TWRP. If you can tell how to do this..

    Are you working on a custom Lineage OS ROM for this device? I'm interested, when you can publish it.. Do you have a prediction of when you will be able to release that ROM?
    Ok, I'll explain in detail how it works: In the guide you will have read that you cannot return to the flyme using the stock rom or an unmodified OTA. This is a tip because once you flash the Engineering ROM, the engineering bootloader (which is essential for unlocking) will also be flashed, but the problem is that if you flash the stock bootloader (the flyme one, the one you surely have when you get the phone), the device for a reason unknown to me, probably the Engineering ROM modifies something in the device (?) and then goes into brick if you try to return to the flyme bootloader. To flash an OTA flyme on TWRP, you must first have some precautions: you must take the OTA on your computer (or a file explorer capable of editing zip files) and remove the following files: lk.bin preloader.bin (it will have a name longer but you still have to remove that) and tz.bin / trustzone.bin. Done like this, now the OTA becomes safe to install, you install it from TWRP, at the end of the flash it will give you an error but it is because it does not find the files we have removed but we can safely ignore it because it will have successfully installed the flyme on the device.

    Regarding lineage: I'm still working on it a bit and gradually I'm discovering bugs. I already warn you that the camera will not work in the Lineage, I have tried in every way to try to make it work but it does not want to go, I have asked for help everywhere but no one has been able to answer so I do not know what to do, for the rest I want to keep a little longer the ROM under test to fix the remaining bugs
    1
    Unfortunately I don't have Windows installed here. I can install it, but it will take a long time and I will have a lot of work to find the right MTK drivers, and even then I doubt it will work.
    Also, I had a lot of work to apply a patch and compile the Linux kernel so I could use the MTK-bypass tool.
    If you can send me a link with the specific drivers for this device for Windows 10, I'd appreciate it, because I've tried it dozens of times in Windows and couldn't, so I use the SP Flash Tool in Linux, which already comes with these drivers included by default.
    https://mega.nz/#!H1k0za6R!FjfhscOlnUQmuOj-9Ml09133-eAUzKNgF0bD5KaBKok , right click on cdc-acm.inf and install