upgrading to 4.2.2 phonesky.apk error

Search This thread

noday42

New member
Sep 23, 2012
4
0
0
can't seem to find the answer to this anywhere, so hopefully someone can help.

I'm running rooted 4.2.1 stock ROM with CMW recovery. Trying to update to 4.2.2 with absolutely no luck. Whether I try to update OTA or from zip, I consistently get a failed install with this error:
assert failed: apply_patch_check ("/system/app/phonesky.apk"

I've tried everything I can think of. Wiping cache/dalvik, factory reset within CMW, overwriting the phonesky.apk with the stock version. Nothing seems to solve the problem. The 4.2.2 zip file I have is the one downloaded from here.

Any advice on where to go next? I'm completely at a loss.

EDIT: I should also note I had previously cracked the Google Play store with the ChelpUS mod
 
Last edited:

noday42

New member
Sep 23, 2012
4
0
0
bump?

can't seem to find the answer to this anywhere, so hopefully someone can help.

I'm running rooted 4.2.1 stock ROM with CMW recovery. Trying to update to 4.2.2 with absolutely no luck. Whether I try to update OTA or from zip, I consistently get a failed install with this error:
assert failed: apply_patch_check ("/system/app/phonesky.apk"

I've tried everything I can think of. Wiping cache/dalvik, factory reset within CMW, overwriting the phonesky.apk with the stock version. Nothing seems to solve the problem. The 4.2.2 zip file I have is the one downloaded from here.

Any advice on where to go next? I'm completely at a loss.

EDIT: I should also note I had previously cracked the Google Play store with the ChelpUS mod
 

Westervoort

Senior Member
Jan 14, 2013
60
34
0
Have you already tried flashing the 4.2.2 stock rom with fastboot? Also, what's your bootloader version and do you have a device with or without 3g (grouper or tilapia).
 

bftb0

Senior Member
Feb 5, 2010
2,594
1,040
0
The OTA works by *patching* existing files.

That can not possibly succeed under any circumstance if a file it expects to patch has been altered or removed. So, the OTA patch process checks all files it intends to patch first to make sure they are identical to the stock version. If even a single file is out of whack, nothing is changed and the install halts immediately with an error message.

The error message is telling you about the first file encountered with this problem, namely

/system/app/phonesky.apk

So, put the original file back. Get it out of your backups. You do make backups, right? (Note that because of the halt-on-first-fail behavior, there may be more problem files awaiting you.)

Either that, or pretend you are installing a new ROM and proceed accordingly.

OTAs are not meant for upgrading arbitrarily-modified stock ROMs.
 

noday42

New member
Sep 23, 2012
4
0
0
thanks guys. I had previously tried replacing the modded app, but it didn't seem to fix anything. Ended up unrooting and restoring to factory 4.2.1, upgrading to 4.2.2 over the air, and re-rooting/restoring apps with TiBu. Thanks for your advice!
 

itsirfandude

Senior Member
Oct 2, 2012
71
2
38
28
Coimbatore
can't seem to find the answer to this anywhere, so hopefully someone can help.

I'm running rooted 4.2.1 stock ROM with CMW recovery. Trying to update to 4.2.2 with absolutely no luck. Whether I try to update OTA or from zip, I consistently get a failed install with this error:
assert failed: apply_patch_check ("/system/app/phonesky.apk"

I've tried everything I can think of. Wiping cache/dalvik, factory reset within CMW, overwriting the phonesky.apk with the stock version. Nothing seems to solve the problem. The 4.2.2 zip file I have is the one downloaded from here.

Any advice on where to go next? I'm completely at a loss.

EDIT: I should also note I had previously cracked the Google Play store with the ChelpUS mod

I'm encountering the same with 4.3 update.... I unrooted my device.... CAN YOU PLS POST THE PHONESKY. APK FROM STOCK 4.2.2 urgently