Urgent firmware flash help.

Search This thread

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
Hello,

I neef urgent help, one day i was trying to flash custom recovery to my razr hd, it is i dont know 925 or 926. It is 16gb.

I was unsuccess to flash recovery then i was everytime getting fastboot msg and i had to press normal recovery everytime. Now i tried to factory data reset my mob and it is stuck on logo and time black screen with dots..

I have rsd lite but i think firmware i am not getting exact one thats why it is nog flashing... Please help me what to do. I have attached pics of recovery and fastboot.
 

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
I can help you but I need to know if you have correct drivers installed unless your using linux otherwise you need to install the correct drivers for the device. xt925 i think is gsm not sure and the xt926 is cdma 4g. I also need to know what version of android you were using so we flash the correct firmware(e.g, jelly bean, kit kat and so on). I also need to know what version of rsd you have because you might need to use a newer version. After we get your device back to life. I will give you the link to the correct recovery for the device. footnote: you will need to re-root device after it is flashed back to life, then flash correct recovery. You can only flash recovery if you unlocked the bootloader witch you do after device is rooted. 0 means bootloader is locked and 3 means it is unlocked. If you flash any recovery with a locked bootloader than you can soft brick or hard brick the device. If this is what you did and your just stuck at the Moto M than it just needs the correct stock firmware flashed so it can come back to life.
 
Last edited:

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
I can help you but I need to know if you have correct drivers installed unless your using linux otherwise you need to install the correct drivers for the device. xt925 i think is gsm not sure and the xt926 is cdma 4g. I also need to know what version of android you were using so we flash the correct firmware(e.g, jelly bean, kit kat and so on). I also need to know what version of rsd you have because you might need to use a newer version. After we get your device back to life. I will give you the link to the correct recovery for the device. footnote: you will need to re-root device after it is flashed back to life, then flash correct recovery. You can only flash recovery if you unlocked the bootloader witch you do after device is rooted. 0 means bootloader is locked and 3 means it is unlocked.

Hello,

RSD lite version is: 6.1.5, Drivers i downloaded from motorola website and it detects my device... I was using last kitkat version.

Device has written backside Verizon 4g but i was using gsm network only 3g was working..

Please check attachment of recovery and fastboot screen.
 

Attachments

  • IMG_20160929_021834.jpg
    IMG_20160929_021834.jpg
    257.5 KB · Views: 55
  • IMG_20160929_022117.jpg
    IMG_20160929_022117.jpg
    230.5 KB · Views: 55

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
Hello,

RSD lite version is: 6.1.5, Drivers i downloaded from motorola website and it detects my device... I was using last kitkat version.

Device has written backside Verizon 4g but i was using gsm network only 3g was working..

Please check attachment of recovery and fastboot screen.
Thanks for the pics. Your status is zero witch means you tried to flash recovery with a locked bootloader this is your problem. we can fix this cause obviously you can still get to fastboot mode. You had the the first version of kitkat Bootloader. we are going to flash the cdma one then you can find the gsm flashable zip in the forum for this device to flash once you get going. Here is the link for the drivers witch are for 64 bit windows if your running 32 bit than let me know so I can link you to those instead. http://forum.xda-developers.com/attachment.php?attachmentid=3187938&d=1425146663. Here is a newer version of rsd lite. http://forum.xda-developers.com/attachment.php?attachmentid=3388466&d=1435873884 first uninstall the rsd you have now then install drivers then install the rsd lite i linked you to. here is the firmware for your device https://www.androidfilehost.com/?fid=24269982087011673 Let me know when you get going ill give the link to a page that explains root and how to unlock the bootloader.
 

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
I can help you but I need to know if you have correct drivers installed unless your using linux otherwise you need to install the correct drivers for the device. xt925 i think is gsm not sure and the xt926 is cdma 4g. I also need to know what version of android you were using so we flash the correct firmware(e.g, jelly bean, kit kat and so on). I also need to know what version of rsd you have because you might need to use a newer version. After we get your device back to life. I will give you the link to the correct recovery for the device. footnote: you will need to re-root device after it is flashed back to life, then flash correct recovery. You can only flash recovery if you unlocked the bootloader witch you do after device is rooted. 0 means bootloader is locked and 3 means it is unlocked. If you flash any recovery with a locked bootloader than you can soft brick or hard brick the device. If this is what you did and your just stuck at the Moto M than it just needs the correct stock firmware flashed so it can come back to life.

Thanks for the pics. Your status is zero witch means you tried to flash recovery with a locked bootloader this is your problem. we can fix this cause obviously you can still get to fastboot mode. You had the the first version of kitkat Bootloader. we are going to flash the cdma one then you can find the gsm flashable zip in the forum for this device to flash once you get going. Here is the link for the drivers witch are for 64 bit windows if your running 32 bit than let me know so I can link you to those instead. http://forum.xda-developers.com/attachment.php?attachmentid=3187938&d=1425146663. Here is a newer version of rsd lite. http://forum.xda-developers.com/attachment.php?attachmentid=3388466&d=1435873884 first uninstall the rsd you have now then install drivers then install the rsd lite i linked you to. here is the firmware for your device https://www.androidfilehost.com/?fid=24269982087011673 Let me know when you get going ill give the link to a page that explains root and how to unlock the bootloader.

Hello,

Thanks for your help please send drivers for Windows 7 32bit i am using 32bit OS.
 

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
Hello,

Thanks for your help please send drivers for Windows 7 32bit i am using 32bit OS.
here is 32 bit drivers http://forum.xda-developers.com/attachment.php?attachmentid=3187936&d=1425146651
I forgot to tell you that for it to flash correctly you can't have a low battery witch I saw on your fastboot. you will need fastbook cable. A fastboot cable is used so you can boot or get to fastboot with or without battery like in your case the battery is to low. I got mine on amazon for 10 dollars. here is the link https://www.amazon.com/gp/aw/s/ref=...43801?k=fastboot+cable&sprefix=fastboot+cable
 
Last edited:

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
here is 32 bit drivers http://forum.xda-developers.com/attachment.php?attachmentid=3187936&d=1425146651
I forgot to tell you that it flash correctly with a low battery witch I saw on your fastboot. you will need fastbook cable. A fastboot cable is used so you can boot or get to fastboot with or without battery like in your c

Hello,

Thanks are you sure, it wi flash on low battery because last time rsd and fasboot both were giving errors cant flash low battery then i had to charge it but flash was still not success due to firmware mismatch.
 

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
Hello,

Thanks are you sure, it wi flash on low battery because last time rsd and fasboot both were giving errors cant flash low battery then i had to charge it but flash was still not success due to firmware mismatch.
You need a fastboot cable i put the link and explanation in previous post

---------- Post added at 08:12 AM ---------- Previous post was at 07:55 AM ----------

You need a fastboot cable i put the link and explanation in previous post
I forgot to tell you that for it to flash correctly you can't have a low battery witch I saw on your fastboot. you will need fastbook cable. A fastboot cable is used so you can boot or get to fastboot with or without battery like in your case the battery is to low. I got mine on amazon for 10 dollars. here is the link https://www.amazon.com/gp/aw/s/ref=i...fastboot+cable
 

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
I can help you but I need to know if you have correct drivers installed unless your using linux otherwise you need to install the correct drivers for the device. xt925 i think is gsm not sure and the xt926 is cdma 4g. I also need to know what version of android you were using so we flash the correct firmware(e.g, jelly bean, kit kat and so on). I also need to know what version of rsd you have because you might need to use a newer version. After we get your device back to life. I will give you the link to the correct recovery for the device. footnote: you will need to re-root device after it is flashed back to life, then flash correct recovery. You can only flash recovery if you unlocked the bootloader witch you do after device is rooted. 0 means bootloader is locked and 3 means it is unlocked. If you flash any recovery with a locked bootloader than you can soft brick or hard brick the device. If this is what you did and your just stuck at the Moto M than it just needs the correct stock firmware flashed so it can come back to life.

You need a fastboot cable i put the link and explanation in previous post

---------- Post added at 08:12 AM ---------- Previous post was at 07:55 AM ----------


I forgot to tell you that for it to flash correctly you can't have a low battery witch I saw on your fastboot. you will need fastbook cable. A fastboot cable is used so you can boot or get to fastboot with or without battery like in your case the battery is to low. I got mine on amazon for 10 dollars. here is the link https://www.amazon.com/gp/aw/s/ref=i...fastboot+cable

I have ordered cable, because i am not able to charge mobile correctly, i will try when i will have cable in my hand.
 

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
Hello,

Really not yet i ordered from ebay china seller so still waiting for it
OK, that sucks. How you got to wait. Thats gonna take 2 to 4 weeks. At least from what I expierinced when I ordered loca glue on amazon and it was coming from china. If you need some guidence when you get the fastboot cable just send me a message.
 

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
Tried another firmware getting same error, preflash preflash validation failed for gpt

Flash "VRZ_XT926_9.8.1Q-94-1_CFC" it is no on 6 stage showing invalid image size for partition tz
 
Last edited:

OGdroidster

Senior Member
Nov 29, 2015
460
95
48
Tried another firmware getting same error, preflash preflash validation failed for gpt

Flash "VRZ_XT926_9.8.1Q-94-1_CFC" it is no on 6 stage showing invalid image size for partition tz
Witch version of rsd are you using and are you flashing from fastboot and also if you can give me in order of steps per say of what you are doing from begining to end. Oh yea did you install the drivers from the link I gave you.
 

efuzone

Senior Member
Jan 23, 2010
286
11
0
www.efuzone.com
Witch version of rsd are you using and are you flashing from fastboot and also if you can give me in order of steps per say of what you are doing from begining to end. Oh yea did you install the drivers from the link I gave you.

Hello,

I have latest drivers, latest RSD which you provided me. I have downloaded firmware which you given me it is giving gpt error, when i tried another one it is giving tz error and then again gpt error. :(

RSD Version is 6.2.4
 

rootdefyxt320

Senior Member
Oct 4, 2012
488
440
0
Sydney, NSW
Hello,

I have latest drivers, latest RSD which you provided me. I have downloaded firmware which you given me it is giving gpt error, when i tried another one it is giving tz error and then again gpt error. :(

RSD Version is 6.2.4

You can't downgrade gpt and tz partition. You can only flash same signature version or higher.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Ok downloading

    Sent from my HUAWEI VNS-L21 using Tapatalk
    Hope that one works for you.

    ---------- Post added at 08:36 AM ---------- Previous post was at 08:30 AM ----------

    Hello,

    Flash finished passed. Now it is charging.. I would like to know do i need to flash again anything to run my sim cards and unlock or it will work automatically
    If you need gsm to work on instead of CDMA you might have to flash a zip but don't qoute me on that. Just look in the forums. I use CDMA. Also glad it worked out for you. If you have problems trying to root with what is in the forums for this device let me know. I had that happen to me before. Oh I forgot if you go to settings and rite under dater click on where it says more then click on mobile networks and then click on type of network and change it to gsm.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone