USB connection to PC - only charging

Search This thread

Xrzysioo

New member
Sep 26, 2010
3
0
Dear All,

Yesterday I switched on my old Pixel 4a5G then connected to the PC and... nothing happened.
I dont have any notification on Windows (even on Ubuntu) about new device (checked also device manager) and the same on the Pixel.
Phone only charged.
I decided to check another cables and I had the same result. I even bought new cable USB Ato C 3.2 gen 1 and still nothing only charging.
I checked on another PC the same - only charging my device and no connection. Of course I switched on usb debugging on Developer Mode and USB/Android Auto File Transfer option, even PTP doesen't work.

So I had:

- no notification about USB connection on the Pixel
- no notification about new device on the Windows (missing sound , no device Android or another name in Device Manager on the Windows)

I switched Pixel in safe mode - the same result

I connected to the Pixel my WD SE protable hard drive and... I had notification about USB device, I opened it and had two options:

- This device (which was choosen)
- Connected Device

rest like File Transfer, Connection Thetering were grayed out

I choose Connected Device and there was an info "switching" and after couple seconds "cound not switch..."

If anyone had the same problems? could be software problem or USB port broken on the Pixel?

I have latest updates installed on the Pixel. I did Factory Reset but nothing changed. Even on Fastboot mode Windows didn't recognize device (no sound nothing)
 
Last edited:

hammered58

Senior Member
Dear All,

Yesterday I switched on my old Pixel 4a5G then connected to the PC and... nothing happened.
I dont have any notification on Windows (even on Ubuntu) about new device (checked also device manager) and the same on the Pixel.
Phone only charged.
I decided to check another cables and I had the same result. I even bought new cable USB Ato C 3.2 gen 1 and still nothing only charging.
I checked on another PC the same - only charging my device and no connection. Of course I switched on usb debugging on Developer Mode and USB/Android Auto File Transfer option, even PTP doesen't work.

So I had:

- no notification about USB connection on the Pixel
- no notification about new device on the Windows (missing sound , no device Android or another name in Device Manager on the Windows)

I switched Pixel in safe mode - the same result

I connected to the Pixel my WD SE protable hard drive and... I had notification about USB device, I opened it and had two options:

- This device (which was choosen)
- Connected Device

rest like File Transfer, Connection Thetering were grayed out

I choose Connected Device and there was an info "switching" and after couple seconds "cound not switch..."

If anyone had the same problems? could be software problem or USB port broken on the Pixel?

I have latest updates installed on the Pixel. I did Factory Reset but nothing changed. Even on Fastboot mode Windows didn't recognize device (no sound nothing)
could very well be the phones usb port i had one similar on a htc u11 that acted the same,the only way to know for sure is to replace it or try cleaning it really goor with a squished qtip ,, lol
 
  • Like
Reactions: Xrzysioo

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Dear All,

    Yesterday I switched on my old Pixel 4a5G then connected to the PC and... nothing happened.
    I dont have any notification on Windows (even on Ubuntu) about new device (checked also device manager) and the same on the Pixel.
    Phone only charged.
    I decided to check another cables and I had the same result. I even bought new cable USB Ato C 3.2 gen 1 and still nothing only charging.
    I checked on another PC the same - only charging my device and no connection. Of course I switched on usb debugging on Developer Mode and USB/Android Auto File Transfer option, even PTP doesen't work.

    So I had:

    - no notification about USB connection on the Pixel
    - no notification about new device on the Windows (missing sound , no device Android or another name in Device Manager on the Windows)

    I switched Pixel in safe mode - the same result

    I connected to the Pixel my WD SE protable hard drive and... I had notification about USB device, I opened it and had two options:

    - This device (which was choosen)
    - Connected Device

    rest like File Transfer, Connection Thetering were grayed out

    I choose Connected Device and there was an info "switching" and after couple seconds "cound not switch..."

    If anyone had the same problems? could be software problem or USB port broken on the Pixel?

    I have latest updates installed on the Pixel. I did Factory Reset but nothing changed. Even on Fastboot mode Windows didn't recognize device (no sound nothing)
    could very well be the phones usb port i had one similar on a htc u11 that acted the same,the only way to know for sure is to replace it or try cleaning it really goor with a squished qtip ,, lol