[usb device not recognized] samsung galaxy s plus i9001 (complete guide)

Search This thread

imDCStar

Senior Member
Oct 25, 2015
65
7
T-Mobile Samsung Galaxy Note5
Hi everybody,
I finally fixed my phone. It took 1 and a half month to fix my Galaxy S PLUS (I9001). I thought I should share my experience. May be it can help others who are facing same issue.

It all started in end of November. I wasn’t happy with Android 2.3.5. I decided to flash a CUSTOM ROM. First I flashed CM9. It was great. So I decided to flash newer than this one. It was CM10.1 and I was happy with it but there was a problem, Wi-Fi wasn’t working! I was new with Custom ROMS. So I didn’t know that flashing a new Kernel can fix it. So I tried CM12.1. and Yeheee! Everything was working and I was happy to run Android 5 on my S PLUS.

Two days later, my brother was playing CUT THE ROPE HD on my phone. He noticed that game is not running smoothly. So he reset the phone from “Backup and Restore” and it was it!

Phone restarted and it was in boot-loop of TWRP. I tried hundred times to make it work but no progress. I checked YouTube and other forums. The only solution mentioned was, put phone in Download Mode and flash CWMR using ODIN. I already installed Samsung Drivers in my Computer. So there was no need to do it again. I put my phone in Download Mode, Started Odin and when I plugged the cable in my phone. It showed “USB DEVICE IS NOT RECOGNIZED”

I changed THREE USB CABLES, TWO PHONE BATTERIES, THREE ODINs, FOUR SAMSUNG DRIVERS and TWO PCs to make it work but nothing!

I Googled the issue, tried many other things like cleaning window temp files, cleaning drivers, removing battery when connecting to ODIN and constantly pressing volume keys when connecting to ODIN in Download Mode. Nothing worked. Some said it is issue of cable, some said it is phone connector interface problem. clean it with something. I tried that too!
After spending ONE MONTH doing this and that, I give up and went to a phone repairing shop. He said, it is not connecting. I don’t know how to make it work again.

No more hope and phone was in my drawer. After fifteen days I tried all that again but no. but two days ago. I was given an assignment from my University. That was a C++ assignment. My DEVC++ software wasn’t working properly on my WIN 10 EDU (64BIT). I found that, it only works on Win 7 and earlier. So I installed a fresh WIN7 ULTIMATE 32BIT on my second Hard Drive. i installed DevC++ and it worked smoothly. I finished my assignment and my mind clicked that I can try my phone on this OS!

I installed:
MOBOGENIE 3.3.7_10002 (it was for my other phone, not for S PLUS of course!)
Ccleaner506 (Only Cleaned TEMP, registry Untouched)
Samsung Drivers v1.5.53.0
Pray To Allah
Opened ODIN_Multi_Downloader_v4.43
Put my phone in Download Mode and Connected the Cable and IT CONNECTED AND DETECTED BY ODIN SUCCESSFULLY!!!!

Everything was same as before: ODIN, Samsung Drivers, Mobogenie, Phone Battery and Ccleaner but two things were different.

OS: WIN 7 ULT 32BIT (NOW), WIN 10 EDU 64BIT (BEFORE)
USB CABLE:NOKIA ORIGINAL CABLE (NOW)SAMSUNG ORIGINAL CABLE (BEFORE)

The steps I did was, after connecting the phone, I selected “AriesVE.ops” in Select OPS option of ODIN then I checked on “ONE PACKEGE” in ODIN and selected “recovery-clockwork-6.0.1.0-ariesve.tar.md5” by clicking One Package button in ODIN. Then I clicked on START

After some second my phone was ALIVE AGAIN! All files were as they were and it was running CM12.1
Now it is working like before and I am happy to have it back. The reason of describing every single step is that I don’t know what exactly is the reason to make it work! The 32bit WIN7 OS or NOKIA USB CABLE! Or both. So, if you are facing the same problem. Try like I did. I hope it will help you!


Drivers: http://www.mediafire.com/download/wsb5kfqapdsv3w7/SAMSUNG_USB_Driver_for_Mobile_Phones.exe
Unbrick tools: http://www.mediafire.com/download/6ymcjpl86fl82j7/Unbrick.rar
 
Last edited: