• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

USB Issues with Oreo 8.1

Search This thread

dburckh

Senior Member
Jan 26, 2011
260
91
Just got the Oreo 8.1 update on my Project Fi Moto X4 (Motorola Version: OPW28.46-13). The phone does not show up in Windows anymore. No MTP, no ADB. It does charge. I've tried it on two different PCs. It was working seconds before applying the update. The cable does work properly with an S8.

Anybody else seeing this?

I'm a professional Android developer and I was using the phone for development before the update. The other issue is that Developer Mode was disabled after update. I re-enabled it after 8.1 and it didn't work. I've disabled/enabled USB Debugging and developer options several times.

Update:
Tried on OS X now too, same issue. OTG does work.

Work-Around:
https://forum.xda-developers.com/showpost.php?p=76430795&postcount=32
 
Last edited:
  • Like
Reactions: jdrch

Neffy27

Senior Member
Nov 27, 2013
614
214
The previous two months became available on there as my phone got the OTA notification. I have yet to see someone who has receive the April, verify they attempted Motoota here on XDA or Reddit.
 

sevenpacesp

New member
May 2, 2018
1
0
Just got the Oreo 8.1 update on my Project Fi Moto X4 (Motorola Version: OPW28.46-13). The phone does not show up in Windows anymore. No MTP, no ADB. It does charge. I've tried it on two different PCs. It was working seconds before applying the update. The cable does work properly with an S8.

Anybody else seeing this?

I'm a professional Android developer and I was using the phone for development before the update. The other issue is that Developer Mode was disabled after update. I re-enabled it after 8.1 and it didn't work. I've disabled/enabled USB Debugging and developer options several times.

Update:
Tried on OS X now too, same issue. OTG does work.


I am experiencing the same situation with Project Fi Moto X4 32G (Motorola Version: OPW28.46-13). No MTP, no ADB. It does charge OK. I had no such problems before the upgrade from 8.0 to 8.1. I tried on both Linux and OS X. The same issue. And yes, USB OTG works.
 

vance6842

New member
Jun 5, 2011
1
0
I have the exact same issue and fun fact, this means it no longer works with an Android Auto head unit (it worked flawlessly right up until the second the OTA update was installed).
 

Irieone

Senior Member
Jul 22, 2010
566
147
The Sticks of Indiana
Folks, I have this too on my Moto G5S Plus after the April security patch for Nougat. No notification shade when I plug into the PC. No way to access MTP, ADB, etc... I also effects my charging. After the MTP interface fails, I have to reboot the phone before it will charge again.

Post in the Moto/Lenovo forum please. It's a HUGE problem.





Just got the Oreo 8.1 update on my Project Fi Moto X4 (Motorola Version: OPW28.46-13). The phone does not show up in Windows anymore. No MTP, no ADB. It does charge. I've tried it on two different PCs. It was working seconds before applying the update. The cable does work properly with an S8.

Anybody else seeing this?

I'm a professional Android developer and I was using the phone for development before the update. The other issue is that Developer Mode was disabled after update. I re-enabled it after 8.1 and it didn't work. I've disabled/enabled USB Debugging and developer options several times.

Update:
Tried on OS X now too, same issue. OTG does work.
 

snic09

Member
May 4, 2018
5
0
I just got the April 1 8.1 update this morning on my Moto X4 OPW28.46-13. Exactly the same thing. Android Auto head unit doesn't recognize the phone (or vice versa), and the USB options are greyed out and say only "not connected" whether plugged into the head unit or a computer. Project Fi support tells me I need to hard reset the phone. I don't have time to do that at the moment, but they tell me that if it doesn't work (and I very much doubt that it will) they'll "check the warranty options." Which I think is a euphemism for "send you a new phone if it's still under warranty".

What aggravates me about this (aside from the huge waste of time of having to deal with it) is - what if the phone were NOT under warranty? After their update breaks my phone, would they then tell me to buy a new phone?
 
Last edited:

jhedfors

Senior Member
Oct 16, 2009
1,445
724
St Paul, AZ
Moto G6
OnePlus 6T
It would seem so. I will probably try to talk them out of it. I would rather have them escalate a fix.
Same response from support. I wonder if anyone that is able to create a TWRP backup, and test if a clean reset fixes issue.
 

Attachments

  • twitter.PNG
    twitter.PNG
    49.7 KB · Views: 439

Top Liked Posts