USB to Note 10+ connection drops... Resolution?

Search This thread

KruseLudsMobile

Senior Member
Sep 12, 2004
1,563
216
Ridgewood, NJ
www.linkedin.com
Given:
I have a brand new powerful PC with USB 3.2 Gen 2 Type C, USB 3.2 Gen 2 Type A, USB 3.1 Type A, USB 3.0 Type A (and USB 2.0 Type A - internal in the tower) connections. I have also replaced all my USB cables with "SuperSpeed" 10Gbps throughput cables, being sure to get any and all Type C -> Type A adapters to also have the "SS" SuperSpeed Logo and the correct circuitry/leads to adhere to the higher standard. (Until I got the new cables I was still getting warnings when I plugged my Verizon Note 10+ 5G 512GB into an older cable connected to the 3.2 Gen 2 port that I was connecting the device into an older slower USB port, which is now resolved...)

I have started using Scrcpy to have my Note 10+ screen shown on the computer screen. Everything is lightning fast. I even tried using one of those cable to connect to an external SSD and tried copying several gigs of files across and CANNOT BELIEVE how fast everything is copied!

My PC is a PowerSpec G464 with and AMD Ryzen Processor (motherboards for Intel CPU's do not yet support the PCIe 4.0 slots which I do have on this system):

http://www.powerspec.com/systems/system_specs.phtml?selection=G465

It is my understanding that these motherboards have all USB connections at some point going through the same controller. Ideally each USB port would go through it's own controller and that's why such add-on PCIe cards are much more expensive and never use a PCIe x1 connection but typically a PCIe x4 slot instead. I have an add-on USB card but stuck with a cheaper one that has 4 ports (all of course sharing the same controller) as I wanted to use a PCIe x1 slot only.

Problem Statement:
So here is my dilemma. The cable connections for the Note 10+ are nice and tight, but every couple of minutes it disconnects once - and then reconnects almost instantly. It is a weird issue and kicks me out of the Scrcpy app which I relaunch - but how to resolve?

(FYI - I have not tried using any of the internal USB 2.0 ports. Also, some of my other devices on the USB SuperSpeed ports would often connect and disconnect periodically but that was all resolved by replacing the cables as mentioned above.)

Ideas? I'll try anything anyone suggests and report back. Is it possible the Note 10+ cannot handle ports expecting a 3.2 Gen 2 connection (although I know they are supposed to adjust automatically)?

Sent from my SM-N976V using Tapatalk