• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Using an eSim without a physical Sim on AT&T

Search This thread
Hi, I'm trying to use an eSim only (without inserting a physical sim) on my pixel 6 pro on AT&T, however I cannot get it to work. When I say not get it to work, I mean with eSim only there is no cell signal and no data signal. Physical sim works fine on both signal and cellular service. If there's another Us AT&T pixel 6 pro user who's using only the eSIM for service please respond and let me know whether or not eSim only works for you. Thanks.
 
  • Like
Reactions: roirraW "edor" ehT

Morgrain

Senior Member
Aug 4, 2015
749
745
Not an AT&T user here, am using a European carrier, just from anecdotal perspective: I also use eSim only and never had an issue on my P6 Pro. So it appears to be something carrier related.

I remember that I had to activate my eSim, maybe you also have to do this? Did you try out the eSim/your contract before using this phone?
 
Not an AT&T user here, am using a European carrier, just from anecdotal perspective: I also use eSim only and never had an issue on my P6 Pro. So it appears to be something carrier related.

I remember that I had to activate my eSim, maybe you also have to do this? Did you try out the eSim/your contract before using this phone?
Yes, I tried 3 times with the help of AT&T and we couldn't get it to work. I'm going to return the device for a new replacement to see if that fixes this issue. Thanks for replying.
 

Morgrain

Senior Member
Aug 4, 2015
749
745
Yes, I tried 3 times with the help of AT&T and we couldn't get it to work. I'm going to return the device for a new replacement to see if that fixes this issue. Thanks for replying.
Before going through the hassle of returning the device for a potential fault - do you have a family member or friend, whose simcard/esim you could try out? That way you can find out if your phone truly has a defect or if its your contract/the specific esim. Of course you can always let them replace your device, but that will take a couple days, maybe there are faster ways to narrow the problem down.
 
Before going through the hassle of returning the device for a potential fault - do you have a family member or friend, whose simcard/esim you could try out? That way you can find out if your phone truly has a defect or if its your contract/the specific esim. Of course you can always let them replace your device, but that will take a couple days, maybe there are faster ways to narrow the problem down.
i tried again today at another AT&T corp store and walked out of the store with it working as expected (wait till the end). the person helping did additional research on my issue and discovered the P6P shipped to me "was not activated" with the inserted physical sim (which i removed when i received the device). apparently, AT&T will park (or associate) a new device with a specific number when shipping to you vs. walking in to buy a device on an existing line. nonetheless, i'm going to return the phone because the data connection isn't working consistently; data is on and then after i go to website, data turns off. i'm probably going to send it back to AT&T next week.
 
  • Wow
Reactions: roirraW "edor" ehT
I'm using an ESIM on AT&t and even originally got the phone My plan was to have a physical TracFone SIM card and my AT&t esim which is exactly what I had on my Pixel 5 and it worked great. Both SIM cards work great... when the other ones not active or inserted. It is impossible to use with both SIM cards like I did on my Pixel 5. Constant signal loss and the majority of the time. No signal at all. But as soon as I deactivate or remove a SIM card it starts working perfect.
 

fyoory

Member
Apr 23, 2010
7
1
Samsung Galaxy Z Fold3
I had a problem with provisioning eSim on my TMobile, well technically its sprint still, says tmobile esim but I am on sprint billing. Anyways, you need to maybe try to do it on another WiFi access point or something. I had issues with mine activating over Viasat2 satellite internet. I live in that area, its either LTE or satellite for internet. Had to tether to my work verizon phone to activate it on sprint/tmobile lol. If the connectivity to the esim server is not great, you'll split hairs until it is.
 
I'm using an ESIM on AT&t and even originally got the phone My plan was to have a physical TracFone SIM card and my AT&t esim which is exactly what I had on my Pixel 5 and it worked great. Both SIM cards work great... when the other ones not active or inserted. It is impossible to use with both SIM cards like I did on my Pixel 5. Constant signal loss and the majority of the time. No signal at all. But as soon as I deactivate or remove a SIM card it starts working perfect.
Exactly the same issue/behavior I had with my AT&T P6P on the AT&T network so I returned mine today. I'm contemplating a Fi version to see if it works for my use case.
 
  • Like
Reactions: galaxys

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi, I'm trying to use an eSim only (without inserting a physical sim) on my pixel 6 pro on AT&T, however I cannot get it to work. When I say not get it to work, I mean with eSim only there is no cell signal and no data signal. Physical sim works fine on both signal and cellular service. If there's another Us AT&T pixel 6 pro user who's using only the eSIM for service please respond and let me know whether or not eSim only works for you. Thanks.
    1
    Finally got the phone working, but will get an unlocked version later; this one is still going back to ATT. 🤬
    1
    I'm using an ESIM on AT&t and even originally got the phone My plan was to have a physical TracFone SIM card and my AT&t esim which is exactly what I had on my Pixel 5 and it worked great. Both SIM cards work great... when the other ones not active or inserted. It is impossible to use with both SIM cards like I did on my Pixel 5. Constant signal loss and the majority of the time. No signal at all. But as soon as I deactivate or remove a SIM card it starts working perfect.
    Exactly the same issue/behavior I had with my AT&T P6P on the AT&T network so I returned mine today. I'm contemplating a Fi version to see if it works for my use case.