[UTIL] SPB Mobile Shell 3.5 [Tricks, Widgets, Themes, Other, FAQ, Config]

Search This thread

jjollyroger

Senior Member
Dec 5, 2009
896
188
i wanne change my backround image.
i have a xperia x1 wvga 480x800 resolution .
but when i try to change the backround i just can choose a part of the 480x800 picture..how to change that?
thanks for help
that is why ( I suppose you're changing the "lifestile" back ground) is required a 6/5 proporpotioned image so the best fitting is a 960x800 image.
HERE you can find them +fundotela.dat files (for other mobile shell pages)
 

bummler

Senior Member
Feb 27, 2011
206
3
that is why ( I suppose you're changing the "lifestile" back ground) is required a 6/5 proporpotioned image so the best fitting is a 960x800 image.
HERE you can find them +fundotela.dat files (for other mobile shell pages)

how to change the resolution from that picture without changing the picture himself...
 

Attachments

  • 3dcubes_vvfjz16n.jpg
    3dcubes_vvfjz16n.jpg
    92.4 KB · Views: 111
  • greycubes_w6izdmtw.jpg
    greycubes_w6izdmtw.jpg
    60.1 KB · Views: 88
  • headphones_pmtmuf7n.jpg
    headphones_pmtmuf7n.jpg
    36.1 KB · Views: 93
Last edited:

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
Need help with MH widgets 1.3 SE

Hello!

I need some help.

I'm using the nice MH-Widgets 1.3 SE Package with MS 3.5.5 on my HD2.

Everything would be wonderfull BUT I can't touch the lower left button (carusel) otherwise Mobile Shell get frozen.

I guess it's only a matter of register key but I don't know enought.

Can anyone guide me to correct this little trouble.

Thanks
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hello!

I need some help.

I'm using the nice MH-Widgets 1.3 SE Package with MS 3.5.5 on my HD2.

Everything would be wonderfull BUT I can't touch the lower left button (carusel) otherwise Mobile Shell get frozen.

I guess it's only a matter of register key but I don't know enought.

Can anyone guide me to correct this little trouble.

Thanks
Does the carousel button work properly without the MH Widgets pack installed?

If it does then its more likely a problem with the pack.

Mark.
 

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
SPB MS 3.5.5 freeze on HD2 with MH widgets pack

Hi Mark !!

Lot of thanks to take care of my little trouble ..

After a fresh copy of MS 3.5.5 the carousel button works perfectly.

It's only after installation of this cab : MH-Widgets 1.3 SE that touching it freeze MS.

This pack is made of several nice widgets just added to the system. The only mods are for the menu bar and the recycle bin size.

The compatibility seems tested with MS 3.5.2 & 3.5.3 and I'm using MS 3.5.5 but I don't know what the difference is.

There is no response from matthew that's why I try to understand which register key is involved in this trouble to correct it.

Thanks again for your help.

Dominique.
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hi Mark !!

Lot of thanks to take care of my little trouble ..

After a fresh copy of MS 3.5.5 the carousel button works perfectly.

It's only after installation of this cab : MH-Widgets 1.3 SE that touching it freeze MS.

This pack is made of several nice widgets just added to the system. The only mods are for the menu bar and the recycle bin size.

The compatibility seems tested with MS 3.5.2 & 3.5.3 and I'm using MS 3.5.5 but I don't know what the difference is.

There is no response from matthew that's why I try to understand which register key is involved in this trouble to correct it.

Thanks again for your help.

Dominique.
Its not simply a case of registering a key for the carousel as the settings are all in a file called qa_layouts.dat which contains many text files to control all the aspects of mobile shell. If Matthews widget pack is made for an earlier version of Mobile Shell and you install it over a new one then you are effectively overwriting a new version of qa_layouts.dat with an older version. This is most probably what is causing your problems.

Its tough to advise of a workaround. If you have experience with modifying mobile shell then you can copy the newer components of qa_layouts using winzip but I wouldnt recommend it if you dont know what you are doing and I have never used the widget pack you installed so I cant comment on it.

Wish I could be more help.

Mark.
 

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
Hi Mark!

Thank you to explain.

I've extracted and unzipped qa_layouts.dat in the .cab

It contains a lot of .xml files. Most of them are dated december 2009 ...

I'm not an absolute beginer but I don't have knowledge enought to touch such files (and I don't know which one).

Until Matthews re appear I'll take care NOT to tuch the lower left button ...

Many thanks ... Regards ...
Dominique.
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hi Mark!

Thank you to explain.

I've extracted and unzipped qa_layouts.dat in the .cab

It contains a lot of .xml files. Most of them are dated december 2009 ...

I'm not an absolute beginer but I don't have knowledge enought to touch such files (and I don't know which one).

Until Matthews re appear I'll take care NOT to tuch the lower left button ...

Many thanks ... Regards ...
Dominique.
If you can point me where the thread is or post a link to the widget pack then I can quickly tell you which xml files need copying to a new version of the qa_layouts file. If I have time tonight I will do it myself as it will be alot quicker but you will have to test it for me.

Mark.
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hi Mark!

The thread is : http://forum.xda-developers.com/showthread.php?p=17087259#post17087259

My post number is #298 and another guy who explain the same behaviour is #294.

Thanks for your help.

Dominique.
Ok I have moved all the amended files from the modified qa_layouts.dat file to the correct MS3.5.5 version. I have no idea whether this will help with your carousel problem but its the only thing I can sugest at this time.

I have packed it all back up as a cab so you will need to install it on a CLEAN install of Mobile Shell 3.5.5. Then restart your phone and see if it fixes your problem.

Let me know how you get on.

Mark.
 

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
Carousel is back

Hi MASTER Mark ...!

You've made a great job.
To correct like that a .cab you've not developped yourself is fantastic.

The lower left button launches the Carousel as expected (pb fixed),
The tranparent SPB menu bar with extra space for widgets is OK,
The small recycle bin (very usefull) is OK.

It's only 99,99 % perfect because we have lost the MH-Battery widget. It is the nice one with multiple colors in a smooth gradian ...
All the other MH widgets (calendar, birthday, digital clock ..) are OK.

This is the confirmation number 8R7762232Y975684A for a drink ...
and let me know what kind of drink you like ...

Lot of thanks,
Dominique.
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hi MASTER Mark ...!

You've made a great job.
To correct like that a .cab you've not developped yourself is fantastic.

The lower left button launches the Carousel as expected (pb fixed),
The tranparent SPB menu bar with extra space for widgets is OK,
The small recycle bin (very usefull) is OK.

It's only 99,99 % perfect because we have lost the MH-Battery widget. It is the nice one with multiple colors in a smooth gradian ...
All the other MH widgets (calendar, birthday, digital clock ..) are OK.

This is the confirmation number 8R7762232Y975684A for a drink ...
and let me know what kind of drink you like ...

Lot of thanks,
Dominique.
Thanks for the drink I prefer Jack Daniels and coke or just a pint of cider ;)

For some reason the missing battery after updating the widgets pack to 3.5.5 seems to be a more in depth problem and I dont have the time to look into it right now but if I get a free minute I will take it apart and rebuild it. Is the battery something that you are in need of or is it just a minor consideration?

Mark.
 

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
Hi Mark!

Have a good Jack Daniels from me ...

I understand that is might be more complicate but ... "Is the battery something that you are in need ..." It's not only a battery meter.

It is a "ALL in one" with a gradian multicolor background with free space for 4 widgets of your choice, and dedicated space for MH Digital clock. (see attached picture).

That's why I choose this pack.

You 're welcome when you get time to look after...

Regards,
Dominique.
 

Attachments

  • MS-Per-Accueil.jpg
    MS-Per-Accueil.jpg
    48.2 KB · Views: 255

Zouluynes

Senior Member
Jan 19, 2009
61
0
Aix les Bains
Hi Mark !!

DON'T touch anything more ...
Believe me or not but now everything is perfect.
Here is step by step the sequence I followed (In my mind, just for a test ..)

- I uninstallled your v2.cab,
- I re installed Matthew's .cab, --> No way .. MH-Battery not there
- I uninstallled Matthew's .cab,
- I uninstallled SPB MS 3.5.5,
- I soft reset my HD2,
- I re installled SPB MS 3.5.5, and finally,
- I re installled Matthew's .cab and
- I soft reset my machine --> All the .cab functions AND Carousel are OK.

I don't know where is the gremlin, I assume that in your v2.cab there is an instruction that wrote a usefull key in the registry which one is not erased by re installing Mobile shell and Matthew's .cab.

I hope not to have to hard reset my machine cause I'm not sure the above procedure will work exactly the same another time.

Once again many thanks for your Job that fixed the trouble and that I saved with security....

regards,
Dominique.
 

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Hi Mark !!

DON'T touch anything more ...
Believe me or not but now everything is perfect.
Here is step by step the sequence I followed (In my mind, just for a test ..)

- I uninstallled your v2.cab,
- I re installed Matthew's .cab, --> No way .. MH-Battery not there
- I uninstallled Matthew's .cab,
- I uninstallled SPB MS 3.5.5,
- I soft reset my HD2,
- I re installled SPB MS 3.5.5, and finally,
- I re installled Matthew's .cab and
- I soft reset my machine --> All the .cab functions AND Carousel are OK.

I don't know where is the gremlin, I assume that in your v2.cab there is an instruction that wrote a usefull key in the registry which one is not erased by re installing Mobile shell and Matthew's .cab.

I hope not to have to hard reset my machine cause I'm not sure the above procedure will work exactly the same another time.

Once again many thanks for your Job that fixed the trouble and that I saved with security....

regards,
Dominique.
Hi Dominique,

Glad you got it working how you wanted it to eventually :)

Mark.
 

spannernick

Senior Member
Feb 7, 2010
519
124
London
Can you post about how to edit the bmp images in the dat files,I know there have to be 16bit but when I change the size of one from wvga to vga and save it and put it back in the dat file and in the theme, image is blank..not there...??
 
Last edited:

mskip

Retired Senior Moderator
Mar 20, 2008
12,328
16,067
Norfolk
Can you post about how to edit the bmp images in the dat files,I know there have to be 16bit but when I change the size of one from wvga to vga and save it and put it back in the dat file and in the theme, image is blank..not there...??
Did you save it in the correct format (R5G6B5) and also make the mask image the same size and save it as 8bit greyscale?

Looking at the index.xml file within the dat file will tell you which images go together as a single mask inage could be serving several main images.

Mark.
 

spannernick

Senior Member
Feb 7, 2010
519
124
London
Did you save it in the correct format (R5G6B5) and also make the mask image the same size and save it as 8bit greyscale?

Looking at the index.xml file within the dat file will tell you which images go together as a single mask inage could be serving several main images.

Mark.

How do i save it in the correct format in photoshop (R5G6B5)

It don't look like they have a mask...??

Code:
<Bitmap Name="LinkBackgdWP7BackBack1" Image="LinkBackgdWP7BackBack1.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackBack2" Image="LinkBackgdWP7BackBack2.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackBack3" Image="LinkBackgdWP7BackBack3.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackOffice1" Image="LinkBackgdWP7BackOffice1.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackOffice2" Image="LinkBackgdWP7BackOffice2.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackOffice3" Image="LinkBackgdWP7BackOffice3.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackGames1" Image="LinkBackgdWP7BackGames1.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackGames2" Image="LinkBackgdWP7BackGames2.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackGames3" Image="LinkBackgdWP7BackGames3.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackLifestyle1" Image="LinkBackgdWP7BackLifestyle1.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackLifestyle2" Image="LinkBackgdWP7BackLifestyle2.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackLifestyle3" Image="LinkBackgdWP7BackLifestyle3.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackPictures1" Image="LinkBackgdWP7BackPictures1.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackPictures2" Image="LinkBackgdWP7BackPictures2.bmp"/>
      <Bitmap Name="LinkBackgdWP7BackPictures3" Image="LinkBackgdWP7BackPictures3.bmp"/>

Example:

Code:
<Bitmap Name="MenuBarGrey40L" Image="MenuBarGrey40L.bmp" Mask="MenuBarGrey40L_m.bmp"/>

Edit:
Worked out how to save it now but its still not working(note widget black) It must be Photoshop...what are you using to save your bmp..??
 
Last edited:

Top Liked Posts