Question V4A working yet?

Search This thread

zoman7663

Senior Member
  • May 23, 2010
    552
    251
    Columbia, MD
    Has anyone gotten viper4android to work on 9pro global yet? I've tried several versions with no luck.
    There is a thread in here in reference to this very topic. You have to install more than just Viper to get the drivers to install. The thread I referred to says to install JamesDSP, reboot, install the DeWitt version on the Viper app (2.7.2.1 I think) it'll prompt you to install the drivers, reboot and done. I had mixed results with this method, sometimes the processing would just stop, start, stop....
    I install AML v4.0 first, install Ainur Sauron, reboot, install Viper apk, the drivers, reboot, Dolby Digital Plus reboot and done. You can remove the Ainur Sauron module after all that if your so inclined, the Dolby Digital Plus isn't necessary either but it all works flawlessly.
     

    vibrantliker

    Senior Member
  • Install in order

    Viper4androidFX via Magisk
    Reboot
    Audio Modification Library via magisk
    Reboot
    Push the file (extract from the zip) to data/adb/modules/ViPER4Android/ that i have uploaded and set permission 644
    (it should now be data/adb/modules/ViPER4Android/post-fs-data.sh)
    Reboot
    Open viper, set to legacy mode, then check if status is now normal

    Amazingly this has been working on all my phones with A11
     

    Attachments

    • post-fs-data.zip
      566 bytes · Views: 29
    Feb 10, 2013
    34
    9
    This is the process that worked for me:

    Uninstall any previous versions of Viper and other audio mods

    Install SELinuxModeChanger or use another method to change your SELinux to permissive

    Install Audio Modification Library from Magisk > Reboot

    Install Audio Compatibility Patch from Magisk > Reboot

    Install Viper4Android 2.7.2.1 from Magisk > DONT REBOOT

    Open the newly installed Viper app and download the drivers > Reboot

    Open Viper and hit the Settings in the top right
    Turn on Legacy Mode

    Good Luck
     
    • Like
    Reactions: bulletbling

    rickysidhu_

    Senior Member
  • Apr 1, 2016
    1,864
    784
    Vancouver
    OnePlus 9
    Yes, you just need to install the "Ainur Narsil" and "Audio Mod Library" modules in magisk first. Reboot, then install viper. Good luck!
    This worked for me! I had to disable AML, reboot, re-enable, reboot as additional steps but got it working at the end of the day. Thank you a ton for this, I've been trying to get V4A to work ever since I got this phone. JamesDSP works and has been fine but I much prefer the UI of V4A.

    Seems like the EQ isn't doing anything but the master limiter seems to increase the overall volume so that's a good sign.

    Thanks again!
     
    • Like
    Reactions: stryver

    bulletbling

    Senior Member
    Jan 14, 2013
    154
    33
    This is the process that worked for me:

    Uninstall any previous versions of Viper and other audio mods

    Install SELinuxModeChanger or use another method to change your SELinux to permissive

    Install Audio Modification Library from Magisk > Reboot

    Install Audio Compatibility Patch from Magisk > Reboot

    Install Viper4Android 2.7.2.1 from Magisk > DONT REBOOT

    Open the newly installed Viper app and download the drivers > Reboot

    Open Viper and hit the Settings in the top right
    Turn on Legacy Mode

    Good Luck
    How I did it but still needed to modify the data/adb/modules/ViPER4Android/post-fs-data.sh upon subsequent tries after removing magisk and reinstalling.
     

    netgar

    Senior Member
    Jan 14, 2012
    917
    89
    OnePlus 9 Pro

    Attachments

    • Screenshot_20210514-190231.jpg
      Screenshot_20210514-190231.jpg
      217.6 KB · Views: 8

    Top Liked Posts

    • There are no posts matching your filters.
    • 3
      Yes, you just need to install the "Ainur Narsil" and "Audio Mod Library" modules in magisk first. Reboot, then install viper. Good luck!
      1
      Has anyone gotten viper4android to work on 9pro global yet? I've tried several versions with no luck.
      1
      This is the process that worked for me:

      Uninstall any previous versions of Viper and other audio mods

      Install SELinuxModeChanger or use another method to change your SELinux to permissive

      Install Audio Modification Library from Magisk > Reboot

      Install Audio Compatibility Patch from Magisk > Reboot

      Install Viper4Android 2.7.2.1 from Magisk > DONT REBOOT

      Open the newly installed Viper app and download the drivers > Reboot

      Open Viper and hit the Settings in the top right
      Turn on Legacy Mode

      Good Luck
      1
      Yes, you just need to install the "Ainur Narsil" and "Audio Mod Library" modules in magisk first. Reboot, then install viper. Good luck!
      This worked for me! I had to disable AML, reboot, re-enable, reboot as additional steps but got it working at the end of the day. Thank you a ton for this, I've been trying to get V4A to work ever since I got this phone. JamesDSP works and has been fine but I much prefer the UI of V4A.

      Seems like the EQ isn't doing anything but the master limiter seems to increase the overall volume so that's a good sign.

      Thanks again!
      1
      Yes, you just need to install the "Ainur Narsil" and "Audio Mod Library" modules in magisk first. Reboot, then install viper. Good luck!
      This one worked for me thanks
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone