[v7.5] Aidan's ROM [S905X] [ATV 7.1.2] (Lag & Bloat Free, Pre Rooted, Samba & Miracast) [TV NETFLIIX] 2021 Update!

Search This thread


Senior Member
Dec 17, 2021
@vilaris, at this moment the box don't turn on, I have tried with several USB cables and ports, power adapter, and the mask rom reset without luck.

I can not to try that you share with me because the box have no connection with the computer.
Does the LED still light up ?
I had similar issue with this v7.5 ROM before, just go back up the thread to see how I solved it.
  • Like
Reactions: aidanmacgregor


Aug 22, 2018
Hello friends HELP me.I have Android TV box MXQ Pro Plus s905x 2/16gb. Why is ui resolution 1280x720 ?Other firmware, then error 0x10302001 appears at 7% I don't know why but only 2 firmware can be installed [v7.5] (MXQ) Aidan's ROM [S905X] [P212, P214 & P242] MXQ Pro 4K 1GB 2GB+ (720pUI & 210DPI) https://mega.nz/folder/rTgUQLyI#jfRgEhOenZ0ZBtRLIOPK6A atvXperience_S905X_mxqpro https://mega.nz/folder/QkZTmaZa#iaFEG4McZUPgz1j3kINW3A/folder/ElwXwSAb In the firmware from [v7.5] (MXQ) Aidan's ROM the remote control and Bluetooth do not work. In the firmware atvXperience the remote control do not work.Here is the firmware from my tv box https://disk.yandex.com/d/njQSLMgQt4f0Hg Help solve this problem.Thanks.


Dec 16, 2019
Does the LED still light up ?
I had similar issue with this v7.5 ROM before, just go back up the thread to see how I solved it.
Thank you @vilaris1.
The only thng I detect is a small red light blink when connect USB or power supply. After blink one time, the box turn off and nothing happen. It continue with no recognized by UTB or USB port. I just hear a little jingle but the port doesn't recognize it.
Last edited:


Senior Member
Dec 17, 2021
Thank you @vilaris1.
The only I detect is a small red light blink when connect USB or power supply. After blink one time, the box turn off and nothing happen. It continue with no recognized by UTB or USB port. I just hear a little jingle but the port doesn't recognize it.
If the LED still lights then it only a soft brick and your box can be saved.
Try plugging in the OTG USB port withtout plugging into the power adapter. The USB should provide enough power to power up the box. You just need to make sure you have plugged into the right USB port that is the OTG one.


New member
Oct 10, 2006
Many thanks to @aidanmacgregor for your great job sir. Burned using amlogic burn tool 3.1 via USB to TX3 pro 1g/8g without any problem and works great. Everything is quite snappy, except latest Youtube app crashes a few times when started playing a video so I installed S Youtube as replacement and now working well. The other issues is the top most recommendation bar is always empty, even though I've enabled all options. So it always display the cloud icon. Any ideas how the recommendation bar can work?
Hey @godhek ,
I was wondering how you get an aidan's ROM running on a Tanix TX3 pro?
I tried every v7.5 and v8 Rom Image with Amlogic Burning Tool (v2.2 and also higher version + v3) but I can't get it on the box... [maybe the uboot is to old?]
Maybe the box is still on Marshmallow Android 6.x - the latest original Firmware form 2017 I found.
My Tanix TX3pro has got 1/8GB and the NANYA DDR, Amlogic S905x
I would be delighted over the moon if you, someone else or maybe @aidanmacgregor could help.


[btw: I've got also a Tanix TX3 mini and @aidanmacgregor your v8 ROM works like charm on it]
  • Love
Reactions: aidanmacgregor


Senior Member
Nov 19, 2011
I have Mini M8IIS with S905X + AP6212 with 6.0.1 Android, so I have a question which ROM to choose at the beginning and start adventure with Aidan's Rom.

i have this box just with ap6212a wifi, these wifi chips dont have great performace in android 9 at the moment, would advise may android 9 (any if using ethernet but ap6212 version may have working (but not fastest) wifi and bluetooth :)


Senior Member
Nov 19, 2011
@vilaris, at this moment the box don't turn on, I have tried with several USB cables and ports, power adapter, and the mask rom reset without luck.

I can not to try that you share with me because the box have no connection with the computer.
oh, thats not a good sign, i want to think maybe youe EMMC had died, i have an s905x stick that shows same issue (my other exact same is still alive though) but not too sure just now :)


Senior Member
Nov 19, 2011


Feb 3, 2011
I've got a Mecool KM9pro with S905X2 chipset but it seems bricked and I'm trying to flash it with this rom.
Anyone knows to unbrick it? Maybe if I knew the pins to short the nand chip I could resurrect it


Apr 17, 2007
Installed with success on COOLEME MB2 (S912) . Very similar to BEELINK GT1

COOLEME® MB2, a real Home Entertainment Center for Games/Apps/UHD Videos/Dolby AudioAmlogic S912 Octa Core ARM Cortex-A53 CPU up to 2GHz (DVFS)ARM Mali-T820MP3 GPU up to 750MHz (DVFS)2GB RAM DDR3 + 16GB eMMC Flash ROM1000Mbps LAN + IEEE 802.11b/g/n/ac 2.4G+5.8G Wi-Fi + Bluetooth 4.0

I've download the rom from this link (navigate to find yours) :

Mine was

2. [v8] Aidan's ROM [S912] [ATV 9] [DDR3 & DDR4] [LAN100].img

I tried the Thrid (Qualcomm Chipset) and i Had blocking errors during writing

Dont try to install with Sd Card, it doesn't work !
Only work with USB cable (Amlogic_USB_Burning_Tool_v2.2.4) .
Note: Burning tool 3.xx is too recent and doesnt Work with old boxes. only download v 2.xx


Amazon Prime Video doesn't work. ("change your HDMI Cable") i suppose due to lack of Widevine level 1.
Remote Control Works (On/off Button, arrows, selection button, home button ..)
Bluetooth Doesn't works. it's annoying to play retroarch with a Bluetooth Gamepad

Thank for your work!
Last edited:
  • Love
Reactions: aidanmacgregor


Nov 7, 2011
Hi everyone, I want to leave my feedback based on what I have tested.
My box is called TX95 (manufacturer unknown) and has 2Gb of ram, S905X, and P212 motherboard.
I have installed version 7.5 (both universal and MXQ version)
1) Rom speed: Excellent
2) WiFi: works fine, but: during the first configuration it loses connection, and to solve it I performed the first boot with cable and then I continued to use the wifi)
3) Infrared remote control (supplied as standard with the box): Everything works
4) Remote Control / Mouse / USB Keyboard (purchased later): Everything works
5) Video calls: It works (I tried with google duo and whatsapp business)
1) Youtube: if I close it and then reopen it, it often crashes and no longer works (to solve this, I installed smart tube next and it seems to work fine)
2) shutdown key: It does not work
3) The launcher: I can't set an alternative launcher as default, I set all the settings (as you do on an android phone) but when I turn on the box, it starts with the stock launcher, and also when I browse with another launcher and from the remote control press the "HOME" button it takes me back to the main screen of the stock launcher and not to the home screen of the launcher that I have installed.
Can anyone help me change launcher ???
I hope my feedback can help


Nov 7, 2011
Sono riuscito a cambiare il launcher in modo permanente !!!
Ho seguito passo passo una guida che ho trovato online, e utilizzando "REMOTE ADB SHELL" ora sono libero di scegliere il launcher.
Questo è il link della guida:

per rimuovere il launcher dallo stato "DEFAULT" la guida dice di eseguire il comando con "REMOTE ADB SHELL":
"pm uninstall --user 0 com.google.android.tvlauncher"
Ma la guida è stata realizzata per google tv launcher (credo) e non per leanback launcher, quindi l'ho cambiata scrivendo:
"pm uninstall --user 0 com.google.android.leanbacklauncher"

D'ora in poi, ogni volta che installo un nuovo launcher, e quindi clicco sul pulsante "HOME", il sistema mi chiederà con quale launcher eseguire l'operazione.
Spero di essere stato utile a qualcuno....


Apr 11, 2014
I been searching if my box is compatible with this rom, can anyone help me as I cannot identify my box. I think it is a clone MXQ Pro. Here are the pictures of the mainboard (back and front).



Just found out that it has armv7 rev 5 v71 cpu with XR819 b/g/n WLan chip. Does anyone knows if this rom is compatible with my box? Thanks

Last edited:


Aug 22, 2018
you can replace youre remote.conf file to the correct one in my android tv 7 :)
Hello. I have a MXQ Pro Plus s905x 2/16gb wifi RTL8327BS . Why is the ui resolution 1280x720 ? When installing other firmware, an error 0x10302001 appears at 4% . I don’t know why, but only 2 firmware work [v7.5] (MXQ) Aidan's [ S905X] [P212, P214 & P242] MXQ Pro 4K 1GB 2GB+ (720pUI & 210DPI) https://mega.nz/folder/rTgUQLyI#jfRgEhOenZ0ZBtRLIOPK6A and
https://mega.nz/folder/QkZTmaZa#iaFEG4McZUPgz1j3kINW3A/folder/ElwXwSAb Remote and Bluetooth not working in Aidan's firmware ,sees 1 GB of memory. The remote control does not work in the atvXperience firmware. Can this be fixed? Thanks.
8 ram chips https://www.datasheets.com/en/part-details/k4b2g0446d-hyh9-samsung-electronics-44468523#parametric
H26M52208FPR NAND https://www.datasheets.com/en/part-details/h26m52208fpr-sk-hynix-inc-98770818#parametric
in this version, the remote works https://disk.yandex.com/d/IJ5uxe-5RK0Vrg ---- is not installed on my tv box


  • 20220124_005153.jpg
    931.3 KB · Views: 4
  • 20220124_145420.jpg
    1.1 MB · Views: 5
  • Mxq-pro-4k.jpg
    236.6 KB · Views: 4


Nov 27, 2021
Moto G6
Hi, I have a MXQ PRO 4K with S905W and Wi-Fi SV6051P, the board says "MXQ_S95W_V1.1". I burned the file "7. [v8] Aidan's ROM [S905W] [ATV 9] (SV6051P).img" and it got stuck on the logo (Android TV Aidan's Rom). Am I installing the wrong file or is it another problem?
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 11

    Aidan's Custom Android TV 7.1.2 ROM
    UPDATED: 10/02/2021

    Netflix For Android TV!

    This is version 7.5 of my Rom, i use this as a daily driver and it is stable, it is CLEAN & NO BLOAT (any included apps are removable), this replaces my previous version (v6, v7 & v7.1 ect...)

    UPDATE: Aidan's Android TV 9 Pie Xiaomi Mi Box Firmware Port To S905X Now Also Available!
    XDA Post Clock Here

    NEW Website! Check it out & Downloads

    Improvements Made [V6]
    ●NOT pre-rooted (Flash Magisk via TWRP for root)
    ●User Interface renders at full 1080p
    ●Fixed bug where remote power button would turn box off/standby but not wake it up again
    ●Added Miracast (scren mirroring) [BROKEN] FIXED IN V7
    ●Removed Chromecast and other bloat (wont work in uncertified devices and would fill storage in 24 hours)
    ●New bootlogo and boot animation (No longer will boot animation appear frozen during 1st boot)
    ●Added New App Drawer (And modified APK) THIS WILL SHOW NON TV APPS
    ●Misc tweaks & adjustments

    Improvements [V7]
    ●Added More Wi-Fi Drivers
    ●WIFI & LAN SPEED fixed (Was maxing about 6Mbps, now sucsesfully got 40Mbps)
    ●DPI Changed to 320 (Android TV Stock DPI)
    ●More tweaks
    ●Now comes with Filelinked Pre-installed (You can uninstall if you dont need)

    Improvements [V7.1]
    ●TWRP replaced as was rendered at 720p in the top left on corner some devices
    ●More WiFi & Bluetooth improvements
    ●Updated boot animation android tv 11 (Thanks khurramrizvi for extracting)
    ●Added more keylayout files (USB)
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.2] (19/09/2020)
    ●Fixed Disney+ No sound issue fixed (Thanks to DiogoSilva48)
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.3] (06/10/2020)
    ●PRE ROOTED! (Root switch does not work, Always ON)
    ●Disney+ now has working sound (v7.2 but worth mentioning again)
    ●All preinstalled apps can be Un installed (exept system apps)
    ●Samba Windows File Server [NAS] (Usb HDD, SD, Internal)
    ●Google Documents UI added (fixes bugs in some apps opening files)
    ●Stock Downloads File Explorer Added (Related to documentsUI)
    ●Google Assistant Text Search Navigation Bug
    ●Phone Settings crash fixed
    ●Wi-Fi Tethering now works (Ethernet to Wi-Fi)
    ●Changed Mouse cursor
    ●Certificate installer fixed
    ●GlobalKeyInterceptor added
    ●OneTimeInitaliser added
    ●GooglePartnerSetup added
    ●Updated Backdrop (no longer claims chromecast built in)
    ●Alternative Screensaver Included (Can uninstall)
    ●Reboot to recovery option in all apps section
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.4] (06/10/2020)
    ●Added missing Files for WiFi Chip AW-NH665 (Thanks Erick)
    ●Special Build for devices that fail to flash Universal ONLY (MXQ Special Build) (Testing Need Feedback)

    Improvements [V7.5] (10/02/2021)
    ● Added Netflix Android TV Version

    Im very happy with how this turned out, please install and let me know if it works for you what device you installed on & if you have any suggestion

    Facebook Page

    Tested on
    ●MXQ Pro 4K (1GB RAM)
    ●Trongle X1 (2GB RAM)
    ●NPET A95X( 2Gb RAM)
    ●rasse-001 (unknown Ram/rom)
    ●Leelbox q2 (unknown RAM/ROM)
    ●X96 (1GB Ram 8GB Rom)
    ●Beelink MXIII-II (Unknown RAM/ROM)
    ●Sammix R95
    ●M9C PRO
    ●X96 Max
    ●Buzz TV XPL 3000 (Needs my Buzz TV 3000 Remote. patch)
    ●Trongle S3 (Report that needs super su to root)
    ●TX3 PRO
    ●KM5 OTT 1GB/8GB (No reset button 1 user reported using "Reboot Update" worked)
    ●Alfawise A12 Plus Projector (AW-NH665 WiFi fixed in v7.4, Also Needs my Remote patch)
    ●T6 S905X 1/8GB
    ●KM5 (This Version only Worked With Alternative Special Build AKA: MXQ Special Build) [No Reset Button, Connect the box to PC with USB & Connect AC Power WHILE also pressing the Power Button, the device should then connect to the software and Flash]
    ●Many More...

    Known Issues
    Wifi chip HS2734A
    ZTE B860H (2 reports didn't work)
    MXQ boxes have hundreds of clones, should work on 90% of boxes if no Roms work at all for you I have some last resot ROMs at bottom of this post

    V7 Download From Google Drive (Fast Download)
    Replaced with v7.1

    V7.1 Download From Google Drive (Fast Download)
    Replaced with v7.2

    V7.2Download From Google Drive (Fast Download)
    Replaced with v7.3

    V7.3 Download From Google Drive (Fast Download) (06/Oct/2020)
    Replaced with v7.4

    [V7.4] Universal Download (Fast Download) (24/Oct/2020)

    Special Builds (Fast Download) (06/Oct/2020)

    [v7.4] Nexbox A95X Remote WITH POWER ON BUX FIX (07/07/2020) (Updated 24/Oct/2020)
    This Version Has Nexbox_Remote.zip pre installed in case can't access recovery to flash the patch (Added 22/06/2020)
    ^ Thanks to klo33 (freaktab) for testing these changes

    [v7.4]Alternative Special Build [ONLY Use IF Universal Fails!] (07/07/2020) (Updated 24/Oct/2020)
    This Version has additional DTB files (Alternative P212 + p214 & p242)
    Drawback is the UI is rendered at 720p with 210 DPI, The UI wont look as Sharp as universal 1080p with 320 DPI

    MY Patches (Flash with TWRP)

    ●Mygica atv 495x REMOTE (Thanks to nicko450 for supplying the remote.conf file)
    ●Buzz TV XPL 3000 Remote patch (You need to use ADB or terminal to enter recovery on these Devices)
    ●Xview R7 Remote Patch
    ●Mini M8S II Remote Patch (Thanks to Kishore12 for finding and fixing a .conf file)
    ●Sunvell T95k Pro Remote Patch
    ●Alfawise A12 Plus Projector Remote Patch

    Patches (Flash with TWRP) [BY MINIXFREAK]
    Nextbox, sunvell, Mecool, Zoomtak Remote Patches
    a95X, l8, Magicsee, T95U, T95Z, Tanix, x92, Zoomtak, Youndoo Clock Patches
    QC9377 & 4.1 Bluetooth patches

    Install using amlogic burn tool

    Donate & Support Me & Buy me an IRN-BRU
    Paypal: http://paypal.me/aidanmacgregor92
    Bitcoin: 1GhSiPf2ZURa9HiVMVh5KXmmB8nXr6nCVZ

    FAQ (WIP)

    Q. Netflix wont work from play store
    A The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, FIXED IN LATEST VERSION PATCHED NETFLIX PREINSTALLED

    Q. Amazon Prime Wont Work

    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Q. Disney+ No Sound
    A. Fixed in v7.2

    Q. Root Switch Wont Work
    A. Unfortunately v7.3 is always rooted and the switch doesn't work (I may offer unrooted versions if there is demand)

    Screenshots On The Website

    If you have one of these devices that really struggle taking any custom ROM, sometimes these are MXQ devices (there are so many clones of these devices) and they may have a locked bootloader or it needs a DTB that isn't common or known, there are some ROMs that have saved some people before, these are only if no other custom ROMs will work for you and are a last resort :)

    See this post:
    Hi, Why should one pick this 7.5 version over the 8.0 one? Thank you
    This one did it because 8 does not support remote control and does not support the same set of keys in BT keyboard. Only 7.5 can be operable, but true, the both works and 8 has mutch better GUI.
    I am having Merlin 4k tv box amologic p212 based.can somoene please tell me which firmware should I use.

    Below are my box specifications
    i cant see what soc from specs but p212 suggests s905x :)
    And the question about the CoreElec on the sd-card? :)
    after updating the box to Android 7.1.2 or later with the exceptional Roms of @aidanmacgregor you have to install a terminal emulator on android from the playstore or any apk.
    After that you prepare the SD card with stable CoreElec (19.3 matrix) and insert it in the box on.
    Once this is done, launch the terminal and type:
    reboot update
    The box will reboot from sd with CoreElec.
    Glad you used the Boot Animation, hoping more devs would include it in their builds ?