• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[v8] Aidan's ROM [S905X] [Android TV 9] [Netflix TV] [Disney+] [Google Play Certified] [ROOT]

Search This thread

asegura074

Member
Jul 10, 2018
20
14
Hi, i have the same tv box (x96 max plus Q2)
How can I go into Mask Rom mode?

Hi, i have the same tv box (x96 max plus Q2)
How can I go into Mask Rom mode or recover it in case of hard brick
You can try number 6 X96Max_plus 2 Q1 but i think ethernet won't work for you model but you can try no problem you won't get brick

i just made a mod to see if you get Ethernet ! i dont have Q2 to test it might give it a try !

Working Roms - For Q2 can use this Slimbox Ports

 
Last edited:

Matapros99

Member
Jan 8, 2020
12
1
Redmi Note 8
You can try number 6 X96Max_plus 2 Q1 but i think ethernet won't work for you model but you can try no problem you won't get brick

i just made a mod to see if you get Ethernet ! i dont have Q2 to test it might give it a try !

Working Roms - For Q2 can use this Slimbox Ports

Yes thanks!
in fact I'm in slimbox, I wanted to try this rom, but in my old tv box I had a hard brick and I no longer knew how to recover it
Thank you!!!!
I will try with Q1
 

Formingus

Senior Member
May 23, 2007
78
11
Fier
Adrian rom [v7.5] (MXQ) Aidan's ROM [S905X] [P212, P214 & P242] MXQ Pro 4K 1GB 2GB+ (720pUI & 210DPI) will brick android beelink mxiii - you cant flash any more or go into recovery
 

radomcafree

New member
Jul 19, 2021
3
1
I am going to try this ROM. I have TX3 with no bluetooth (didn't realize that this android box version has no build in bluetooth). Will this customs ROM make Bluetooth dongle works on my TX3 Andorid Box?
 

wamy007

Member
Nov 10, 2017
21
2
I have a z69 4k (s905x soc) box and tried version 1,2 and 11 of atv9 with no luck enabling wifi.
Only version 1 and 2 boots.
The wifi chip is a rlt8723bs.
Any idea if that chipset is supported?
Thank u kindly for the answer
 

aidanmacgregor

Senior Member
Nov 19, 2011
1,341
375
Caithness
aidansrom.freecluster.eu
hi all and @aidanmacgregor ,
first thing first : thx for ur quick answer...

for my VPN issue i'ved figured out that your android TV 7 (standard) fix the issue and run quite good on my geniatech atv598max except the tv tunner part
i really understand that it is not the same as other CFW u was able to create but i was expected that there is a way to 'compile' a cfw for a different targeted chip like s905D ...may be using similar device firmware like the meecool KI or KII that are easy to find compare to geniatech's once...i know it would involved a lot of work and i'm ready to make everything necessary because im kind of desperate here in regard of the complete lack of support and absolute silence from geniatech here...
anyway thanks for all kind of help you could provide even if i have to do it myself but with instructions i can follow...

regards
its not so much that, im no expert, im learning as i go only been doing this since covid started with no background in this sort of thing, just wanted to fix my device :)
 

aidanmacgregor

Senior Member
Nov 19, 2011
1,341
375
Caithness
aidansrom.freecluster.eu
Request ur Hep bro..
Flashed few times mine box with different your firmwares

Fashed those ones
[v7.5] (UNIVERSAL) Aidan's ROM [S905X] 1GB 2GB+
[v7.5] (Nexbox) Aidan's ROM [S905X] Nexbox a95x 1GB 2GB+
but when i flash this one
[v7.5] (MXQ) Aidan's ROM [S905X] [P212, P214 & P242] MXQ Pro 4K 1GB 2GB+ (720pUI & 210DPI)ky mut
Resolution not OK and remote not work

Trying to flash back to one of 2 first ones but USB Burning Tool Not recognize anymore for flashing. All times flashed easy - Open USB Tool > Chose image > Pres start > Insert USB thats all. I try different PC different cable and USB Same think

Mine Box is Beelink Mini MXIII 2GB S905X 32GB
Any help from you or any one will be highly appreciated . Thanks in Advance
may need to use mask rom mode i made a video here with a beellink board
 

jamez_warner

Member
Oct 12, 2010
11
0
Does anyone know how to set custom resolutions? Ideally after 3840x1100, but the more common 2560x1080 would work. I've tried setting via "wm size" but that just changes the scaling, the output resolution remains the same... Thanks!
 

masinski

Member
Jul 26, 2021
5
0
Hello there! Ive got problem with boot of my device or/and problem with USB Burning Tool.

First of all ive tried few hours to put right image to my device. When i tried with S905W but got problems with Uboot in USB Burning Tool ("0x32030201]Uboot/Get result/DiskInitial error". But i tried S905X and it went well but only when i uncheck erase flash and boot sections. That was the only way to finish burning correctly. And of course its not working and hanging on Aidens Rom Logo (i was w8ing more than 5 mins).

When i check "erase flash and boot" sections ive got those mostly
[0x10105002]Romcode/Initialize DDR/Read initialize status/USB Control setup error
[0x00101004]Erase bootloader/Lowper/Identify/Error result

And yes ive done the Mask Rom thing :/

Pls help
 

s_sevan

Member
Jun 17, 2014
22
10
I have t95m box 2g 8g s905x works perfect with v7.5 android 7.1.2 with universal 7.5 firmware with bluetooth 4.1 patch i have wifi and bluetooth working. with v8 android 9 i installed firmware #3 wifi works but no bluetooth. is there a way to make the 4.1 bluetooth patch from v7.5 work with v8? thanks
 
Jun 8, 2007
9
0
Hi @aidanmacgregor aidanmacgregor, I really need your kind help to revive my bricked T95m 4K (S905X, 1GB/8GB). I tried to use your ROM and flash it to my box, by shorting pin 3&4 on emmc chip. It doesn't allow to be programmed.

Display Chip: FD628
USB Chip: GL850G
Network Chip: SV6051P
eMMC: Essencore I3E-8GTH7CMRE

fetch

fetch

fetch


Would you please help me let me know how to do?
Many many thanks!!!!
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    OK, so I tried SlimboxTV and the remote works, from what I can see they are both Android TV 9 based (yours being patched with 2021 security patches). Is there anyway I can "transfer" the remote config files from the Sling rom to yours, perhaps with Ricky's tools?

    I should have perhaps added that the box I am testing on is a Nexbox A95X B7N (1/8)...

    UPDATE: Tried copying over dtbo partition from one from ROM to the other, no effect on the behavior of the remote control... still not working properly...
    1
    Hello @aidanmacgregor excellent rom I tested it on S905x Realtek 2gb of ram, the only problem I encountered was that the audio pass through does not work. I noticed that in android audio settings selecting the manual option does not show the activatable audio formats. When I start a film with Ac3 or eac3 audio on plex this is not heard. With Kodi, on the other hand, the audio pass through cannot be activated. Can the problem be solved?
    Hi, if you have not found I solution to your problem (or if anyone else stumbles upon this issue), my novice research has led me to believe that this appears to be an issue with certain boxes (had the same issue on my A95X).

    The box reports to Plex that it can support the codecs however there seem to be output issues with them (no idea what as the original Android 6 rom it came with did not appear to have this issue), this issue creeps up on numerous roms I have tried.

    There is a "solution" to the problem (more like a workaround), as follows:
    1. You need root access
    2. Disable passthrough in Plex
    3. Force close Plex app and Clear Cache
    4. Edit the following file (either copy the file over and edit and copy back or directly edit on box): /data/data/com.plexapp.android/shared_prefs/com.plexapp.android.xml
    5. make sure the following are false (to be on the safe side you can "false" out DTS, TrueHD and whatever else you find in there related to audio codec support :) )
    <boolean name=“general.deviceSupportsEAC3” value=“false” />
    <boolean name=" general.deviceSupportsAC3" value=“false" />

    This seems to force Plex to transcode audio to AAC.

    There have been some reports that once you play a file successfully following the above steps, force closing plex/clearing cache and reediting the file makes Plex behave normally (i.e. playback of EAC3 without transcoding), however I have not tested this myself yet.
    1
    i forget to mention that the usb burning tool stuck in 4% with the famous uboot error and that was with all the roms I tried.
    try s905x versions too, some s905w devices work with the s905x DTB :)
    1
    this is an issue with android 9 and ethernet, it is a google issue and i dont think i can do anything to change this
    Hi,
    so that's cleared. Sadly, have to go back to stock ROM, it was android 5 or 6, something. It worked there. Have to find a way to root it and uninstall most of the c..p apps.
    Anyway, thanks for the answer.
    1
    It will never get better than that.

    If you want 1080p or 4K, get one of the certified boxes like Mi Box or Mi Stick.
    Moved to Mi Box S 👍
    L1 certifed.
  • 21
    to brighten.png

    Home Screen With Apps
    Screenshot_20210725-010734.png

    ^^^NEW Home Screen, Update From Play Store ^^^
    Screenshot_20210725-010752.png

    Preinstalled Apps
    Screenshot_20210712-104107.png

    Initial Set Up Screen
    Screenshot_20210712-104128.png

    Initial Set Up Screen 2
    Screenshot_20210725-010826.png

    About
    Screensaver.png

    New Google Dream X Included
    Screenshot_20201116-025413 - Copy.png

    Google Play Protect Certified
    Screenshot_20210207-224128.png

    Android TV Netflix! (Install Apk From Website)


    Aidan's Custom Android TV 9 ROM For S905X

    This is My Android 9.0 Firmware, This Is Based On The Official Mi Box Android TV 9.0 Firmware

    This Is A Firmware Port Of The Xiaomi Mi Box Firmware Designed To Run On Other Amlogic S905X Devices

    This Firmware Is FAST & STABLE

    WARNING: This Is Experimental & Requires Multiple Steps, Please Read About "Mask Rom Mode" To Know How To Recover Your Device If Installation Fails!
    This Has The New Amlogic Kernel And As Such Will Not Work On All S905X Devices, My Older Android 7 Based Firmware Works On Most Devices

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up


    Enjoy!
    ------------------------------------------------
    NEW Website! Check it out & Download!
    >>>> Website Click Here <<<<
    -----------------------

    v8 New Features (25.July.2021)
    BASED ON LATEST MI BOX Official Pie Build 3595
    Security Patch 5.March.2021
    Low Ram False All Roms
    Forceencrypt Disabled
    Default Volume MAX
    New Bootanimation
    More Debloating
    DPI Set At 320/213
    New Welcome (Thanks AcidIce18)
    No Remote Pair Screen
    More Cleaned & De Bloat
    More Tweaks...

    v7 New Features (29.April.2021)
    BASED ON LATEST MI BOX Official Pie Build 3409
    Security Patch 5.January.2021
    NEW Mygica ATV495x (maybe more) Version Available
    NEW F30UP (maybe more) Version Available
    Now Includes App Drawer (Non Tv Apps)
    Now Includes File Browser
    Now 11 Wi-Fi Versions Available
    Cleaned & De Bloat
    More Tweaks...

    v6 New Features (21.Jan.2021)
    Netflix TV Version (APK Provided)
    Stability Improved (Fixed Random Reboot Bug)
    Now 10 Wi-Fi Versions Available
    Cleaned Further & De Bloat
    More Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v5 New Features (08.Jan.2021)
    Universal Version Now Available
    More WIFI Chips supported
    Cleaned Further & De Bloat
    Now The Versions Are More Similar Than Ever
    Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burnig tool Image
    New Install Method Now 1 Step Install

    v1 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP


    Help & FAQ

    USB Burning Tool Cant See Device
    if usb burning tool cant detect your device, and youve tried other ports, cables ect then Mask ROM Mode May Be Needed, See Here
    Youtube Unbrick Guide

    Netflix wont work from play store
    The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, Patched Netflix Apk Now Available

    Amazon Prime Wont Work
    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Disney+ No Sound
    A. Fixed Earlier Release

    No Root
    There Is No Root In This Firmware Because This Is a User Build (Not User Debug)
    User Build: This Is Like The official Android Tv Devices (Like Mi Box), it does not have root or TWRP, Uses Release Keys and is SELINUX enforced
    Why?
    This Makes More Apps Show Up In The Play Store that didn't show before, (Example: Isp Android TV live tv app, only shows in Play Store On non rooted and SELINUX enforced devices, also the streams in the app do not even play in rooted devices.) And other Apps With Similar Issues On Non Certified Devices....

    myCANAL App No Sound...
    See This Post

    -------------------------------------------------------------------------
    [OLD] How To Install: [OLD]
    1) Download One Of The Base Firmwares That We Will Write Over (By Wi-Fi Chip If Possible But This Will Work Without Wi-Fi Using Ethernet)
    1.2) Download Reboot Revovery.zip & TWRP 3.3.1 AML By ViT
    1.3) Download One Of My Custom Mi Box Update Zip File
    1.4) Download USB Burning Tool (I Use v2.2.0 Download On My Website)
    2) Flash The Base Firmware Image Using USB Burn Tool,
    2.1) See If Wi-Fi & Bluetooth Seem To Work And Try The Other Version If Not
    3) Open The Update App And Choose Select, Choose Reboot To Recovery.zip & Chose Update & Update Again
    4) You Will Be Inside Recovery Now, Choose Update From EXT, And Choose (USB/SD Depending What You Use)
    5) Choose TWRP 3.3.1 .zip, This Will Boot Into TWRP, Slide The Screen To Accept (Mouse Needed) & Choose Install
    6) Flash My Custom Mi Box Update Zip File By WiFi Chip If Possible, If You Don't Have One Of These Chips You Will Have To Try The Versions & See Or Use Ethernet
    7) You Will Be Rebooted Automatically After Installation And Put Into The Stock Android Recovery
    8) Choose "Wipe/Factory Data Reset" Option Here, And Then Once Done Choose Reboot
    9) Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up
    10) Open Settings & Navigate To "Apps", Then Choose "See All Apps" Then "Show System Apps" Find The App "Chromecast Android Shell" And DISABLE It (Wont Work Without Widevine Level1 & slows device down)
    11 Disable "Movie Player" & Any Other Apps You Want To Hide
    12 Enjoy!

    --------------------------------------------------------------------------------

    Thanks DiogoSilva48

    --------------------------------------------------------------------------------
    4
    Thanks for the reply and eagerly waiting for manual update. The existing rom is almost like stock one. Happy with it, and the manual update would enhance it further.

    I tried sideloading many .apk for prime video of different versions and both platforms - mobile and android tv. Even tried aptroid.tv app store with someone's suggestions on google.
    However, the mobile versions did not even install. And the TV versions though installed but returned with the same error. Only trailers are able to play. Main content isn't playing and the error "Something went wrong" shows up.

    If you could help me with any working apk for prime video, kindly provide. Just like the netflix you provided.

    Thank you so much in advance Aidan.
    hey v7 is now available, most are uploaded 2 still uploading :)
    3
    3. [V6](Qualcomm QCA9377 & LTM8830)

    Wifi working perfectly fine on my 8189etv.
    3
    Hello Timosat, as I understood I have to find ly remote file and then after several step sut this folder in aidans rom... Where to find the right remote folder for my box? I have the remote.conf from a previous rom can I use this file?
    I read that you use Atvx 4 rom to do this ? You choosed this rom because your remote works with this rom?
    It's a long process with patience. Your remote.conf file has to be renamed to remote.tab1 and use any good file explorer eg mixexplorer and transfer tthe remote file to vendor/etc folder .But before you do this make sure you are rooted. You may try and root Aidan's rom first by patching recovery.Partition method.And see if your remote will work. As for my case yes I use atvx4 rom because I've tried Aidan's rom my remote did not work. So I made (should I call it hybrid) rom.By taking system.PARTITION from Aidan's rom and substitute it in atvx4 and also patching atvx4 recovery.PARTITION with Magisk.Then I repacked and flashed to my box.