• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[v8] Aidan's ROM [S905X] [Android TV 9] [Netflix TV] [Disney+] [Google Play Certified] [ROOT]

Search This thread


Aug 9, 2021
Find out your bluetooth drivers, there are flashable patches available on slimbox site, flash the one suits your box
Slimbox on the A95X F3 works fine. Aidan's rom unfortunately on firmware "[v8] Aidan's ROM [S905X3] (A95X F3) FB-Zeyn Elenson.img" - clock does not work (displays 'boot'), bluetooth finds devices but cannot pair them properly. What patch are you talking about? I tried replace drivers but no change, maybe I made some mistake.


Mar 20, 2018
Hello guys.

Firstly, congratulation Aidan, on this ROM. And thank you. I have X96 Max+. The ROM is fast, cleaned from most bloatware, and it works. Mostly.

For me, the one thing I am having difficulty with is using VPN. The very second I start and connect VPN, all connection is lost! 2 different VPNs!
And this is very, very important. So unfortunately, I stopped using this ROM until I find out how to fix this. Maybe Aidan can look into this in the near future.


Sep 26, 2021

Many thanks to Aidan for the ROM, it brought new life to an old A95X box long forgotten with ATV 6 on it... this ROM worked like a charm, eveything appears to be working as it should, except the remote (some butons work, others do what they should not, most don't register at all....)

I've read quite a few posts but can't seem to get my bearings stright...
Has anyone managed to get a problematic remote working with this ROM and if so, could you please point me in the right direction?

Much appreciated!


Mar 5, 2014
Hi Aidan

Firstly, many thanks for the ROM . . . I am ecstatic

FEEDBACK: X96 Air P2 is compatible running on:-

I have tried the Rom listed in #1 but there is no display clock so one does not know wheather the box is on/off ? . . . that was my main issue, so i uninstalled and next up was Rom (#7) . . .

A Working & Certified Box . . . what more can u ask for ?

A few slight problems but i can live with this for the time being, otherwise the box is slick (y)

1 Major stumbling block for me:-
How do you Power Off the Box ? . . . . . or do i look for a Power on/off in Play Store ?

Oh . . . by the way, the Netflix doesn't work (Mod) v2.7 . . . . i've been running this for a while but lately it just knocked me off . . . installed the latest version from the play store (not compatible with this box) . . . so for now i have no Netflix !

I will report back on some other issues as i go along
i.e Bluetooth (not working); No Power on/off option etc etc

Thanks once again


New member
Sep 27, 2021
hi all i have a x96 mini i've successfully installed the rom but i'm not able to press the key on the keyboard i've tried remote, keyboard but nothing someone can help here?

also jsut noticed that the selection can be done only if the remote is set up as mouse without doesnt appear any selection



Sep 26, 2021
OK, so I tried SlimboxTV and the remote works, from what I can see they are both Android TV 9 based (yours being patched with 2021 security patches). Is there anyway I can "transfer" the remote config files from the Sling rom to yours, perhaps with Ricky's tools?

I should have perhaps added that the box I am testing on is a Nexbox A95X B7N (1/8)...

UPDATE: Tried copying over dtbo partition from one from ROM to the other, no effect on the behavior of the remote control... still not working properly...
Last edited:
  • Like
Reactions: aidanmacgregor


Sep 26, 2021
Hello @aidanmacgregor excellent rom I tested it on S905x Realtek 2gb of ram, the only problem I encountered was that the audio pass through does not work. I noticed that in android audio settings selecting the manual option does not show the activatable audio formats. When I start a film with Ac3 or eac3 audio on plex this is not heard. With Kodi, on the other hand, the audio pass through cannot be activated. Can the problem be solved?
Hi, if you have not found I solution to your problem (or if anyone else stumbles upon this issue), my novice research has led me to believe that this appears to be an issue with certain boxes (had the same issue on my A95X).

The box reports to Plex that it can support the codecs however there seem to be output issues with them (no idea what as the original Android 6 rom it came with did not appear to have this issue), this issue creeps up on numerous roms I have tried.

There is a "solution" to the problem (more like a workaround), as follows:
1. You need root access
2. Disable passthrough in Plex
3. Force close Plex app and Clear Cache
4. Edit the following file (either copy the file over and edit and copy back or directly edit on box): /data/data/com.plexapp.android/shared_prefs/com.plexapp.android.xml
5. make sure the following are false (to be on the safe side you can "false" out DTS, TrueHD and whatever else you find in there related to audio codec support :) )
<boolean name=“general.deviceSupportsEAC3” value=“false” />
<boolean name=" general.deviceSupportsAC3" value=“false" />

This seems to force Plex to transcode audio to AAC.

There have been some reports that once you play a file successfully following the above steps, force closing plex/clearing cache and reediting the file makes Plex behave normally (i.e. playback of EAC3 without transcoding), however I have not tested this myself yet.
  • Love
Reactions: aidanmacgregor


Senior Member
Nov 19, 2011
你好,我的盒子是 Mini M8S II。我刷了你的 ATV7 和 ATV9 的最新通用版本,但是有两个问题。问题之一是遥控器问题。我的遥控器是小米蓝牙遥控器。连接后 按下确认按钮时没有反应。第二个问题是刷过的所有版本的wifi速度都很慢,即使显示信号很强,连接速度也只有几kb。如果用网线连接就没有问题。wifi连接速度问题应该如何解决?谢谢。
do you have an AP6121a wifi chip, i have a device with this chip and performance isnt great with this chip, not had time to look into this too deeply though :)

Top Liked Posts

  • 1
    Which type of x96 air do you have ? 2GB RAM/16GB ROM ?
    Do you have the original build number of the box ? Before flashing the ROM
    @emiljano539, mine is 4/64 version. unfortunately i dont have the original build (messedup the rom so had to flash custom and recover - no backup of original) but know that X96Air_P2_20191017-1917 works (if i,m not wrong this is the build number)
  • 2
    You are right my friend this was an old box and I think I was able to do the best that I could with such a box but I am terribly stubborn and I just cant figure this problem out . Its a good exercize and I learned a lot. I got a box that was a brick and I put it back to life , also I dont have sound with HBOMAX I figure it must require some codec. One thing I like with this ROM is that it is quite stable I plan to buy a OON IPTV box for the fun of it and some 905X3 box to see how far I can go with those. by the way I put a tread explaining how to install the google TV launcher maybe you might like it , the thread is under google tv general, try it out and let me know how it went, I also put instruction on how to roll it back in case you dont like it. Cheers
    It's probably not a codec issue but an issue with DRM/Widevine. All these cheap China boxes have Widevine L3 and can't play Netflix in FullHD, for example.

    The Mi Box 3 (MDZ-16-AA) has an S905X as well and can play everything.

    Buy an original box with official Widevine and your box will play everything for many many years.
    OK my friend the version that I have working is prime video AOSP v3.0.294.10145

    you can try the following link it has newer versions but I think they should work
    To give credit to Aidan this version is also available there
    No problem but go to the link of Aidan its definitely there and let me know if you were successfull Cheers my friend
    Thanks Mattc! It worked perfectly! You are very kind to help us. Greetings!
    You are welcome my dear friend. But if anyone can help me with my problem regarding my being unable to access google servers I would be ver very grateful ; I am pulling my hair over this problem; latest thing I did was amend the host files again to no avail!!!
    Matt, I've seen what happens to you with the play sotre. That is very strange ... I do not understand much of the subject, I installed the version of Aidan because it is the only certified rom. When I entered the play store for the first time, it obviously asked me for my credentials and I accessed without problems and without the need to root. Could it be that you use VPN and that is causing problems? Honestly I would like to help you, but I can not think where the problem could be. I hope you can solve it as soon as possible or that Aidan gives you some instructions on how to solve it when he sees and responds to the post ... A hug!
    Which type of x96 air do you have ? 2GB RAM/16GB ROM ?
    Do you have the original build number of the box ? Before flashing the ROM
    @emiljano539, mine is 4/64 version. unfortunately i dont have the original build (messedup the rom so had to flash custom and recover - no backup of original) but know that X96Air_P2_20191017-1917 works (if i,m not wrong this is the build number)
  • 23
    to brighten.png

    Home Screen With Apps

    ^^^NEW Home Screen, Update From Play Store ^^^

    Preinstalled Apps

    Initial Set Up Screen

    Initial Set Up Screen 2


    New Google Dream X Included
    Screenshot_20201116-025413 - Copy.png

    Google Play Protect Certified

    Android TV Netflix! (Install Apk From Website)

    Aidan's Custom Android TV 9 ROM For S905X

    This is My Android 9.0 Firmware, This Is Based On The Official Mi Box Android TV 9.0 Firmware

    This Is A Firmware Port Of The Xiaomi Mi Box Firmware Designed To Run On Other Amlogic S905X Devices

    This Firmware Is FAST & STABLE

    WARNING: This Is Experimental & Requires Multiple Steps, Please Read About "Mask Rom Mode" To Know How To Recover Your Device If Installation Fails!
    This Has The New Amlogic Kernel And As Such Will Not Work On All S905X Devices, My Older Android 7 Based Firmware Works On Most Devices

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up

    NEW Website! Check it out & Download!
    >>>> Website Click Here <<<<

    v8 New Features (25.July.2021)
    BASED ON LATEST MI BOX Official Pie Build 3595
    Security Patch 5.March.2021
    Low Ram False All Roms
    Forceencrypt Disabled
    Default Volume MAX
    New Bootanimation
    More Debloating
    DPI Set At 320/213
    New Welcome (Thanks AcidIce18)
    No Remote Pair Screen
    More Cleaned & De Bloat
    More Tweaks...

    v7 New Features (29.April.2021)
    BASED ON LATEST MI BOX Official Pie Build 3409
    Security Patch 5.January.2021
    NEW Mygica ATV495x (maybe more) Version Available
    NEW F30UP (maybe more) Version Available
    Now Includes App Drawer (Non Tv Apps)
    Now Includes File Browser
    Now 11 Wi-Fi Versions Available
    Cleaned & De Bloat
    More Tweaks...

    v6 New Features (21.Jan.2021)
    Netflix TV Version (APK Provided)
    Stability Improved (Fixed Random Reboot Bug)
    Now 10 Wi-Fi Versions Available
    Cleaned Further & De Bloat
    More Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v5 New Features (08.Jan.2021)
    Universal Version Now Available
    More WIFI Chips supported
    Cleaned Further & De Bloat
    Now The Versions Are More Similar Than Ever
    Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burnig tool Image
    New Install Method Now 1 Step Install

    v1 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP

    Help & FAQ

    USB Burning Tool Cant See Device
    if usb burning tool cant detect your device, and youve tried other ports, cables ect then Mask ROM Mode May Be Needed, See Here
    Youtube Unbrick Guide

    Netflix wont work from play store
    The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, Patched Netflix Apk Now Available

    Amazon Prime Wont Work
    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Disney+ No Sound
    A. Fixed Earlier Release

    No Root
    There Is No Root In This Firmware Because This Is a User Build (Not User Debug)
    User Build: This Is Like The official Android Tv Devices (Like Mi Box), it does not have root or TWRP, Uses Release Keys and is SELINUX enforced
    This Makes More Apps Show Up In The Play Store that didn't show before, (Example: Isp Android TV live tv app, only shows in Play Store On non rooted and SELINUX enforced devices, also the streams in the app do not even play in rooted devices.) And other Apps With Similar Issues On Non Certified Devices....

    myCANAL App No Sound...
    See This Post

    [OLD] How To Install: [OLD]
    1) Download One Of The Base Firmwares That We Will Write Over (By Wi-Fi Chip If Possible But This Will Work Without Wi-Fi Using Ethernet)
    1.2) Download Reboot Revovery.zip & TWRP 3.3.1 AML By ViT
    1.3) Download One Of My Custom Mi Box Update Zip File
    1.4) Download USB Burning Tool (I Use v2.2.0 Download On My Website)
    2) Flash The Base Firmware Image Using USB Burn Tool,
    2.1) See If Wi-Fi & Bluetooth Seem To Work And Try The Other Version If Not
    3) Open The Update App And Choose Select, Choose Reboot To Recovery.zip & Chose Update & Update Again
    4) You Will Be Inside Recovery Now, Choose Update From EXT, And Choose (USB/SD Depending What You Use)
    5) Choose TWRP 3.3.1 .zip, This Will Boot Into TWRP, Slide The Screen To Accept (Mouse Needed) & Choose Install
    6) Flash My Custom Mi Box Update Zip File By WiFi Chip If Possible, If You Don't Have One Of These Chips You Will Have To Try The Versions & See Or Use Ethernet
    7) You Will Be Rebooted Automatically After Installation And Put Into The Stock Android Recovery
    8) Choose "Wipe/Factory Data Reset" Option Here, And Then Once Done Choose Reboot
    9) Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up
    10) Open Settings & Navigate To "Apps", Then Choose "See All Apps" Then "Show System Apps" Find The App "Chromecast Android Shell" And DISABLE It (Wont Work Without Widevine Level1 & slows device down)
    11 Disable "Movie Player" & Any Other Apps You Want To Hide
    12 Enjoy!


    Thanks DiogoSilva48

    Thanks for the reply and eagerly waiting for manual update. The existing rom is almost like stock one. Happy with it, and the manual update would enhance it further.

    I tried sideloading many .apk for prime video of different versions and both platforms - mobile and android tv. Even tried aptroid.tv app store with someone's suggestions on google.
    However, the mobile versions did not even install. And the TV versions though installed but returned with the same error. Only trailers are able to play. Main content isn't playing and the error "Something went wrong" shows up.

    If you could help me with any working apk for prime video, kindly provide. Just like the netflix you provided.

    Thank you so much in advance Aidan.
    hey v7 is now available, most are uploaded 2 still uploading :)
    3. [V6](Qualcomm QCA9377 & LTM8830)

    Wifi working perfectly fine on my 8189etv.
    Hello Timosat, as I understood I have to find ly remote file and then after several step sut this folder in aidans rom... Where to find the right remote folder for my box? I have the remote.conf from a previous rom can I use this file?
    I read that you use Atvx 4 rom to do this ? You choosed this rom because your remote works with this rom?
    It's a long process with patience. Your remote.conf file has to be renamed to remote.tab1 and use any good file explorer eg mixexplorer and transfer tthe remote file to vendor/etc folder .But before you do this make sure you are rooted. You may try and root Aidan's rom first by patching recovery.Partition method.And see if your remote will work. As for my case yes I use atvx4 rom because I've tried Aidan's rom my remote did not work. So I made (should I call it hybrid) rom.By taking system.PARTITION from Aidan's rom and substitute it in atvx4 and also patching atvx4 recovery.PARTITION with Magisk.Then I repacked and flashed to my box.