• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[v8] Aidan's ROM [S905X] [Android TV 9] [Netflix TV] [Disney+] [Google Play Certified] [ROOT]

Search This thread


Senior Member
Nov 19, 2011
Super long thread...trying to read from the end backwards...can someone please confirm my findings regarding the remote control? Am I understanding correctly that flashing this ROM will leave the box (such as Nexbox A95X) with the remote control inoperable? And in order to get the remote to function, one must root the device, then muck with remote.conf files?
your remote may or may not work in not entierly sure from memmory, android 9 no longer uses remote.comf files, other options are HDMI CEC, android tv remote app, a usb remote etc :)


Senior Member
Nov 19, 2011
Dear aidan

What do you think: i would like order MECOOL KM2 box. This box using Netflix 4k, but i need mouse version. So im use your modding mouse apk it will work with 1080p/4K? Or just the original version?
And where is the Android 10 Netflix mouse version apk? I dont find your site :(

Thank you
hi, so if you need to use the mouse version you should look for HD mods for netflix mobile app, thes should (did at one point at leat) provide HD on your widevine device wit hthe mouse UI, the apk is the same across android versions :)


Senior Member
Nov 19, 2011
Once I had a problem maybe similar, I couldn't use any stream services at all, the thing was that the isp that I got my service from for some incredible stupid reason that only their stupid engineers know black listed the NTP servers protocol from their network, so when I started my box it couldn't sync date and it always had like 5 years old date, the box couldn't ever be connected to any service at all.
what a dumb ISP :)
  • Like
Reactions: MarvinUQ


Senior Member
Nov 19, 2011
Thank you for this firmware. I have nexbox s905x 2G/16G. I installed twrp and libreelec 6-7 years ago and used it some months. After years I diged out this equipment and find 255 error when I restored data partition in twrp. I was not able to find any twrp compatible firmware for this device and I found this thread.
I installed 8.+[v8]+Aidan's+ROM+[S905X]+[ATV+9]+(Ampak+AP6330).img without problem and have been suprised the lack of any apps installed in it. I found youtube where is a link to fixed appplications and will use usb to install all.
The firmware does not work with my original remote control. Is it able to add this functionality ?
I use china small BT keyboard with touch pad instead and this is not fine because I do not have any possibility to return to previous menu entry. Escape key does not do it and I do not see any other key with this functionality.
(Should I change firmware to version 7 [v7.5] (Nexbox) Aidan's ROM [S905X] Nexbox a95x 1GB 2GB+.img ?)
Is possible to start working remote or simulate return key on keyboard ?

I migrated to TV7 and here ESC key works as return. It has to be a bug in TV9.
the del key on some roms does back. or right click in others :)


Senior Member
Nov 19, 2011
I install today this ROM on H96 PRO, works ok, i have wifi connection, works stably and fast.
Only the USB (wifi) mouse doesn't work propertly in app like youtube, yt kids, and the mouse also does not work when selecting keyboard buttons...
It posibble to shutdown device from menu or only from the remote control?
android TV is not designed for mouse operation whre as AOSP is, the UI hasnt been designed with mouse functionality in mind so many parts just don't click with a mouse :)


Senior Member
Nov 19, 2011
Unfortunately, I regularly had major problems with the WiFi on my A95X box , which meant that streaming wasn´t possible because no data was transmitted.
So I bought an original Mi Box S in the black friday deals and say goodbye to the forum. :)

Thanks again to Aidan, I had a lot of fun with your Custom Roms last year. :)
haha your a certified L1 man now! Glad your happy with an official box, less workariynds needed, Thanks for your suppoort! :)
  • Like
Reactions: Otzelot21


Nov 20, 2010
Xiaomi Mi 9
Minha A905x DE Air usa um wi-fi AI6356 então nenhuma das roms funciona wi-fi e Bluetooth. Este trocarte, um pois vários aplicativos originais não estavam funcionando.
Um outro detalhe é que eu não consigo achar a ROM Stock dela.


  • IMG_20211130_143951.jpg
    841.7 KB · Views: 16
  • IMG_20211130_144038.jpg
    1 MB · Views: 15
  • IMG_20211130_143947.jpg
    1 MB · Views: 14


Senior Member
Oct 24, 2016
Does this firmware allow the Mi Box to be always on like the Chromecast does? So that I can start my TV from my mobile.

The original firmware does not allow that because when the Mi Box is turned off it becomes unavailable to cast.


Jan 26, 2014
Last edited:
  • Like
Reactions: aidanmacgregor


Senior Member
Dec 25, 2009
Hi i need some help with my device.
I have T95X S905X. I tried flasing universal rtl rom (i have rtl8189etv wifi) but wifi is not working. And remote control buttons are messed up or not even working. Any help how can i fix this?

Thank you!

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Sometimes I have to hold the reset button in with a stick to make it connect to the computer for flashing, sometimes not. Too bad USB burning tool doesn't let you backup your old firmware, that would make things easy.

    There is a trick of momentarily shorting the NAND pins while connecting to the computer, I've done it successfully on a s905x (after flashing incompatible rom) but there's a chance it could break something.

    I have never had an s905x2 device,so I don't know what works or doesn't

    When you find a flashable zip file, take a look inside and if you see "bootloader.img" know that it can potentially brick your device if its not 100% compatible.
    The USB Burning Tool detects the box so shorting the NAND is not the issue. The problem is I get a "[0x00101004] Erase bootloader/Lowper/Identify/Error result" message about 25 seconds into the flashing process. This only happened when I flashed to this ATV ROM.

    The reset button in the ATV 495 series of MyGica boxes is built into the Power On/Off button.
    Normally if you want to get into the Android Recovery Menu for a SD Card firmware update you have to press on the Power On/Off button while you plug in the power. For UBT flashing I noticed you simply plug the USB cable without pressing anything and UBT will instantly recognize it, but if you plug the box's power adapter and then the USB cable you will not get it to connect to UBT.

    EDIT: Found a way to flash to another ROM once this [v7.5] (UNIVERSAL) Aidan's ROM [S905X] 1GB 2GB+.img is installed. Took me a couple hours to figure this out and I will leave it here as a reference for others with the same box.

    1. Open USB Burning Tool (I used v2.1.6) and load the new ROM you want to flash
    2. Do not plug in the power adapter to your box or it will not pair with the USB Burning Tool
    3. Plug the USB cable into the USB/OTG port located at the rear on the left hand side of the box (2nd USB port after the "micro SD" card slot)
    4. While pressing down on the Power On/Off button connect the USB cable to the PC until you hear it pair and it should start to flash automatically if not press Start, once it starts to flash you can let go of pressing the Power On/Off button
    5. While it is flashing plug in the power adapter to ensure it has enough power during the flash
    6. Wait about 5-1/2 minutes for it to finish flashing. Once the USB Burning Tool shows 100% : Burning successfully press Stop and unplug the USB cable from the PC.
    7. Unplug the power adapter and plug it in again to reboot the box and wait another 6 minutes for the new firmware to install itself.
    8. The new ROM has now been properly installed !
    BOX : MyGica ATV 495PRO HDR S905X-B 2GB/8GB with Ampak AP6255 WiFi module
    ROM: 12.+[v8]+Aidan's+ROM+[S905X]+[ATV+9]+(Mygica+ATV195x-ATV495-ATV598max-Maybe+More...).img

    1. WiFi connected after first reboot, but after a second reboot cannot connect to WiFi no matter how many tines I did a full reset
    2. Power button works when pressed stays blue for Stand-By(normally red) and blue for On
    3. Internal storage shows only 3.82GB out of 8GB
    4. System Update downloads, but fails to install after reboot to Android Recovery Menu
    5. IR remote function like Power On/Off don't work on the stock MyGica KR41 remote
    6. Bluetooth pairs and works
    Is it normal for System Update to fail to install after reboot to Android Recovery Menu ?
    From whose server is the ROM trying to update from, Google ?
    How can I disable this update from notification if the ROM cannot accept updates ?
    Tried these on my NEXBOX A95X-B7N 2G/8G (Amlogic S905X, RTL8723BS Wi-Fi) from 2016:
    • 1. [v8] Aidan's ROM [S905X] [ATV 9] (Universal RTL & BCM).img: No Wi-Fi
    • 2. [v8] Aidan's ROM [S905X] [ATV 9] (Realtek RTL & SSV).img: No Wi-Fi
    • 3. [v8] Aidan's ROM [S905X] [ATV 9] (RTL QCA9377 LTM8830).img: Working Wi-Fi, no Bluetooth, no IR remote control
    • 8. [v8] Aidan's ROM [S905X] [ATV 9] (Ampak AP6330).img: No Wi-Fi.

    Oh well.
    Hi Aidan. I installed your ROM for s905x with my wifi driver and it works fine. The only problem is the remote which doesn't work. I have the appropriate remote.tab1 file but I can't log in. Is there any way I can replace the remote.tab1 with my working one? Thank you.
    Have you tried using a USB keyboard?
  • 23
    to brighten.png

    Home Screen With Apps

    ^^^NEW Home Screen, Update From Play Store ^^^

    Preinstalled Apps

    Initial Set Up Screen

    Initial Set Up Screen 2


    New Google Dream X Included
    Screenshot_20201116-025413 - Copy.png

    Google Play Protect Certified

    Android TV Netflix! (Install Apk From Website)

    Aidan's Custom Android TV 9 ROM For S905X

    This is My Android 9.0 Firmware, This Is Based On The Official Mi Box Android TV 9.0 Firmware

    This Is A Firmware Port Of The Xiaomi Mi Box Firmware Designed To Run On Other Amlogic S905X Devices

    This Firmware Is FAST & STABLE

    WARNING: This Is Experimental & Requires Multiple Steps, Please Read About "Mask Rom Mode" To Know How To Recover Your Device If Installation Fails!
    This Has The New Amlogic Kernel And As Such Will Not Work On All S905X Devices, My Older Android 7 Based Firmware Works On Most Devices

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up

    NEW Website! Check it out & Download!
    >>>> Website Click Here <<<<

    v8 New Features (25.July.2021)
    BASED ON LATEST MI BOX Official Pie Build 3595
    Security Patch 5.March.2021
    Low Ram False All Roms
    Forceencrypt Disabled
    Default Volume MAX
    New Bootanimation
    More Debloating
    DPI Set At 320/213
    New Welcome (Thanks AcidIce18)
    No Remote Pair Screen
    More Cleaned & De Bloat
    More Tweaks...

    v7 New Features (29.April.2021)
    BASED ON LATEST MI BOX Official Pie Build 3409
    Security Patch 5.January.2021
    NEW Mygica ATV495x (maybe more) Version Available
    NEW F30UP (maybe more) Version Available
    Now Includes App Drawer (Non Tv Apps)
    Now Includes File Browser
    Now 11 Wi-Fi Versions Available
    Cleaned & De Bloat
    More Tweaks...

    v6 New Features (21.Jan.2021)
    Netflix TV Version (APK Provided)
    Stability Improved (Fixed Random Reboot Bug)
    Now 10 Wi-Fi Versions Available
    Cleaned Further & De Bloat
    More Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v5 New Features (08.Jan.2021)
    Universal Version Now Available
    More WIFI Chips supported
    Cleaned Further & De Bloat
    Now The Versions Are More Similar Than Ever
    Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burnig tool Image
    New Install Method Now 1 Step Install

    v1 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP

    Help & FAQ

    USB Burning Tool Cant See Device
    if usb burning tool cant detect your device, and youve tried other ports, cables ect then Mask ROM Mode May Be Needed, See Here
    Youtube Unbrick Guide

    Netflix wont work from play store
    The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, Patched Netflix Apk Now Available

    Amazon Prime Wont Work
    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Disney+ No Sound
    A. Fixed Earlier Release

    No Root
    There Is No Root In This Firmware Because This Is a User Build (Not User Debug)
    User Build: This Is Like The official Android Tv Devices (Like Mi Box), it does not have root or TWRP, Uses Release Keys and is SELINUX enforced
    This Makes More Apps Show Up In The Play Store that didn't show before, (Example: Isp Android TV live tv app, only shows in Play Store On non rooted and SELINUX enforced devices, also the streams in the app do not even play in rooted devices.) And other Apps With Similar Issues On Non Certified Devices....

    myCANAL App No Sound...
    See This Post

    [OLD] How To Install: [OLD]
    1) Download One Of The Base Firmwares That We Will Write Over (By Wi-Fi Chip If Possible But This Will Work Without Wi-Fi Using Ethernet)
    1.2) Download Reboot Revovery.zip & TWRP 3.3.1 AML By ViT
    1.3) Download One Of My Custom Mi Box Update Zip File
    1.4) Download USB Burning Tool (I Use v2.2.0 Download On My Website)
    2) Flash The Base Firmware Image Using USB Burn Tool,
    2.1) See If Wi-Fi & Bluetooth Seem To Work And Try The Other Version If Not
    3) Open The Update App And Choose Select, Choose Reboot To Recovery.zip & Chose Update & Update Again
    4) You Will Be Inside Recovery Now, Choose Update From EXT, And Choose (USB/SD Depending What You Use)
    5) Choose TWRP 3.3.1 .zip, This Will Boot Into TWRP, Slide The Screen To Accept (Mouse Needed) & Choose Install
    6) Flash My Custom Mi Box Update Zip File By WiFi Chip If Possible, If You Don't Have One Of These Chips You Will Have To Try The Versions & See Or Use Ethernet
    7) You Will Be Rebooted Automatically After Installation And Put Into The Stock Android Recovery
    8) Choose "Wipe/Factory Data Reset" Option Here, And Then Once Done Choose Reboot
    9) Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up
    10) Open Settings & Navigate To "Apps", Then Choose "See All Apps" Then "Show System Apps" Find The App "Chromecast Android Shell" And DISABLE It (Wont Work Without Widevine Level1 & slows device down)
    11 Disable "Movie Player" & Any Other Apps You Want To Hide
    12 Enjoy!


    Thanks DiogoSilva48

    Thanks for the reply and eagerly waiting for manual update. The existing rom is almost like stock one. Happy with it, and the manual update would enhance it further.

    I tried sideloading many .apk for prime video of different versions and both platforms - mobile and android tv. Even tried aptroid.tv app store with someone's suggestions on google.
    However, the mobile versions did not even install. And the TV versions though installed but returned with the same error. Only trailers are able to play. Main content isn't playing and the error "Something went wrong" shows up.

    If you could help me with any working apk for prime video, kindly provide. Just like the netflix you provided.

    Thank you so much in advance Aidan.
    hey v7 is now available, most are uploaded 2 still uploading :)
    Hello Timosat, as I understood I have to find ly remote file and then after several step sut this folder in aidans rom... Where to find the right remote folder for my box? I have the remote.conf from a previous rom can I use this file?
    I read that you use Atvx 4 rom to do this ? You choosed this rom because your remote works with this rom?
    It's a long process with patience. Your remote.conf file has to be renamed to remote.tab1 and use any good file explorer eg mixexplorer and transfer tthe remote file to vendor/etc folder .But before you do this make sure you are rooted. You may try and root Aidan's rom first by patching recovery.Partition method.And see if your remote will work. As for my case yes I use atvx4 rom because I've tried Aidan's rom my remote did not work. So I made (should I call it hybrid) rom.By taking system.PARTITION from Aidan's rom and substitute it in atvx4 and also patching atvx4 recovery.PARTITION with Magisk.Then I repacked and flashed to my box.
    3. [V6](Qualcomm QCA9377 & LTM8830)

    Wifi working perfectly fine on my 8189etv.