[v9] Aidan's ROM [S905X-S905W-S912-S905X2-S905Y2-S905X3-S905W4-S922] [Android TV 9] [Disney+] [Google Play Certified] [ROOT]

Search This thread


Senior Member
Nov 22, 2017
Actually, you can get any remote to work if you have root access:
  • Love
Reactions: aidanmacgregor


Dec 20, 2017
I have a "Beelink GT1 mini_a" with serial number B95X (not exactly as the Beelink GT1 mini with SN = S95X2), I have tried the 6 ROM:

1. no power LED, no internet (wired)
2. install failed
3. no power LED, no internet (wired)
4. install failed
5. no power LED, no internet (wired)
6. install failed

Any help on what goes wrong with this box ?

Wifi is working
Ethernet is not working
The LED is lit when the box is ON and unlit when the box is on
The box gets definitely hotter than with the previous ROM or CoreELEC
@aidanmacgregor Is there a chance that will be looked into, because this seems a pretty ROM ?


Senior Member
Apr 11, 2016
Xiaomi Mi A2 Lite
Nokia 5.4
Has anybody had any luck with EmuElec? With Aidan's Rom my box doesn't boot from SD. It was working with atvXperience v5 beta 1 (but the rom itself doesn't work as smooth as Aidan's). My box is Trongle S3 (so it's s905x with LTM8830 Wi Fi).


New member
Apr 28, 2019
Hi everyone, my name is Paolo and I apologize for the English, but I'm using Google translate. I have a Tanix T9 pro 3 / 32gb. I installed Aidan's firmware and it works perfectly. It rarely freezes, but it restarts by itself and resumes working, without problems. I saw that he asks me to do an update, which obviously does not work and restart the device as before, so here too no serious problems. Some lag using Netflix, Prime video or Disney + and in Spotify, but again nothing serious. I am very happy with this rom, the only thing I can not get it to work is the shutdown from the remote control, holding down the power button, I can only restart or take screenshots. Anyone show me a way to not have to brutally cut the power? Thank you


New member
Jan 6, 2022
HI Aidan,

I installed the ATV 9 version ROM on my X96S Android stick, seems working fine except the wifi.
I check the board and there is a rtl8723 wifi chip on it.
rtl8723 is supported in you ROM?

Thank you.

Hi Aidan,
I unpack the image using vtx_kitchen_v4 and I see the necessary drivers (8723bs.ko) under \vendor\lib\modules\ but I do not find any related firmware under \vendor\firmware.
I assume the missing firmware couse the issue.
Could you please check if the X96S image alle necessary files contain?


Jan 7, 2013
I have about ten S912 boxes I use for TV Viewing. They have all been rooted, have 7.12 Android, TWRP and Magisk installed. This was done several years back. I would like to install this ATV Rom as an upgrade to these. Will the current config I have mentioned above cause any issues or can I just follow the instructions with the USB Cable and move to ATV 9 from where I am? Thanks in advance for any clarification.....


New member
May 3, 2019
hi guys - i have this box
but on back sticker is written X96+, also seen this in Android device properties. Tried apk WiFi Chipset info for know which wifi chip is onboard - written only SHENZEN BILIAN Ltd.
Here in this review (this X96 mini looks like mine beside that X96+ difference in name)
is stated that wifi chip is RTL8189.
Is this ROM [v8] Aidan's ROM [S905W] [ATV 9] (RTL8189...) (x9 plus...).img right thing for my gizmo?


Nov 21, 2009
Hi all, I'm trying to install this rom :1.+[v8]+Aidan's+ROM+[S912]+[ATV+9]+[DDR3+&+DDR4]+[LAN1000]
in a T95Z plus S912 3Go+32Go but I'm always stuck at 2% with this error:

[14:22:37 801][Global][Inf]--USB_Burning_Tool soft Version: VUSB_Burning_Tool_V2.2.4
[14:22:37 801][Global][Inf]--Windows Version: Microsoft Windows 10, Bit: 64
[14:22:37 802][Global][Inf]--Scan usb device
[14:22:37 802][Global][Inf]--Aml scan WorldCup Device
[14:22:37 806][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:22:37 806][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:22:37 806][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:22:37 806][Global][Inf]-------->[Port0]NoDeviceConnected
[14:22:37 817][Global][Inf]-------->[Port1]Other device
[14:22:37 817][Global][Inf]-------->[Port2]NoDeviceConnected
[14:22:37 817][Global][Inf]-------->[Port3]NoDeviceConnected
[14:22:37 817][Global][Inf]-------->[Port4]NoDeviceConnected
[14:22:37 817][Global][Inf]-------->[Port5]NoDeviceConnected
[14:22:37 817][Global][Inf]-------->[Port6]Other device
[14:22:37 817][Global][Inf]-------->[Port7]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port8]Other device
[14:22:37 818][Global][Inf]-------->[Port9]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port10]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port11]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port12]Other device
[14:22:37 818][Global][Inf]-------->[Port13]Other device
[14:22:37 818][Global][Inf]-------->[Port14]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port15]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port16]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port17]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port18]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port19]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port20]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port21]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port22]NoDeviceConnected
[14:22:37 818][Global][Inf]-------->[Port23]NoDeviceConnected
[14:22:37 819][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:22:37 819][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:22:38 095][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:22:38 095][Global][Inf]-------->[Port0]NoDeviceConnected
[14:22:38 095][Global][Inf]-------->[Port1]NoDeviceConnected
[14:22:38 095][Global][Inf]-------->[Port2]NoDeviceConnected
[14:22:38 095][Global][Inf]-------->[Port3]NoDeviceConnected
[14:22:38 095][Global][Inf]-------->[Port4]NoDeviceConnected
[14:22:38 095][Global][Inf]-------->[Port5]NoDeviceConnected
[14:22:38 095][Global][Inf]--Scan USB host controller complete
[14:22:38 095][Global][Inf]--Update data center with HubMap
[14:22:38 095][Global][Inf]--Scan end
[14:27:01 697][Global][Inf]--Catch DBT_DEVICEARRIVAL
[14:27:01 697][Global][Inf]--Scan usb device
[14:27:01 697][Global][Inf]--Aml scan WorldCup Device
[14:27:01 698][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:27:01 698][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:27:01 698][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:27:01 698][Global][Inf]-------->[Port0]NoDeviceConnected
[14:27:01 699][Global][Inf]-------->[Port1]Other device
[14:27:01 699][Global][Inf]-------->[Port2]\\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:27:01 699][Global][Inf]-------->[Port3]NoDeviceConnected
[14:27:01 699][Global][Inf]-------->[Port4]NoDeviceConnected
[14:27:01 700][Global][Inf]-------->[Port5]NoDeviceConnected
[14:27:01 700][Global][Inf]-------->[Port6]Other device
[14:27:01 700][Global][Inf]-------->[Port7]NoDeviceConnected
[14:27:01 701][Global][Inf]-------->[Port8]Other device
[14:27:01 701][Global][Inf]-------->[Port9]NoDeviceConnected
[14:27:01 701][Global][Inf]-------->[Port10]NoDeviceConnected
[14:27:01 701][Global][Inf]-------->[Port11]NoDeviceConnected
[14:27:01 701][Global][Inf]-------->[Port12]Other device
[14:27:01 702][Global][Inf]-------->[Port13]Other device
[14:27:01 702][Global][Inf]-------->[Port14]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port15]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port16]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port17]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port18]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port19]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port20]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port21]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port22]NoDeviceConnected
[14:27:01 702][Global][Inf]-------->[Port23]NoDeviceConnected
[14:27:01 703][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:27:01 703][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:27:01 987][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:27:01 987][Global][Inf]-------->[Port0]NoDeviceConnected
[14:27:01 987][Global][Inf]-------->[Port1]NoDeviceConnected
[14:27:01 987][Global][Inf]-------->[Port2]NoDeviceConnected
[14:27:01 987][Global][Inf]-------->[Port3]NoDeviceConnected
[14:27:01 987][Global][Inf]-------->[Port4]NoDeviceConnected
[14:27:01 987][Global][Inf]-------->[Port5]NoDeviceConnected
[14:27:01 987][Global][Inf]--Scan USB host controller complete
[14:27:01 987][Global][Inf]--Update data center with HubMap
[14:27:01 987][Global][Inf]--Insert new hub1
[14:27:01 987][Global][Inf]--Update hub1 device data
[14:27:01 987][Global][Inf]--Update HUB1-1
[14:27:01 987][Global][Inf]--Update HUB1-2
[14:27:01 987][Global][Inf]--Update HUB1-3 \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:27:01 988][Global][Inf]--Begin thread for HUB1-3
[14:27:01 988][Global][Inf]--Update HUB1-4
[14:27:01 988][Global][Inf]--Update HUB1-5
[14:27:01 988][Global][Inf]--Update HUB1-6
[14:27:01 988][Global][Inf]--Update HUB1-7
[14:27:01 988][Global][Inf]--Update HUB1-8
[14:27:01 988][Global][Inf]--Burning thread HUB1-3 start
[14:27:01 988][Global][Inf]--Update HUB1-9
[14:27:01 988][Global][Inf]--Burning thread HUB1-3 begin run
[14:27:01 988][Global][Inf]--Update HUB1-10
[14:27:01 988][Global][Inf]--Update HUB1-11
[14:27:01 988][Global][Inf]--Update HUB1-12
[14:27:01 988][Global][Inf]--Update HUB1-13
[14:27:01 988][Global][Inf]--Update HUB1-14
[14:27:01 988][Global][Inf]--Update HUB1-15
[14:27:01 988][Global][Inf]--Update HUB1-16
[14:27:01 988][Global][Inf]--Update HUB1-17
[14:27:01 988][Global][Inf]--Update HUB1-18
[14:27:01 988][Global][Inf]--Update HUB1-19
[14:27:01 988][Global][Inf]--Update HUB1-20
[14:27:01 988][Global][Inf]--Update HUB1-21
[14:27:01 988][Global][Inf]--Update HUB1-22
[14:27:01 988][Global][Inf]--Update HUB1-23
[14:27:01 988][Global][Inf]--Update HUB1-24
[14:27:01 988][Global][Inf]--Add Hub1: \\.\USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8} to m_HubDeviceDataVector
[14:27:01 988][Global][Inf]--Scan end
[14:27:06 600][Global][Inf]--User click open button
[14:27:14 954][Global][Inf]--Image path C:\Users\coron\Downloads\3.+[v8]+Aidan's+ROM+[S912]+[ATV+9]+[DDR792]+[LAN1000]+(qca9377)+(H96+Pro+Plus...).img
[14:27:14 954][Global][Inf]--OpenImg C:\Users\coron\Downloads\3.+[v8]+Aidan's+ROM+[S912]+[ATV+9]+[DDR792]+[LAN1000]+(qca9377)+(H96+Pro+Plus...).img
[14:27:18 468][Global][Inf]--check img crc success!
[14:27:18 469]Parse platform.conf
[14:27:18 472][Global][Inf]--Parsing burning package
[14:27:18 472][Global][Inf]--Load configuration file C:\Amlogic\USB_Burning_Tool\temp
[14:27:18 472][Global][Inf]--Parse burning configuration file C:\Amlogic\USB_Burning_Tool\temp\burn_config.xml
[14:27:18 478][Global][Inf]--Get burning key
[14:27:52 101][Global][Inf]--Catch DBT_DEVICEREMOVECOMPLETE
[14:27:52 102][Global][Inf]--Scan usb device
[14:27:52 102][Global][Inf]--Aml scan WorldCup Device
[14:27:52 102][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:27:52 102][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:27:52 102][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:27:52 102][Global][Inf]-------->[Port0]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port1]Other device
[14:27:52 103][Global][Inf]-------->[Port2]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port3]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port4]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port5]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port6]Other device
[14:27:52 103][Global][Inf]-------->[Port7]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port8]Other device
[14:27:52 103][Global][Inf]-------->[Port9]NoDeviceConnected
[14:27:52 103][Global][Inf]-------->[Port10]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port11]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port12]Other device
[14:27:52 104][Global][Inf]-------->[Port13]Other device
[14:27:52 104][Global][Inf]-------->[Port14]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port15]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port16]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port17]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port18]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port19]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port20]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port21]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port22]NoDeviceConnected
[14:27:52 104][Global][Inf]-------->[Port23]NoDeviceConnected
[14:27:52 105][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:27:52 105][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:27:52 393][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:27:52 393][Global][Inf]-------->[Port0]NoDeviceConnected
[14:27:52 393][Global][Inf]-------->[Port1]NoDeviceConnected
[14:27:52 393][Global][Inf]-------->[Port2]NoDeviceConnected
[14:27:52 393][Global][Inf]-------->[Port3]NoDeviceConnected
[14:27:52 393][Global][Inf]-------->[Port4]NoDeviceConnected
[14:27:52 393][Global][Inf]-------->[Port5]NoDeviceConnected
[14:27:52 393][Global][Inf]--Scan USB host controller complete
[14:27:52 393][Global][Inf]--Update data center with HubMap
[14:27:52 393][Global][Inf]--Update hub1 device data
[14:27:52 393][Global][Inf]--Update HUB1-1
[14:27:52 393][Global][Inf]--Update HUB1-2
[14:27:52 393][Global][Inf]--Update HUB1-3
[14:27:52 393][Global][Inf]--Update HUB1-4
[14:27:52 393][Global][Inf]--Update HUB1-5
[14:27:52 393][Global][Inf]--Update HUB1-6
[14:27:52 393][Global][Inf]--Update HUB1-7
[14:27:52 393][Global][Inf]--Update HUB1-8
[14:27:52 393][Global][Inf]--Update HUB1-9
[14:27:52 393][Global][Inf]--Update HUB1-10
[14:27:52 393][Global][Inf]--Update HUB1-11
[14:27:52 393][Global][Inf]--Update HUB1-12
[14:27:52 393][Global][Inf]--Update HUB1-13
[14:27:52 393][Global][Inf]--Update HUB1-14
[14:27:52 393][Global][Inf]--Update HUB1-15
[14:27:52 393][Global][Inf]--Update HUB1-16
[14:27:52 393][Global][Inf]--Update HUB1-17
[14:27:52 393][Global][Inf]--Update HUB1-18
[14:27:52 393][Global][Inf]--Update HUB1-19
[14:27:52 393][Global][Inf]--Update HUB1-20
[14:27:52 393][Global][Inf]--Update HUB1-21
[14:27:52 393][Global][Inf]--Update HUB1-22
[14:27:52 393][Global][Inf]--Update HUB1-23
[14:27:52 393][Global][Inf]--Update HUB1-24
[14:27:52 393][Global][Inf]--Scan end
[14:28:23 319][Global][Inf]--Catch DBT_DEVICEARRIVAL
[14:28:23 320][Global][Inf]--Scan usb device
[14:28:23 320][Global][Inf]--Aml scan WorldCup Device
[14:28:23 321][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:23 321][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:23 321][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:23 321][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:23 322][Global][Inf]-------->[Port1]Other device
[14:28:23 323][Global][Inf]-------->[Port2]\\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:23 323][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:23 323][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:23 323][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:23 324][Global][Inf]-------->[Port6]Other device
[14:28:23 324][Global][Inf]-------->[Port7]NoDeviceConnected
[14:28:23 326][Global][Inf]-------->[Port8]Other device
[14:28:23 326][Global][Inf]-------->[Port9]NoDeviceConnected
[14:28:23 326][Global][Inf]-------->[Port10]NoDeviceConnected
[14:28:23 326][Global][Inf]-------->[Port11]NoDeviceConnected
[14:28:23 327][Global][Inf]-------->[Port12]Other device
[14:28:23 328][Global][Inf]-------->[Port13]Other device
[14:28:23 328][Global][Inf]-------->[Port14]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port15]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port16]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port17]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port18]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port19]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port20]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port21]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port22]NoDeviceConnected
[14:28:23 328][Global][Inf]-------->[Port23]NoDeviceConnected
[14:28:23 328][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:23 328][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:23 612][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:23 612][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:23 612][Global][Inf]-------->[Port1]NoDeviceConnected
[14:28:23 612][Global][Inf]-------->[Port2]NoDeviceConnected
[14:28:23 612][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:23 612][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:23 612][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:23 612][Global][Inf]--Scan USB host controller complete
[14:28:23 612][Global][Inf]--Update data center with HubMap
[14:28:23 612][Global][Inf]--Update hub1 device data
[14:28:23 612][Global][Inf]--Update HUB1-1
[14:28:23 612][Global][Inf]--Update HUB1-2
[14:28:23 612][Global][Inf]--Update HUB1-3 \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:23 612][Global][Inf]--Update HUB1-4
[14:28:23 612][Global][Inf]--Update HUB1-5
[14:28:23 612][Global][Inf]--Update HUB1-6
[14:28:23 612][Global][Inf]--Update HUB1-7
[14:28:23 612][Global][Inf]--Update HUB1-8
[14:28:23 612][Global][Inf]--Update HUB1-9
[14:28:23 612][Global][Inf]--Update HUB1-10
[14:28:23 612][Global][Inf]--Update HUB1-11
[14:28:23 612][Global][Inf]--Update HUB1-12
[14:28:23 612][Global][Inf]--Update HUB1-13
[14:28:23 612][Global][Inf]--Update HUB1-14
[14:28:23 612][Global][Inf]--Update HUB1-15
[14:28:23 612][Global][Inf]--Update HUB1-16
[14:28:23 612][Global][Inf]--Update HUB1-17
[14:28:23 612][Global][Inf]--Update HUB1-18
[14:28:23 612][Global][Inf]--Update HUB1-19
[14:28:23 612][Global][Inf]--Update HUB1-20
[14:28:23 612][Global][Inf]--Update HUB1-21
[14:28:23 612][Global][Inf]--Update HUB1-22
[14:28:23 612][Global][Inf]--Update HUB1-23
[14:28:23 612][Global][Inf]--Update HUB1-24
[14:28:23 612][Global][Inf]--Scan end
[14:28:26 615][Global][Inf]--User click start button
[14:28:26 615][Global][Inf]--SetErase Bootloader 1, Flash1
[14:28:26 617][Global][Inf]--Enable burning 1
[14:28:26 617][Global][Inf]--Scan usb device
[14:28:26 617][Global][Inf]--Aml scan WorldCup Device
[14:28:26 617][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:26 617][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:26 617][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:26 617][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port1]Other device
[14:28:26 618][Global][Inf]-------->[Port2]\\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:26 618][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port6]Other device
[14:28:26 618][Global][Inf]-------->[Port7]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port8]Other device
[14:28:26 618][Global][Inf]-------->[Port9]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port10]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port11]NoDeviceConnected
[14:28:26 618][Global][Inf]-------->[Port12]Other device
[14:28:26 619][Global][Inf]-------->[Port13]Other device
[14:28:26 619][Global][Inf]-------->[Port14]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port15]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port16]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port17]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port18]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port19]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port20]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port21]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port22]NoDeviceConnected
[14:28:26 619][Global][Inf]-------->[Port23]NoDeviceConnected
[14:28:26 619][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:26 619][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:26 621][HUB1-3][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x00000950
[14:28:26 667][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:26 667][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:26 667][Global][Inf]-------->[Port1]NoDeviceConnected
[14:28:26 667][Global][Inf]-------->[Port2]NoDeviceConnected
[14:28:26 667][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:26 667][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:26 667][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:26 667][Global][Inf]--Scan USB host controller complete
[14:28:26 667][Global][Inf]--Update data center with HubMap
[14:28:26 667][Global][Inf]--Update hub1 device data
[14:28:26 667][Global][Inf]--Update HUB1-1
[14:28:26 667][Global][Inf]--Update HUB1-2
[14:28:26 667][Global][Inf]--Update HUB1-3 \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:26 683][HUB1-3][Inf]--CloneImageProxy
[14:28:26 683][Global][Inf]--Update HUB1-4
[14:28:26 683][Global][Inf]--Update HUB1-5
[14:28:26 683][Global][Inf]--Update HUB1-6
[14:28:26 683][Global][Inf]--Update HUB1-7
[14:28:26 683][Global][Inf]--Update HUB1-8
[14:28:26 683][Global][Inf]--Update HUB1-9
[14:28:26 683][Global][Inf]--OpenImg C:\Users\coron\Downloads\3.+[v8]+Aidan's+ROM+[S912]+[ATV+9]+[DDR792]+[LAN1000]+(qca9377)+(H96+Pro+Plus...).img
[14:28:26 683][Global][Inf]--Update HUB1-10
[14:28:26 683][Global][Inf]--Update HUB1-11
[14:28:26 683][Global][Inf]--Update HUB1-12
[14:28:26 683][Global][Inf]--Update HUB1-13
[14:28:26 683][Global][Inf]--Update HUB1-14
[14:28:26 683][Global][Inf]--Update HUB1-15
[14:28:26 683][Global][Inf]--Update HUB1-16
[14:28:26 683][Global][Inf]--Update HUB1-17
[14:28:26 683][Global][Inf]--Update HUB1-18
[14:28:26 683][Global][Inf]--Update HUB1-19
[14:28:26 683][Global][Inf]--Update HUB1-20
[14:28:26 683][Global][Inf]--Update HUB1-21
[14:28:26 683][Global][Inf]--Update HUB1-22
[14:28:26 683][Global][Inf]--Update HUB1-23
[14:28:26 683][Global][Inf]--Update HUB1-24
[14:28:26 683][Global][Inf]--Scan end
[14:28:26 683][HUB1-3][Inf]--Connect path=Contrôleur d’hôte compatible xHCI USB/P0/P2
[14:28:26 683][HUB1-3][Inf]--Start burning...
[14:28:26 746][HUB1-3][Inf]--------------ERASE BOOTLOADER------------
[14:28:26 855][HUB1-3][Inf]--0-7-0-16
[14:28:26 855][HUB1-3][Inf]--Identify status success
[14:28:26 855][HUB1-3][Inf]-- low_power
[14:28:26 860][HUB1-3][Inf]--Low power command success
[14:28:26 864][HUB1-3][Inf]--Read low power success
[14:28:26 864][HUB1-3][Inf]--bootloader_is_old
[14:28:26 864][HUB1-3][Inf]--Bootloader command success
[14:28:26 867][HUB1-3][Inf]--Bootloader is old
[14:28:26 867][HUB1-3][Inf]--erase_bootloader
[14:28:26 867][HUB1-3][Inf]--Erase command success
[14:28:26 871][HUB1-3][Inf]--Read erase status success
[14:28:26 871][HUB1-3][Inf]--reset
[14:28:26 871][HUB1-3][Inf]--reset command success
[14:28:26 871][HUB1-3][Inf]--CheckDevRemoved start
[14:28:27 887][Global][Inf]--Catch DBT_DEVICEREMOVECOMPLETE
[14:28:27 887][Global][Inf]--Scan usb device
[14:28:27 887][Global][Inf]--Aml scan WorldCup Device
[14:28:27 888][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:27 889][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:27 889][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:27 889][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:27 889][Global][Inf]-------->[Port1]Other device
[14:28:27 889][Global][Inf]-------->[Port2]NoDeviceConnected
[14:28:27 889][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:27 889][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:27 889][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:27 890][Global][Inf]-------->[Port6]Other device
[14:28:27 890][Global][Inf]-------->[Port7]NoDeviceConnected
[14:28:27 890][Global][Inf]-------->[Port8]Other device
[14:28:27 890][Global][Inf]-------->[Port9]NoDeviceConnected
[14:28:27 890][Global][Inf]-------->[Port10]NoDeviceConnected
[14:28:27 890][Global][Inf]-------->[Port11]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port12]Other device
[14:28:27 891][Global][Inf]-------->[Port13]Other device
[14:28:27 891][Global][Inf]-------->[Port14]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port15]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port16]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port17]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port18]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port19]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port20]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port21]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port22]NoDeviceConnected
[14:28:27 891][Global][Inf]-------->[Port23]NoDeviceConnected
[14:28:27 892][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:27 892][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:27 892][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:27 892][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:27 892][Global][Inf]-------->[Port1]NoDeviceConnected
[14:28:27 892][Global][Inf]-------->[Port2]NoDeviceConnected
[14:28:27 892][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:27 892][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:27 892][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:27 892][Global][Inf]--Scan USB host controller complete
[14:28:27 892][Global][Inf]--Update data center with HubMap
[14:28:27 892][Global][Inf]--Update hub1 device data
[14:28:27 892][Global][Inf]--Update HUB1-1
[14:28:27 892][Global][Inf]--Update HUB1-2
[14:28:27 892][Global][Inf]--Update HUB1-3
[14:28:27 892][Global][Inf]--Update HUB1-4
[14:28:27 892][Global][Inf]--Update HUB1-5
[14:28:27 892][Global][Inf]--Update HUB1-6
[14:28:27 892][Global][Inf]--Update HUB1-7
[14:28:27 892][Global][Inf]--Update HUB1-8
[14:28:27 892][Global][Inf]--Update HUB1-9
[14:28:27 892][Global][Inf]--Update HUB1-10
[14:28:27 892][Global][Inf]--Update HUB1-11
[14:28:27 892][Global][Inf]--Update HUB1-12
[14:28:27 892][Global][Inf]--Update HUB1-13
[14:28:27 892][Global][Inf]--Update HUB1-14
[14:28:27 893][Global][Inf]--Update HUB1-15
[14:28:27 893][Global][Inf]--Update HUB1-16
[14:28:27 893][Global][Inf]--Update HUB1-17
[14:28:27 893][Global][Inf]--Update HUB1-18
[14:28:27 893][Global][Inf]--Update HUB1-19
[14:28:27 893][Global][Inf]--Update HUB1-20
[14:28:27 893][Global][Inf]--Update HUB1-21
[14:28:27 893][Global][Inf]--Update HUB1-22
[14:28:27 893][Global][Inf]--Update HUB1-23
[14:28:27 893][Global][Inf]--Update HUB1-24
[14:28:27 893][Global][Inf]--Scan end
[14:28:27 947][HUB1-3][Inf]--Device is removed
[14:28:27 947][HUB1-3][Inf]--CheckDevRemoved end
[14:28:27 947][HUB1-3][Inf]--CheckDevConnected start
[14:28:29 347][Global][Inf]--Catch DBT_DEVICEARRIVAL
[14:28:29 347][Global][Inf]--Scan usb device
[14:28:29 347][Global][Inf]--Aml scan WorldCup Device
[14:28:29 348][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:29 348][Global][Inf]--DevPath:\\?\pci#ven_8086&dev_a36d&subsys_12721462&rev_10#3&11583659&0&a0#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:29 348][Global][Inf]---->Roothub:USB#ROOT_HUB30#4&309b3f4b&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:29 348][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:29 349][Global][Inf]-------->[Port1]Other device
[14:28:29 349][Global][Inf]-------->[Port2]\\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:29 349][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:29 349][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:29 349][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:29 350][Global][Inf]-------->[Port6]Other device
[14:28:29 350][Global][Inf]-------->[Port7]NoDeviceConnected
[14:28:29 350][Global][Inf]-------->[Port8]Other device
[14:28:29 350][Global][Inf]-------->[Port9]NoDeviceConnected
[14:28:29 350][Global][Inf]-------->[Port10]NoDeviceConnected
[14:28:29 350][Global][Inf]-------->[Port11]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port12]Other device
[14:28:29 351][Global][Inf]-------->[Port13]Other device
[14:28:29 351][Global][Inf]-------->[Port14]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port15]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port16]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port17]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port18]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port19]NoDeviceConnected
[14:28:29 351][Global][Inf]-------->[Port20]NoDeviceConnected
[14:28:29 352][Global][Inf]-------->[Port21]NoDeviceConnected
[14:28:29 352][Global][Inf]-------->[Port22]NoDeviceConnected
[14:28:29 352][Global][Inf]-------->[Port23]NoDeviceConnected
[14:28:29 352][Global][Inf]--Host: Contrôleur d’hôte compatible xHCI USB
[14:28:29 352][Global][Inf]--DevPath:\\?\pci#ven_10de&dev_1aec&subsys_12721462&rev_a1#4&39ad1466&0&0208#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
[14:28:29 392][Global][Inf]---->Roothub:USB#ROOT_HUB30#5&275909a9&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
[14:28:29 392][Global][Inf]-------->[Port0]NoDeviceConnected
[14:28:29 392][Global][Inf]-------->[Port1]NoDeviceConnected
[14:28:29 392][Global][Inf]-------->[Port2]NoDeviceConnected
[14:28:29 392][Global][Inf]-------->[Port3]NoDeviceConnected
[14:28:29 392][Global][Inf]-------->[Port4]NoDeviceConnected
[14:28:29 392][Global][Inf]-------->[Port5]NoDeviceConnected
[14:28:29 392][Global][Inf]--Scan USB host controller complete
[14:28:29 392][Global][Inf]--Update data center with HubMap
[14:28:29 392][Global][Inf]--Update hub1 device data
[14:28:29 392][Global][Inf]--Update HUB1-1
[14:28:29 392][Global][Inf]--Update HUB1-2
[14:28:29 392][Global][Inf]--Update HUB1-3 \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
[14:28:29 392][Global][Inf]--Update HUB1-4
[14:28:29 392][Global][Inf]--Update HUB1-5
[14:28:29 392][Global][Inf]--Update HUB1-6
[14:28:29 392][Global][Inf]--Update HUB1-7
[14:28:29 392][Global][Inf]--Update HUB1-8
[14:28:29 392][Global][Inf]--Update HUB1-9
[14:28:29 392][Global][Inf]--Update HUB1-10
[14:28:29 392][Global][Inf]--Update HUB1-11
[14:28:29 392][Global][Inf]--Update HUB1-12
[14:28:29 392][Global][Inf]--Update HUB1-13
[14:28:29 392][Global][Inf]--Update HUB1-14
[14:28:29 392][Global][Inf]--Update HUB1-15
[14:28:29 392][Global][Inf]--Update HUB1-16
[14:28:29 392][Global][Inf]--Update HUB1-17
[14:28:29 392][Global][Inf]--Update HUB1-18
[14:28:29 392][Global][Inf]--Update HUB1-19
[14:28:29 392][Global][Inf]--Update HUB1-20
[14:28:29 392][Global][Inf]--Update HUB1-21
[14:28:29 392][Global][Inf]--Update HUB1-22
[14:28:29 392][Global][Inf]--Update HUB1-23
[14:28:29 392][Global][Inf]--Update HUB1-24
[14:28:29 392][Global][Inf]--Scan end
[14:28:29 439][HUB1-3][Inf]--Device is connected
[14:28:29 439][HUB1-3][Inf]--CheckDevConnected end
[14:28:29 439][HUB1-3][Inf]--Close device handle 0x00000950
[14:28:29 502][HUB1-3][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&1345566e&0&3#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x00000ccc
[14:28:29 563][HUB1-3][Inf]-------------Download DDR.USB-----------
[14:28:29 563][HUB1-3][Inf]--2-2-0-0-0-1-0-0
[14:28:29 564][HUB1-3][Inf]--Control write pll reg1 0xd9000000:0x000000b1
[14:28:30 080][HUB1-3][Inf]--Control write pll reg1 0xd9000000:0x00005183
[14:28:30 594][HUB1-3][Inf]--Write initial succeed
[14:28:30 594][HUB1-3][Inf]--Upload encrypt at 0xc8100228
[14:28:30 596][HUB1-3][Inf]--chipid= 0x0ac02d39be9e4842db1013d0, ulValue = 0xadfc318c
[14:28:30 596][HUB1-3][Inf]--Read encrypt value succeed
[14:28:30 596][HUB1-3][Inf]--Download DDR.USB,size: 49152!
[14:28:30 604][HUB1-3][Inf]--Transfer complete 49152
[14:28:30 605][HUB1-3][Inf]--Run at address 0xd9000000
[14:28:30 605][HUB1-3][Inf]--RunInRam success
[14:28:30 627][HUB1-3][Inf]--2-2-0-8-0-1-0-0
[14:28:30 627][HUB1-3][Inf]--Identify return 5
[14:28:30 627][HUB1-3][Inf]--CheckFileRunState return 8
[14:28:30 627][HUB1-3][Inf]--Run at address 0xd900c000
[14:28:30 627][HUB1-3][Inf]--RunInRam succeed
[14:28:45 640][HUB1-3][Err]--ReadLargeMemCMD failed ret = -116
[14:28:45 640][HUB1-3][Err]--ReadPara failed
[14:28:45 646][HUB1-3][Err]--[0x10105002]Romcode/???DDR/???????/USB??????
[14:28:45 646][HUB1-3][Inf]--Close device handle 0x00000ccc

Do you know what i'm doing wrong?


Senior Member
Jun 19, 2010
London, UK
I installed v8 on my Alfawise H96 Pro+ (S912) , it boots ok, wifi and ethernet seem to be working, mouse is working,, but I cannot access the onscreen keyboard. Gboard appears, I click, and nothing happens. I installed AOSP keyboard, and it doesn't even appear. I'm stumped... and it's a pity :|


Senior Member
Oct 15, 2011
on mecool m8s pro l (912) broadcom one, i flashed the rom and won't go past the androidtv with line under going left to right. I found an old nexus firmware and flashed that and it booted. the wifi won't accept a password but the bluetooth works, so i think that means the lb is the right software. it may be the driver is too old for more modern wifi. everything else works. should i try to flash again with your firmware. i am using the broadcom variant for this model. since i now have twrp from what i just installed is there any easy way to flash your from that recovery ?
Last edited:


Senior Member
Oct 15, 2011

Just finished attempting install on my other box mecool m8s pro +, that one worked. I
used universal for 905x. Rom is quite nice, Thank you. At first boot it prompts for system upgrade, i presume that is from mi box, so i declined it. Is this the correct action or should i install that. The wifi does not work, but thats expected it did not work on coreelec either and i remember there was nothing from realtek beyond the one kernel. Box has no bluetooth. everything else good, except i am having issue with sound on eac3 codec in plex. nothing plays. i tried every sound option and in sound settings, if you set to manual on codecs it does not show any codecs. even under pcm no sound only on that codec. nothing in plex settings corrects either. my setup is hdmi to tv, tv out to sound bar, but even without soundbar just to tv, still no sound on that codec. I have emby which does local downmix and that works ok. Maybe this helps when it comes time for next release. Thank you for the Rom.
Last edited:
  • Love
Reactions: aidanmacgregor


Aug 22, 2013
I do use wifi connection, and i did find t95q version rom image on his file host. But then again, i found out that there is actually 2 difference version of T95Q wifi chip. I think mine is the older revision, i wanted to make sure the rom works for older revision or not..
Hi, i have a T95q with old wifi version too, did the rom "2.+[v8]+Aidan's+ROM+[s905x2]+(T95Q)[email protected]" work for you?

Remove Control?
Can you turn on?
the light turned off?

And about the stock rom, yes it already exist, i have been flashed my t95q with alot of roms and returned back to stock
  • Love
Reactions: aidanmacgregor


New member
Feb 26, 2012


I've manage to flash my MINI M8S II using aidam custom rom. The only problem is intermittent wifi.

So i decide to flash it back to stock rom but i kept bricking the device. I only have luck if i re-flash it back using any aidan S90X rom but eveytime i try flashing to stock rom or other dev custom rom, it will brick my device.

i did a test by flashing my other identical device with different custom rom, and i able to rollback to stock. Only problem is that if i flash using aidan rom, i unable to rollback to stock rom.

Here is the problem i facing.

*Mini M8S II S90X (Currently on Aidan ATV 9)
- Flash back to Stock Rom : Brick
-Mask rom and flash back to Aidan ATV 9 : Successful
- Flash again using other developer custom rom : Brick
-Mask rom again and flash back to Aidan ATV 7 : Successful.

If anyone can tell me other way around this. Appreciate it.


Senior Member
Oct 15, 2011
@aidanmacgregor is there anyway to flash your rom for 912 - mecool pro L via twrp ? i tried again with rom burning tool and the image fails early with an error about ddr. i can though flash the megadanz nexus. but that is only one i can flash and run. that has twrp built in as recovery. so i am wondering if there is a way i can take you img file and get it to an upgrade type zip, or anything else i can do to get beyond very intitial step in the amlogic burn disc flashing program ?

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I did the same thing just like you said. but when I type " reboot update " the USB_Burning_Tool didn't start flashing and the tv box booted to Recovery as attached pic
    Ok just to be sure everything is correct. Open the usb burning tool program, select the rom to flash and mark only the erease flash options, erease bootloader and press start. Turn on the tv box and connect it to the pc, the program will still not detect it, now on the cell phone connect to adb and write reboot uptade, the tv box will restart and the program should detect it and start the installation, if that does not happen try with different usb ports of the pc and the tv box

    When activating the usb debugging sometimes some ports of the tv box stop working, so try with everyone by doing all the previous steps again
    Can u explain what's mash rom, sir?
    Gsearch for "nand chip mask rom mode". ;)
    Can u explain what's mash rom, sir?
    The mask rom method is technically to force the detection of the tv box on the pc, when the tv box does not respond to the reset button or has no way to enter reboot update mode. A short nand pins ascending short circuit but it is not universal, you have to look for the method for your device. I leave you a video that I publish aidan

  • 40
    to brighten.png
    Home Screen With Apps
    ^^^NEW Home Screen, Update From Play Store ^^^

    Preinstalled Apps

    Initial Set Up Screen

    Initial Set Up Screen 2


    New Google Dream X Included
    Screenshot_20201116-025413 - Copy.png

    Google Play Protect Certified

    This is My Android 9.0 Firmware, This Is Based On The Official Mi Box Android TV 9.0 Firmware

    This Is A Firmware Port Of The Xiaomi Mi Box Firmware Designed To Run On Other Amlogic Devices

    This Firmware Is FAST & STABLE

    WARNING: This Is Experimental & Requires Multiple Steps, Please Read About "Mask Rom Mode" To Know How To Recover Your Device If Installation Fails!
    This Has The New Amlogic Kernel And May Not Work On All Device

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up


    >>>> Website Click Here <<<<
    Website Updated March 2022


    v9 New Features (17.March.2022)
    BASED ON LATEST MI BOX Official Pie Build 3933
    Security Patch 5.July.2021
    More Games Controller Support
    Moved More to the system
    More Devices
    New Files App
    Rotation App
    More Games Controller Support
    Probably More

    v8 New Features (25.July.2021)
    BASED ON LATEST MI BOX Official Pie Build 3595
    Security Patch 5.March.2021
    Low Ram False All Roms
    Forceencrypt Disabled
    Default Volume MAX
    New Bootanimation
    More Debloating
    DPI Set At 320/213
    New Welcome (Thanks AcidIce18)
    No Remote Pair Screen
    More Cleaned & De Bloat
    More Tweaks...

    v7 New Features (29.April.2021)
    BASED ON LATEST MI BOX Official Pie Build 3409
    Security Patch 5.January.2021
    Now Includes App Drawer (Non Tv Apps)
    Now Includes File Browser
    Cleaned & De Bloat
    More Tweaks...

    v6 New Features (N/A)
    Not Released On This Chip

    v5 New Features (N/A)
    Not Released On This Chip

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burning tool Image
    New Install Method Now 1 Step Install

    v1 Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up


    USB Burning Tool Cant See Device
    if usb burning tool cant detect your device, and you've tried other ports, cables etc then Mask ROM Mode May Be Needed, See Here
    Youtube Unbrick Guide

    Netflix wont work from play store
    The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, Patched Netflix Apk Now Available


    Amazon Prime Wont Work
    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Disney+ No Sound
    A. Fixed Earlier Release

    No Root
    There Is No Root In This Firmware Because This Is a User Build (Not User Debug)
    User Build: This Is Like The official Android Tv Devices (Like Mi Box), it does not have root or TWRP, Uses Release Keys and is SELINUX enforced
    This Makes More Apps Show Up In The Play Store that didn't show before, (Example: Isp Android TV live tv app, only shows in Play Store On non rooted and SELINUX enforced devices, also the streams in the app do not even play in rooted devices.) And other Apps With Similar Issues On Non Certified Devices....

    myCANAL App No Sound...
    See This Post

    updates to S905W & S912 are slow due to not having test devices, makes stability improvements hard to diagnose, wifi improvements should be easier to add without testing and i will do this ass soon as i can, i have been working on a private project in most of my free time so not had a chance to further refine these chips, thanks for being paitent :)
    Is it and Android TV apk, or an apk of the mobile app? Can you share the link to that?
    Android TV apk I will upload the link
    I am still running the s912 Version als Said in page 1 :) any relevant Changes? Maybe changelog? If Not i'll Stick to my Version :) thanks for your hard work!
    ahh forgot to add changelog here put on the s912 & s905w post haha will copy here :)

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burnig tool Image
    New Install Method Now 1 Step Install

    v1 Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP