Question Very bad selfie photo quality

Search This thread

ManuBBXX_3

Member
Apr 16, 2017
5
0
Hi all
Here is the fact
Coming from a realme X2 pro, where selfie quality was insanely good.

But I clearly can't get that quality level with GT Neo 3
Main photo from the back is very good, but selfie quality is blurry and not detailed as hell

Is it the same for you ? What can I do to improve it ?

I tried google cam 8.4 for comparison, but it does not work, instant crash when taking photos.
 
Last edited:

kessaras

Recognized Developer
Sep 28, 2013
4,667
9,448
37
Athens
www.audioshow.gr
Google Pixel 5
Hi all
Here is the fact
Coming from a realme X2 pro, where selfie quality was insanely good.

But I clearly can't get that quality level with GT Neo 3
Main photo from the back is very good, but selfie quality is blurry and not detailed as hell

Is it the same for you ? What can I do to improve it ?

I tried google cam 8.4 for comparison, but it does not work, instant crash when taking photos.
I'm using MGC 8.3.252_v0e which is older version of 8.3.252_v0g. Since 8.3.252_v0e is working perfectly fine i haven't tested any other versions. My guess is that the updated versions should work too. Just in case they don't you could grab the MGC 8.3.252_v0e from here. Do keep your backup because this is personal folder and link will be removed later on

*Use pixel 4 or newer camera setup. It will take little more time to load the camera device but it is 100% working. Even night mode is working. Even the star photo mode is working.
 
Last edited:

datdat2210

New member
Jul 11, 2022
4
0
I'm using MGC 8.3.252_v0e which is older version of 8.3.252_v0g. Since 8.3.252_v0e is working perfectly fine i haven't tested any other versions. My guess is that the updated versions should work too. Just in case they don't you could grab the MGC 8.3.252_v0e from here. Do keep your backup because this is personal folder and link will be removed later on

*Use pixel 4 or newer camera setup. It will take little more time to load the camera device but it is 100% working. Even night mode is working. Even the star photo mode is working.
Night mode not working on mine