• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

ViPER4Android FX Legacy/XHiFI [Unity][Deprecated]

Search This thread

mehediceps

Member
Feb 11, 2015
19
1
Sylhet
LG Nexus 5X
Realme 7 Pro
For people having the "abnormal" and "not enabled" here's a Fix i found that works on my xiaomi.eu A11 rom. It might be worth testing on other roms too.
The problem seems to be that magisk/viper can't patch the selinux policy when it's set to enforcing.
Thanks a lot man! Huge respect. Follow your instructions and it works like charm in Samsung M21 One UI 3.0
 

Eric_Nobrega

New member
May 31, 2015
1
0
Sao Paulo
V4A is running on Android 11, the only problem is the audio limitation on Bluetooth devices.

Legacy mode works but "Convolver" does not work on Bluetooth devices.


Please help me fix this bug. 😁🙏
 
Last edited:
May 16, 2014
7
0
Я сегодня с этой проблемой столкнулся , I ran into this problem today, I cannot find the reason. Presumably I did not install RIRU correctly myself могу причину найти. Предположительно я сам не правильно поставил RIRU.
 
May 17, 2021
7
1
It bootloops again, selinux was in permissive, installs everything correctly when installing the drivers and restarts it bootloops 😞

Ícone Verificada pela comunidade


assistant_24dp.png

https://www.google.com/search?hl=pt...&ampcct=4472&source=com.teslacoilsw.launcher#
 

Wolfcity

Recognized Contributor
Apr 26, 2013
4,317
2,703
Germany
Moto G 2014
Moto G5 Plus
It bootloops again, selinux was in permissive, installs everything correctly when installing the drivers and restarts it bootloops 😞

View attachment 5358901

assistant_24dp.png

https://www.google.com/search?hl=pt...&ampcct=4472&source=com.teslacoilsw.launcher#
Your post doesn't really help. The link goes to a Google search (see screenshot).
Also there are no information about
- your device
- Android version (10/11?)
- Root method/ magisk version?
- Viper build (apk?/ magisk module?)
- maybe a log?
 

Attachments

  • Screenshot_2021-07-10-21-40-11-338_org.mozilla.firefox_beta.jpg
    Screenshot_2021-07-10-21-40-11-338_org.mozilla.firefox_beta.jpg
    396.4 KB · Views: 11
Jul 24, 2015
22
5
Hi! I installed the rootless method, and it works, the status is enabled, but the processing is "NO", everything should be installed fine, but no effect is applied in the end, even if NEON is enabled.
Anyone have an idea of what can I do to make the processing work? is just that, some random times it works for a few minutes, then stop working again with the same apps.

I'm not using any other equalizer.
I have the notification of viper that say "Processing (headphones)", but it's not processing in the status check.
I tried it in a lot of apps like Youtube, Stellio, the miui music preinstalled app etc.

I already use viper with my phone rooted time ago, but this time I don't want to root my device, so it means it's compatible with the driver, my device is a Redmi Note 7.
 
May 17, 2021
7
1
Sorry the link was wrong, my phone is a galaxy A8 2018 with custom rom TreeUI Android 11, I'm using the latest version of magisk 23.0, the installation happens normally but when I install the drivers and I asked to restart it from the bootloop and it keeps appearing in the corner blocked OEM screen, this does not only happen with viper4android it also happens with dolby digital and other sound modules even with permissive selinux!!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 460
    Deprecated - Use the New ViPER4Android v2.7:
    GO TO THE THREAD LINKED ABOVE. You don't need to flash any zips. Just install it as a regular apk, allow it to install the drivers, and you're good to go.
    For magisk users: I made a zip on the repo that includes the original vdc's and my profile converter (will convert your old profiles to the new and better format).
    For rootless users: I made a zip to install drivers and such
    Zips can be found here
    ALL SUPPORT QUESTIONS FOR 2.7 SHOULD BE AT THE THREAD ABOVE.

    This is ViPER4Android FX and Xhifi Unity installers

    These installers utilize my Unified installer that can install on Magisk OR System if Magisk is not detected (with Pixel support).

    Credits of Originality:
    - @zhuhang (Official Thread)
    - @Osm0sis
    - Viper's Audio (Official blog)
    - @ViPER520
    - @Team_DeWitt

    Special Instructions:
    • If you already know which original v4a you want to use, just add 'old' for 2.3.4.0, 'mid' for 2.4.0.1, 'new' for 2.5.0.5, or 'mat' for material to the zipname prior to flashing.
    • If you already know if you want it installed as a user or system app, add "uapp" for user app or "sapp" to system app to zipname.
    • If you already know if you want to apply the libstdc++.so lib workaround, add "lib" or "nlib" to zipname (note that there are some devices that are already known to require it and so they'll apply workaround regardless of choice)
    • If you already know if your device/rom requires the v4a open/close/fc audioserver workaround, add "ocw" to zipname. Otherwise, add "nocw" to zipname
    • To skip volkeys (if your device isn't compatible with them), add "novk" to the zipname. Note that if you don't specify the above, defaults will be applied which are: sapp, new
    • Make sure there are no spaces in the zipname

    Audio Mod Troubleshooting Guide

    Downloads

    XDA:DevDB Information
    ViPER4Android FX Legacy/XHiFI [Unity], App for the XDA Community Apps

    Contributors
    ahrion, Zackptg5

    Version Information
    Status: Stable
    Current Stable Version: v4.4
    Stable Release Date: 2019-08-11

    Created 2019-01-18
    Last Updated 2020-01-01
    31
    Updated V4A to v1.6.4! Changelog: Unity 1.5.2 update, add AML detection/notification for noobs, update old material to latest repo version (no longer trips play protect, uses switches like original 2.5 v4a, lots of other improvements)
    26
    Updated v4a to v4.0! Changelog:
    * Fix boot script once and for all
    * Don't prompt for lib workaround if device that needs it
    * Get rid of aroma option
    * Update to Unity v4.0
    25
    Been busy with my new mod specific stuff and then work. The problem is that I have to update like 13ish update binaries because this new Magisk changed quite a bit. Usually I just do batch editing which allows me to make changes in minutes. This will take like a good days worth of work for one of my days off.

    It's not just for this mod though. Thank you for your patience.
    25
    V4A has been updated! Changelog: Updated to unity v1.5.5