VirtualXposed: Use Xposed without root, unlock the bootloader or modify system image.

Feb 19, 2015
11
11
0
Panic City
Hey Guys,

I try now all possible Versions and some patches but on the following Device it is not possible to start VirtualXposed.

Phone - Huawei XS
Model - TAH-N29m
EMUI - 10.1.0.156

Install works (of course with critical virus warning) but possible to ignore all this.
After install I see a short second "Launcher 3" and the GUI close.
The App is still visible in the ShortCut.
It is only possible to Stop it but no GUI available.

Any Ideas?
Regards
Panic Brothers
 

laclac

Member
Aug 19, 2013
30
3
0
Is it possible to install the real Google play in virtualXposed ?
Currently VirtualXposed installed Yalp.. but I want to use my real account google so I would like to use the real store.
 

florin0x01

Member
Jan 10, 2020
5
1
0
Tried VirtualXposed 1.9 latest version from github on Android 10, P40 PRo with some apps and Gms (microg) installed (from Advanced settings).
Uber starts but after I receive SMS and login, crashed
Reddit crashes
Foodpanda crashes
etc
Also tried installing via Taichi, same thing
 

NaughtyJothi

Member
Feb 23, 2015
17
0
0
Had virtual exposed installed some ages ago but didt use it. Now tried some basic apps (file explorer etc), works but app won't load when I tried to install instagram.

Crashes on load. Shift files to VM still same results. Any advice? Didt install Google stuff

Note 10+, Android 10, One UI 2.5, unrooted
 

R0ttenB4ndit

Senior Member
Jun 23, 2016
151
8
18
Nope, I've tried a module called customiuizer for miui to disable secure flag but it isn't working.
I assumed you were right so didn't try until I'm ready to upgrade and must find out for sure because I may get the s20+ with snap so I can't root it. Magicmazo has the right way. I had trouble at first which I explain below.

Its a little annoying at first because of the chinese keyboard, but easy fix. Don't bother downloading they're weird version of chrome it doesn't work, just go to the apps, add the apps you want to screenshot, you can also add a browser, I had luck with puffin browser, chrome wouldn't work for me but you can try, the only real reason is to install a different keyboard I installed SwiftKey you can probably just do it from your apps though because it lets you share the apps so you probably don't even need a browser. anyway point is you share the app you want to screenshot and then you just screenshot flag secure doesn't detect it at all! your phone thinks you're screenshotting the app and the app thinks there's no screenshot happening because it's running in a virtual machine.
Thanks friend. You gave me hope and so I gave it a try since I might get a rootless device soon. I had trouble at first but it was because the flag secure module wasn't installed! Then again because I didn't "reboot" the app properly. I did get it working by installing the module + app and rebooting the app! Proof is in the pudding (screenshots)

Note: my oneplus 6 IS rooted with edexposed but I disabled the module from there to confirm it was not active and interfering with my test.
 

Attachments

R0ttenB4ndit

Senior Member
Jun 23, 2016
151
8
18
As we all know, Xposed needs modify system image because we need to replace the app_process and ART runtime.

In some case, This is a bit troublesome. So i wrote an App named VirtualXposed to use xposed without modify system, you can install it like a normal APP, no need root or system privilege.

VirtualXposed is like a virtual environment, in this virtual world, all app are running with the same UID, so all app running in it are under control. then we can load xposed module for any process within it. The only thing we need to do is to Implement a Java Method hook module to support Xposed runtime.

To be honest, VirtualXposed is forked from VirtualApp, just likes docker on Android platform. And the Java method hook module——epic, is a dynamic java aop method hook framework, just like dexposed.

You can refer the code on github: https://github.com/android-hacker/VirtualXposed

It's my first time here. All the things I need to learn from you :)
Works well with my needs on this device, oneplus 6 android 9. I pray it works on the newer ones! Good job and thank you!

---------- Post added at 12:11 AM ---------- Previous post was at 12:08 AM ----------

I can not install it on Snapdragon 800 devices. Any help?
Uh oh. What device? What is the resulting message or behavior?
 
Last edited:

A1deparagon

Senior Member
Dec 11, 2012
243
18
48
Lagos
Definitely, this app saves my life !
Actually, I have 17 working phones.
Sadly, I can't unlock bootloader of 4.
But, VirtualXposed works like a charm !
I can use Xposed and XprivacyLua perfectly.
The android versions of them, are: 6.0, 7.0, 9.0 and 10.0.

THANK YOU VERY MUCH,
I LOVE YOU
❤
Which phone did you unlock? Xaiomi?