Question VoLTE and 5G - Pixel 7 on none supported countries

Search This thread


Senior Member
Apr 22, 2011
Call with VoWiFi


  • Screenshot_20230207-202400.png
    380.5 KB · Views: 227
  • Screenshot_20230207-202505.png
    121.2 KB · Views: 229


Jan 16, 2011
Google Pixel 7 Pro
Glad that works for so many of you guys.

Confirmed on my side for Vodafone RO phisical SIM

Doesn't seem to work for Orange Esim ... guess it recognizez only the phisical SIM


  • Screenshot_20230208-101219.png
    253.5 KB · Views: 89
  • Like
Reactions: woojtekn and Josh


Dec 25, 2011
Wondering if it stays after updates. If someone will find it out please let us know in this topic - thanks!

This alone would convince me to unroot and relock bootloader, as It's the main reason for me to be rooted.


Senior Member
Nov 6, 2017
Google Pixel 7 Pro
I'm in the states and on Verizon. Should I have that volte switch? I dont. I have an unlocked p7p I purchased and brought to their network. I see the "HD" icon during calls sometimes. Is this volte?


Oct 14, 2010
Polish operator - Orange - works well! VoWIFI and VoLTE - great!
Polish operator - Plus - works well! VoWIFI and VoLTE - great!
Polish operator - T-Mobile - VoWIFI, VoLTE not working at all, i see that phone asks for edge servers via WiFi but dont attepming to connect.

In Polish Play operator VoLTE wirking, but voWIFI not - did anybody managed it to work?

I see that IPSec session is setup but after some handshake is down:

16:41:47.879021 IP > isakmp: parent_sa ikev2_init
16:41:47.919832 IP > isakmp: parent_sa ikev2_init[R]
16:41:47.942979 IP > isakmp: parent_sa ikev2_init
16:41:47.983686 IP > isakmp: parent_sa ikev2_init[R]
16:41:48.016234 IP > NONESP-encap: isakmp: child_sa ikev2_auth
16:41:48.163529 IP > NONESP-encap: isakmp: child_sa ikev2_auth[R]
16:41:48.315983 IP > NONESP-encap: isakmp: child_sa ikev2_auth
16:41:48.406161 IP > NONESP-encap: isakmp: child_sa ikev2_auth[R]
16:41:48.417290 IP > NONESP-encap: isakmp: child_sa ikev2_auth
16:41:48.481634 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x1), length 168
16:41:48.481688 IP > NONESP-encap: isakmp: child_sa ikev2_auth[R]
16:41:49.730284 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x1), length 1304
16:41:49.730285 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x2), length 1128
16:41:49.795468 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x2), length 168
16:41:50.104259 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x3), length 1464
16:41:50.169513 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x3), length 168
16:41:50.193627 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x4), length 936
16:41:50.219036 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x5), length 792
16:41:50.223319 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x4), length 168
16:41:50.246168 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x5), length 168
16:41:50.246168 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x6), length 168
16:41:50.249155 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x7), length 168
16:41:50.265083 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x8), length 168
16:41:50.267608 IP > UDP-encap: ESP(spi=0x051b016c,seq=0x9), length 168
16:41:50.282822 IP > UDP-encap: ESP(spi=0x051b016c,seq=0xa), length 120
16:41:50.295657 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x6), length 168
16:41:50.295713 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x7), length 168
16:41:50.317985 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x8), length 168
16:41:50.318042 IP > UDP-encap: ESP(spi=0x59cfb5b6,seq=0x9), length 168
16:41:50.359287 IP > NONESP-encap: isakmp: child_sa inf2
16:41:50.399064 IP > NONESP-encap: isakmp: child_sa inf2[R]

is there any possibility to debug with Pixel what is going on?
Last edited:
  • Like
Reactions: woojtekn


Senior Member
Oct 28, 2007
Do you guys think there's a chance of getting 5G to work using a similar method, without root?


New member
Apr 8, 2013
For me it's not working with Polish carrier orange. Says IMS status is unregistered all the time

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Play Poland
    VoLTE working
    No VoWiFi
    No 5G
    Orange Poland is working!
    I'm surprised how simply it went. One step at a time as per Shizuku's instuction. Switching the sliders in the Pixel IMS. Restarting and starting the Shizuku service via pc. Going into the phone settings and I see that connections via 4G and WiFi have appeared. Another reboot and launching the Shizuku service from pc. I then turn off WiFi and see the 4G+ icon. I turn on WiFi and make a call. And I am shocked. VoWifi and HDVoice is working!
    Phone without root. Pixel 7Pro. Orange Flex.

    Zrzut ekranu 2023-02-25 110207.jpg
    Hi guys, did anyone updated to latest March update and tested the patch?
    I've updated to March, volte and vowifi still work after pathing.
    I don't know why, but it does not work for me on my Pixel 7 with Slovak O2 carrier. I am able to do all steps without problems. But when I make the call, icon "HD" is not always shown, sometimes it is, sometimes it is not. It seems to work randomly. No idea why.
    This is because the numbers you are calling does not support hd voice or they are have VoLte off. I think it is normal.
    It works on lat st beta, just sometimes it needs a restart after a few days.
    I already sold Pixel, I bought S23Ultra, all features are out of the box.
    We all knew that. But we have Pixel, not S23 Ultra. If I want buy Samsung I will buy Samsung. I prefer Pixel more then S23

    I'm lucky and I live in supported country and I have all features out of the box.
  • 8
    I managed to root my device and get 5G, VOLTE and call screening enabled on Pixel 7 in an unsupported country (Bahrain).

    Let me know if u guys need a guide I will prepare one
    This guy has my avatar with my name on it 😂
    Guys I turned this out and on right now.
    Pixel 7 - Poland - Plus Carrier - VOLTE and VoWiFi are working!
    IMS Registered. Did few calls through LTE and WiFi, separately, WORKS!
    Of course without root, only quick ADB commands like described on website.
    Recommend this!
    For Poland - Play, Poland - T-Mobile - finally get worked - need to add new apn - name IMS, apn name ims, apn type ims, data protocols Ipv4/Ipv6.

    Restart phone and VoWIFI will work! - With patch, of course - without root! Finally full working phone!

    Guys check the guide i did, it worked for me on Pixel 7, but i expect it to work for the pro the same way.